#1 20.04.2016 09:51:17

Stephan Lahl
Mitglied

Wiki? (Quicklisp installation von iolib und g++ mögen sich nicht)

Problem: Die Installation von iolib mit Quicklisp in SBCL scheitert an einer unverständlichen Fehlermeldung.
Ursache: Zum Compilieren wird das externe Paket libfixposix (eine Lib in C) benötigt.
Lösung: yaourt libfixposix.

Schön. Wo kann man das so unterbringen, daß man es schnell ergoogeln kann?
Für einen Lisp-Anfänger ist das Problem nämlich etwas verwirrend.
Wiki-Eintrag? Hier im Forum irgendwo?

Offline

#2 20.04.2016 14:47:06

chepaz
Mitglied

Re: Wiki? (Quicklisp installation von iolib und g++ mögen sich nicht)

Dann gehört libfixposix als dependency in das Packagbuild von $problemprogramm. Wenn du allerding von Hand wilde Sachen kompilierst gehört es eher nach /dev/brain wink

Offline

#3 20.04.2016 15:02:49

stefanhusmann
Moderator

Re: Wiki? (Quicklisp installation von iolib und g++ mögen sich nicht)

Bitte nicht systemweite Installation mit der User-spezifischen Installation mittels quicklisp (oder npm oder pkg oder...) verwechseln. Das eine weiß vom anderen nichts.

Online

#4 20.04.2016 19:53:04

Stephan Lahl
Mitglied

Re: Wiki? (Quicklisp installation von iolib und g++ mögen sich nicht)

Hmm, um Mißverständisse  zu vermeiden: Ich hab das Problem ja gelöst. Ist ganz einfach und auch nicht die Schuld der dependencies. Die wissen ja nichts von Quicklisp und iolib. Allerdings war es gar nicht so einfach, das Problem zu ergoogeln. Ich suche jetzt einen Ort, wo man diese Info ablegen kann, damit sie schnell gefunden werden kann, da es so ziemlich das erste ist, worüber man stolpert, wenn man Lisp-Anfänger ist.
Nuja, eine lebensrettende Maßnahme ist es jetzt auch wieder nicht. smile

Offline

#5 22.04.2016 17:06:30

stefanhusmann
Moderator

Re: Wiki? (Quicklisp installation von iolib und g++ mögen sich nicht)

Da wir keinen Common-Lisp-Eintrag im Wiki haben, müsste man diesen erst erstellen. Dort könnte man dann auf quicklisp eingehen, und als Tipp auf libfixposix eingehen.

Unter welcher Common-Lisp-Geschmacksrichtung ist das Problem denn aufgetreten? Edit: sorry, SBCL, hattest du ja geschrieben. Möglicherweise ist das sogar einen Feature Request im Bugtracker wert. Quicklisp ist ja anscheinend recht beliebt sollte m.E. ohne weiteres Zutun funktionieren.

Online

#6 23.04.2016 00:39:02

Stephan Lahl
Mitglied

Re: Wiki? (Quicklisp installation von iolib und g++ mögen sich nicht)

Ich werde dann nächste Woche mal schauen, ob ich einen Eintrag baue.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums