Du bist nicht angemeldet.

#1 19.01.2015 01:44:54

Werner
Mitglied

[Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Beim Nvidia-Upgrade ist anscheinend im Augenblick der Wurm drin.
Nach dem Upgrade auf 343.36 auf 346.35-1 startete bei mir X (GDM) nicht mehr. Und das geht wohl nicht nur mir so:
https://bbs.archlinux.org/viewtopic.php?id=192401

Nach einem Downgrade der entsprechenden Nvidia-Pakete aus dem pkg-Cache war wieder alles OK.

Bei mir sind das die problemrelevanten Pakete:

pacman -Syuv --ignore nvidia-utils,nvidia-libgl,lib32-nvidia-utils,lib32-nvidia-libgl,nvidia,nvidia-lts,openctl-nvidia,lib32-opencl-nvidia 

Warnung: lib32-nvidia-libgl: Ignoriere Paket-Aktualisierung (343.36-1 => 346.35-1)
Warnung: lib32-nvidia-utils: Ignoriere Paket-Aktualisierung (343.36-1 => 346.35-1)
Warnung: nvidia: Ignoriere Paket-Aktualisierung (343.36-6 => 346.35-1)
Warnung: nvidia-libgl: Ignoriere Paket-Aktualisierung (343.36-1 => 346.35-1)
Warnung: nvidia-utils: Ignoriere Paket-Aktualisierung (343.36-1 => 346.35-1)

Mir ist noch nicht klar, ob das Problem nur in Zusammenhang mit GDM auftritt.
Aber es schadet sicher nicht, vorsichtshalber vor dem Nvidia-Upgrade zu prüfen, ob die für ein Downgrade nötigen Pakete in /var/cache/pacman/pkg vorhanden sind.

Gruß, Werner

Edit: auf den Hinweis von @QiBock hin habe ich "--ignore" sicherheitshalber mit diesen Einträgen ergänzt: nvidia-lts,openctl-nvidia,lib32-opencl-nvidia

Beitrag geändert von Werner (19.01.2015 14:33:16)

Offline

#2 19.01.2015 10:15:47

OiBock
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Bei mir bleibt, obwohl ich deinen obigen befehl aufgeführt haben mein Rechner immer noch bei
Reached target Graphical Interface hängen.
Dazu kommt noch, das mein lightdm nicht startet. Hab es mal neu installiert, leider hat sich da aber auch nix geändert.
Über Eure hilfe wäre ich sehr dankbar.

Offline

#3 19.01.2015 10:21:12

qui
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Offline

#4 19.01.2015 10:40:17

Zelda35
Gast

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Ups habe diesen Thread übersehen.
Ich habe auch Probleme mit dem Update:
https://bbs.archlinux.de/viewtopic.php?id=27446

#5 19.01.2015 10:44:28

Zelda53
Gast

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

@qui

Ich habe unter /usr/share/X11/xorg.conf.d/ eine nvidia-drm-outputclass.conf Datei mit dem Inhalt:
Section "OutputClass"
        Identifier "nvidia"
        MatchDriver "nvidia-drm"
        Driver "nvidia"
EndSection


In dem Link sieht der Eintrag so aus:
Section "Device"
   Identifier "Device0"
   Driver "nvidia"
   VendorName "NVIDIA Corporation"
   BoardName "GeForce GT 610"
   BusID "PCI:1:0:0"
EndSection

Könnte ich bei mir auch probieren, aber kann ich die BusID so übernehmen? und den Identifier?

#6 19.01.2015 11:02:06

Werner
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

@OiBock
Schau doch mal nach, ob bei dir eventuell ein anderes Nvidia-Paket der Version 346.35 installiert ist (nvidia-lts oder openctl-nvidia)

pacman -Q | grep -i nvidia

@Svenstaro
Als ergänzende Info die Ausgabe meiner Xorg.0.log nach dem Problemupgrade:

[    91.020] (II) LoadModule: "glx"
[    91.020] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    91.031] (II) Module glx: vendor="NVIDIA Corporation"
[    91.031] 	compiled for 4.0.2, module version = 1.0.0
[    91.031] 	Module class: X.Org Server Extension
[    91.031] (II) NVIDIA GLX Module  346.35  Sat Jan 10 20:53:39 PST 2015
[    91.031] (==) Matched nouveau as autoconfigured driver 0
[    91.031] (==) Matched nv as autoconfigured driver 1
[    91.031] (==) Matched modesetting as autoconfigured driver 2
[    91.031] (==) Matched fbdev as autoconfigured driver 3
[    91.031] (==) Matched vesa as autoconfigured driver 4
[    91.031] (==) Assigned the driver to the xf86ConfigLayout
[    91.031] (II) LoadModule: "nouveau"
[    91.032] (WW) Warning, couldn't open module nouveau
[    91.032] (II) UnloadModule: "nouveau"
[    91.032] (II) Unloading nouveau
[    91.032] (EE) Failed to load module "nouveau" (module does not exist, 0)
[    91.032] (II) LoadModule: "nv"
[    91.032] (WW) Warning, couldn't open module nv
[    91.032] (II) UnloadModule: "nv"
[    91.032] (II) Unloading nv
[    91.032] (EE) Failed to load module "nv" (module does not exist, 0)
[    91.032] (II) LoadModule: "modesetting"
[    91.032] (WW) Warning, couldn't open module modesetting
[    91.032] (II) UnloadModule: "modesetting"
[    91.032] (II) Unloading modesetting
[    91.032] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    91.032] (II) LoadModule: "fbdev"
[    91.032] (WW) Warning, couldn't open module fbdev
[    91.032] (II) UnloadModule: "fbdev"
[    91.032] (II) Unloading fbdev
[    91.032] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    91.032] (II) LoadModule: "vesa"
[    91.033] (WW) Warning, couldn't open module vesa
[    91.033] (II) UnloadModule: "vesa"
[    91.033] (II) Unloading vesa
[    91.033] (EE) Failed to load module "vesa" (module does not exist, 0)
[    91.033] (EE) No drivers available.
[    91.033] (EE) 
Fatal server error:
[    91.033] (EE) no screens found(EE) 
[    91.033] (EE) 

Gruß, Werner

Offline

#7 19.01.2015 11:27:43

OiBock
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Meine Xorg.0.log sieht so aus.

 [    19.522] 
X.Org X Server 1.16.3
Release Date: 2014-12-20
[    19.522] X Protocol Version 11, Revision 0
[    19.522] Build Operating System: Linux 3.18.1-1-ARCH x86_64 
[    19.522] Current Operating System: Linux localhost 3.18.2-2-ARCH #1 SMP PREEMPT Fri Jan 9 07:37:51 CET 2015 x86_64
[    19.522] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=05028d27-a51b-47eb-a05e-c6472c113388 rw quiet
[    19.522] Build Date: 29 December 2014  01:09:58PM
[    19.522]  
[    19.522] Current version of pixman: 0.32.6
[    19.522] 	Before reporting problems, check [url]http://wiki.x.org[/url]
	to make sure that you have the latest version.
[    19.522] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    19.522] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 19 09:37:36 2015
[    19.523] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    19.523] (==) No Layout section.  Using the first Screen section.
[    19.523] (==) No screen section available. Using defaults.
[    19.523] (**) |-->Screen "Default Screen Section" (0)
[    19.523] (**) |   |-->Monitor "<default monitor>"
[    19.523] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    19.523] (==) Automatically adding devices
[    19.523] (==) Automatically enabling devices
[    19.523] (==) Automatically adding GPU devices
[    19.523] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF/".
[    19.523] 	Entry deleted from font path.
[    19.523] 	(Run 'mkfontdir' on "/usr/share/fonts/OTF/").
[    19.523] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    19.523] 	Entry deleted from font path.
[    19.523] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    19.523] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    19.523] 	Entry deleted from font path.
[    19.523] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    19.523] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[    19.523] (==) ModulePath set to "/usr/lib/xorg/modules"
[    19.523] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    19.523] (II) Loader magic: 0x818d80
[    19.523] (II) Module ABI versions:
[    19.523] 	X.Org ANSI C Emulation: 0.4
[    19.523] 	X.Org Video Driver: 18.0
[    19.523] 	X.Org XInput driver : 21.0
[    19.523] 	X.Org Server Extension : 8.0
[    19.525] (EE) systemd-logind: failed to get session: PID 324 does not belong to any known session
[    19.526] (II) xfree86: Adding drm device (/dev/dri/card0)
[    19.527] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Invalid argument
[    19.529] (--) PCI:*(0:2:0:0) 10de:0de1:10b0:0401 rev 161, Mem @ 0xfb000000/16777216, 0xd8000000/134217728, 0xe6000000/33554432, I/O @ 0x0000ac00/128, BIOS @ 0x????????/524288
[    19.529] (--) PCI: (0:4:0:0) 14f1:8852:0070:71d3 rev 2, Mem @ 0xfd800000/2097152
[    19.529] (II) Open ACPI successful (/var/run/acpid.socket)
[    19.529] (II) LoadModule: "glx"
[    19.529] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    19.558] (II) Module glx: vendor="NVIDIA Corporation"
[    19.558] 	compiled for 4.0.2, module version = 1.0.0
[    19.558] 	Module class: X.Org Server Extension
[    19.558] (II) NVIDIA GLX Module  346.35  Sat Jan 10 20:53:39 PST 2015
[    19.558] (==) Matched nouveau as autoconfigured driver 0
[    19.558] (==) Matched nv as autoconfigured driver 1
[    19.558] (==) Matched modesetting as autoconfigured driver 2
[    19.558] (==) Matched fbdev as autoconfigured driver 3
[    19.558] (==) Matched vesa as autoconfigured driver 4
[    19.558] (==) Assigned the driver to the xf86ConfigLayout
[    19.558] (II) LoadModule: "nouveau"
[    19.558] (WW) Warning, couldn't open module nouveau
[    19.558] (II) UnloadModule: "nouveau"
[    19.558] (II) Unloading nouveau
[    19.558] (EE) Failed to load module "nouveau" (module does not exist, 0)
[    19.558] (II) LoadModule: "nv"
[    19.558] (WW) Warning, couldn't open module nv
[    19.558] (II) UnloadModule: "nv"
[    19.558] (II) Unloading nv
[    19.559] (EE) Failed to load module "nv" (module does not exist, 0)
[    19.559] (II) LoadModule: "modesetting"
[    19.559] (WW) Warning, couldn't open module modesetting
[    19.559] (II) UnloadModule: "modesetting"
[    19.559] (II) Unloading modesetting
[    19.559] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    19.559] (II) LoadModule: "fbdev"
[    19.559] (WW) Warning, couldn't open module fbdev
[    19.559] (II) UnloadModule: "fbdev"
[    19.559] (II) Unloading fbdev
[    19.559] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    19.559] (II) LoadModule: "vesa"
[    19.559] (WW) Warning, couldn't open module vesa
[    19.559] (II) UnloadModule: "vesa"
[    19.559] (II) Unloading vesa
[    19.559] (EE) Failed to load module "vesa" (module does not exist, 0)
[    19.559] (EE) No drivers available.
[    19.559] (EE) 
Fatal server error:
[    19.559] (EE) no screens found(EE) 
[    19.559] (EE) 
Please consult the The X.Org Foundation support 
	 at [url]http://wiki.x.org[/url]
 for help. 
[    19.559] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    19.559] (EE)  

um wegen dem nvidia paket nachzusehen, muss ich gleich arch neu booten

Beitrag geändert von OiBock (19.01.2015 11:43:01)

Offline

#8 19.01.2015 11:45:21

OiBock
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Also bei dem Befehl

 pacman -Q | grep -i nvidia 

erscheint bei mir

 nvidia 346.35-2, nvidia-libgl 346.35-2, nvidia-utils 346.35-2

Offline

#9 19.01.2015 12:19:59

Werner
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

@OiBock
Dann brauchst du für ein Downgrade die entsprechenden Vorversionen im pkg-Cache:

ls /var/cache/pacman/pkg/ | egrep "nvidia|nvidia-libgl|nvidia-utils"

Bei mir sind das dann die jüngsten (und funktionierenden) Vorversionen fürs Downgrade:

cd /var/cache/pacman/pkg/
pacman -U nvidia-libgl-343.36-1-x86_64.pkg.tar.xz nvidia-utils-343.36-1-x86_64.pkg.tar.xz nvidia-343.36-6-x86_64.pkg.tar.xz

Aber prüf die Versionen der Pakete aus deinem pkg-Cache bitte, bevor du diesen Downgrade-Befehl losschießt.

Gruß, Werner

Offline

#10 19.01.2015 13:56:44

derwebworker
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Ich weiß nicht ob es hilft aber ich musste nach meinem Downgrade die lib32-nvidia-libgl nochmal neuinstallieren.

Offline

#11 19.01.2015 14:12:15

OiBock
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Der Fehler wurde behoben. Bei einer Systemaktualisierung wird das neue nvidia 346.35-3 paket installiert. Danach läuft wieder alles.
@ Werner
Trotzdem Danke für die Hilfe!!!!!

Offline

#12 19.01.2015 14:32:39

Werner
Mitglied

Re: [Gelöst] Hinweis: Probleme beim Upgrade auf Nvidia 346.35

Ja, kann ich bestätigen, danke für den Hinweis!
Aktueller funktionierender Versionsstand:

lib32-nvidia-libgl-346.35-1  
lib32-nvidia-utils-346.35-1 
nvidia-346.35-3
nvidia-libgl-346.35-2
nvidia-utils-346.35-2

Ich setze das Thema auf gelöst.

Gruß, Werner

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums