#1 11.01.2015 22:42:40

veita
Mitglied

[Wiki] Anleitung "Statische IP" funktioniert nicht

Folgt man der Anleitung https://wiki.archlinux.de/title/Statische_IP, so startet die Netzwerkverbindung nach dem Booten nicht.

Das Problem lässt sich beheben, indem man ähnlich wie im englischen Wiki beschrieben vorgeht.

# cat /etc/conf.d/net-conf-ens33
address=192.168.1.2
netmask=24
broadcast=192.168.1.255
gateway=192.168.1.1
# cat /etc/systemd/system/network@.service
[Unit]
Description=Network startup (%i)
Wants=network.target
Before=network.target
BindsTo=sys-subsystem-net-devices-%i.device
After=sys-subsystem-net-devices-%i.device

[Service]
Type=oneshot
RemainAfterExit=yes
EnvironmentFile=/etc/conf.d/net-conf-%i
ExecStart=/sbin/ip link set dev %i up
ExecStart=/sbin/ip addr add ${address}/${netmask} broadcast ${broadcast} dev %i
ExecStart=/sbin/ip route add default via ${gateway}
ExecStop=/sbin/ip addr flush dev %i
ExecStop=/sbin/ip link set dev %i down

[Install]
WantedBy=multi-user.target
systemctl enable network@ens33.service

ens33 muss ggf. durch das jeweilige Device ersetzt werden.

Da man im Wiki nicht editieren kann, habe ich hier gepostet.

Offline

#2 11.01.2015 22:47:49

matthias
Moderator

Re: [Wiki] Anleitung "Statische IP" funktioniert nicht

Hmm??? Deine Anmelde-Daten sollten hier wie im Wiki die gleichen sein. Natürlich kannst du dort editieren.

Offline

#3 12.01.2015 23:57:18

veita
Mitglied

Re: [Wiki] Anleitung "Statische IP" funktioniert nicht

Danke für den Hinweis. Ich hatte fälschlich angenommen, dass nur privilegierten Benutzern Änderungen im Wiki erlaubt seien.

Habe den Wiki-Artikel geändert.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums