Du bist nicht angemeldet.

#1 28.01.2009 19:34:19

Yoschi
Mitglied

net usershare are currently disabled - Wie aktivieren?

Hallo,
wie aktiviere ich net usershare?

include = /etc/samba/usershare.conf

habe ich schon zu smb.conf hinzugefügt.

Und zur Samba Gruppe habe ich mich auch schon hinzugefügt inklusiv ausgeloggt.

Beitrag geändert von Yoschi (31.01.2009 21:42:46)

Offline

#2 28.01.2009 21:14:11

GerBra
Mitglied

Re: net usershare are currently disabled - Wie aktivieren?

Hilft dir: man net -> USERSHARE nicht? Klingt mir zumindest ziemlich präzise....

Offline

#3 28.01.2009 21:32:31

Yoschi
Mitglied

Re: net usershare are currently disabled - Wie aktivieren?

GerBra schrieb:

Hilft dir: man net -> USERSHARE nicht? Klingt mir zumindest ziemlich präzise....

Uih hab ich nich dran gedacht dort mal nachzusehen.

Was ich mich aber frage warum es bei meiner vorherigen Arch Installation die eine Zeile (
include = /etc/samba/usershare.conf) ausreichte und warum die der ganze Weg nicht nach der Installation gesagt wird. (bis jetzt wird nur gesagt die Zeile müsse man hinzufügen und sich zur samba Gruppe hinzufügen)

Offline

#4 31.01.2009 21:42:27

Yoschi
Mitglied

Re: net usershare are currently disabled - Wie aktivieren?

Ich habe jetzt den Fehler gefunden man soll

include = /etc/samba/usershare.conf

nicht ans Ende der /etc/samba/smb.conf Datei anhängen sondern ans Ende der Global Kategorie in der Datei.

Offline

#5 12.08.2009 18:08:45

uvok
Mitglied

Re: net usershare are currently disabled - Wie aktivieren?

Hi,

ich wollte Verzeichnisse über net usershare freigeben.

ich habe 2 PCs:
1 Desktop (Archlinux) und 1 Netbook (Ubuntu Netbook Remix).

Ich habe eig. alles laut Anleitung gemacht (http://wiki.ubuntuusers.de/Heimnetzwerk … -freigeben) - außer dass es unter archlinux keine sambashare (und auch keine Gruppe samba) zu geben scheint (deshalb habe ich mich zu policykit hinzugefügt, weil der Gruppe gehört /var/lib/samba/usershare).

Nun bin ich soweit, dass ich von meinem Desktop auf den freigegebenen Ordner vom Netbook zugreifen kann - nur umgekehrt funktioniert es nicht, da erhalte ich die Fehlermeldung Einhängen fehlgeschlagen.

Nun habe ich es mal über die Kommandozeile probiert:

$ smbclient -L 192.168.178.21
Enter user's password: 
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.3.7]
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
tree connect failed: SUCCESS - 0

Wobei 192.168.178.21 die Adresse des Desktops ist. Kann das das Problem sein?
Und wie aktiviere ich client lanman auth?

Achso, zwei Sachen noch;

Muss der Samba-Service auch für die net usershare Freigaben laufen?

und:

Was hat es mit diesen worksgroups zu tun? Müssen beide Samba-Server die gleiche Bezeichnung haben?

EDIT:

Lösung:

client lanman auth = yes

musste noch mit ans Ende des global-Abschnittes
Außerdem war dere Wert von hosts allow falsch, statt 192.168.1. musste 192.168.178. dastehen...

Die zwei Fragen würde ich alllerdings noch gern beantwortet haben smile

UPDATE3:

Hab mich geirrt, Verbindung geht immer noch nicht...

UPDATE4:

$ smbclient //localhost/share -U user
Enter user's password:
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.3.7]
Server not using user level security and no password supplied.
tree connect failed: NT_STATUS_WRONG_PASSWORD

Was soll das? Ich bin mir 100%ig sicher dass das Passwort richtig ist, und level security ist auf user gesetzt,,,

UPDATE5:

/etc/samba/usershare.conf setzt security auf share, da kann das ja nicht gehen. ,,,
Funktioniert usershare auch noch bei security = user?
wenn nicht, hab ich ein echtes Problem...

Beitrag geändert von uvok (12.08.2009 20:55:17)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums