Du bist nicht angemeldet.

#1 26.06.2007 16:48:09

Computerspezi.com
Mitglied

snd-hda-intel - Kein Sound

Hallo !

Habe auf meinem Notebook Asus A7TC nun Arch Linux mit XFCE4 installiert.
Allerdings habe ich keinen Sound.

Der Benutzer ist in Gruppe audio eingetragen.
Das Modul snd-hda-intel wurde erfolgreich ohne Fehlermeldung geladen.
Alsaconf hab ich ausgeührt.
Der xfce4-mixer erkennt das Gerät als #0: HDA NVidia und ich hab dort folgende Einstellmöglichkeiten:
Headphone,0 - PCM,0 - Front,0 - Front Mic,0 - Line,0 - Mic,0 - IEC958,0 - Capture,0 - Capture,1 - Capture,2 - Input Source,0 - Input Source,1 - Input Source,2

Wenn ich im XMMS eine Audiodatei (MP3) abspiele, spielt zwar XMMS die File ab aber es kommt null Sound aus den Boxen.
Auch verschieben der Regler im Mixer, Mute an/aus usw. hat alles nix geholfen.
Es kommt absolut kein Ton raus.

Wie bekomme ich das Teil denn zum laufen, sodass ich auch Sound habe?

Habe bereits die Suche genutzt und auch was gefunden.
Nr wird dortgeschrieben, dass man was in die /etc/modules.conf eintragen oll.
Nur habe ich diese Datei in meinem Arch gar nicht.

Wo muss ich denn da was einstellen?

Danke für Eure Hilfe !

<<<Ausgabe von lsmod>>>

[root@localhost computerspezi]# lsmod | grep snd
snd_seq_oss 29056 0
snd_seq_midi_event 6528 1 snd_seq_oss
snd_seq 46544 4 snd_seq_oss,snd_seq_midi_event
snd_seq_device 6796 2 snd_seq_oss,snd_seq
snd_hda_intel 260508 6
snd_pcm_oss 38688 0
snd_pcm 69124 3 snd_hda_intel,snd_pcm_oss
snd_timer 19076 3 snd_seq,snd_pcm
snd_page_alloc 7816 2 snd_hda_intel,snd_pcm
snd_mixer_oss 14592 1 snd_pcm_oss
snd 44516 18 snd_seq_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore 6496 1 snd
[root@localhost computerspezi]#

Beitrag geändert von Computerspezi.com (26.06.2007 16:52:08)

Offline

#2 26.06.2007 18:13:50

dongiovanni
Mitglied

Re: snd-hda-intel - Kein Sound

Hast du alle nötigen Kanäle aktiviert und auf ein gewisses Level eingestellt? Am besten funktioniert als Mixser alsamixer aus alsa-utils.

Johannes

Offline

#3 26.06.2007 18:30:06

Computerspezi.com
Mitglied

Re: snd-hda-intel - Kein Sound

ja. Es sind alle Kanäle aktiviert und die Lautstärke überall voll aufgedreht.

Trotzdem kommt absolut kein Ton raus. sad

Offline

#4 26.06.2007 20:25:03

BurnOver
Mitglied

Re: snd-hda-intel - Kein Sound

hast du in anderen programmen ton?

xmms kann man ja noch umstellen was den sound angeht

Offline

#5 26.06.2007 20:41:20

danlei
Mitglied

Re: snd-hda-intel - Kein Sound

Computerspezi.com schrieb:

ja. Es sind alle Kanäle aktiviert und die Lautstärke überall voll aufgedreht.

Auch wenn es sich blöd anhört: Mach das auf jeden Fall mit alsamixer auf der Konsole (</>), andere Mixer sind eine häufige Fehlerquelle.

Ansonsten habe ich mir zum Thema HDA folgendes in meinen Privat-Howtos notiert:

/etc/modprobe.conf:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel

# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

~/.asoundrc:

~/.asoundrc

pcm.hda-intel {
  type hw
    card 0
}

ctl.hda-intel {
  type hw
    card 0
}

Ich hatte mir das mal ergoogelt, weil der Sound mit meiner HDA extrem leise war, danach hats funktioniert. Vielleicht hilft es Dir ja weiter.

Offline

#6 26.06.2007 20:46:23

Computerspezi.com
Mitglied

Re: snd-hda-intel - Kein Sound

diese ~/.asound.rc.....wo befindet die sich denn oder wo muss ich die anlegen?

Offline

#7 26.06.2007 20:50:52

danlei
Mitglied

Re: snd-hda-intel - Kein Sound

Im Homeverzeichnis anlegen.

Ich hab auch nochmal meine Lesezeichen nach dem Link durchsucht, ihn aber leider nicht mehr gefunden. Naja, vielleicht hilfts ja auch so was...

Offline

#8 26.06.2007 22:08:40

Computerspezi.com
Mitglied

Re: snd-hda-intel - Kein Sound

danlei schrieb:
Computerspezi.com schrieb:

ja. Es sind alle Kanäle aktiviert und die Lautstärke überall voll aufgedreht.


Auch wenn es sich blöd anhört: Mach das auf jeden Fall mit alsamixer auf der Konsole (</>), andere Mixer sind eine häufige Fehlerquelle.

Ansonsten habe ich mir zum Thema HDA folgendes in meinen Privat-Howtos notiert:

/etc/modprobe.conf:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel

# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

~/.asoundrc:

~/.asoundrc

pcm.hda-intel {
  type hw
    card 0
}

ctl.hda-intel {
  type hw
    card 0
}

Ich hatte mir das mal ergoogelt, weil der Sound mit meiner HDA extrem leise war, danach hats funktioniert. Vielleicht hilft es Dir ja weiter.

Leider funktioniert auch das nicht. Absolut kein Ton kommt hier aus den Lautsprechern.

Au Mann, woran kann das denn liegen???

Hat noch jemand ne Idee?

Nen Notebook ohne Sound is doch blöd... sad

Offline

#9 26.06.2007 23:36:18

piet
Mitglied

Re: snd-hda-intel - Kein Sound

Auf tuxmobil gibt es diesen Beitrag, da steht was von noapic bzw nolapic als Option im Bootmanager. Versuchs doch mal.
Ist allerdings ein A7D und wie groß der Unterschied ist weiß ich nicht.

cu

Offline

#10 26.06.2007 23:38:24

danlei
Mitglied

Re: snd-hda-intel - Kein Sound

Schade, bei mir hatte es funktioniert. Ich weiß sonst nichts mehr. Vielleicht hilft ja dieser Thread:

http://forum.archlinux.de/?page=Posting … hread=5794

Offline

#11 27.06.2007 10:33:31

Computerspezi.com
Mitglied

Re: snd-hda-intel - Kein Sound

Also habe alles gelesen und probiert. Irgendwie will das scheiss Ding keinen Ton von sich geben.

Bei der dmesg-Ausgabe steht Folgendes:
hda_codec: Unknown model for ALC882, trying auto-probe from BIOS.

Vielleicht liegt da der Hund begraben?

Offline

#12 03.07.2007 22:33:36

Computerspezi.com
Mitglied

Re: snd-hda-intel - Kein Sound

piet schrieb:

Auf tuxmobil gibt es diesen Beitrag, da steht was von noapic bzw nolapic als Option im Bootmanager. Versuchs doch mal.
Ist allerdings ein A7D und wie groß der Unterschied ist weiß ich nicht.

cu

Hallo !

Das hab ich auch schon versucht aber bringt leider auch keinen Erfolg.

Irgendwie muss man doch der Kiste einen Ton entlocken können???

Offline

#13 03.07.2007 23:21:34

Computerspezi.com
Mitglied

Re: snd-hda-intel - Kein Sound

hier nochmal die Ausgabe von "lspci | grep Audio"

vielleicht hilft das ja?

[root@localhost computerspezi]# lspci | grep Audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
[root@localhost computerspezi]#

Offline

Fußzeile des Forums