Du bist nicht angemeldet.

#1 11.05.2007 19:56:57

defcon
Mitglied

Programmstart dauert ewig

So, auch mal wieder um Hilfe betteln lol

Mir ist aufgefallen, das einige Programme, wenn ich die starte, meist Ewigkeiten brauchen, bis es mal aufgepoppt ist hmm

z.B.
im Streamtuner.. auf "verbinden" klicken, dauerts gut 15 sek. bis mal der player aufgeht.

Firefox ebenso... dauert ebenfalls gut 10-15 sek. bis er sich öffnet.

Und kommt mir jetzt nicht mit Alternativ-Programmen wie z.B. Amarok... *gg*

Also laufen tut kdemod, falls das jemand wissen will.
Und interessieren würde mich natürlich wieso der Programmstart teilweise so übelst lang dauert. Hat da jemand ne Idee?

Beitrag geändert von dongiovanni (15.05.2007 19:38:09)

Offline

#2 11.05.2007 21:40:19

dongiovanni
Mitglied

Re: Programmstart dauert ewig

Firefox2 braucht auch auf meinem AthlonX2 im vergleich zu z.B. Konqueror Ewigkeiten! Kommt auch auf deinen Rechner an! Oder treten die langen Ladezeiten erst seit kurzem auf?

Beitrag geändert von dongiovanni (11.05.2007 21:41:04)

Offline

#3 12.05.2007 13:48:06

defi
Gast

Re: Programmstart dauert ewig

Nein, das ist schon länger so. Am System wird es wohl hoffentlich nicht liegen (AMD Athlon 3700+ und 2GB RAM).

#4 12.05.2007 13:56:12

GerBra
Mitglied

Re: Programmstart dauert ewig

Könnte es evtl. ein Netzproblem sein?
Auch wenn man kein Netzwerk hat brauchen manche Programme doch zumindest zur Kommunikation auf dem lokalen Rechner ein funktionierendes TCP/IP.

Das wird normalerweise durch das loopback Device lo abgedeckt.
Kannst du ohne Fehler ausführen:
ping 127.0.0.1
ping localhost (localhost sollte zu 127.0.0.1 aufgelöst werden)

Gab es gerade im Zusammenhang mit Firefox nicht auch mal Probleme mit ipv6, wenn das Modul entweder geladen oder eben nicht geladen ist?

Nur so als mögliche Fehlerursachen...

Offline

#5 12.05.2007 13:58:41

jean-paul
Mitglied

Re: Programmstart dauert ewig

Viele Programme verlangen einen korrekt angegebenen Host-Namen und warten sehr lange (langer Programmstart) bis es weiter geht.

Wenn du in deiner rc.conf HOSTNAME geändert hast, sollte dieser auch in der /etc/hosts stehen.
Ansonsten, hast du die langsam startenden Programme auch schon im Terminal gestartet ?
Gibts da Meldungen ?

Jean-Paul

Offline

#6 12.05.2007 15:16:21

defcon
Mitglied

Re: Programmstart dauert ewig

Nein, ist auch alles korrekt eingetragen.
IPv6 hab ich im übrigen im Firefox deaktiviert, brauch ich ja eh nicht.

Offline

#7 12.05.2007 15:28:24

Pierre
Entwickler

Re: Programmstart dauert ewig

Startet Firefox beim zweiten Mal deutlich schneller? Oder anders gesagt: ist die Plattenperformance OK.

Offline

#8 12.05.2007 15:39:55

GerBra
Mitglied

Re: Programmstart dauert ewig

defcon schrieb:

Nein, ist auch alles korrekt eingetragen.
IPv6 hab ich im übrigen im Firefox deaktiviert, brauch ich ja eh nicht.

Also bei mir startet FF auf einem langsameren System deutlich flotter als von dir geschildert (ich weiß, das hilft dir jetzt wenig wink )

Installiere dir doch mal strace und starte aus einem Terminal den FF mal mit:
strace firefox
Achtung: da kommt sehr viel an Ausgabe, aber es läßt dich evtl. erkennen an welcher Stelle eine Pause entsteht. Wenn eine deutliche Pause erkennbar ist kannst du diese Zeilen evtl. mal posten oder irgendwo auffindbar ablegen.

Offline

#9 12.05.2007 16:09:54

defcon
Mitglied

Re: Programmstart dauert ewig

Ich hab das Gefühl, das je öfters ich das Programm starte, es auch schneller startet mit der Zeit.
Bis auf audacious, welches gestartet wird, wenn ich in streamtuner nen sender anklicke.. da dauert gut 30-40 sekunden (hab ich vorhin mal gemessen)

Offline

#10 13.05.2007 18:01:42

defi
Gast

Re: Programmstart dauert ewig

Und grad eben hab ich noch etwas festgestellt...
Wenn ich auf dem Desktop das FF Icon anklicke, und für 1-2sec. gedrückt halte, dann loslasse, geht der FF sofort auf <huh2>

Tolles Feature, oder? <laugh>

#11 15.05.2007 09:37:52

Laurin
Gast

Re: Programmstart dauert ewig

Das Problem mit dem ewig langen Programmstarts habe ich auch.

Erst war es gar nicht da. Dann brauchte mal hin und wieder ein Programm etwas länger. Und jetzt braucht ++jedes++ Programm exakt 20 Sekunden, um zu starten.

Das sieht dann so aus: Doppelklick aufs Icon auf dem Desktop. Im CPU-Monitor verschwinden plötzlich sämtliche Auslastungslinien, als ob gar nichts mehr verarbeitet wird. Dann zähle ich von 1 bis 20 und dann sehe ich, wie die CPU voll aufdreht und innerhalb von Millisekunden bis Sekunden (je nach Programmumfang) das Programm startet.

Wenn man das Programm schließt und wieder öffnen will, dauert es ebenfalls 20 Sekunden. Die Startgeschwindigkeit wird einfach nicht besser.

Für mich sieht das so aus, als ob von dem eigendlichen Programm auf irgendwas gewartet wird. Das kommt wohl nicht und dann springt der Timeout rein. Ich hab aber keinen Plan, wo ich nach dem Fehler suchen soll. Es ist mir einfach unverständlich.

Das mit dem Hostnamen probiere ich heute abend mal aus. Bis dahin hoffe ich, dass noch jemand einen guten Tipp weiß.

Greetz Laurin

#12 15.05.2007 16:21:54

defcon
Mitglied

Re: Programmstart dauert ewig

Also bei mir hab ich die Probleme nur beim Firefox und wie schon erwähnt bei der Kombination Streamtuner -> Audacious.

Firefox hab ich durch Swiftfox-athlon-xp ersetzt, und audacious durch Xmms.

Jetzt läufts wieder wie geschmiert, die Anwendungen starten sofort wenn ich draufklicke.

Offline

#13 15.05.2007 16:33:34

GerBra
Mitglied

Re: Programmstart dauert ewig

defcon schrieb:

Firefox hab ich durch Swiftfox-athlon-xp ersetzt, und audacious durch Xmms.

Ich mußte ja wirklich mal nachschauen, was Swiftfox ist...
Mittlerweile forked wirklich jeder alles wink
Du bist dir aber schon bewußt, daß du dich um (Sicherheits)-Updates selbst kümmern mußt - was bei einem Webbrowser ja nicht unerheblich ist.

Offline

#14 15.05.2007 16:37:49

defcon
Mitglied

Re: Programmstart dauert ewig

Ist doch kein Problem... wink

Offline

#15 15.05.2007 19:13:25

Laurin
Gast

Re: Programmstart dauert ewig

Bei mir läufts jetzt durch ein Update aller Pakete wieder verzögerungsfrei. Muss wohl ein Bug in irgendeiner Software gewesen sein.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums