Du bist nicht angemeldet.

#1 08.04.2007 22:13:04

Domi2007
Mitglied

Kann Grub nicht installieren

Hallo,
ich habe mich, nachdem ich lange Ubuntu und Fedora benutzt habe dazu entschlossen einmal Arch Linux auszuprobieren und ich bin absolut begeistert, ich habe nur ein Problem, ich kann Grub nicht installieren, während der Installation kamen andauernt Fehler wie "Unbekanntes DAteisystem" und jetzt nachdem ich das System aufgesetzt habe und (leider) per Lilo gebootet habe und versuche mit grub-install /dev/sda Grub zu installieren kommt folgender Fehler:

The file /boot/grub/stage1 not read correctly.

Da ich bereits gelesen habe, dass es sich dabei um einen Fehler in der fstab oder mtab handelt, ich aber keinen feststellen kann, habe ich hier mal beide Dateien angehängt

Meine fstab:

# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
/dev/cdrom             /mnt/cdrom    iso9660   ro,user,noauto,unhide   0      0
/dev/cdrom1            /mnt/cdrom1   iso9660   ro,user,noauto,unhide   0      0
/dev/dvd               /mnt/dvd      udf       ro,user,noauto,unhide   0      0
/dev/sda2              swap          swap      defaults           0       0
/dev/sda3              /              ext3      defaults           0       0
/dev/sdb1 	       /media/daten   ext3      defaults           0       0
/dev/sdb2              /media/multimedia ext3   defaults           0       0
/dev/sda1              /media/windows ntfs-3g   defaults           0       0

none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0

und hier meine mtab

/dev/sda3 / ext3 rw 0 0
none /proc proc rw 0 0
none /sys sysfs rw 0 0
none /proc/bus/usb usbfs rw 0 0
none /dev/pts devpts rw 0 0
none /dev/shm tmpfs rw 0 0
/dev/sdb1 /media/daten ext3 rw 0 0
/dev/sdb2 /media/multimedia ext3 rw 0 0
/dev/sda1 /media/windows fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0

Ich hoffe ihr könnt mir helfen

Gruß Domi

Beitrag geändert von dongiovanni (09.04.2007 12:43:49)

Offline

#2 08.04.2007 22:32:41

jean-paul
Mitglied

Re: Kann Grub nicht installieren

Hi,

was steht denn in deiner menu.lst ?

Jean-Paul

Offline

#3 08.04.2007 22:38:53

Domi2007
Mitglied

Re: Kann Grub nicht installieren

Hallo Jean-Paul,
danke für deine schnelle Antwort,
in meiner menu.lst steht folgendes:

# Config file for GRUB - The GNU GRand Unified Bootloader
# /boot/grub/menu.lst

# DEVICE NAME CONVERSIONS 
#
#  Linux           Grub
# -------------------------
#  /dev/fd0        (fd0)
#  /dev/hda        (hd0)
#  /dev/hdb2       (hd1,1)
#  /dev/hda3       (hd0,2)
#

#  FRAMEBUFFER RESOLUTION SETTINGS
#     +-------------------------------------------------+
#          | 640x480    800x600    1024x768   1280x1024
#      ----+--------------------------------------------
#      256 | 0x301=769  0x303=771  0x305=773   0x307=775
#      32K | 0x310=784  0x313=787  0x316=790   0x319=793
#      64K | 0x311=785  0x314=788  0x317=791   0x31A=794
#      16M | 0x312=786  0x315=789  0x318=792   0x31B=795
#     +-------------------------------------------------+

# general configuration:
timeout   5
default   0
color light-blue/black light-cyan/blue

# boot sections follow
# each is implicitly numbered from 0 in the order of appearance below
#
# TIP: If you want a 1024x768 framebuffer, add "vga=773" to your kernel line.
#
#-*

# (0) Arch Linux
title  Arch Linux
root   (hd0,2)
kernel /boot/vmlinuz26 root=/dev/sda3 ro
initrd /boot/kernel26.img

# (1) Arch Linux
title  Arch Linux Fallback
root   (hd0,2)
kernel /boot/vmlinuz26 root=/dev/sda3 ro
initrd /boot/kernel26-fallback.img

# (1) Windows
title Microsoft Windows XP Professional
rootnoverify (hd0,0)
makeactive
chainloader +1

Offline

#4 08.04.2007 22:54:06

jean-paul
Mitglied

Re: Kann Grub nicht installieren

Hi,

also ich kann an deiner fstab / mtab nichts entdecken was nicht okay wäre. Ausser dass dein Filesystem nicht geprüft wird:

/dev/sda3 / ext3 defaults 0 0

sollte so aussehen:

/dev/sda3 / ext3 defaults 0 1

Deine menu.lst sieht auch okay aus.
Mit was ich mich nicht auskenne sind die Einträge von der gewissen Firma (/dev/sda1), ob das nach /media gemountet wird - keine Ahnung.

Hast du die Wiki-Einträge schon gelesen?

http://wiki.archlinux.org/index.php/Reinstalling_GRUB
http://wiki.archlinux.org/index.php/GRUB

Jean-Paul

Offline

#5 08.04.2007 23:04:40

MacWolf
Mitglied

Re: Kann Grub nicht installieren

ext 3 überprüfen ist aber recht egal wink ist ein journal system und das muss genau genommen nicht überprüft werden

Offline

#6 09.04.2007 09:36:44

the_gamer
Mitglied

Re: Kann Grub nicht installieren

Ich habe mal eine Frage dazu, entweder verstehe ich etwas nicht richtig oder es könnte weiterhelfen.

Warum stehen in der fstab und in der mtab sd* und in grub hd* ? Müssten das nicht dieselben Bezeichnungen sein ?

Offline

#7 09.04.2007 09:45:51

dongiovanni
Mitglied

Re: Kann Grub nicht installieren

Es steht in keinerlei Beziehung. GRUB verwendet nicht das Schema von Linux, sondern ein eigenes.

Offline

#8 09.04.2007 11:42:08

the_gamer
Mitglied

Re: Kann Grub nicht installieren

dongiovanni schrieb:

Es steht in keinerlei Beziehung. GRUB verwendet nicht das Schema von Linux, sondern ein eigenes.

Dass die Partionen anders bezeichnet werden, wusste ich, hda1 ist ja z.B. in grub hd0,0 aber ich meine auch nicht die Partitionen sondern die devicenamen. Einmal wird auf sd* bezogen und einmal auf hd*. Müsste es nicht beide Male hd* oder sd* sein ? Bei mir steht bei beiden hd*

Kann mir das jemand erklären ?

Offline

#9 09.04.2007 11:54:52

Domi2007
Mitglied

Re: Kann Grub nicht installieren

Hat sich erledigt,
ich hatte keine Bootpartition erstellt, deshalb wusste Grub nich wohin, hab den Fehler behoben, jetzt äuft alles smile

Danke für eure Hilfe

Gruß
Domi

Offline

#10 09.04.2007 12:43:30

dongiovanni
Mitglied

Re: Kann Grub nicht installieren

newbie schrieb:
dongiovanni schrieb:

Es steht in keinerlei Beziehung. GRUB verwendet nicht das Schema von Linux, sondern ein eigenes.


Dass die Partionen anders bezeichnet werden, wusste ich, hda1 ist ja z.B. in grub hd0,0 aber ich meine auch nicht die Partitionen sondern die devicenamen. Einmal wird auf sd* bezogen und einmal auf hd*. Müsste es nicht beide Male hd* oder sd* sein ? Bei mir steht bei beiden hd*

Kann mir das jemand erklären ?

Bei GRUB gibt es nur hd*, ist einfahc so. Es bezeiht die Informationen vom BIOS. Seit Kernel 2.6.19 gibt es im Linuxkernel nur noch die bezeichnung sd*, hd* wird nur noch bei ide-legacy verwendet und über kurz oder lang verschwinden.

Offline

#11 09.04.2007 12:53:46

the_gamer
Mitglied

Re: Kann Grub nicht installieren

Danke dongiovanni.

Ich habe den neuesten Kernel und bei mir gehts auch noch mit hd * smile

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums