Du bist nicht angemeldet.

#1 19.02.2006 03:09:17

Binaer
Gast

Widescreen Auflösung

Hallo Zusammen

Ich habe nun Arch auf meinem Laptop aufgesetzt der eine Auflösung von 1280x800 hat.
In KDE kann ich allerdings nur Auflösungen von 640x350 bis 1024x768 einstellen.
Ich habe schon verschiedene Varianten versucht in /etc/X11/xorg.conf einzutragen, allerdings ohne Erfolg.
Obwohl in xorg.conf nur die Auflösungen 1024x768 und 1280x800 eingetragen sind, kann ich in KDE zwischen 1024x768 und diversen darunter auswählen. Ausserdem zeigt KDE (Switch & Rotate) an, dass ich eine Refresh Rate von 0Hz hätte.

Meine xorg.conf:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "extmod"
Load "record"
Load "dbe"
Load "xtrap"
Load "glx"
Load "dri"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de_CH"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
#ModeLine "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828 +HSync +Vsync
#ModeLine "1024x768" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync

EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "DefaultRefresh" # [<bool>]
Identifier "Card0"
Driver "vesa"
VendorName "ATI Technologies Inc"
BoardName "Unknown Board"
BusID "PCI:3:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
# Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
# Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
# Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
# Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
# Viewport 0 0
Modes "1024x768"
Depth 16
EndSubSection
SubSection "Display"
# Viewport 0 0
Modes "1024x768"
Depth 24
EndSubSection
EndSection

Gruss Nicolas

#2 19.02.2006 12:23:53

MacWolf
Mitglied

Re: Widescreen Auflösung

wie hast du die xorg erstellt?

Offline

#3 19.02.2006 13:34:15

Binaer
Gast

Re: Widescreen Auflösung

Ich habe sie mit "Xorg -configure" erstellt und nacher noch ein bischen bearbeitet bis der Xserver wieder startete... Wenn ich xorgconfig verwende funktioniert nacher der Xserver nicht mehr und wenn ich hwd verwende funktionieren die alt Tasten nicht.

#4 19.02.2006 15:02:47

MacWolf
Mitglied

Re: Widescreen Auflösung

ja das mit dem alttasten lässt sich aber beheben...mh...
also erstmal:
versuch mal das in deiner Screen "abteilung" (das ist meine musst sie also vll ein bisschen verändern)

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultColorDepth 16
	SubSection "Display"
		Depth     1
		Modes "1152x864" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     4
		Modes "1152x864" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes "1152x864" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     15
		Modes "1152x864" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes "1152x864" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes "1152x864" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     32
		Modes "1152x864" "800x600" "640x480"
	EndSubSection
EndSection

ansonsten mal mit hwd versuchen (hwd -a war das glaub ich) und dann was sagen dann sag ich dir was du noch umstellen musst

Beitrag geändert von MacWolf (19.02.2006 15:05:16)

Offline

#5 19.02.2006 15:06:19

Pierre
Entwickler

Re: Widescreen Auflösung

Ersetze doch mal Modes "1024x768" durch Modes "1280x800". In der xorg.conf von Dir wird ja auch nur die kleinere Auflösung erwähnt.

Und btw.: Du solltest den richtigen Treiber für Deine Karte verwenden; vesa ist nicht zu gebrauchen.

Beitrag geändert von Pierre (19.02.2006 15:08:09)

Offline

#6 19.02.2006 15:14:04

MacWolf
Mitglied

Re: Widescreen Auflösung

jap das stimmt geht auch.... so hab ich meine auflösung von 1024 auf 1152 gebracht... nur das mit den 0Hz ist nicht normal-> da scheint was zu fehlen

Offline

#7 20.02.2006 00:56:16

Binaer
Gast

Re: Widescreen Auflösung

Super, es funktioniert!

Ich habe einfach die ati-treiber richtig installiert und dann das aticonfig tool benutzt.
Nun erscheinen zwar noch diverse Auflösungen zur Auswahl die ich nirgendwo definiert habe (was ja eigentlich egal ist), aber die 1280x800 funktioniert und die refresh rate zeigt 60Hz an.

Danke!!!
Gruss Nicolas

#8 20.10.2006 20:12:38

Heibo
Mitglied

Re: Widescreen Auflösung

hat zwar nur indirekt mit diesem Thread zu tun, wollte nicht extra einen neuen aufmachen smile aber ich bräuchte mal hilfe für meinen Framebuffer, hab mir mal nen neuen Monitor gegönnt - ist es möglich den FB in 1680x1050 laufen zu lassen? (Wenn ja, wie? ^^) Ich nutze grub und hab da noch irgendwas in erinnerung mit dem "vga=" Wert aber ich finde überall nur Infos bis zu einer Auflösung von 1280x1024 sad

Beitrag geändert von Heibo (20.10.2006 20:13:46)

Offline

#9 21.10.2006 19:42:03

jakob
Mitglied

Re: Widescreen Auflösung

Also ich benutz unter X 1280x1024, für den Framebuffer hab ich aber "vga=773" ausgewählt, was glaube ich für 1024x768 konzipiert ist. Sieht aber trotzdem recht schick aus bei mir. Evtl. probierst du es mal mit dieser Einstellung?

In /boot/grub/menu.lst findest du übrigens eine kleine Tabelle, die das erklärt:

#  FRAMEBUFFER RESOLUTION SETTINGS
#     +-------------------------------------------------+
#          | 640x480    800x600    1024x768   1280x1024
#      ----+--------------------------------------------
#      256 | 0x301=769  0x303=771  0x305=773   0x307=775
#      32K | 0x310=784  0x313=787  0x316=790   0x319=793
#      64K | 0x311=785  0x314=788  0x317=791   0x31A=794
#      16M | 0x312=786  0x315=789  0x318=792   0x31B=795
#     +-------------------------------------------------+

Offline

#10 21.10.2006 22:13:29

Heibo
Mitglied

Re: Widescreen Auflösung

danke hellwoofa smile mein FB rennt auch unter 1024x768 aber das sieht halt alles bissel matschig aus, weil es dann so gestreched wird sad. Ne Widescreen Auflösung wär mal n1 smile

edit: danke für die Tabelle, die hab ich mal gelöscht damals wink

Beitrag geändert von Heibo (21.10.2006 22:14:52)

Offline

#11 21.10.2006 22:19:41

Pierre
Entwickler

Re: Widescreen Auflösung

Es gibt irgendwie fb-ng oder so; da sollten so Auflösungen möglich sein. Könnte sein, daß es im beyond-Kernel mit drin ist.

Offline

#12 22.10.2006 21:18:23

Heibo
Mitglied

Re: Widescreen Auflösung

hmm, da find ich irgendwie keine Infos drüber, aber danke erstmal - werd mich mal schlaumachen smile

Offline

#13 23.10.2006 18:12:15

SiD
Mitglied

Re: Widescreen Auflösung

falls du eine ATI (Radeon) hast:

im standart kernel gibt es den Radeon-Framebuffer --> radeonfb

edit: jedenfalls bei den original kerneln von kernel.org ...

Beitrag geändert von SiD (23.10.2006 18:13:09)

Offline

#14 24.10.2006 22:34:46

Heibo
Mitglied

Re: Widescreen Auflösung

benutz wohl die sourcen von kernel.org, allerdings mit 'ner Nvidia sad. Aber danke erstma für eure Mühe - habs mal auf 1280x1024 gestellt, das sieht schon annehmbarer aus wink. Ich werd es wohl erstmal so lassen, bis ich eine Lösung gefunden habe.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums