Du bist nicht angemeldet.

#1 06.10.2006 21:19:25

dongiovanni
Mitglied

Beryl ohne Fensterdekoration!

hallo zusammen!

ich hab versucht, beryl mit dem neuen nvidia beta-treiber zu menutzen! der treiber funktioniert, beryl soweit auch. ich seh die effecte, wenn menüs ausklappen, aber mir fehlt die fensterdekoration!

ich starte beryl in kde wie in der wiki auf archlinux.org beshrieben. ich starte beryl-start und beryl-manager mit dbus-launch!

muss ich sonst noch was starten?

Beitrag geändert von dongiovanni (06.10.2006 21:21:30)

Offline

#2 06.10.2006 21:45:05

dongiovanni
Mitglied

Re: Beryl ohne Fensterdekoration!

problem hat sich erledigt....war zu doof, die xorg.conf richtig zu editieren! AddARGBGLXVisuals will nen boolschen wert und nicht "Enable"!!!

Offline

#3 07.10.2006 17:06:31

Brwlr
Gast

Re: Beryl ohne Fensterdekoration!

Hi.
hab das gleiche problem,
kannst du bitte dein ausschnitt der xorg posten?
gruß

#4 08.10.2006 16:34:58

TheTwister
Mitglied

Re: Beryl ohne Fensterdekoration!

was mach ich eigentlich falsch?
ich hab ne geforce fx 5200 (256 mb) und wenn ich die beta treiber verwende hab ich nur nen schwarzen bildschirm wenn x startet, und der xserver reagiert auf nichts mehr...

Offline

#5 08.10.2006 19:18:56

dongiovanni
Mitglied

Re: Beryl ohne Fensterdekoration!

also ich poste mal meine xorg.conf:

Section "ServerLayout"
	Identifier     "Layout0"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Mouse0" "CorePointer"
	Option         "AIGLX" "true"
EndSection

Section "Files"
EndSection

Section "Module"
	Load "freetype"
	Load  "extmod"
	Load  "glx"
	Load  "dri"
	Load  "dbe"
	Load  "record"
	Load  "xtrap"
	Load  "type1"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "ImPS/2"
	Option	    "Device" "/dev/input/mice"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "de"
	Option      "XkbVariant" "nodeadkeys"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
EndSection

Section "Device"
	Identifier  "Card0"
	Driver      "nvidia"
	Option      "AddARGBGLXVisuals" "true"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024"
	EndSubSection
EndSection

Section "Extensions"
	Option "Composite" "Enable"
EndSection

das problem mit schwarzem bildschirm haben anscheinend viele. schau mal ob die xorg.conf stimmt! ansonsten ließ dir mal den thread zum beta treiber auf dem enlischen forum durch!

Beitrag geändert von dongiovanni (08.10.2006 19:23:04)

Offline

#6 10.10.2006 17:45:24

TheTwister
Mitglied

Re: Beryl ohne Fensterdekoration!

mh, danke für die hilfe, ich hab gestern auch im englischen forum nachgelesen und probiert. leider ohne erfolg. was ich mich frage ist hast du die treiber aus dem aur oder von brain0's repo?

grüße alex

Offline

#7 10.10.2006 18:42:33

dongiovanni
Mitglied

Re: Beryl ohne Fensterdekoration!

ich habe die die pakete von pierre genommen: ~pierre/packages

Offline

#8 10.10.2006 18:51:06

Pierre
Entwickler

Re: Beryl ohne Fensterdekoration!

Aus der xorg.conf würde ich dri und aiglx mal rausnehmen. Das Problem mit den Fensterdekos oder dem schwarzen Schirm hatte ich ab einer bestimmten beryl-Version dann auch. Es soll wohl helfen, das Ding dann einfach nochmal zu starten. wink

Offline

#9 10.10.2006 20:45:59

dongiovanni
Mitglied

Re: Beryl ohne Fensterdekoration!

also bei mir funktionierts mit den zwei dingen....

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums