Du bist nicht angemeldet.

#1 14.06.2006 18:19:07

TheGrudge
Mitglied

Komisches Locales-Problem

Habe ein komisches Problem, naja eigentlich ist es ja keins, aber dennoch:

Ich mag keine deutsche Übersetzung in Software, also habe ich meine locales auf en_US.utf8 gesetzt.
Nur Tastatur ist auf de gestellt:

LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="Europe/Berlin"
KEYMAP="de"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

Naja nun starte ich kdm und will mein Passwort eintippen, dann sagt er auf einmal:
"login failed".

"Aha" denke ich mir, die Tastatur ist wohl auf englisch, also Passwort nochmal mit englische Tastenbelegung eingegeben, geht schon wieder nicht...

Nun dann halt mal neu starten und sehen was passiert... und nun kann ich mich auf einmal anmelden, aber komischerweise wird mein Passwort falsch dargestellt! Eigentlich dürfte es gar nicht funktionieren...

Beispiel:
Ich tippe in das Feld vom Benutzernamen mein Passwort ein, sagen wir "abc-def", nun erscheint aber dort der Schriftzug "abc?def", also doch eigentlich das falsche Passwort.
Trotzdem geht der Login, wieso ist das so?

Ist meine Tastatur deutsch, und KDM baut die Zeichen während der Anzeige um?
Kann mir das nicht erklären.

In KDE ist alles wieder auf Deutsch, da habe ich ja meine Tastenbelegung auf Deutsch gestellt.

Offline

#2 14.06.2006 18:22:12

TheGrudge
Mitglied

Re: Komisches Locales-Problem

Achja:

Hatte auch mal den XServer auf Deutsch gesetzt, damit KDE das nicht für mich übernehmen muss und ich in anderen WMs auch eine deutsche Tastatur habe, aber dann passiert was noch viel komischeres. Hier der Eintrag in der xorg.conf:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
EndSection

X fährt hoch, aber ich kann mich in KDM nicht einloggen, OBWOHL mein Passwort im Benutzerfeld (also das ohne die Sternchen) richtig angezeigt wird!
Versuche ich es dann so einzugeben, als hätte ich eine englische Tastatur, kann ich mich aber AUCH NICHT einloggen!

Was ist das denn?

Sehr komisch das alles!

Offline

#3 18.06.2006 15:23:03

dejot
Mitglied

Re: Komisches Locales-Problem

afair müsste die zeile in der rc.conf lauten:

KEYMAP="de-latin1-nodeadkeys"

Offline

#4 23.06.2006 14:20:57

TheGrudge
Mitglied

Re: Komisches Locales-Problem

ich habe noch ein Problem gefunden:
ich kann mich nicht als normaler User in der Konsole einloggen.
Ich habe folgende Passwortstruktur: "bb-zzzz"
wobei b = Buchstabe und z = Ziffer.

Ich kann mich einfach nicht einloggen, auch wenn ich versuche es wie mit einer englischen Tastatur einzutippen. KDM funktioniert komischerweise...

habe auch KEYMAP="de-latin1-nodeadkeys" gesetzt.

Was muss man denn da noch alles beachten?

Offline

#5 23.06.2006 14:22:17

TheGrudge
Mitglied

Re: Komisches Locales-Problem

Anmerkung: Das hat jetzt bestimmt nix mit dem User an sich zu tun, sondern mit dem Passwort.
Mein root-Account hat ein Passowrt ohne Sonderzeichen, y oder z, somit tippt es sich wohl auch so wie es bei englischen Locales standard wäre...

und nochwas:
wenn ich bei login ein "-" eintrage, steht es auch da, d.h. doch das die Passworteingabe gar nicht falsch sein kann...

Beitrag geändert von TheGrudge (23.06.2006 14:23:35)

Offline

#6 31.08.2006 10:48:33

svens
Mitglied

Re: Komisches Locales-Problem

wenn du die xorg.conf aus einer anderen installation übernommen hast versuch mal unter driver "keyboard"

viel glück

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums