Du bist nicht angemeldet.

#1 04.04.2007 10:07:23

intensief
Mitglied

kann nur per pacman -Sf installieren

Hi,
wenn ich ein Paket installieren will versucht er immer die schon installierten Abhängigkeiten mitzuinstallieren, bricht aber mit der Meldung ab:
root@archie# Fehler: Konnte die Transaktion nicht vorbereiten
Fehler: Konnte den Vorgang (In Konflikt stehende Dateien) nicht durchfhren
"foo" existiert im Dateisystem

es hilft nur ein pacman -Sf foo , der dann alle Abhängigkeiten wieder neu installiert sad
Ich habe mir mal aus versehen die /var/lib/pacman/local gelöscht, liegt es daran, wie kann ich die neu bauen?

etwas ratloser Gruss
Benedikt

Offline

#2 04.04.2007 10:13:50

Pierre
Entwickler

Re: kann nur per pacman -Sf installieren

/var/lib/pacman/local zu löschen ist ziemlich schlecht, da pacman dann nicht mehr weiß, welche Pakete installiert sind. Du kannst versuchen alle Pakete anhand von pacman.log neu zu installieren.

Offline

#3 04.04.2007 10:22:50

intensief
Mitglied

Re: kann nur per pacman -Sf installieren

Na immerhin etwas.
Gelöscht hab ich es damals wohl wegen einer obskuren Fehlermeldung, etwa so:
:: nicht gefunden

EDIT:
pacman -S mutt

jede Menge Fehler openssl: /usr/man/man1/openssl_s*** existiert im Dateisystem
Fehler aufgetreten, keine Pakete wurden aktualisiert.

----

pacman -S mutt
Installation fortsetzen? [J/n]
Prfe Paketintegritt... fertig.
Rume auf... fertig.
(1/3) Installiere ncurses [#####################] 100%
(2/3) Installiere openssl [#####################] 100%
(3/3) Installiere mutt [#####################] 100%

warum will er immer wieder ncurses und openssl installieren?

Gruss
Benedikt

Beitrag geändert von intensief (04.04.2007 10:41:04)

Offline

Fußzeile des Forums