Du bist nicht angemeldet.

#1 28.10.2006 15:10:47

BehindTheScenes
Gast

Xgl für x64 arch

Hi,

wo kann man xgl für x64 arch linux downloaden???

habe die anleitung auf archwiki befolgt, aber jetzt geht mein firefox gaim etc nicht, kommt en error:
libcairo.so:2
irrgend was mit ELFCLASS32

#2 28.10.2006 15:11:49

Pierre
Entwickler

Re: Xgl für x64 arch

Was hast Du für eine Grafikkarte? XGL braucht man eigentlich nicht mehr.

Offline

#3 28.10.2006 15:14:48

Gast
Gast

Re: Xgl für x64 arch

Ich habe eine Ge-Force 7900 GT wink

ein MSI Mainboard K8N SLI

#4 28.10.2006 15:17:23

Pierre
Entwickler

Re: Xgl für x64 arch

Gut, Du brauchst kein XGL, aber die nvidia-Beta-Treiber um beryl zum Laufen zu kriegen:~pierre/packages/x86_64/

Offline

#5 28.10.2006 15:21:13

BehindTheScenes
Gast

Re: Xgl für x64 arch

was ist beryl?

#6 28.10.2006 15:24:20

Pierre
Entwickler

Re: Xgl für x64 arch

Der Fork von compiz.

Offline

#7 28.10.2006 15:29:39

Gast
Gast

Re: Xgl für x64 arch

wie ich sehe sind hier ~pierre/packages/x86_64/ nur x86 libs ... keine x64

#8 28.10.2006 15:35:47

Pierre
Entwickler

Re: Xgl für x64 arch

Was ist bei Dir denn x64? Also die Pakete im angegebenen Verzeichnis sind für x86_64 bzw. amd64.

Offline

#9 28.10.2006 15:36:43

Gast
Gast

Re: Xgl für x64 arch

ja aber da steht lib32_*

d.h das die für 32 bit prozessor sind ... net für die 64 bit version wink

war immerschon so wink

#10 28.10.2006 15:39:37

Pierre
Entwickler

Re: Xgl für x64 arch

Du sollst ja auch nur nvidia-beta-* installieren (utils und den passenden Treiber). Die lib32-Pakete sind 32-Bit-Pakete für Arch64.

Offline

#11 28.10.2006 15:41:34

Gast
Gast

Re: Xgl für x64 arch

ahh, ok
aber habe schon nvidia treiber von der nvidia page ...
außerdem habe ich ja kommisches problem mit firefox, gaim etc ...halt alles was libcairo braucht, komme gleich wieder ins linux rein und mache dann neuen thread mit error etc auf

#12 28.10.2006 15:44:30

Pierre
Entwickler

Re: Xgl für x64 arch

Naja, Du solltest alle Schritte wieder rückgängig machen und XGL loswerden.

Offline

#13 28.10.2006 15:50:41

Gast
Gast

Re: Xgl für x64 arch

ok, wie den?

habe bis jetzt nur pacman benutzt wink

#14 28.10.2006 17:27:33

dongiovanni
Mitglied

Re: Xgl für x64 arch

Du solltest die XGL-Pakete, die du mit pacman installiert hast, wieder deinstallieren!

Zur Zeit ist die ganze Angelegenheit mit 3D-beschleunigten Desktops noch sehr instabil und experimentell! Man sollte sich mit der Materie auskennen! XGL ist mitlerweile obsolet.

Die x86_64 Arch Version hat zur Zeit ebenfalls noch wenig zustrom und es fehlt deswegen noch an Paketen. Wenn du dich noch nicht so viel mit Linux beschäftigt hast, solltest du die reguläre Version nehmen (ich weiß leider nicht, wie weit du dich mit Linux auskennst).

Deine Fehler mit firefox hängen wahrscheinlich damit zudammen, das die Bibiliothek und die Programme enmal für 64 einmal für 32 bit kompiliert wurden...

Beitrag geändert von dongiovanni (28.10.2006 17:29:17)

Offline

#15 03.11.2006 15:18:31

jakob
Mitglied

Re: Xgl für x64 arch

Wie darf ich das verstehen, dass XGL obsolet ist?

Hat AIGLX die selben Funktionalitäten, nur dass es bereits im Standard x.org integriert ist?

Offline

#16 03.11.2006 15:28:10

dongiovanni
Mitglied

Re: Xgl für x64 arch

Sofern dein Grafiktreiber AIGLX unterstütz, ist das die bessere Wahl, weil es bereits im normalen X.org integreirt ist! Es bietet auf jeden Fall die gleiche Funktionalietät, evtl. sogar mehr, was ich aber nicht genau weiß!

Die Unerstützung für AIGLX bringen zur Zeit die NVIDIA beta Treiber und die Treiber von X.org.

Offline

#17 03.11.2006 15:36:46

jakob
Mitglied

Re: Xgl für x64 arch

Also momentan müsste ich noch testing aktiviert haben, um AIGLX nutzen zu können?

Ab welcher Versionsnummer unterstützen die NVIDIA-Treiber AIGLX denn?

Offline

#18 03.11.2006 15:42:01

dongiovanni
Mitglied

Re: Xgl für x64 arch

Es wird seit 1.0-9625 unterstützt.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums