Du bist nicht angemeldet.

#1 21.09.2006 17:25:11

microtux
Mitglied

X will nicht

habe heute zum 3. mal innerhalb 2 tagen arch installiert, bekomm aber mein X einfach nicht..

ich habe in der installation "base" und "X11" ausgewählt, nur font-misc-ethiopic nicht, weil es mit dem nicht gegangen ist, aber das habe ich jetzt nachinstalliert

gebe ich jetzt als user in der konsole "startx" ein, 'wechselt' er mir sogar in den grafikmodus aber am bildschirm steht nur "out of range 59hz / 64 kHz"

folgende fehler stehen in der konsole:

(EE) Unable to locate/open config file
(EE) Failed to load module "ati" (module does otexist, 0)
(EE) Failed to load module "fbdev" (module does not exist,0)
(EE) Failed to oad module "vga" (module doe not exist,0)

woran kann es liegen?

Offline

#2 21.09.2006 17:28:16

MacWolf
Mitglied

Re: X will nicht

du hast dir eine xorg.conf womit angelegt?

Offline

#3 21.09.2006 17:52:52

danlei
Mitglied

Re: X will nicht

Probier mal:

# Xorg -configure

und kopiere die neue xorg.conf nach /etc/X11.

HTH

Offline

#4 21.09.2006 19:17:41

dongiovanni
Mitglied

Re: X will nicht

hallo microtux!

ich glaube ich weiß was dein problem ist! seit xorg 7.0 ist x.org modular, d.h. die treiber sind extra pakete! ati, fbdev und vga sind diese! wenn du einen davon in der xorg.conf benutzt, musst du ihn erst einzeln mit pacman installieren!

wenn du mir deine karte sagst, kann ich dir den richtigen treiber nennen (ich weiß nicht, wie gut du linux kennst!!!)

die treiberpakete sind:

fbdev:
xf86-video-fbdev

ati:
xf86-video-ati

vga:
xf86-video-vga

du brauchst aber nicht alle installieren! nur den, den du in der xorg.conf benutzt! ich denke mal das das der ati ist, da das der erste ist, der genannt ist!!! pakete einfach mit pacman -Sy installieren und dann müsste es gehen!

Offline

#5 22.09.2006 11:02:31

microtux
Mitglied

Re: X will nicht

Wolf schrieb:

du hast dir eine xorg.conf womit angelegt?

# xorgconfig

# Xorg -configure
und kopiere die neue xorg.conf nach /etc/X11.

Viele Fehler, zB
(EE) module ABI major version (1) doesn't match the server's version (0)
(EE) Failed to load module "vga" (mdule requirement mismatch, 0) - das selbe mit radeon und ati
(EE) Failed to load /usr/lib/xorg/modules/drivers/atimisc_drv.so
(EE) Failed to load module "atimisc" (loader failed, 7)

Die Pakete von DonGiovanni hab ich alle installiert, und jetzt gebe ich als user ein # startx

Er springt wieder in den Grafikmodus, schreibt wieder out of range "59hz / 64 kHz" und springt dann wieder auf die Konsole, wo folgendes steht

hostname: Unknown host
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 22 17:00:53 2006"
(==) Using config file: "/etc/X11/xorg.conf"

waiting for X server to sut down FreeFontPath: FPE "/usr/sahre/fonts/misc" refcount is 2, should be 1; fixing.

sonst ist nichts auffälliges dabei..

Andere Frage, gibt es irgendwo ein detailliertes HowTo (richtig "einfach", Schritt für Schritt) zum Installieren eines X systems?

MfG

Offline

#6 22.09.2006 14:08:25

dongiovanni
Mitglied

Re: X will nicht

du hast die installation ja schon fast geschafft! da du (denke ich mal) keine .xinitrc datei im home verzeichniss hast, beendet sich x wieder! um zu testen ob X.org geht, gib einfach mal den befehl "X" ein danach startet X.org! falls es klappt, siehst du nen mauszeiger! um es anschließend wieder zu beenden, drückst du Strg+Alt+Backspace jetzt brauchst du nur noch einen loginmanager, windowmanager oder gleich ein ganzes desktop environment wie KDE oder GNOME aussuchen und installieren ( jemand sollte mal eine wiki seite schreiben....vielleich tu ich mal)

Offline

#7 22.09.2006 15:26:02

microtux
Mitglied

Re: X will nicht

dongiovanni schrieb:

du hast die installation ja schon fast geschafft! da du (denke ich mal) keine .xinitrc datei im home verzeichniss hast, beendet sich x wieder! um zu testen ob X.org geht, gib einfach mal den befehl "X" ein danach startet X.org! falls es klappt, siehst du nen mauszeiger! um es anschließend wieder zu beenden, drückst du Strg+Alt+Backspace jetzt brauchst du nur noch einen loginmanager, windowmanager oder gleich ein ganzes desktop environment wie KDE oder GNOME aussuchen und installieren ( jemand sollte mal eine wiki seite schreiben....vielleich tu ich mal)

.xinitrc habe ich schon im home verzeichniss!
befehl X - funktioniert
dann habe ich gnome und gdm installiert, in die .xinitrc "exec gnome-session" eingetragen und jetzt wird folgende fehlermeldung ausgegeben:

gnome-session: error while loading shared libaries: libexpat.so.0: cannot open shared object file: No such file or directory

waiting for X server to shut down...

Offline

#8 22.09.2006 16:54:57

MacWolf
Mitglied

Re: X will nicht

dann ist dein system nicht aktuell
oder der mirror...was für mirror benutzt du?

expat ist installiert oder?

pacman -Qs expat

Offline

#9 24.09.2006 21:50:11

microtux
Mitglied

Re: X will nicht

expat ist aktuell

mein system: 2.6.16 - arch #1 smp preempt ....

mirrors sind einige drinnen, welche brauchst du genau?
MfG

Offline

#10 24.09.2006 22:20:58

MacWolf
Mitglied

Re: X will nicht

die ersten

also von jedem repo nur den ersten

Beitrag geändert von MacWolf (24.09.2006 22:21:15)

Offline

#11 24.09.2006 22:40:38

microtux
Mitglied

Offline

#12 24.09.2006 22:41:53

MacWolf
Mitglied

Re: X will nicht

nein!
die repos!

also...
[current] und [extra]

Offline

#13 24.09.2006 22:46:54

microtux
Mitglied

Re: X will nicht

in /etc/pacman.d ?
ich hoffe du meinst folgendes:

[extra]
# north america
server = ftp://ftp.nethat.com/pub/linux/archli...

[current]
# north america
server = ftp://ftp.archlinux.org/current/os/i686

wenn du das nicht meinst was genau dann?

Offline

#14 24.09.2006 23:41:54

MacWolf
Mitglied

Re: X will nicht

beide gleich machen!

also

[extra]
# north america
server = ftp://ftp.archlinux.org/extra/os/i686

dann ein pacman -Syu machen

Beitrag geändert von MacWolf (24.09.2006 23:42:43)

Offline

#15 24.09.2006 23:48:17

microtux
Mitglied

Re: X will nicht

Wolf schrieb:

beide gleich machen!

also

[extra]
# north america
server = ftp://ftp.archlinux.org/extra/os/i686

dann ein pacman -Syu machen

ich muss jetzt 200 mb runterladen, danach sollte X funktioniern oder?

edit:in der extra stehen jetzt 2x
ftp://ftp.archlinx.org... einmal unter north america, einmal unter europe

Beitrag geändert von microtux (24.09.2006 23:50:21)

Offline

#16 25.09.2006 06:46:02

MacWolf
Mitglied

Re: X will nicht

och egal

na...obs danach funktioniert werden wir sehen

Offline

Fußzeile des Forums