Du bist nicht angemeldet.

#2726 07.10.2019 09:54:45

schard
Moderator

Re: Motzraum

Toll, in Version 2 des neuen base Pakets schreiben die Core Devs einem nun vor, systemd-sysvcompat zu installieren, auch wenn man es überhaupt nicht benötigt.
Grrr....

Offline

#2727 07.10.2019 23:03:41

Dirk
Moderator

Re: Motzraum

Och nee … Ich hab das seit Jahren nicht mehr installiert, und war ganz happy, dass das endlich nicht mehr standardmäßig das System vollmüllt.

Ich ging inzwischen sogar davon aus, dass das Paket deprecated ist.

Edit: https://bugs.archlinux.org/task/64071

Beitrag geändert von Dirk (10.10.2019 13:28:11)

Offline

#2728 13.10.2019 19:36:27

TBone
Mitglied

Re: Motzraum

Schard hat mich Troll genannt :'(

Offline

#2729 13.10.2019 20:42:34

sanni
Mitglied

Re: Motzraum

Nicht ganz richtig:  Foren-Troll.
Außerdem, versuch es doch mal mit Selbstreflexion!?

Offline

#2730 13.10.2019 20:45:14

TBone
Mitglied

Re: Motzraum

big_smile big_smile big_smile

Offline

#2731 13.10.2019 20:45:58

TBone
Mitglied

Re: Motzraum

Also ich sollte dich ja jetzt nicht beleidigen, aber ... big_smile

Offline

#2732 31.10.2019 15:27:11

TBone
Mitglied

Re: Motzraum

Alter...
Gestern Abend ein Update gemacht (darunter iwd).
Hat mich direkt genervt, dass die main.conf wieder aus dem Paket heraus genommen wurde, vor 3 Packaging-Releases wurde sie erst rein genommen (mMn korrekterweise).
.pacsave wieder zurück verschoben, dann iwd direkt neu gestartet um zu sehen, ob alles klappt -> geht.
Heute morgen, Netzwerk verbindet sich nicht. Gesehen: Aha, es gibt nicht nur UseDefaultInterface (welches ich bereits aktiviert habe), sondern auch noch 80-iwd.link, welche dafür sorgt, die (Schimpfwort) Interfacenamen wlan* beizubehalten. (Was aber erst nach einem Neustart von networkd geschieht, weshalb es gestern abend nicht gestört hat, da ich nicht wusste, dass der iwd da herumpfuscht)
Ok, Config überschrieben, alte Namen (wlpXYZ). iwd baut nun eine Verbindung auf, aber systemd-networkd bekommt keine dynamische IP zugewiesen.
Also wollte ich nach Updates schauen, ob iwd in einer neueren Version gefixt wurde. (Ich dachte, nur iwd wurde geupdated, liegt bestimmt daran)
Ich habe hier einen Router als WLan-Bridge für Notfälle konfiguriert: Per ETH angestöpselt -> Keine IP zugewiesen bekommen.
Also geschaut: Handy funktioniert in diesem WLan. Dann wollte ich USB-Tethering nutzen -> nun kommen beide Geräte nicht mehr ins WLan.
Anderes Telefon genommen, USB-Tethering über WLan -> Funktioniert. Kein relevantes Update vorhanden, sieht mir momentan aber eh nicht mehr nach einem Problem mit meinem Netzwerk Stack auf. Kontrolle: Verhalten mit wpa_supplicant + dhcpcd ist identisch.
Zwischen meinem Laptop und dem Gateway sitzen noch andere Geräte, also mal geschaut, wo es hakt.

Ergebnis: Der DHCP-Server hatte keine freien IPs mehr verfügbar.
Weshalb das zweite Handy ging? Es war im Gast-Netzwerk angemeldet -> anderer IP-Pool.
Alle Geräte gelöscht, die keine feste Adresse haben und die letzten X-Tage nicht mehr angemeldet waren, dann ging alles wie geschmiert.

Frustrierend, wenn man 20 Minuten braucht, um das WLan zum laufen zu kriegen.
Das gute: WLan-Bridge Router geupdatet und herausgefunden, für ein weiteres Gerät dazwischen ist der Quelltext öffentlich.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums