Du bist nicht angemeldet.

#1 26.03.2005 09:51:02

Annie Versary
Gast

Modul shpchp und nach Installation ins w3?

Hallo zusammen,

habe AL nach anfänglichen Problemen (Installer bietet für die Installation des bootloaders nur die Partitionen bis part9, ich wollte part13 - und habe das dann "zu Fuß" erledigt) installiert und kann es auch booten smile . Jetzt habe ich noch folgende Fragen:

1. Während des Bootvorgangs wird angezeigt "Can't load module shpchp", aber das wäre "not fatal". Kann mir bitte jemand sagen, um was für ein Modul es sich handelt (also wofür es 'eigentlich' da ist/wäre) und wie ich es korrekt laden lassen kann?

und

2. Wie komme ich nach der Installation des Basissystems ins Internet, um pacman auszuführen (zum Browsen mit anderen Distros benutze ich einen Router, auf den ich via Firefox zugreife; dort sind auch meine Zugangsdaten gespeichert; nach Eingabe eines Passworts klicke ich lediglich auf verbinden - und das war's)? Gibt es eine Konfigurationsdatei / ein Script, in die / das ich meine Zugangsdaten eintragen kann pp.?

Ich nehme an, mindestens die 2. Frage ist 'ne billige Anfängerfrage. Ihr braucht Euch nicht viel Zeit für die Beantwortung zu nehmen, falls so was nervt. Hinweis auf irgendeine Online-Fundstelle, in der das abgehandelt wird,reicht völlig.

Besten Dank im voraus...

Annie

#2 26.03.2005 15:08:18

MatrixP
Mitglied

Re: Modul shpchp und nach Installation ins w3?

zu 1: hab das gleiche Problem. Modul wird nicht geladen. Brauch es nicht, da auch alles so funzt :>:>:>

zu 2: in der /etc/rc.conf eth0="dhcp" eintragen. Und vor gateway ein "!" setzen, damit er deaktiviert wird.

wenn dein router kein dhcp unterstützt (wovon ich mal nicht ausgehe) findest du bei der gentoo installationsanleitung eine sehr gut doku zum ifconfig befehl. Dein modul für die netzwerkkarte muss natürlich geladen sein und funktionieren.

Willst du deine zugangsdaten auf deinem lokalen rechner ablegen? Ich glaub die sind besser auf dem router aufgehoben.

MatrixP

Offline

#3 26.03.2005 22:00:12

Annie
Gast

Re: Modul shpchp und nach Installation ins w3?

Hallo MatrixP,

vielen Dank!

Ich antworte schon unter AL lol . Ein paar Einstellungen muss ich zwar noch aendern (deutsches Tastaturlayout, Scrollrad, nVidia-Treiber pp.), aber im grossen und ganzen laeuft es schon. Ob AL allerdings wirklich die beste Linux-Distro der Welt und aller Zeiten ist oder die anderen besten Linux-Distros der Welt und aller Zeiten, habe ich fuer mich noch nicht entschieden big_smile .

Das Modul shpchp scheine ich auch nicht yu brauchen, aber interessieren wuerde mich natuerlich schon, wozu man es haette gebrauchen koennen, wenn es zu laden gewesen waere. Waere also schoen, falls jemand, der eine Idee hat, sich noch mal melden koennte.

Ciao, ciao...

Annie

#4 02.04.2005 11:06:42

Pierre
Entwickler

Re: Modul shpchp und nach Installation ins w3?

Das sollte in der Kernel-Config-Doku zu finden sein. Vielleicht mal xconfig starten und suchen.

Offline

#5 03.04.2005 16:59:47

Guzzio
Gast

Re: Modul shpchp und nach Installation ins w3?

Leider kann ich darüber nicht erstmal hinwegsehen. Ich habe gerade arch 0.7 base distribution installiert und erstmal alles bei den Voreinstellungen gelassen. Leider fährt das System nicht hoch, da is beim Booten hängt , und zwar bei der Stelle: startup hotplug daemon - mit der Fehlermeldung, dass er das modul shpchp nicht findet.
Wäre wirklich toll, wenn dazu jemand einen Rat hätte.

#6 03.04.2005 17:03:36

Pierre
Entwickler

Re: Modul shpchp und nach Installation ins w3?

Füge das Modul in die Blacklist ein. Als root folgendes ausführen könnte klappen:

echo "shpchp" >> /etc/hotplug/blacklist

Offline

#7 03.04.2005 18:56:18

guzzio
Gast

Re: Modul shpchp und nach Installation ins w3?

Vielen Dank, hat geholfen.
Es war allerdings etwas trickreich, da ich ja noch nicht im System war. Eine Störaktion über die Tastatur an dieser Stelle führte dazu, dass der boot-Vorgang weiterging und dann war ich drin und konnte shpchp in die blacklist eintragen. smile
Jetzt läuft das booten ohne Störung.

#8 03.04.2005 19:02:29

Pierre
Entwickler

Re: Modul shpchp und nach Installation ins w3?

Generell würde ich eh dazu raten, einen eigenen Kernel zu kompilieren. Der Arch-Standard-Kernel läuft auf keinem meiner Systeme so ideal.

Offline

#9 04.05.2005 21:44:01

chris78
Gast

Re: Modul shpchp und nach Installation ins w3?

Hi, habe gerade dasselbe Problem an meinem Laptop.
Leider geht der Bootvorgang nicht einfach weiter, sondern er bleibt richtig böse hängen...

guzzio, kannst du mal sagen, welche "Störaktion" wink du durchgeführt hast beim Bootvorgang?

hab jetzt alles mal gedrückt, aber er rennt jedesmal in den start des hotplugd rein und bleibt hängen.

Oder gibts ne Möglichkeit, dem grub mal ne option mitzugeben, das arch in ein anderes runlevel bootet, wo vielleicht der hotplud nicht geladen wird?

es reicht ja, wenn ich ein einziges Mal reinkomme und das besagte Modul auf die Blacklist setzen kann....

#10 04.05.2005 22:28:25

Pepinot
Gast

Re: Modul shpchp und nach Installation ins w3?

Ich weiß zwar auch nicht, von welcher "Störaktion" guzzio geredet hat, aber du könntest versuchen, entweder:

a) mit einer Live-CD zu booten, die fragliche Partition mounten und die blacklist-Datei editieren, oder

b) die grub-shell aufrufen ('e' drücken im Grub-Menü) und dann die Kernel-Parameter editieren. Z.B. startet der Parameter 'single' das System in den Single-User-Modus.

#11 05.05.2005 10:24:34

chris78
Gast

Re: Modul shpchp und nach Installation ins w3?

Danke, habs so ähnlich hingekriegt. Windoof hochgefahren, von da aus mit ext2ifs-Treiber schnell das modul rausgekickt, dann gings. Hatte grad keine Live-Cd zur Hand.

Leider bleibt der Hotplug Deamon trotzdem hängen, musste auch ihn rauswerfen. >:(

Probier es gerade nochmal mit dem 2.4er Kernel...

#12 05.05.2005 11:11:10

Pepinot
Gast

Re: Modul shpchp und nach Installation ins w3?

Vielleicht kannst du ja irgendwie herausfinden, welches Modul sich da quer stellt. Bekannt ist zumindest:

http://bugs.archlinux.org/index.php?d...ls&id=1712

#13 06.05.2005 11:24:06

chris78
Gast

Re: Modul shpchp und nach Installation ins w3?

momentan läuft die alte Kiste mit dem 2.4er Kernel, und es geht auch alles bis auf sound, was nicht sooo wichtig ist.

Hauptsache Netzwerk und ich kann wieder damit arbeiten.

Und was ich hauptsächlich erreichen wollte: Es ist alles nen Zacken flotter und schlanker als mit Xandros 3.0 oder Suse, das ist schonmal viel wert.

#14 06.05.2005 11:28:04

Pierre
Entwickler

Re: Modul shpchp und nach Installation ins w3?

Generell würde ich empfehlen den Kernel selbst zu kompilieren. Bei mir läuft der Standardkernel auch auf keinem Rechner wirklich gut. Hotplug startet dann auch wesentlich schneller. smile

Offline

#15 06.05.2005 22:22:07

chris78
Gast

Re: Modul shpchp und nach Installation ins w3?

Ja das Thema Kernel kompilieren werd ich mir demnächst mal reinziehen. Sobald ich dazu komme. wink

#16 07.05.2005 11:13:00

MatrixP
Mitglied

Re: Modul shpchp und nach Installation ins w3?

Also bei mir laufen die STOCK Kernel recht gut.

Hab mich trotzdem mal dran gemacht einen kernel selbst mit abs zu bauen. Hat auch auf anhieb funktioniert (hatte sonst nur mir gentoo meine kernel selbst gebaut). hab jetzt den 2.6.11.8 am laufen und er ist wesentlich schlanker als der stock kernel. Kann man jedem nur empfehlen wenn er mal ein bissl Zeit hat.

Mfg MatrixP

Offline

Fußzeile des Forums