Du bist nicht angemeldet.

#1 19.02.2005 01:24:20

Unrealius
Gast

Netzwerk geht nicht. [dhcp]

Hallo,

Ich hab' grad das erste mal Arch Linux installiert.

Wenn ich jetzt versuche meinen Router anzupingen steht da nur "Network is unreachable".

Wenn ich "dmesg | grep Ethernet" eingeb', steht da: "8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)"(keine Ahnung, ob das ne hilfreiche Information ist... lol).

In meiner rc.conf steht:"
lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo eth0)

gateway="default gw 192.168.2.1"
ROUTES=(gateway)
"

Ich weiß jetzt nicht, was ich tun soll... in der Doku hab ich auch nichts gefunden.

--Unrealius

#2 19.02.2005 11:02:34

dr.gonzo
Gast

Re: Netzwerk geht nicht. [dhcp]

> Wenn ich jetzt versuche meinen Router anzupingen steht da nur
> "Network is unreachable".
Kabel überprüfen. Hardware überprüfen. Erst mal schauen, ob es nicht irgendwas an der Hardware ist.

> Wenn ich "dmesg | grep Ethernet" eingeb', steht da: "8139cp: 10/100
> PCI Ethernet driver v1.2 (Mar 22, 2004)"(keine Ahnung, ob das ne
> hilfreiche Information ist... ).
Hast du das Kernelmodul für deine Netzwerkkarte geladen?
schau mal auf http://cdb.novell.com/index.php?LANG=de nach dem richtigen Treiber.

> In meiner rc.conf steht:"
> lo="lo 127.0.0.1"
> eth0="dhcp"
> INTERFACES=(lo eth0)
Ist in deinem Router DHCP aktiviert?

Ansonsten:
Im Forum suchen; http://wiki2.archlinux.org/index.php/...6%20Dialup

Gruss dr.gonzo

#3 19.02.2005 16:10:08

Unrealius
Gast

Re: Netzwerk geht nicht. [dhcp]

Danke für die Antwort. smile

Die Hardware funktioniert. Unter Windows, Gentoo, Ubuntu und FreeBSD ging's auch. wink

DHCP ist auch an.

Der Treiber ist wohl http://cdb.novell.com/showProduct.php...d=&dist_id .
Scheint ja geladen zu werden...? Muss ich da irgentwas einstellen? big_smile In der Doku stand man musses in /etc/modules.conf schreiben aber in der Datei steht, die ist nur für 2.4-Kernel? Ich glaube bei 2.6 muss man's in /etc/modprobe.conf schreiben oder? Hat die Datei die gleiche... erm... "Syntax"?

Ah, danke, das im Wiki scheint das Richtige zu sein. smile Ich versuch's dann mal.

#4 19.02.2005 17:22:05

Unrealius
Gast

Re: Netzwerk geht nicht. [dhcp]

Es gibt eth0 gar nicht. sad
Beim booten steht hinter "Starting Network" "[FAIL]". sad

Woran kann das liegen? Das richtige modul wird geladen. Denk ich.

#5 19.02.2005 18:10:51

Unrealius
Gast

Re: Netzwerk geht nicht. [dhcp]

Der Hotplugdämon geht auch nich... Kann irgentson Modul nicht laden... pciehp oder sowas... kann das daran liegen?

#6 20.02.2005 15:58:31

dr.gonzo
Gast

Re: Netzwerk geht nicht. [dhcp]

> Der Hotplugdämon geht auch nich... Kann irgentson Modul nicht
> laden... pciehp oder sowas... kann das daran liegen?
Wenn ich mich recht entsinne ist das irgendein Fehler in Hotplug oder sowas, vielleicht hilft es dir im englischen Forum mal zu suchen, da wurde der Fehler mal beschrieben. Glaube ich. Jedenfalls hatte ich den Fehler auch und hab mal danach gesucht ...

> Scheint ja geladen zu werden...?
lsmod sollte das Modul anzeigen.

> /etc/modules.conf schreiben aber in der Datei steht, die ist nur für
> 2.4-Kernel? Ich glaube bei 2.6 muss man's in /etc/modprobe.conf
> schreiben oder? Hat die Datei die gleiche... erm... "Syntax"?
Gleiche Syntax? Keine Ahnung. Gehört sowieso in rc.conf rein:
#
# Module to load at boot-up (in this order)
# (prefix a module with a ! to disable it)
#
MODULES=(!usbserial !ide-scsi ... hier das Modul eintragen)

Also schrittweise:
1. Das richtige Modul mit modprobe MODULNAME laden.
2. Mit
/etc/rc.d/network restart
das Netzwerk neu starten.
3. Gucken ob's läuft.
4. Wenn's läuft, den Modulnamen in rc.conf eintragen.

Gruss dr.gonzo

#7 21.02.2005 22:40:18

Pierre
Entwickler

Re: Netzwerk geht nicht. [dhcp]

Erstmal solltest Du versuchen ein "!" vor gateway in der rc.conf zu setzen. Prüfe, ob das Modul geladen ist (lsmod). Was gibt "ifconfig" aus?

Die Fehlermeldung mit hotplug kannst Du vernachlässigen. Du kannst das entsprechende Modul in die Balcklist eintragen. Es ist für PCI-Hotplug zuständig, was kaum einer hat. (Hotplug will das aber trotzdem immer laden)

Offline

#8 22.02.2005 11:06:34

Unrealius
Gast

Re: Netzwerk geht nicht. [dhcp]

Ich hab's gestern abend hingekriegt(mit Hilfe von welchen aus dem #archlinux.de-channel). 8139cp war das falsche Modul, mit 8139too geht's. Das Modul hatte ich Samstag schonmal getestet aber da hat's nicht geklappt. War wohl irgentwas noch falsch eingestellt.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums