#1 12.02.2005 18:38:07

INTRU
Gast

Login geht nicht mehr nach booten!

hallo

ich bin linux-neuling und habe folgendes problem:

ich habe heute morgen den rechner hochgefahren und denke an nichts böses.
aufeinmal steht folgendes auf dem bildschirm:

unable to determine your tty name

login geht nicht!

(name) login

beim booten habe ich gesehen, dass es folgende fehlermeldung gab:
/bin/sh error

SELTSAM!

ich würde mal gerne wissen, was da passiert ist und wie ich das jetzt wieder hinbekomme? ich bin wie gesagt linuxneuling!

gestern hatte ich übrigens ein systemupdate gemacht mit pacman -Syu (AFAIR). da sind glaube ich auch ein oder zwei libs geupdatet worden.

aber bewusst an irgendetwas rumgespielt habe ich nicht.

edit:

scheint wohl ein bug in der distri zu sein?!

http://bbs.archlinux.org/viewtopic......e+tty+name

aber ansonsten bin ich von arch-linux wirklich begeistert. und richtig flott ist arch auch (vorallem im vergleich zu meinen kurzen suse und mandrakeerfahrungen).

#2 12.02.2005 19:06:26

Pierre
Entwickler

Re: Login geht nicht mehr nach booten!

Da hast Du aber auch Pech gehabt. Es ware kurzzeitig ein Fehler im Bashscript. Aus der Mailinglist:

The problem is not libreadline per se - it's the new bash. The new bash was
built with links to libreadline & libhistory in /usr/lib. Unfortunately if your
system has /usr on a separate partition which is not mounted until later then
you have an unbootable system. Boot from a boot CD, grab the 'bash' executable
from an earlier bash package, move it into /bin & you should be O.K. That's what
worked for me.

Meine Idee: Boote von CD (Knoppix) Lade das aktuelle bash und readline-Paket und entpacke es in Deine root-Partition.

Offline

#3 13.02.2005 02:37:37

Gast
Gast

Re: Login geht nicht mehr nach booten!

Hallo

Mir ist nicht ganz klar was ich machen muss!

Es sollte reichen die "bash executable" in /bin auszutauschen, wenn ich das in einem Thread im Forum richtig verstanden habe.

Nur ich finde in dem Paket keine ausführbare Datei?

http://www.archlinux.org/packages.php?id=4021

Wäre nett wenn mal jemand die nötigen Schritte ausführlich beschreiben könnte (von z.B. Kanotix aus).
Für mich ist das alles noch ziemlich Neuland (hoffentlich bald nicht mehr wink ) und ich möchte jetzt nicht unnötig das Archlinux total zerschiessen!

#4 13.02.2005 02:52:26

Pierre
Entwickler

Re: Login geht nicht mehr nach booten!

Entpacke diese Paket auf Deine /-Partition: ftp://ftp.belnet.be/packages/archlinu...pkg.tar.gz

Dabei mußt Du vorhandene Dateien ersetzen. Dann sollte es eigentlich funktionieren.

Offline

#5 13.02.2005 12:17:52

INTRU
Gast

Re: Login geht nicht mehr nach booten!

das hat leider nicht geholfen! hmm

ich werde wohl neuinstallieren müssen. nur dazu habe ich momentan weder zeit noch lust sad

mein usr liegt übrigens auf einer anderen partition!

#6 28.02.2005 20:54:56

gast
Gast

Re: Login geht nicht mehr nach booten!

nach dem einloggen erhalte ich jetzt folgende meldung:

unable to determine your tty name

ich hatte auch mind. 1 fehlermeldung beim booten gesehen. wenn ich 'nen warmstart machen möchte erscheint folgendes:

/bin/sh error while loading shared libraries: libreadline.so.5: canno't open shared object file: no such file or directory

#7 28.02.2005 21:55:41

gast
Gast

Re: Login geht nicht mehr nach booten!

geht wieder alles smile

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums