Du bist nicht angemeldet.

#1 12.03.2021 08:33:54

cmoetzing
Mitglied

Boot-Vorgang stoppt systemd-fstab-generator “but it is not a device”

Seit ein paar Wochen (nach einem Update?) fährt mein Arch nicht mehr alleine hoch. Es bleibt direkt am Anfang stehen.

[    0.658449] nvme nvme0: missing or invalid SUBNQN field.
[    0.851921] nvme nvme0: 16/0/0 default/read/poll queues
[    0.857780]  nvme0n1: p1 p2
[    9.541817] systemd-fstab-generator[440]: Checking was requested for "/dev/nvme0n1p1", but it is not a device.

Ich muss dann in die Konsole wechseln und

mount /dev/nvme0n1p1 /boot; exit

eingeben und dann fährt der Rechner normal hoch.

Meine fstab

/dev/nvme0n1p1              /boot   vfat    rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 2
/dev/mapper/root            /               ext4         defaults        0 1
/dev/mapper/tmp             /tmp            tmpfs        defaults        0 0
/dev/mapper/swap            none            swap         sw              0 0

Weitere Infos

$ ls -l /dev/nvme0n1p1
brw-rw---- 1 root disk 259, 1  3. Mär 07:49 /dev/nvme0n1p1
$ file /dev/nvme0n1p1
/dev/nvme0n1p1: block special (259/1)
$ file -s /dev/nvme0n1p1
/dev/nvme0n1p1: DOS/MBR boot sector, code offset 0x58+2, OEM-ID "mkfs.fat", sectors/cluster 8, Media descriptor 0xf8, sectors/track 32, heads 64, hidden sectors 2048, sectors 1046529 (volumes > 32 MB), FAT (32 bit), sectors/FAT 1024, reserved 0x1, serial number 0x1560e429, unlabeled
$ uname -a
Linux archy 5.11.5-arch1-1 #1 SMP PREEMPT Tue, 09 Mar 2021 18:56:28 +0000 x86_64 GNU/Linux

Offline

#2 12.03.2021 13:01:40

tuxnix
Mitglied

Re: Boot-Vorgang stoppt systemd-fstab-generator “but it is not a device”

Schon mal probiert, ob es klappt wenn in der fstab auch für die boot-Partition ein schlichtes 'defaults' steht?
Das Mounten gelingt ja offensichtlich auf der Konsole auch ohne all die Parameter.

Offline

#3 12.03.2021 17:39:07

cmoetzing
Mitglied

Re: Boot-Vorgang stoppt systemd-fstab-generator “but it is not a device”

Gute Idee aber leider keine Veränderung. Kann das ein zeitliches Problem sein? Bis ich in der Shell angemeldet bin ist das Device vielleicht da?

/dev/mapper/root ist verschlüsselt, falls das was ändert.

Offline

#4 12.03.2021 18:00:58

tuxnix
Mitglied

Re: Boot-Vorgang stoppt systemd-fstab-generator “but it is not a device”

cmoetzing schrieb:

Bis ich in der Shell angemeldet bin ist das Device vielleicht da?

Glaub ich weniger, aber das 'timeout' vom bootloader zu erhöhen schadet zumindest nicht.

Welcher bootloader ist denn installiert? Und was passiert wenn du die fstab neu generieren lässt?
Also im Prinzip das noch einmal der Reihenfolge mal durchchecken: https://wiki.archlinux.de/title/Moderne … on_mounten

Beitrag geändert von tuxnix (12.03.2021 18:01:48)

Offline

#5 12.03.2021 23:35:19

cmoetzing
Mitglied

Re: Boot-Vorgang stoppt systemd-fstab-generator “but it is not a device”

Ich habe nochmal etwas herum gespielt und nun geht es wieder. Erkenntnis 1: meine Änderung war schuld. Ich hatte Einträge entfernt und dabei auch alle Kommentare entfernt. Danach sah meine Datei so aus (ging nicht):

UUID=1560-E429  /boot  vfat  rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro  0 2
/dev/mapper/root            /               ext4         defaults        0 1
/dev/mapper/tmp             /tmp            tmpfs        defaults        0 0
/dev/mapper/swap            none            swap         sw              0 0

Nun so (geht):

# nvme0n1p1
UUID=1560-E429  /boot  vfat  rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro  0 2
/dev/mapper/root            /               ext4         defaults        0 1
/dev/mapper/tmp             /tmp            tmpfs        defaults        0 0
/dev/mapper/swap            none            swap         sw              0 0

Muss ich das verstehen? Ich habe auf die Schnelle auch nichts gefunden, dass in der ersten Zeile nicht gleich ein Eintrag sehen darf. Kann jemand etwas dazu sagen?

Offline

#6 12.03.2021 23:39:29

tuxnix
Mitglied

Re: Boot-Vorgang stoppt systemd-fstab-generator “but it is not a device”

Bisher war mir nur bekannt, dass die fstab mit einer Leerzeile enden muss.
Man lernt halt nicht aus! wink
Aber irgend einen Formfehler bei dieser Datei hatte ich schon vermutet, deshalb der Tipp mit dem Neugenerieren.

Beitrag geändert von tuxnix (12.03.2021 23:43:04)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums