Du bist nicht angemeldet.

#1 16.02.2021 02:10:44

artjom
Gast

Nach Installation kein Internet und Keyboardlayout auf US

Hallo,

habe mir nach der Arch Installation XFCE als Desktop geholt. Während der Installation funktionierte die Ping -c3 abfrage und eine IP wurde angezeigt,
auch Pakete wurden geladen.
Nun hab ich kein Internet mehr, auch wenn von der Oberfläche ein Netzwerk angezeigt wird. Die Ping abfrage bringt: Temporärer Fehler bei der Namensauflösung.
Außerdem wir kein Programm gefunden wenn ich den Internetnavigator öffnen möchte.

Desweiteren hab ich die Datei hier angelegt: 00-keyboard.conf und alles wie vorgegeben eingegeben.
und das hier gemacht localectl set-x11-keymap
Jetzt habe ich trotzdem eine US Tastatur welche sich leider nicht umstellen lässt und im Terminal extrem nervig ist. Leider kann ich ja grade kein Xorg runterladen um das Problem zu beheben.
Hat jemand eine andere Idee? Musste mich schon als root anmelden um direkt wieder das Nutzer PW zu ändern, da ich keine Ahnung hatte wo bei der US Version das Fragezeichen ist... Glück gehabt dass der root ohne Sonderzeichen ist.

Ach und noch eine Frage:
Kennt ihr eine bessere Anleitung zur grafischen Anzeige für AMD GPUs als die offizielle? Ich habe leider nicht verstanden in welcher conf Datei man die Kernel Parameter für SICK ändern muss. Wäre cool das mal ausprobieren zu können.

Vielen Dank für eure Hilfe bisher, nach ca. 24 h gesamtarbeitszeit habe ich es endlich geschafft eine grafische Benutzeroberfläche zu erreichen, sieht schön aus aber wenn was nicht funktioniert und man alles wieder löschen müsste wäre mehr verloren als wie wenn man "nur" an irgendwelchen Datenbanken herum hantiert. Spaß.

#2 16.02.2021 09:22:09

Aid9Gi7O
Gast

Re: Nach Installation kein Internet und Keyboardlayout auf US

artjom schrieb:

Nun hab ich kein Internet mehr, auch wenn von der Oberfläche ein Netzwerk angezeigt wird. Die Ping abfrage bringt: Temporärer Fehler bei der Namensauflösung.
Außerdem wir kein Programm gefunden wenn ich den Internetnavigator öffnen möchte.

Entscheide dich für einen Netzwerkmanager, und konfiguriere diesen gemäß den Beschreibungen.

Jetzt habe ich trotzdem eine US Tastatur welche sich leider nicht umstellen lässt und im Terminal extrem nervig ist.

https://wiki.archlinux.org/index.php/Li … figuration

#3 16.02.2021 09:49:53

tuxnix
Mitglied

Re: Nach Installation kein Internet und Keyboardlayout auf US

Hallo artjom,

wenn alles gelöscht werden müsste, bist du beim zweiten mal viel schneller und verstehst es obendrein auch noch viele besser.
Vielleicht wäre das eine Vorteil. smile Aber schauen wir mal... 

Zur Tastatureinstellung:
Ein

loadkey de

hilft bestimmt schon mal für das Scheiben auf der Konsole.

Zu xorg:
Xorg hast du bereits installiert sonst könnte XFCE nicht laufen.
Bitte überprüfe das aber trotzem mal mit einem

pacman -Qs xorg

es müsste dir einige Pakete anzeigen u. a. xorg-server und xorg-xinit.

Zur Internetverbindung:
Überprüfe ob du das Paket dhcpcd installiert hast.

pacman -Qs dhcpcd

Falls dies nicht der Fall ist,
musst du den Rechner noch einmal mit der ISO starten,
die / (root) Partition mounten, und ein

pacstrap /mnt dhcpcd

ausführen.

Für den Fall, das dhcpcd schon auf dem Rechner ist führst  du ein

ip link

aus und postest hier mal die Ausgabe davon . (Bitte in tags)

Bis dann.

Beitrag geändert von tuxnix (16.02.2021 10:01:47)

Online

#4 16.02.2021 20:18:31

phunsoft
Mitglied

Re: Nach Installation kein Internet und Keyboardlayout auf US

artjom schrieb:

Desweiteren hab ich die Datei hier angelegt: 00-keyboard.conf und alles wie vorgegeben eingegeben.
und das hier gemacht localectl set-x11-keymap
Jetzt habe ich trotzdem eine US Tastatur welche sich leider nicht umstellen lässt und im Terminal extrem nervig ist.

In den Wikis steht üblicherweise, dass das erstellen des Files /etc/vconsole.conf mit dem entsprechendem KEYMAP= Inhalt die Tastatur füerdas Terminal einstellen soll. Z.B.

echo KEYMAP=de-latin1 > /etc/vconsole.conf

Hat bei mir nicht funktioniert. Einzig, nachdem ich die Tastatur -- nach längerem Try-and-Error --  mit dem LOCALECTL Befehl eingestellt hatte, hatte ich zuverlässig meine (Schweizerdeutsche) Tastatur im Terminal, X-Terminal und in den XFCE Applikationen. Sie dazu auch Arch Linux auf Deutsch stellen # localectl.
Gruss

Offline

#5 17.02.2021 00:00:29

artjom
Gast

Re: Nach Installation kein Internet und Keyboardlayout auf US

Aid9Gi7O schrieb:
artjom schrieb:

Nun hab ich kein Internet mehr, auch wenn von der Oberfläche ein Netzwerk angezeigt wird. Die Ping abfrage bringt: Temporärer Fehler bei der Namensauflösung.
Außerdem wir kein Programm gefunden wenn ich den Internetnavigator öffnen möchte.

Entscheide dich für einen Netzwerkmanager, und konfiguriere diesen gemäß den Beschreibungen.

Hier bekomme ich FluxBB BBCode-Test
Das verstehe ich auch weil wie will er denn ohne Internet Pakete laden? Doch bei der Installation ging es ja auch? Also an der VM kann es nicht liegen... Wäre vllt besser gewesen den direkt mit zu installen.


Jetzt habe ich trotzdem eine US Tastatur welche sich leider nicht umstellen lässt und im Terminal extrem nervig ist.

https://wiki.archlinux.org/index.php/Li … figuration

Ja das gebe ich ja schon ständig ein, das Problem ist dass sich nichts ändert 0 = - ....
Und wenn ich jetzt den Tipp aus dem Wiki befolge und mir einen Überblick über die Einstellungen verschaffen möchte mit localectl status dann erscheint dick in rot:
localectl could not get properties: is a direction

Das komische ist, dass ich schon während der Installation mehrere Dinge konfigurierte um das hier zu verhindern und es jetzt trotzdem habe? big_smile

#6 17.02.2021 00:20:10

artjom
Gast

Re: Nach Installation kein Internet und Keyboardlayout auf US

tuxnix schrieb:

Hallo artjom,

wenn alles gelöscht werden müsste, bist du beim zweiten mal viel schneller und verstehst es obendrein auch noch viele besser.
Vielleicht wäre das eine Vorteil. smile Aber schauen wir mal... 

Zur Tastatureinstellung:
Ein

loadkey de

hilft bestimmt schon mal für das Scheiben auf der Konsole.

Zu xorg:
Xorg hast du bereits installiert sonst könnte XFCE nicht laufen.
Bitte überprüfe das aber trotzem mal mit einem

pacman -Qs xorg

es müsste dir einige Pakete anzeigen u. a. xorg-server und xorg-xinit.

Zur Internetverbindung:
Überprüfe ob du das Paket dhcpcd installiert hast.

pacman -Qs dhcpcd

Falls dies nicht der Fall ist,
musst du den Rechner noch einmal mit der ISO starten,
die / (root) Partition mounten, und ein

pacstrap /mnt dhcpcd

ausführen.

Für den Fall, das dhcpcd schon auf dem Rechner ist führst  du ein

ip link

aus und postest hier mal die Ausgabe davon . (Bitte in tags)

Bis dann.

Hi danke für die ausführliche Antwort. Habe das nun mal alles durchprobiert. Also ich meine dass das alles da ist und so passt. Aber sieh selbst:
  // meinst du das mit Tag für den Code? Wie bekomme ich den Code aus der VM kopiert? Er übernimmt ihn nicht in den Speicher vom "echten" System.
habs jetzt erstmal als Bildausschnitt.
FluxBB BBCode-Test
FluxBB BBCode-Test

#7 17.02.2021 00:26:29

artjom
Gast

Re: Nach Installation kein Internet und Keyboardlayout auf US

phunsoft schrieb:
artjom schrieb:

Desweiteren hab ich die Datei hier angelegt: 00-keyboard.conf und alles wie vorgegeben eingegeben.
und das hier gemacht localectl set-x11-keymap
Jetzt habe ich trotzdem eine US Tastatur welche sich leider nicht umstellen lässt und im Terminal extrem nervig ist.

In den Wikis steht üblicherweise, dass das erstellen des Files /etc/vconsole.conf mit dem entsprechendem KEYMAP= Inhalt die Tastatur füerdas Terminal einstellen soll. Z.B.

echo KEYMAP=de-latin1 > /etc/vconsole.conf

Hat bei mir nicht funktioniert. Einzig, nachdem ich die Tastatur -- nach längerem Try-and-Error --  mit dem LOCALECTL Befehl eingestellt hatte, hatte ich zuverlässig meine (Schweizerdeutsche) Tastatur im Terminal, X-Terminal und in den XFCE Applikationen. Sie dazu auch Arch Linux auf Deutsch stellen # localectl.
Gruss

Es scheint halt irgendwas nicht installiert zu sein oder zu fehlen vom Xorg?
FluxBB BBCode-Test

#8 17.02.2021 01:02:09

Aid9Gi7O
Gast

Re: Nach Installation kein Internet und Keyboardlayout auf US

artjom schrieb:

Das verstehe ich auch weil wie will er denn ohne Internet Pakete laden? Doch bei der Installation ging es ja auch? Also an der VM kann es nicht liegen... Wäre vllt besser gewesen den direkt mit zu installen.

Wenn du die verlinkten Wiki-Artikel gelesen hättest wüsstest du, dass du ausdrücklich die Netzwerkdienste aktivieren und starten musst. Auf dem Installationsmedium wird dazu der systemd-networkd-Service verwendet, aber nicht mehr in der Installation, da musst du dir selber einen geeigneten Netzwerkmanager suchen und konfigurieren. systemd-networkd ist eh an Bord, muss aber auch konfiguriert, aktiviert und gegebenenfalls noch gestartet werden. Auch das wird alles in den genannten Wiki-Artikeln beschrieben.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums