Du bist nicht angemeldet.

#1 11.01.2021 00:27:34

T-matze
Mitglied

[gelöst] Mikrophon lässt sich in BigBlueButton nicht aktivieren

Liebe erfahrene Archlinux-Nutzer,

dies ist mein erster Beitrag in diesem Forum, ich delurke heute sozusagen, nachdem ich schon viel und erfolgreich in anderen Themen hier fündig geworden bin.
Für folgendes Problem suche ich nun einen Lösungsansatz:

Aufgrund der geschlossenen Schulen werden meine Kinder zu Hause unterrichtet. Inzwischen gibt es einige Lehrer, die die eine oder andere Schulstunde über die schuleigene Plattform BigBlueButton als Videokonferenz durchführen. Die Schüler schalten sich zu und können sehen, hören und - sofern das Mikrophon funktioniert - auch reden. Genau bei letzterem Punkt hakt es bei zwei von drei Laptops, die wir in meinem Haushalt haben. Da wird, anstatt dass der Echotest bei Aktivierung des Mikrophons aufgerufen wird, eine Fehlermeldung gebracht, dass auf das Mikrophon nicht zugegriffen werden könne und man doch die Browsereinstellungen entsprechend anpassen solle. Da ist der Zugriff auf das Mikrophon aber bereits erlaubt.

Alle bisherigen eigenständigen Versuche meiner Kinder oder mir, vor und nach entsprechender Internetrecherche, der Lektüre der FAQ https://schuleonline.bildung-rp.de/digi … n/faq.html sowie ein Anruf bei der dort genannten Hotline und Mailkontakt mit dem dortigen Support brachte leider bisher keinen Erfolg.

Alle verwendeten Rechner sind mit einem aktuell gehaltenen (vanilla) Arch Linux betrieben, haben ein eingebautes Mikrophon und Webcam, die für Zoom und Skype oder Aufnahmen im OBS-Studio funktionieren, die verwendeten Browser sind ebenfalls aktuell:

Linux 5.10.5-arch1-1
Name                     : opera
Version                  : 73.0.3856.284-1
Name                     : firefox
Version                  : 84.0.1-1
Name                     : chromium
Version                  : 87.0.4280.88-3

Ich habe beide Varianten getestet: Aktivieren des Mikrophons auf Nachfrage bei Betreten der Seite; oder Aktivieren bereits im Vorfeld in den Einstellungen des Browsers für die betreffende Seite.

Das Ergebnis ist identisch: Wenn die BBB-Seite aufgerufen wird, wird der Echo-Test gar nicht erst angeboten. Wenn man bei der Auswahl "nur zuhören" oder "sprechen" dann "sprechen" anklickt, wird eine Fehlermeldung ausgegeben, dass das Mikrophon nicht gefunden werden könne oder so ähnlich.

Ein Aufruf der Seite https://test.webrtc.org/ bringt zunächst auch die Fehlermeldung:

Welcome to WebRTC Troubleshooter Failed to access your computer's camera and microphone (NotReadableError: Could not start audio source).

Wenn ich dann "continue without audio/or video" auswähle, kann ich den Test laufen lassen. Natürlich ist in den Seiteneinstellungen Mikrophon und Kamera erlaubt. Dennoch findet die Seite zunächst das Mikrophon nicht. Wenn ich dann aber im Burgermenu (diese 3 waagerechten Balken) der Seite die Settings aufrufe, kann ich beim Mikrophon von "Standard" auf "Internes Audio Analog Stereo" umstellen. Dann läuft der Test auch fehlerfrei durch:

Microphone
Audio capture
[ OK ] Audio track created using device=Internes Audio Analog Stereo
[ INFO ] Channel 0 levels: -1.1 dB (peak), -2.5 dB (RMS)
[ INFO ] Channel 1 levels: -2.7 dB (peak), -3.7 dB (RMS)
[ OK ] Active audio input channels: 2
[ INFO ] Stereo microphone detected.

Ein solches Burgermenu gibt es jedoch in BBB nicht.

Heute konnte ich mit allen drei Laptops (Tuxedo, HP und Lenovo) in einer BBB-Sitzung testen, jedoch ohne den Fehler oder Unterschied zu finden. Nur der HP konnte das Mikrophon aktivieren, die anderen beiden nicht.
Wenn gewünscht (und wenn ich herausfinde, wie ich hier Bilder hochladen kann), kann ich zwei Bildschirmfotos von meinem Laptop liefern, einmal mit den Browsereinstellungen in der BBB-Probesitzung, einmal mit den Toneinstellungen des Systems, das sowohl das interne Mikrophon des Laptops als auch das Mikrophon des zu diesem Zeitpunkt per Bluetooth verbundenen Headsets mit einem Pegelausschlag anzeigt.
Mit beiden Mikrophonen kann ich problemlos in einer Zoomkonferenz sprechen oder via OBS-Studio einen Webcast vertonen.

Ich verstehe nicht, warum bei identischen Grundvoraussetzungen seitens der Software (Betriebssystem und Browser) sowie der Einstellungen das Mikrophon am einen Rechner gefunden und aktiviert wird, in derselben BBB-Sitzung jedoch die beiden anderen Rechner eine Fehlermeldung angezeigt bekommen.

Kann einer der hiesigen Experten sich da einen Reim drauf machen? Unvollständige Unterstützung der Hardware? Fehlende Firmware? Aber in anderen Anwendungen funktionieren die Mikros ja...
Wenn irgendwelche Errorlogs hilfreich sind, kann ich die gerne - wenn mir jemand die passenden Bash-Befehle nennt - erstellen und posten.

Vielen Dank schon mal fürs Mitdenken und hilfreiche Hinweise!

Gruß, T-matze

Beitrag geändert von T-matze (12.01.2021 00:07:29)

Offline

#2 11.01.2021 11:03:58

tuxnix
Mitglied

Re: [gelöst] Mikrophon lässt sich in BigBlueButton nicht aktivieren

Das Burger Menu heißt eigentlich Hamburger Menu, weil Hamburger aus drei Scheiben bestehen. ;-)

Hallo T-matze,
wahrscheinlich kann ich nicht allein die Lösung herbeiführen, aber den Anfang kann ich hier mal versuchen.

Geht es um eine Sitzung mit Big Blue Button? Und handelt es sich um diese Testseite. https://test.bigbluebutton.org/

In KDE-Plasma kann man diese Einstellungen recht einfach in Systemsteuerung -> Audio vornehmen.
Bei mir hat geholfen dort die Mikrofon-Einstellung von "Analog-Stereo-Eingabe" auf "Digital-Stereo-Eingabe" zu setzen.

Welche GUI nutzt ihr denn? Dort müsse es auch diese Einstellungen geben.

Beitrag geändert von tuxnix (11.01.2021 11:55:51)

Offline

#3 11.01.2021 23:32:34

T-matze
Mitglied

Re: [gelöst] Mikrophon lässt sich in BigBlueButton nicht aktivieren

Hi tuxnix,

danke für Deine Überlegungen und den Link zur Testseite. Das ist eine andere, als die von mir auf den Hilfeseiten der Schule gefundene.

Auf https://test.bigbluebutton.org/ klappt es jetzt mit dem Firefox auf meinem Tuxedo-Laptop, wenn man bei der Frage nach der Zustimmung nicht nur zustimmt, sondern dort auch von "Monitor of Internes Audio Analog Stereo" auf "Internes Audio Analog Stereo" umstellt, wie meine Frau von der heutigen Schulstunde auch schon berichtete. Opera und Chromium bekommen weiterhin diese Auswahl nicht zu sehen. Auf dem Lenovo-Laptop ist es identisch. Nur der HP-Laptop (auf dem Chromium gar nicht installiert ist) kann sowohl mit Opera als auch Firefox den vollen Funktionsumfang nutzen. Das verwirrt mich.

Unser Desktop-Environment ist XFCE, da kann ich in Pavucontrol auch einiges einstellen. Bei mir steht es auf "Analog Stereo Duplex", verfügbar wäre noch "Analog Stereo-Ausgabe" und "Analog Stereo-Eingabe", aber alle "Digital ..." sind als "nicht verfügbar" markiert.

... Mehrere Versuche später ...
Jetzt bin ich noch verwirrter: Nachdem ich einmal von "Analog Stereo Duplex" auf "Analog Stereo-Eingabe" umgestellt hatte, hat mich die Testseite auch in Opera zum Echotest vorgelassen. Da konnte ich natürlich nichts hören, weil bei "-Eingabe" kein Lautsprecher angesprochen wird. Also zurück zu "Analog Stereo Duplex", und seither läuft die Erkennung des Mikrophons nicht mehr nur im Firefox, sondern auch in Opera. Und zwar auf beiden Laptops, die diesbezüglich bisher streikten (Lenovo + Tuxedo).

Jetzt scheint also das Problem gelöst zu sein, wenngleich ich weder das Problem noch die Lösung verstanden habe. hmm
Vielen Dank nochmal!

Offline

#4 12.01.2021 00:04:42

tuxnix
Mitglied

Re: [gelöst] Mikrophon lässt sich in BigBlueButton nicht aktivieren

Hallo T-matze,

freut mich wenn es jetzt klappt.
Im Prinzip ist es wie bei einer Stereoanlage, bei der man die jeweiligen Eingabegeräte und die Ausgabegeräte mit einander verbinden muss.
Da hier alsa, pulseaudio und die jeweilige GUI zusammen werkeln ist es aber gar nicht so einfach hier durchzublicken.
Denke das muss man auch nicht unbedingt. Die Spezialisten nutzen lieber allein nur alsa, weil man dann auch weiß was man da macht.
Wünsche möglichst wenig Stress im Home-Schooling.

Grüße tuxnix

P,S,: Du kannst beim Titel deines Threads ein [gelöst] hinschreiben wenn es so ist.

Beitrag geändert von tuxnix (12.01.2021 00:17:30)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums