Du bist nicht angemeldet.

#1 28.10.2020 18:38:27

Edward d'Eath
Mitglied

Frage zu xdg-desktop-portal-wlr

Hallo Gemeinschaft,

seit einigen Tagen bekomme ich, wenn ich

# pacman -Syyu

ausführe, die folgende Meldung. Dann breche ich den Vorgang immer ab.

# pacman -Syyu
:: Synchronisiere Paketdatenbanken...
 core                  129,7 KiB  2,53 MiB/s 00:00 [######################] 100%
 extra                1632,2 KiB  6,93 MiB/s 00:00 [######################] 100%
 community               5,2 MiB  6,92 MiB/s 00:01 [######################] 100%
:: Starte vollständige Systemaktualisierung...
Löse Abhängigkeiten auf...
:: Es stehen 3 Provider für xdg-desktop-portal-impl zur Verfügung:
:: Repositorium extra
   1) xdg-desktop-portal-gtk  2) xdg-desktop-portal-kde
:: Repositorium community
   3) xdg-desktop-portal-wlr

Geben Sie eine Zahl ein (Voreinstellung=1): 

Ich finde auch nichts im pacman-log.

# grep -e xdg-desktop-portal-wlr -i /var/log/pacman.log 

Im Internet habe ich die folgenden Seiten dazu gefunden.
https://github.com/emersion/xdg-desktop-portal-wlr
https://github.com/emersion/xdg-desktop … r/wiki/FAQ
https://github.com/flatpak/xdg-desktop-portal
Für mich scheint es etwas mit Flatpak zu tun zu haben.

A portal frontend service for Flatpak and possibly other desktop containment frameworks...

Leider werde ich aus den ganzen Informationen nicht schlau. Wissentlich habe ich so ein Paket nicht installiert. Wofür ist es und wie kann ich es loswerden?

Offline

#2 28.10.2020 19:03:21

stefanhusmann
Moderator

Re: Frage zu xdg-desktop-portal-wlr

Eins der Pakete, die du installiert hast, benötigt - möglicherweise über ein paar Ecken hinweg - xdg-desktop-portal-impl als Abhängigkeit. Dafür stehen drei Implementationen zur Verfügung, die pacman dir zur Auswahl anbietet. Zwei davon sind laut dem dritten Link expererimentell, eine (xdg-desktop-portal-gtk) ist es nicht.

Entweder wählst du also eine der Optionen aus (drücke 1, 2 oder 3) oder du belässt es bei der Voreinstellung, welche dann auf xdg-desktop-portal-gtk hinausläuft, oder du versuchst herauszufinden, welches deiner installierten Pakete xdg-desktop-portal-impl nach sich zieht und deinstallierst es.

Ich vermute mal, es ist flatpak.

Offline

#3 28.10.2020 19:03:31

Greg
Mitglied

Re: Frage zu xdg-desktop-portal-wlr

Edward d'Eath schrieb:

... Wissentlich habe ich so ein Paket nicht installiert.

Du kannst ja mal pacman -R xdg-desktop-portal-impl eingeben, dann weißt du welches Paket es braucht.

Hier als Beispiel an libxfce4util

# pacman -R libxfce4util
Prüfe Abhängigkeiten...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Entfernen von libxfce4util verletzt Abhängigkeit 'libxfce4util', benötigt von libxfce4ui
:: Entfernen von libxfce4util verletzt Abhängigkeit 'libxfce4util', benötigt von thunar
:: Entfernen von libxfce4util verletzt Abhängigkeit 'libxfce4util', benötigt von xfconf
[root@duda gl]# 

Oder auch

# pacman -Qi libxfce4util
Name                     : libxfce4util
Version                  : 4.14.0-2
Beschreibung             : Basic utility non-GUI functions for Xfce
Architektur              : x86_64
URL                      : https://www.xfce.org/
Lizenzen                 : GPL2
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : glib2
Optionale Abhängigkeiten : Nichts
Benötigt von             : libxfce4ui  thunar  xfconf
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 821,90 KiB
Packer                   : Felix Yan <felixonmars@archlinux.org>
Erstellt am              : Di 19 Mai 2020 10:38:39 CEST
Installiert am           : Di 26 Mai 2020 15:19:07 CEST
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Nein
Verifiziert durch        : Signatur

Beitrag geändert von Greg (28.10.2020 19:04:45)

Offline

#4 28.10.2020 19:11:30

stefanhusmann
Moderator

Re: Frage zu xdg-desktop-portal-wlr

Greg, das würde nur funktionieren, wenn er xdg-desktop-portal-impl installiert hätte, hat er aber nicht.

Offline

#5 28.10.2020 19:14:59

scnr-man2000
Gast

Re: Frage zu xdg-desktop-portal-wlr

stefanhusmann schrieb:

Grep, das würde nur funktionieren, wenn er xdg-desktop-portal-impl installiert hätte, hat er aber nicht.

Steffen, er heisst Greg tongue

#6 28.10.2020 19:27:14

stefanhusmann
Moderator

Re: Frage zu xdg-desktop-portal-wlr

Mein Brille sitzt wohl schief, oder ich brauch ne neue.

Offline

#7 08.11.2020 17:15:48

Edward d'Eath
Mitglied

Re: Frage zu xdg-desktop-portal-wlr

Sorry für meine späte Rückmeldung. Leider habe ich auf Arbeit viel zu tun (Automatisierung der Konstruktionsabteilung durch CAD, Konfigurator, PDM), daher melde ich mich erst jetzt.

Einige Versuche habe ich durchgeführt, um rauszufinden, wo die Abhängigkeit liegt, aber nichts gefunden. Flatpak habe ich nicht installiert. Möglicherweise hat es etwas mit Xorg zu tun, denn ich habe hier drei Rechner, die mir dieselbe Frage stellen und auf allen läuft Xorg, Openbox, Tint2, LibreOffice und einige weitere Pakete. Die Pakete sind mehr oder weniger identisch auf den drei Geräten.

Ich habe mich jetzt für die Standardvorgabe (1) entschieden.

Vielen Dank für Eure Zuschriften.

Edward

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums