Du bist nicht angemeldet.

#1 16.10.2020 14:34:02

Erl
Mitglied

[gelöst] Startprobleme

Beim Start bekomme ich folgende Fehlermeldung:

Loading Linux linux ...
error: file /boot/vmlinuz-linux' not found.
Loading initial ramdisk ...
error: you need to load the kernel first.

Press any key to continue...

Ich habe mit einem ManjaroLive System gebootet und nach dieser Anleitung "geChrootet"

Ein

pacman -Syu

ergibt:

:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (73) alsa-card-profiles-13.99.2+13+g7f4d7fcf5-1  apache-2.4.46-3
            apm-2.5.0-3  arduino-1:1.8.13-2  atom-1.52.0-1
            avr-binutils-2.35.1-1  cups-filters-1.28.5-1  curl-7.73.0-1
            dnssec-anchors-20190629-3  electron6-6.1.12-1  firefox-81.0.2-1
            freetype2-2.10.3-1  fuse-common-3.10.0-1  fuse3-3.10.0-1
            gdm-3.38.1-2  glibc-2.32-5  gnome-settings-daemon-3.38.1-1
            gst-editing-services-1.16.2-1  haskell-ipynb-0.1.0.1-94
            haskell-unicode-transforms-0.3.7.1-1  iana-etc-20201012-1
            lib32-freetype2-2.10.3-1  lib32-glibc-2.32-5  libanjuta-3.34.0-6
            libcap-ng-0.8-1  libcurl-compat-7.73.0-1  libcurl-gnutls-7.73.0-1
            libgdm-3.38.1-2  libgphoto2-2.5.26-1  libmbim-1.24.4-1
            libmm-glib-1.14.6-1  libmtp-1.1.18-1
            libnautilus-extension-3.38.1-1  libnm-1.26.4-1  libp11-0.4.11-1
            libpulse-13.99.2+13+g7f4d7fcf5-1  libqmi-1.26.6-1  libraw-0.20.2-1
            libreoffice-fresh-7.0.2-1  libreoffice-fresh-de-7.0.2-1
            libsecret-0.20.4-1  libupnp-1.14.0-1  linux-5.8.14.arch1-1
            linux-firmware-20200916.00a84c5-1  linux-headers-5.8.14.arch1-1
            lua-5.4.1-1  md4c-0.4.6-1  modemmanager-1.14.6-1  nano-5.3-1
            nautilus-3.38.1-1  networkmanager-1.26.4-1  nodejs-14.14.0-1
            pandoc-2.10.1-41  perl-html-parser-3.75-1
            pulseaudio-13.99.2+13+g7f4d7fcf5-1
            pulseaudio-bluetooth-13.99.2+13+g7f4d7fcf5-1  python-isort-5.6.0-1
            python-patiencediff-0.2.1-1  python-setuptools-1:50.3.1-1
            python-sqlalchemy-1.3.20-1  qt5-base-5.15.1-3
            quadrapassel-3.38.1-1  ruby-2.7.2-1  rygel-0.40.0-1
            seahorse-1:3.37.2+29+g1d84684a-1  simple-scan-3.38.1-1
            soundtouch-2.2-1  sysprof-3.38.1-1  telegram-desktop-2.4.3-1
            totem-3.38.0-1  vlc-3.0.11.1-4  whois-5.5.7-1  yajl-2.1.0-4

Gesamtgröße der installierten Pakete:  2348,43 MiB
Größendifferenz der Aktualisierung:   149,71 MiB

:: Installation fortsetzen? [J/n] 
(73/73) Prüfe Schlüssel im Schlüsselring           [----------------------] 100%
(73/73) Überprüfe Paket-Integrität                 [----------------------] 100%
(73/73) Lade Paket-Dateien                         [----------------------] 100%
(73/73) Prüfe auf Dateikonflikte                   [----------------------] 100%
Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-async-command.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-async-notify.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-autogen.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-cell-renderer-captioned-image.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-close-button.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-column-text-view.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-command-bar.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-command-queue.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-command.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-completion.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-convert.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-debug.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-dock-pane.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-dock.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-drop-entry.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-encodings.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-entry.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-enum-types.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-environment-editor.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-file-drop-entry.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-file-list.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-language-provider.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-launcher.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-marshal.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-modeline.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-pkg-config-chooser.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-pkg-config.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-pkg-scanner.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-plugin-description.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-plugin-handle.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-plugin-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-plugin.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-preferences-dialog.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-preferences.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-profile-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-profile.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-project.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-save-prompt.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-serializer.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-session.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-shell.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-status.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-sync-command.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-tabber.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-token-file.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-token-list.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-token-stream.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-token.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-tree-combo.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-ui.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-utils.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-vcs-status-tree-view.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-vcs-status.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/anjuta-version.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-buildable.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-builder.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-debug-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-debugger-breakpoint.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-debugger-instruction.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-debugger-memory.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-debugger-register.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-debugger-variable.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-debugger.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-document-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-document.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-assist.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-cell-style.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-cell.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-comment.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-convert.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-factory.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-folds.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-glade-signal.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-goto.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-hover.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-language.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-line-mode.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-search.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-selection.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-tip.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-view.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor-zoom.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-editor.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-environment.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-file-loader.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-file-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-file-savable.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-file.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-glade.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-help.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-indenter.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-indicable.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-iterable-tree.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-iterable.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-language-provider.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-language.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-loader.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-markable.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-message-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-message-view.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-plugin-factory.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-preferences.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-print.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-project-backend.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-project-chooser.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-project-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-project.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-provider.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-snippets-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-stream-loader.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-stream-savable.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-stream.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-symbol-manager.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-symbol-query.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-symbol.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-terminal.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-todo.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-vcs.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/ianjuta-wizard.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/libanjuta-iface-marshallers.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/libanjuta-interfaces.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/interfaces/libanjuta.idl existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/libanjuta.h existiert im Dateisystem
libanjuta: /usr/include/libanjuta-3.0/libanjuta/resources.h existiert im Dateisystem
libanjuta: /usr/lib/girepository-1.0/Anjuta-3.0.typelib existiert im Dateisystem
libanjuta: /usr/lib/girepository-1.0/IAnjuta-3.0.typelib existiert im Dateisystem
libanjuta: /usr/lib/glade/modules/libgladeanjuta.so existiert im Dateisystem
libanjuta: /usr/lib/libanjuta-3.so existiert im Dateisystem
libanjuta: /usr/lib/libanjuta-3.so.0 existiert im Dateisystem
libanjuta: /usr/lib/libanjuta-3.so.0.0.0 existiert im Dateisystem
libanjuta: /usr/lib/pkgconfig/libanjuta-3.0.pc existiert im Dateisystem
libanjuta: /usr/share/gir-1.0/Anjuta-3.0.gir existiert im Dateisystem
libanjuta: /usr/share/gir-1.0/IAnjuta-3.0.gir existiert im Dateisystem
libanjuta: /usr/share/glade/catalogs/anjuta-glade.xml existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Ein

mkinitcpio -p linux

ergibt:

/etc/mkinitcpio.d/linux.preset: Zeile 1: $: Kommando nicht gefunden.
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-linux'

HILFE

Beitrag geändert von Erl (16.10.2020 15:32:10)

Offline

#2 16.10.2020 15:02:44

stefanhusmann
Moderator

Re: [gelöst] Startprobleme

Wie sieht denn die /etc/mkinitcpio.d/linux.preset aus?

Offline

#3 16.10.2020 15:03:34

schard
Moderator

Re: [gelöst] Startprobleme

Ganz offensichtlich ist die Datei /etc/mkinitcpio.d/linux.preset fehlerhaft.
Poste deren Inhalt in Code-Tags.
Stelle bitte auch die Ausgaben von

$ mount
$ lsblk
$ cat /etc/fstab

aus dem Chroot zur Verfügung.

Zudem scheint mindestens das Paket extra/libanjuta defekt zu sein.
Bitte poste dafür dein vollständiges /var/log/pacman.log.

Offline

#4 16.10.2020 15:14:33

Erl
Mitglied

Re: [gelöst] Startprobleme

/etc/mkinitcpio.d/linux.preset :

$ cat /etc/mkinitcpio.d/linux.preset
# mkinitcpio preset file for the 'linux' package

ALL_config="/etc/mkinitcpio.conf"
ALL_kver="/boot/vmlinuz-linux"

PRESETS=('default')

#default_config="/etc/mkinitcpio.conf"
default_image="/boot/initramfs-linux.img"
#default_options=""

#fallback_config="/etc/mkinitcpio.conf"
fallback_image="/boot/initramfs-linux-fallback.img"
fallback_options="-S autodetect"
[root@manjaro-gnome boot]# mount
/dev/sda1 on / type ext4 (rw,relatime)
proc on /proc type proc (rw,relatime)
sys on /sys type sysfs (rw,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=1768288k,nr_inodes=442072,mode=755)
/dev/pts on /dev/pts type devpts (rw,relatime,mode=600,ptmxmode=000)
[root@manjaro-gnome boot]# lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0    7:0    0  59,4M  1 loop 
loop1    7:1    0 574,7M  1 loop 
loop2    7:2    0   1,3G  1 loop 
loop3    7:3    0 580,2M  1 loop 
sda      8:0    0 119,2G  0 disk 
├─sda1   8:1    0   115G  0 part /
└─sda2   8:2    0   4,2G  0 part 
sdb      8:16   1  59,6G  0 disk 
├─sdb1   8:17   1   2,5G  0 part 
└─sdb2   8:18   1     4M  0 part 
[root@manjaro-gnome boot]# cat /etc/fstab


# UUID=a5c87fcb-64ac-46fc-8790-073618a31d33 LABEL=ARCH
/dev/sda1           	/         	ext4      	rw,relatime,data=ordered0 1

# UUID=427ad749-f9f9-436e-b911-bb99dc5f41c5 LABEL=swap
/dev/sda2           	none      	swap      	defaults  	0 0

//192.168.5.1/FRITZ.NAS/TRANSCEND/FRITZ /home/uwe/fritzNAS cifs credentials=/home/uwe/.smbcredentials,vers=1.0,uid=1000,gid=1000,x-systemd.automount,x-systemd.requires=network-online.target 0 0

Offline

#5 16.10.2020 15:22:39

schard
Moderator

Re: [gelöst] Startprobleme

Okay,

die erste Zeile aus /etc/mkinitcpio.d/linux.preset bitte löschen:

$ cat /etc/mkinitcpio.d/linux.preset

Du scheinst keine separate Bootpartition zu haben, also ist das auch kein Problem.
Zunächst sollten wir mal das defekte Paket reparieren und dein System updaten:

# pacman -Sy libanjuta --overwrite usr/*
# pacman -Syu

Bitte unbedingt das zweite Kommando direkt nach dem ersten ausführen, da dein System ansonsten auf einem partiellen Updatestand bleibt.

Offline

#6 16.10.2020 15:24:17

Erl
Mitglied

Re: [gelöst] Startprobleme

Ah vergessen:
/var/log/pacman.log

[2020-03-18T12:57:14+0100] [PACMAN] Running 'pacman -r /mnt -Sy --cachedir=/mnt/var/cache/pacman/pkg --noconfirm base'
[2020-03-18T12:57:14+0100] [PACMAN] synchronizing package lists
[2020-03-18T12:57:53+0100] [ALPM] transaction started
[2020-03-18T12:57:53+0100] [ALPM] installed iana-etc (20200311-1)
[2020-03-18T12:57:53+0100] [ALPM] installed filesystem (2019.10-2)
[2020-03-18T12:57:53+0100] [ALPM] installed linux-api-headers (5.4.17-1)
[2020-03-18T12:57:53+0100] [ALPM] installed tzdata (2019c-3)
[2020-03-18T12:57:53+0100] [ALPM] installed glibc (2.31-2)
[2020-03-18T12:57:54+0100] [ALPM] installed gcc-libs (9.3.0-1)
[2020-03-18T12:57:54+0100] [ALPM] installed ncurses (6.2-1)
[2020-03-18T12:57:54+0100] [ALPM] installed readline (8.0.004-1)
[2020-03-18T12:57:54+0100] [ALPM] installed bash (5.0.016-1)
[2020-03-18T12:57:54+0100] [ALPM] installed attr (2.4.48-2)
[2020-03-18T12:57:54+0100] [ALPM] installed acl (2.2.53-2)
[2020-03-18T12:57:54+0100] [ALPM] installed gmp (6.2.0-1)
[2020-03-18T12:57:54+0100] [ALPM] installed libcap (2.33-1)
[2020-03-18T12:57:54+0100] [ALPM] installed gdbm (1.18.1-3)
[2020-03-18T12:57:54+0100] [ALPM] installed db (5.3.28-5)
[2020-03-18T12:57:56+0100] [ALPM] installed perl (5.30.1-1)
[2020-03-18T12:57:56+0100] [ALPM] installed openssl (1.1.1.d-2)
[2020-03-18T12:57:57+0100] [ALPM] installed coreutils (8.31-3)
[2020-03-18T12:57:57+0100] [ALPM] installed zlib (1:1.2.11-4)
[2020-03-18T12:57:57+0100] [ALPM] installed xz (5.2.4-2)
[2020-03-18T12:57:57+0100] [ALPM] installed bzip2 (1.0.8-3)
[2020-03-18T12:57:57+0100] [ALPM] installed libseccomp (2.4.2-1)
[2020-03-18T12:57:57+0100] [ALPM] installed file (5.38-3)
[2020-03-18T12:57:57+0100] [ALPM] installed findutils (4.7.0-2)
[2020-03-18T12:57:57+0100] [ALPM] installed mpfr (4.0.2-2)
[2020-03-18T12:57:57+0100] [ALPM] installed gawk (5.0.1-2)
[2020-03-18T12:57:57+0100] [ALPM] installed pcre (8.44-1)
[2020-03-18T12:57:57+0100] [ALPM] installed grep (3.4-1)
[2020-03-18T12:57:57+0100] [ALPM] installed libgpg-error (1.37-1)
[2020-03-18T12:57:57+0100] [ALPM] installed libgcrypt (1.8.5-2)
[2020-03-18T12:57:57+0100] [ALPM] installed lz4 (1:1.9.2-2)
[2020-03-18T12:57:57+0100] [ALPM] installed systemd-libs (245-3)
[2020-03-18T12:57:57+0100] [ALPM] installed procps-ng (3.3.16-1)
[2020-03-18T12:57:57+0100] [ALPM] installed sed (4.8-1)
[2020-03-18T12:57:57+0100] [ALPM] installed tar (1.32-3)
[2020-03-18T12:57:57+0100] [ALPM] installed libffi (3.2.1-4)
[2020-03-18T12:57:57+0100] [ALPM] installed libutil-linux (2.35.1-1)
[2020-03-18T12:57:57+0100] [ALPM] installed glib2 (2.64.1-1)
[2020-03-18T12:57:57+0100] [ALPM] installed libunistring (0.9.10-2)
[2020-03-18T12:57:58+0100] [ALPM] installed icu (65.1-3)
[2020-03-18T12:57:58+0100] [ALPM] installed libxml2 (2.9.10-1)
[2020-03-18T12:57:58+0100] [ALPM] installed libcroco (0.6.13-1)
[2020-03-18T12:57:58+0100] [ALPM] installed gettext (0.20.1-3)
[2020-03-18T12:57:58+0100] [ALPM] installed hwids (20200204-1)
[2020-03-18T12:57:58+0100] [ALPM] installed kmod (27-1)
[2020-03-18T12:57:58+0100] [ALPM] installed pciutils (3.6.4-1)
[2020-03-18T12:57:58+0100] [ALPM] installed psmisc (23.3-2)
[2020-03-18T12:57:58+0100] [ALPM] installed cracklib (2.9.7-2)
[2020-03-18T12:57:58+0100] [ALPM] installed e2fsprogs (1.45.5-1)
[2020-03-18T12:57:58+0100] [ALPM] installed libsasl (2.1.27-2)
[2020-03-18T12:57:58+0100] [ALPM] installed libldap (2.4.49-1)
[2020-03-18T12:57:58+0100] [ALPM] installed keyutils (1.6.1-3)
[2020-03-18T12:57:58+0100] [ALPM] installed krb5 (1.17.1-1)
[2020-03-18T12:57:58+0100] [ALPM] installed libtirpc (1.2.5-1)
[2020-03-18T12:57:58+0100] [ALPM] installed pambase (20190105.1-2)
[2020-03-18T12:57:58+0100] [ALPM] installed pam (1.3.1-2)
[2020-03-18T12:57:58+0100] [ALPM] installed libcap-ng (0.7.10-1)
[2020-03-18T12:57:58+0100] [ALPM] installed audit (2.8.5-6)
[2020-03-18T12:57:58+0100] [ALPM] installed shadow (4.8.1-1)
[2020-03-18T12:57:58+0100] [ALPM] installed util-linux (2.35.1-1)
[2020-03-18T12:57:58+0100] [ALPM] installed less (551-3)
[2020-03-18T12:57:58+0100] [ALPM] installed gzip (1.10-3)
[2020-03-18T12:57:58+0100] [ALPM] installed licenses (20191011-2)
[2020-03-18T12:57:58+0100] [ALPM] installed expat (2.2.9-3)
[2020-03-18T12:57:58+0100] [ALPM] installed zstd (1.4.4-1)
[2020-03-18T12:57:59+0100] [ALPM] installed libarchive (3.4.2-1)
[2020-03-18T12:57:59+0100] [ALPM] installed libtasn1 (4.16.0-1)
[2020-03-18T12:57:59+0100] [ALPM] installed libp11-kit (0.23.20-3)
[2020-03-18T12:57:59+0100] [ALPM] installed device-mapper (2.02.186-5)
[2020-03-18T12:57:59+0100] [ALPM] installed popt (1.16-12)
[2020-03-18T12:57:59+0100] [ALPM] installed json-c (0.13.1-3)
[2020-03-18T12:57:59+0100] [ALPM] installed argon2 (20190702-2)
[2020-03-18T12:57:59+0100] [ALPM] installed cryptsetup (2.3.1-1)
[2020-03-18T12:57:59+0100] [ALPM] installed dbus (1.12.16-5)
[2020-03-18T12:57:59+0100] [ALPM] installed libmnl (1.0.4-3)
[2020-03-18T12:57:59+0100] [ALPM] installed libnftnl (1.1.5-1)
[2020-03-18T12:57:59+0100] [ALPM] installed libnl (3.5.0-2)
[2020-03-18T12:57:59+0100] [ALPM] installed libusb (1.0.23-2)
[2020-03-18T12:57:59+0100] [ALPM] installed libpcap (1.9.1-2)
[2020-03-18T12:57:59+0100] [ALPM] installed libnfnetlink (1.0.1-3)
[2020-03-18T12:57:59+0100] [ALPM] installed libnetfilter_conntrack (1.0.7-1)
[2020-03-18T12:57:59+0100] [ALPM] installed iptables (1:1.8.4-1)
[2020-03-18T12:57:59+0100] [ALPM] installed kbd (2.2.0-5)
[2020-03-18T12:57:59+0100] [ALPM] installed libidn2 (2.3.0-1)
[2020-03-18T12:57:59+0100] [ALPM] installed libelf (0.178-2)
[2020-03-18T12:57:59+0100] [ALPM] installed pcre2 (10.34-3)
[2020-03-18T12:58:00+0100] [ALPM] installed systemd (245-3)
[2020-03-18T12:58:00+0100] [ALPM-SCRIPTLET] Initializing machine ID from random generator.
[2020-03-18T12:58:00+0100] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/getty.target.wants/getty@tty1.service → /usr/lib/systemd/system/getty@.service.
[2020-03-18T12:58:00+0100] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/multi-user.target.wants/remote-fs.target → /usr/lib/systemd/system/remote-fs.target.
[2020-03-18T12:58:00+0100] [ALPM-SCRIPTLET] :: Append 'init=/usr/lib/systemd/systemd' to your kernel command line in your
[2020-03-18T12:58:00+0100] [ALPM-SCRIPTLET]    bootloader to replace sysvinit with systemd, or install systemd-sysvcompat
[2020-03-18T12:58:00+0100] [ALPM] installed p11-kit (0.23.20-3)
[2020-03-18T12:58:00+0100] [ALPM-SCRIPTLET] Created symlink /etc/systemd/user/sockets.target.wants/p11-kit-server.socket → /usr/lib/systemd/user/p11-kit-server.socket.
[2020-03-18T12:58:00+0100] [ALPM] installed ca-certificates-utils (20181109-3)
[2020-03-18T12:58:00+0100] [ALPM] installed ca-certificates-mozilla (3.51-1)
[2020-03-18T12:58:00+0100] [ALPM] installed ca-certificates (20181109-3)
[2020-03-18T12:58:00+0100] [ALPM] installed libssh2 (1.9.0-2)
[2020-03-18T12:58:00+0100] [ALPM] installed libpsl (0.21.0-2)
[2020-03-18T12:58:00+0100] [ALPM] installed libnghttp2 (1.39.2-2)
[2020-03-18T12:58:00+0100] [ALPM] installed curl (7.69.1-1)
[2020-03-18T12:58:00+0100] [ALPM] installed npth (1.6-2)
[2020-03-18T12:58:00+0100] [ALPM] installed libksba (1.3.5-2)
[2020-03-18T12:58:00+0100] [ALPM] installed libassuan (2.5.3-2)
[2020-03-18T12:58:00+0100] [ALPM] installed libsecret (0.20.2-1)
[2020-03-18T12:58:00+0100] [ALPM] installed pinentry (1.1.0-5)
[2020-03-18T12:58:00+0100] [ALPM] installed nettle (3.5.1-2)
[2020-03-18T12:58:00+0100] [ALPM] installed gnutls (3.6.12-1)
[2020-03-18T12:58:00+0100] [ALPM] installed sqlite (3.31.1-1)
[2020-03-18T12:58:01+0100] [ALPM] installed gnupg (2.2.19-1)
[2020-03-18T12:58:01+0100] [ALPM] installed gpgme (1.13.1-3)
[2020-03-18T12:58:01+0100] [ALPM] installed pacman-mirrorlist (20200207-1)
[2020-03-18T12:58:01+0100] [ALPM] installed archlinux-keyring (20200108-1)
[2020-03-18T12:58:01+0100] [ALPM] installed pacman (5.2.1-4)
[2020-03-18T12:58:01+0100] [ALPM] installed systemd-sysvcompat (245-3)
[2020-03-18T12:58:01+0100] [ALPM] installed iputils (20190709-2)
[2020-03-18T12:58:01+0100] [ALPM] installed iproute2 (5.5.0-1)
[2020-03-18T12:58:01+0100] [ALPM] installed base (2-2)
[2020-03-18T12:58:01+0100] [ALPM] transaction completed
[2020-03-18T12:58:01+0100] [ALPM] running '20-systemd-sysusers.hook'...
[2020-03-18T12:58:01+0100] [ALPM] running '30-systemd-catalog.hook'...
[2020-03-18T12:58:01+0100] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-03-18T12:58:01+0100] [ALPM-SCRIPTLET] Running in chroot, ignoring request: daemon-reload
[2020-03-18T12:58:01+0100] [ALPM] running '30-systemd-hwdb.hook'...
[2020-03-18T12:58:02+0100] [ALPM] running '30-systemd-sysctl.hook'...
[2020-03-18T12:58:02+0100] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-03-18T12:58:02+0100] [ALPM] running '30-systemd-udev-reload.hook'...
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET] Running in chroot, ignoring request.
[2020-03-18T12:58:02+0100] [ALPM] running '30-systemd-update.hook'...
[2020-03-18T12:58:02+0100] [ALPM] running 'dbus-reload.hook'...
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET] Running in chroot, ignoring request: try-reload-or-restart
[2020-03-18T12:58:02+0100] [ALPM] running 'detect-old-perl-modules.hook'...
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET] perl: warning: Setting locale failed.
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET] perl: warning: Please check that your locale settings:
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET] 	LANGUAGE = (unset),
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET] 	LC_ALL = (unset),
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET] 	LANG = "de_DE.UTF-8"
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET]     are supported and installed on your system.
[2020-03-18T12:58:02+0100] [ALPM-SCRIPTLET] perl: warning: Falling back to the standard locale ("C").
[2020-03-18T12:58:02+0100] [ALPM] running 'update-ca-trust.hook'...
[2020-03-18T13:18:59+0100] [PACMAN] Running 'pacman -r /mnt -Sy --cachedir=/mnt/var/cache/pacman/pkg --noconfirm base'
[2020-03-18T13:18:59+0100] [PACMAN] synchronizing package lists
[2020-03-18T13:20:03+0100] [PACMAN] Running 'pacman -r /mnt -Sy --cachedir=/mnt/var/cache/pacman/pkg --noconfirm base'
[2020-03-18T13:20:03+0100] [PACMAN] synchronizing package lists
[2020-03-18T13:20:03+0100] [ALPM] transaction started
[2020-03-18T13:20:03+0100] [ALPM] reinstalled base (2-2)
[2020-03-18T13:20:03+0100] [ALPM] transaction completed
[2020-03-18T13:59:40+0100] [PACMAN] Running 'pacman -r /mnt -Sy --cachedir=/mnt/var/cache/pacman/pkg --noconfirm base'
[2020-03-18T13:59:40+0100] [PACMAN] synchronizing package lists
[2020-03-18T13:59:40+0100] [ALPM] transaction started
[2020-03-18T13:59:40+0100] [ALPM] reinstalled base (2-2)
[2020-03-18T13:59:40+0100] [ALPM] transaction completed

Offline

#7 16.10.2020 15:31:47

Erl
Mitglied

Re: [gelöst] Startprobleme

Vielen lieben Dank !!

Offline

#8 16.10.2020 15:37:28

stefanhusmann
Moderator

Re: [gelöst] Startprobleme

Die Zeile

$ cat /etc/mkinitcpio.d/linux.preset

hat in der Datei /etc/mkinitcpio.d/linux.preset nichts zu suchen.

Die Sache mit dem libanjuta-Paket solltest du auch fixen, aber das sollte den Boot nicht verhindern.

Offline

#9 16.10.2020 15:56:37

schard
Moderator

Re: [gelöst] Startprobleme

stefanhusmann schrieb:

Die Zeile

$ cat /etc/mkinitcpio.d/linux.preset

hat in der Datei /etc/mkinitcpio.d/linux.preset nichts zu suchen.

Die Sache mit dem libanjuta-Paket solltest du auch fixen, aber das sollte den Boot nicht verhindern.

Naja, offensichtlich hat er das bereits alles gemacht und gelöst.
Und wahrscheinlich war ein abgebrochenes Update für die Startprobleme verantwortlich.
Pacman löscht nämlich in den Pre-Install Hooks die Kernel Images und Initcpios aus /boot und erzeugt sie in den Post-Install Hooks neu.
Wenn zwischenzeitlich unterbrochen wird, ist das System dann nicht mehr bootbar.

Offline

#10 16.10.2020 16:15:57

stefanhusmann
Moderator

Re: [gelöst] Startprobleme

Okay, da war ich wohl viiiiiiel zu spät... sad

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums