Du bist nicht angemeldet.

#1 09.10.2020 14:46:24

Spatzenhirn
Mitglied

Mein Desktop ist teilweise english

Moinsen mein Archlinux hat gnome 3.38.1
Teile meines Panells sind english ich will den kompletten Desktop auf deutsch.
Was muss ich tun oder hier posten damit ihr mir helfen könnt?

Offline

#2 09.10.2020 19:03:26

Maren
Gast

Re: Mein Desktop ist teilweise english

Schau mal hier:

Locale

Locale.conf

#3 10.10.2020 04:38:53

Spatzenhirn
Mitglied

Re: Mein Desktop ist teilweise english

Leider habe ich das gesuchte nicht gefunden. Wer weiss Rat?

Offline

#4 10.10.2020 07:07:58

Dirk
Moderator

Re: Mein Desktop ist teilweise english

Spatzenhirn schrieb:

Leider habe ich das gesuchte nicht gefunden.

Was hast du denn gesucht? In den beiden Artikeln steht alles, was du wissen musst. Umsetzen musst du es selbst.

Allerdings ist es so, dass Anwendungen manchmal einfach nicht übersetzt sind, die sind dann auch trotz deutscher Spracheinstellung auf englisch.

Online

#5 10.10.2020 10:35:55

Spatzenhirn
Mitglied

Re: Mein Desktop ist teilweise english

nano /etc/locale.gen

#de_AT.UTF-8 UTF-8
#de_AT ISO-8859-1
#de_AT@euro ISO-8859-15
#de_BE.UTF-8 UTF-8
#de_BE ISO-8859-1
#de_BE@euro ISO-8859-15
#de_CH.UTF-8 UTF-8
#de_CH ISO-8859-1
de_DE.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE@euro ISO-8859-15
#de_IT.UTF-8 UTF-8
#de_IT ISO-8859-1
#de_LI.UTF-8 UTF-8
#de_LU.UTF-8 UTF-8
#de_LU ISO-8859-1

Trotzdem bleibt es teilweise bei english auf meinem gnome Panel

Offline

#6 10.10.2020 10:48:28

Icecube63
Mitglied

Re: Mein Desktop ist teilweise english

Spatzenhirn schrieb:

Leider habe ich das gesuchte nicht gefunden. Wer weiss Rat?

Ich will gar nicht fragen wo du gesucht hast...

Wiki-Artikel Arch auf deutsch stellen

Offline

#7 10.10.2020 15:36:11

Spatzenhirn
Mitglied

Re: Mein Desktop ist teilweise english

Vielleicht hilft das noch:

 locale
locale: Kann »LC_ALL« nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
LANG=de_DE.utf8
LC_CTYPE="de_DE.utf8"
LC_NUMERIC=en_DK.utf8
LC_TIME=en_DK.utf8
LC_COLLATE="de_DE.utf8"
LC_MONETARY="de_DE.utf8"
LC_MESSAGES="de_DE.utf8"
LC_PAPER="de_DE.utf8"
LC_NAME="de_DE.utf8"
LC_ADDRESS="de_DE.utf8"
LC_TELEPHONE="de_DE.utf8"
LC_MEASUREMENT="de_DE.utf8"
LC_IDENTIFICATION="de_DE.utf8"
LC_ALL=

l

Beitrag geändert von Spatzenhirn (10.10.2020 15:36:25)

Offline

#8 10.10.2020 17:03:09

Aiy0bee1
Gast

Re: Mein Desktop ist teilweise english

Nach

Kann »LC_ALL« nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden

suchen und Fehler korrigieren!

LC_NUMERIC=en_DK.utf8
LC_TIME=en_DK.utf8

passt nicht zum Gebietsschema; korrigieren!

de_DE.utf8

ist ungleich

de_DE.UTF-8

korrigieren!

#9 10.10.2020 18:09:41

GerBra
Mitglied

Re: Mein Desktop ist teilweise english

@Spatzenhirn
Es geht dir ja um einige Gnome-Anwendungen im Panel (Post #1)
Nenne dochmal bitte eine/einige dieser Anwendungen, die im Gnome-Panel "englisch" statt wie von dir erwartet "deutsch" ist. Dann können zumindest andere Gnome-User ggf, bestätigen: Ja, die sind nur englisch (oder) Nein, bei mir ist das in Deutsch. Dirk schrieb das ja schon mal in einem seiner ersten Antwortposts.
Wenn es komplizierter ist evtl. auch einen Screenshot erstellen auf dem das Problem ersichtlich ist.

Bisher ging es im Thread ja (richtigerweise) nur um die Feststellung, ob schon grundlegende Systemeinstellungen die Ursache sein könnten. Da besteht m.E. schon noch Klärungsbedarf.
Poste bitte mal folgende Ausgaben:

locale -a
localedef --list-archive
localectl list-locales
localectl
cat /etc/vconsole.conf
cat /etc/X11/xorg.conf.d/*keyboard*
cat /etc/X11/xorg.conf

Außerdem: Welche Sprache ist in deinen Gnome-Einstellungen als "Ausgabe/Systemsprache" eingestellt?
Bei Gnome scheint diese Einstellung die systemweite Spracheinstellung ja zu überschreiben, zumindest gibt es einen Hinweis im englischen Wiki:
https://wiki.archlinux.org/index.php/LO … g_language
Dann hätte aber wohl der gesamte Desktop die falsche Sprache und nicht nur einzelne Anwendungen.

Zur schon geposteten /etc/locale.conf
und @Aiy0bee1(Gast)
Diese scheint ja auf dem Wiki-Artikel zu locales zu basieren. https://wiki.archlinux.de/title/Locale
Mit der en_DK-Variante für einige LC-Variablen *kann* man machen bei Bedarf, dann muß die en_DK Locale aber auch aktiviert sein.
Die Schreibweise für z.B. de_DE.UTF-8 und de_DE.utf8 scheinen beide "gültig" zu sein (ich habe nur ein RFC kurz überflogen und nichts gefunden...), aber "locale -a" gibt die notierte de_DE.UTF-8 Schreibweise auch als de_DE.utf8 aus.
NB: Trotzdem sollte man (@Dirk ?) evtl. den o.a. Wiki-Artikel zu locale in der Schreibweise so anpassen, daß in der /etc/locale.conf die Notation "de_DE.UTF-8" verwendet wird. Wie in darin weiterverlinkten Wikiartikeln auch, und wie auch auf der passenden archlinux.org Seite zu locale. Das würde m.E. "Verwirrung" beseitigen.

Beitrag geändert von GerBra (10.10.2020 18:13:22)

Offline

#10 10.10.2020 18:37:17

Aiy0bee1
Gast

Re: Mein Desktop ist teilweise english

GerBra schrieb:

Die Schreibweise für z.B. de_DE.UTF-8 und de_DE.utf8 scheinen beide "gültig" zu sein (ich habe nur ein RFC kurz überflogen und nichts gefunden...), aber "locale -a" gibt die notierte de_DE.UTF-8 Schreibweise auch als de_DE.utf8 aus.

Das hatte ich auch erwartet, sieht aber bei mir so aus:

C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
deutsch
german
POSIX

aber

$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES=de_DE.UTF8
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

Nachdem aber in locale.conf

LANG=de_DE.UTF8
LC_MESSAGES=de_DE.UTF8

und auch in locale.gen

de_DE.UTF-8 UTF-8 

steht, sollte es nach locale-gen eigentlich auch genau so in die Systemkonfiguration übernommen werden

#11 10.10.2020 19:01:37

GerBra
Mitglied

Re: Mein Desktop ist teilweise english

Aiy0bee1 schrieb:

Das hatte ich auch erwartet, sieht aber bei mir so aus:

C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
deutsch
german
POSIX

Die gleiche Ausgabe erhalte ich hier auch (außer daß bei mir noch zusätzlich en_US.utf8 aktiv ist). In  meiner locale.conf steht z.B. nur LANG=de_DE.UTF-8 drin, in der /etc/locale.gen ist für die Kodierungsvariante auch xx_YY.UTF-8 drin. Trotzdem scheint die Schreibweise für die Kodierung mehrdeutig erlaubt zu sein, also sowohl für die locales(locale.gen) als auch für die LC-Variablen(locale.conf), also
UTF-8
utf8
UTF8.
Ich habe wie gesagt im RFC  http://tools.ietf.org/html/bcp47 auf die "Schnelle" nichts diesbezüglich gefunden, vermute aber das ein Parser im gesamten Locale-Prozedere den Bindestrich und Groß-/Kleinschreibung filtert, so daß die Kodierung letztendlich eben zu utf8 wird (wie locale -a es anzeigt).
Trotzdem wäre IMHO (auch aufgrund unserer Diskusssion jetzt) eine einheitliche Schreibweise sinnvoll, ich habe es im Wiki-Artikel auch nochmal zur Diskussion gestellt.

Beitrag geändert von GerBra (10.10.2020 19:02:54)

Offline

#12 10.10.2020 20:38:17

Dirk
Moderator

Re: Mein Desktop ist teilweise english

Eventuell mal die Locales aufräumen?

$ locale -a
C
de_DE.utf8
en_DK.utf8
en_US.utf8
POSIX

$ cat /etc/locale.gen
de_DE.UTF-8 UTF-8  
en_DK.UTF-8 UTF-8  
en_US.UTF-8 UTF-8  

$ locale
LANG=de_DE.utf8
LC_CTYPE="de_DE.utf8"
LC_NUMERIC=en_DK.utf8
LC_TIME=en_DK.utf8
LC_COLLATE="de_DE.utf8"
LC_MONETARY="de_DE.utf8"
LC_MESSAGES="de_DE.utf8"
LC_PAPER="de_DE.utf8"
LC_NAME="de_DE.utf8"
LC_ADDRESS="de_DE.utf8"
LC_TELEPHONE="de_DE.utf8"
LC_MEASUREMENT="de_DE.utf8"
LC_IDENTIFICATION="de_DE.utf8"
LC_ALL=

iso8601 und die @euro-Varianten nutzt doch keiner™ mehr big_smile

Online

#13 11.10.2020 05:28:27

Spatzenhirn
Mitglied

Re: Mein Desktop ist teilweise english

@GerBra
der gewünschte Output

locale -a
C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
deutsch
german
POSIX
bash: PROMPT_COMMAND: Zeile 1: Syntaxfehler beim unerwarteten Wort `;'
bash: PROMPT_COMMAND: Zeile 1: `history -a; history -n; history -a; history -n; ; printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
ocaledef --list-archive
de_DE
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
de_DE@euro
deutsch
german
bash: PROMPT_COMMAND: Zeile 2: Syntaxfehler beim unerwarteten Wort `;'
bash: PROMPT_COMMAND: Zeile 2: `history -a; history -n; history -a; history -n; ; printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
localectl list-locales
de_DE.UTF-8
localectl
   System Locale: LANG=de_DE.UTF-8
       VC Keymap: de-latin1-nodeadkeys
      X11 Layout: de,de
     X11 Variant: ,bone
cat /etc/X11/xorg.conf.d/*keyboard*
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de,de"
        Option "XkbVariant" ",bone"
EndSection
Section "InputClass"
Identifier "keyboard"
MatchIskeyboard "yes"
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbVariant" "nodeadkey"
EndSection
cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory

Offline

#14 11.10.2020 10:35:43

Aiy0bee1
Gast

Re: Mein Desktop ist teilweise english

Spatzenhirn schrieb:

bash: PROMPT_COMMAND: Zeile 1: Syntaxfehler beim unerwarteten Wort `;'
bash: PROMPT_COMMAND: Zeile 1: `history -a; history -n; history -a; history -n; ; printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'

Deine /etc/bash.bashrc ist offenbar auch kaputt

#15 11.10.2020 10:44:39

Spatzenhirn
Mitglied

Re: Mein Desktop ist teilweise english

Wie kann ich die /etc/bash.bashrc reparieren?
# /etc/bash.bashrc


#

#
# /etc/bash.bashrc
#

# If not running interactively, don't do anything
[[ $- != *i* ]] && return

[[ $DISPLAY ]] && shopt -s checkwinsize

PS1='[\u@\h \W]\$ '

case ${TERM} in
  xterm*|rxvt*|Eterm|aterm|kterm|gnome*)
    PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }'printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'

    ;;
  screen*)
    PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }'printf "\033_%s@%s:%s\033\\" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
    ;;
esac

[ -r /usr/share/bash-completion/bash_completion   ] && . /usr/share/bash-completion/bash_completion

Beitrag geändert von Spatzenhirn (11.10.2020 10:47:30)

Offline

#16 11.10.2020 11:05:14

Aiy0bee1
Gast

Re: Mein Desktop ist teilweise english

Spatzenhirn schrieb:

Wie kann ich die /etc/bash.bashrc reparieren?

Die scheint in Ordnung zu sein, trotzdem sieht es so aus, als wenn deine Umgebungsvariable PROMPT_COMMAND falsch aufgebaut wird. Was sagt "echo $PROMPT_COMMAND"? Bei mir sieht der Inhalt so aus:

printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"

Das wird zwar keine Auswirkungen auf dein Lokalisierungsproblem haben, zeigt aber doch, das an deinem System mehr vermurkst ist als nur die Sprachen.

#17 11.10.2020 12:02:46

GerBra
Mitglied

Re: Mein Desktop ist teilweise english

Spatzenhirn schrieb:

@GerBra
der gewünschte Output

Mehrere Dinge:
a) Wenn du in der /etc/locale.conf (aus deinem Post #7) die LC-Varianten mit en_DK.UTF-8 verwenden willst, dann muß diese Locale in der /etc/locale.gen auch aktiviert sein. Das steht auch im Wiki-Artikel, indem über die "Vorteile" dieser LC-Varianten geschrieben wird. Also en_DK.UTF-8 aktivieren und die geänderten Locales mit locale-gen neu erstellen lassen.
locale -a bzw. localectl list-locales müssen die Änderungen dann anzeigen.
Tip: in dem Zuge auch gleich die Locale en_US.UTF-8 mitaktivieren/generieren, viele Programme nutzen diese als Ausweich-Anzeige (englisch) falls es keine andere Ausgabesprache gibt.

b) Du hast scheinbar mehr als eine *keyboard*.conf Datei in /etc/x11/xorg.conf.d/
Beide konfigurieren das "gleiche" Tastatur-Eingabegerät für Xorg, diejenige Datei die allerdings verwendet wird (wahrscheinlich die mit höherer Nummer im Dateinamen) ist falsch bzw. irreführend.

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de,de"
        Option "XkbVariant" ",bone"
EndSection

Diese Variante wird bei dir (das zeigt die Ausgabe von localectl) verwendet. Die definierte Variante "bone" für das zweite de-Layout ist m.E. absolut falsch/unsinnig, außer du kannst belegen woher/warum du diese verwendest. Es soll bei wir wohl eher "nodeadkeys" sein (wie in der zweiten keyboard-Datei, dort fehlt allerdings IMHO das "s" bei nodeadkey. Du solltest dich für eine Methode entscheiden zu Erstellung *einer* *keyboard*.conf: Entweder mittels localectl oder per Hand. Und auf die richtigen Optionen achten. Siehe alle oben im Thread aufgeführten Wiki-Artikel oder (englisch, ausführlicher) https://wiki.archlinux.org/index.php/Ke … on_in_Xorg

c) Dein bash_prompt /prompt_command ist "kaputt". Dort ist ein Semikolon zuviel drin. Stört dich diese Meldung bei jedem Shell-Befehl nicht?
Du hast ja deine bashrc schon gepostet. Dazu:
Bei dir wird PROMPT_COMMAND noch in einer anderen Datei (evtl. in /etc) festgelegt/definiert (nämlich mit den zwei history Befehlen). Was du in deiner bashrc nun m.W. "falsch" machst sind:
1. Du verkettest $PROMPT_COMMAND nochmal mit sich selbst im case-Statement ohne allerdings PROMPT_COMMAND nochmal anders zu definieren (nur dann würde eine Verkettung von "altem Wert" mit "neuem Wert" überhaupt "Sinn" machen. So erhältst du nur zweimal die gleichen Befehle, nämlich:  history -a; history -n; history -a; history -n;
2. Dadurch, daß du deinen (sonstwo) definierten PROMPT_COMMAND mit einem Semikolon abschließt und noch ein zusätzliches Semikolon im case-Statement bei der (unsinnigen) Verkettung der beiden PROMPT_COMMAND's einfügst produzierst du diese Fehlermeldung. Also entweder die (woimmerauch) Definition des PROMPT_COMMAND='history -a; history -n;' anpassen oder die Verkettung in case "richtig" machen (nicht zweimal, und das fehlerhafte Semikolon entfernen).
//Edit 2
Muß mich korrigieren, diese "Verkettung" ist ja nur eine bedingte Verkettung falls die erste Variable nicht definiert ist. Dadurch entsteht *nicht* dieser zweimalige Aufruf der beiden history-Kommandos. Das läßt vermuten, daß in deiner ursprünglichen Festlegung von PROMPT_COMMAND zweimal das "Gleiche" drinsteht. Einmal "history -a; history -n;" würde genügen. Zur Verdeutlichung was zum zweiten, fehlerhaften Semikolon führt (PC steht hier für PROMPT_COMMAND):

# Das ist bei dir irgendwo definiert, mit abschließendem Semikolon als Befehlstrenner
$ PC="history -a; history -n; history -a; history -n;"
$ echo $PC
history -a; history -n; history -a; history -n;
# jetzt zu deinen case-Statements in der bashrc
$ PC=${PC:+$PC; }'printf  '
$ echo $PC
# durch +$PC; wird nun das zweite fehlerhafte Semikolon hinzugefügt
#           ^
history -a; history -n; history -a; history -n;; printf
# was die Fehlermeldung produziert. Richtiger wäre
$ PC=${PC:+$PC}' printf '

Versuche diese Dinge mal zu bereinigen, aber !!!!!:
a) Grundlegend scheinen diese Fehler nicht für Probleme bei dir zu sorgen (Dann wären deine Fragen anders)
b) Was du absolut schuldig geblieben bist ist die Antwort auf deine eigentliche Eingangsfrage, um die ich dich bat.
//Edit

GerBra schrieb:

@Spatzenhirn
Es geht dir ja um einige Gnome-Anwendungen im Panel (Post #1)
Nenne dochmal bitte eine/einige dieser Anwendungen, die im Gnome-Panel "englisch" statt wie von dir erwartet "deutsch" ist. Dann können zumindest andere Gnome-User ggf, bestätigen: Ja, die sind nur englisch (oder) Nein, bei mir ist das in Deutsch. Dirk schrieb das ja schon mal in einem seiner ersten Antwortposts.
Wenn es komplizierter ist evtl. auch einen Screenshot erstellen auf dem das Problem ersichtlich ist.

Beitrag geändert von GerBra (11.10.2020 12:57:30)

Offline

#18 11.10.2020 14:09:23

Spatzenhirn
Mitglied

Re: Mein Desktop ist teilweise english

Openweather und das Panel sind english
Einstellungen sind english

Offline

#19 11.10.2020 15:50:22

GerBra
Mitglied

Re: Mein Desktop ist teilweise english

Gut, da muß dir dann jemand weiterhelfen der diese Erweiterung auch nutzt. Oder zumindest Gnome nutzt.

Hast du gnome-shell-extension-openweather aus den AUR gebaut/installiert oder händisch sonstwie?
Laut Quellcode ist diese Erweiterung zumindest mit einer deutschen Sprachdatei für Ausgabe/Einstellungen versehen, sollte also bei korrekter Erkennung der Systemsprache durch Gnome auch verwendet werden.

Offline

#20 11.10.2020 16:13:23

Spatzenhirn
Mitglied

Re: Mein Desktop ist teilweise english

Ja gnome-shell-extension-openweather aus den AUR

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums