Du bist nicht angemeldet.

#1 18.09.2020 17:44:17

unitymedia
Mitglied

Brother 375CW + archlinux

Hallo Archianer,
bin neu hier und bräuchte Hilfe ,
Anscheinend verläuft die Treiber-installation erfolgreich , und trotzdem wird printer/scanner nicht angesprochen
hier der Log

[user@user-pc BrotherPrinter]$ sudo ./linux-brprinter-installer-2.2.2-1
Input model name ->DCP-375CW

You are going to install following packages.
   dcp375cwlpr-1.1.3-1.i386.deb
   dcp375cwcupswrapper-1.1.3-1.i386.deb
   brscan3-0.2.13-1.amd64.deb
   brscan-skey-0.3.1-1.amd64.deb
OK? [y/N] ->y

./linux-brprinter-installer-2.2.2-1: Zeile 2184: apt-get: Kommando nicht gefunden.
./linux-brprinter-installer-2.2.2-1: Zeile 2188: apt-get: Kommando nicht gefunden.
./linux-brprinter-installer-2.2.2-1: Zeile 2192: apt-get: Kommando nicht gefunden.
ln: die symbolische Verknüpfung '/etc/init.d/cupsys' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
ln: die symbolische Verknüpfung '/etc/init.d/cups' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
ln: die symbolische Verknüpfung '/etc/init.d/lpd' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
ln: die symbolische Verknüpfung '/etc/init.d/lprng' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
dpkg -x dcp375cwlpr-1.1.3-1.i386.deb /
dpkg -x dcp375cwcupswrapper-1.1.3-1.i386.deb /
(Lese Datenbank ... 75 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von dcp375cwcupswrapper:i386 (1.1.3-1) ...
lpadmin: Der Drucker oder die Klasse existiert nicht.
dpkg-deb: Paket »dcp375cwlpr« wird in »dcp375cwlpr-1.1.3-1a.i386.deb« gebaut.
dpkg -b ./brother_driver_packdir dcp375cwlpr-1.1.3-1a.i386.deb
dpkg-deb: Paket »dcp375cwcupswrapper« wird in »dcp375cwcupswrapper-1.1.3-1a.i386.deb« gebaut.
dpkg -b ./brother_driver_packdir dcp375cwcupswrapper-1.1.3-1a.i386.deb
dpkg -i --force-all dcp375cwlpr-1.1.3-1a.i386.deb
dpkg: Warnung: Problem wird übergangen, weil --force angegeben ist: 
dpkg: Warnung: Paket-Architektur (i386) passt nicht zum System (amd64)
(Lese Datenbank ... 71 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von dcp375cwlpr-1.1.3-1a.i386.deb ...
Entpacken von dcp375cwlpr:i386 (1.1.3-1) über (1.1.3-1) ...
dcp375cwlpr:i386 (1.1.3-1) wird eingerichtet ...
mkdir: das Verzeichnis „/var/spool/lpd/dcp375cw“ kann nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
chown: ungültiger Benutzer: „lp“
chgrp: Zugriff auf '/var/spool/lpd/dcp375cw' nicht möglich: Datei oder Verzeichnis nicht gefunden
chmod: Zugriff auf '/var/spool/lpd/dcp375cw' nicht möglich: Datei oder Verzeichnis nicht gefunden
dpkg -i --force-all dcp375cwcupswrapper-1.1.3-1a.i386.deb
dpkg: Warnung: Problem wird übergangen, weil --force angegeben ist: 
dpkg: Warnung: Paket-Architektur (i386) passt nicht zum System (amd64)
Vormals nicht ausgewähltes Paket dcp375cwcupswrapper:i386 wird gewählt.
(Lese Datenbank ... 71 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von dcp375cwcupswrapper-1.1.3-1a.i386.deb ...
Entpacken von dcp375cwcupswrapper:i386 (1.1.3-1) ...
dcp375cwcupswrapper:i386 (1.1.3-1) wird eingerichtet ...
lpadmin: Printer drivers are deprecated and will stop working in a future version of CUPS.
#
The security level of AppArmor has been lowered. (aa-complain cups)
aa-complain cupsd
Profil für /usr/bin/cupsd nicht gefunden, wird übersprungen
Will you specify the Device URI? [Y/n] ->y


0: cups-brf:/
1: lpd
2: ipps
3: socket
4: beh
5: https
6: cups-pdf:/
7: ipp
8: http
9: smb
10: dnssd://Brother%20DCP-375CW._pdl-datastream._tcp.local/
11: dnssd://Kyocera%20ECOSYS%20M5526cdn._ipp._tcp.local/?uuid=4509a320-0061-00fc-008c-0025074fcd7a
12: dnssd://kyocera%20%40%20xpenology._printer._tcp.local/
13: socket://192.168.153.130
14: lpd://BRWF07BCB2E1A55/BINARY_P1
15: ipps://Kyocera%20ECOSYS%20M5526cdn._ipps._tcp.local/
16: ipp://kyocera%20%40%20xpenology._ipp._tcp.local/
17 (I): Specify IP address.
18 (A): Auto. (dnssd://Brother%20DCP-375CW._pdl-datastream._tcp.local/)

select the number of destination Device URI. ->18

lpadmin -p DCP375CW -v dnssd://Brother%20DCP-375CW._pdl-datastream._tcp.local/ -E
Test Print? [y/N] ->y

wait 5s.
lpr -P DCP375CW /usr/share/cups/data/testprint
You are going to install following packages.
   brscan3-0.2.13-1.amd64.deb
dpkg -i --force-all brscan3-0.2.13-1.amd64.deb
(Lese Datenbank ... 75 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von brscan3-0.2.13-1.amd64.deb ...
Entpacken von brscan3 (0.2.13-1) über (0.2.13-1) ...
brscan3 (0.2.13-1) wird eingerichtet ...
You are going to install following packages.
   brscan-skey-0.3.1-1.amd64.deb
dpkg -i --force-all brscan-skey-0.3.1-1.amd64.deb
(Lese Datenbank ... 75 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von brscan-skey-0.3.1-1.amd64.deb ...
Entpacken von brscan-skey (0.3.1-1) über (0.3.1-1) ...
dpkg: brscan-skey: Abhängigkeitsprobleme, wird aber trotzdem wie gefordert konfiguriert:
 brscan-skey hängt ab von libc6 (>= 2.3.4-1); aber:
  Paket libc6 ist nicht installiert.
 brscan-skey hängt ab von libsane (>= 1.0.11-3); aber:
  Paket libsane ist nicht installiert.

brscan-skey (0.3.1-1) wird eingerichtet ...
ls: Zugriff auf '/etc/udev/rules.d/*.rules' nicht möglich: Datei oder Verzeichnis nicht gefunden
ls: Zugriff auf '/etc/udev/rules.d/*.rules' nicht möglich: Datei oder Verzeichnis nicht gefunden
 enter IP address ->^C
[user@user-pc BrotherPrinter]$ brsaneconfig3 -q | grep SCANNER 
[user@user-pc BrotherPrinter]$ sudo ./linux-brprinter-installer-2.2.2-1
[sudo] Passwort für user: 
Input model name ->DCP-375CW

You are going to install following packages.
   dcp375cwlpr-1.1.3-1.i386.deb
   dcp375cwcupswrapper-1.1.3-1.i386.deb
   brscan3-0.2.13-1.amd64.deb
   brscan-skey-0.3.1-1.amd64.deb
OK? [y/N] ->y

./linux-brprinter-installer-2.2.2-1: Zeile 2184: apt-get: Kommando nicht gefunden.
./linux-brprinter-installer-2.2.2-1: Zeile 2188: apt-get: Kommando nicht gefunden.
./linux-brprinter-installer-2.2.2-1: Zeile 2192: apt-get: Kommando nicht gefunden.
ln: die symbolische Verknüpfung '/etc/init.d/cupsys' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
ln: die symbolische Verknüpfung '/etc/init.d/cups' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
ln: die symbolische Verknüpfung '/etc/init.d/lpd' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
ln: die symbolische Verknüpfung '/etc/init.d/lprng' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
dpkg -x dcp375cwlpr-1.1.3-1.i386.deb /
dpkg -x dcp375cwcupswrapper-1.1.3-1.i386.deb /
(Lese Datenbank ... 75 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von dcp375cwcupswrapper:i386 (1.1.3-1) ...
dpkg-deb: Paket »dcp375cwlpr« wird in »dcp375cwlpr-1.1.3-1a.i386.deb« gebaut.
dpkg -b ./brother_driver_packdir dcp375cwlpr-1.1.3-1a.i386.deb
dpkg-deb: Paket »dcp375cwcupswrapper« wird in »dcp375cwcupswrapper-1.1.3-1a.i386.deb« gebaut.
dpkg -b ./brother_driver_packdir dcp375cwcupswrapper-1.1.3-1a.i386.deb
dpkg -i --force-all dcp375cwlpr-1.1.3-1a.i386.deb
dpkg: Warnung: Problem wird übergangen, weil --force angegeben ist: 
dpkg: Warnung: Paket-Architektur (i386) passt nicht zum System (amd64)
(Lese Datenbank ... 71 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von dcp375cwlpr-1.1.3-1a.i386.deb ...
Entpacken von dcp375cwlpr:i386 (1.1.3-1) über (1.1.3-1) ...
dcp375cwlpr:i386 (1.1.3-1) wird eingerichtet ...
mkdir: das Verzeichnis „/var/spool/lpd/dcp375cw“ kann nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
chown: ungültiger Benutzer: „lp“
chgrp: Zugriff auf '/var/spool/lpd/dcp375cw' nicht möglich: Datei oder Verzeichnis nicht gefunden
chmod: Zugriff auf '/var/spool/lpd/dcp375cw' nicht möglich: Datei oder Verzeichnis nicht gefunden
dpkg -i --force-all dcp375cwcupswrapper-1.1.3-1a.i386.deb
dpkg: Warnung: Problem wird übergangen, weil --force angegeben ist: 
dpkg: Warnung: Paket-Architektur (i386) passt nicht zum System (amd64)
Vormals nicht ausgewähltes Paket dcp375cwcupswrapper:i386 wird gewählt.
(Lese Datenbank ... 71 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von dcp375cwcupswrapper-1.1.3-1a.i386.deb ...
Entpacken von dcp375cwcupswrapper:i386 (1.1.3-1) ...
dcp375cwcupswrapper:i386 (1.1.3-1) wird eingerichtet ...
lpadmin: Printer drivers are deprecated and will stop working in a future version of CUPS.
#
The security level of AppArmor has been lowered. (aa-complain cups)
aa-complain cupsd
Profil für /usr/bin/cupsd nicht gefunden, wird übersprungen
Will you specify the Device URI? [Y/n] ->y


0: lpd
1: beh
2: http
3: ipp
4: https
5: cups-pdf:/
6: cups-brf:/
7: ipps
8: socket
9: smb
10: dnssd://Brother%20DCP-375CW._pdl-datastream._tcp.local/
11: dnssd://Kyocera%20ECOSYS%20M5526cdn._ipp._tcp.local/?uuid=4509a320-0061-00fc-008c-0025074fcd7a
12: dnssd://kyocera%20%40%20xpenology._printer._tcp.local/
13: socket://192.168.153.130
14: lpd://BRWF07BCB2E1A55/BINARY_P1
15: ipps://Kyocera%20ECOSYS%20M5526cdn._ipps._tcp.local/
16: ipp://kyocera%20%40%20xpenology._ipp._tcp.local/
17 (I): Specify IP address.
18 (A): Auto. (dnssd://Brother%20DCP-375CW._pdl-datastream._tcp.local/)

select the number of destination Device URI. ->10

lpadmin -p DCP375CW -v dnssd://Brother%20DCP-375CW._pdl-datastream._tcp.local/ -E
Test Print? [y/N] ->y

wait 5s.
lpr -P DCP375CW /usr/share/cups/data/testprint
You are going to install following packages.
   brscan3-0.2.13-1.amd64.deb
dpkg -i --force-all brscan3-0.2.13-1.amd64.deb
(Lese Datenbank ... 75 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von brscan3-0.2.13-1.amd64.deb ...
Entpacken von brscan3 (0.2.13-1) über (0.2.13-1) ...
brscan3 (0.2.13-1) wird eingerichtet ...
You are going to install following packages.
   brscan-skey-0.3.1-1.amd64.deb
dpkg -i --force-all brscan-skey-0.3.1-1.amd64.deb
(Lese Datenbank ... 75 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von brscan-skey-0.3.1-1.amd64.deb ...
Entpacken von brscan-skey (0.3.1-1) über (0.3.1-1) ...
dpkg: brscan-skey: Abhängigkeitsprobleme, wird aber trotzdem wie gefordert konfiguriert:
 brscan-skey hängt ab von libc6 (>= 2.3.4-1); aber:
  Paket libc6 ist nicht installiert.
 brscan-skey hängt ab von libsane (>= 1.0.11-3); aber:
  Paket libsane ist nicht installiert.

brscan-skey (0.3.1-1) wird eingerichtet ...
ls: Zugriff auf '/etc/udev/rules.d/*.rules' nicht möglich: Datei oder Verzeichnis nicht gefunden
ls: Zugriff auf '/etc/udev/rules.d/*.rules' nicht möglich: Datei oder Verzeichnis nicht gefunden
 enter IP address ->192.168.153.183

brsaneconfig3 -a name=DCP-375CW model=DCP-375CW ip=192.168.153.183
Hit Enter/Return key.
[user@user-pc BrotherPrinter]$ brsaneconfig3 -q | grep SCANNER 
[user@user-pc BrotherPrinter]$ cd /usr/share/cups/model
[user@user-pc model]$ ls
Brother  brother_dcp375cw_printer_en.ppd  CUPS-PDF_noopt.ppd  CUPS-PDF_opt.ppd
[user@user-pc model]$
  

Offline

#2 18.09.2020 18:18:21

Greg
Mitglied

Re: Brother 375CW + archlinux

unitymedia schrieb:

... apt-get: Kommando nicht gefunden, ...symbolische Verknüpfung '/etc/init.d/cupsys' konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden

Du versuchst ein Debianpaket auf Arch-Linux zu installieren.
Das klappt natürlich nicht.
Für deinen Drucker gibt es im AUR das richtige um ein Paket zu bauen und dieses zu installieren.
Du gehst wie folgt vor:
Auf der Seite https://aur.archlinux.org/packages/brother-dcp375cw/
ist oben rechts unter download snapshot ein Link. Das Ding lädst du dir runter und entpackst es.

tar -xf brother-dcp375cw.tar.gz

danach wechselst du in das entpackte Verzeichnis cd brother...
dann gibst du

makepkg

ein.
Es werden die nötigen Dateien runtergeladen und ein Paket gebaut.
Das nennt sich brother-dcp375cw-1.1.3-1-x86_64.pkg.tar.zst  .
Mit pacman -U brother-dcp375cw-1.1.3-1-x86_64.pkg.tar.zst installierst du das Paket in dein Arch-Linux.
fertig.
Das Gleiche machst du auch mit brscan3 https://aur.archlinux.org/packages/brscan3.

Siehe dir noch das Kapitel https://wiki.archlinux.de/title/Arch_User_Repository  an.
Ausserdem noch https://wiki.archlinux.de/title/AUR_Hilfsprogramme
z.B. pikaur das du genauso installieren kannst wie zuvor beschrieben.
Ist einmal pikaur oder ein anderes AUR-Hilfsprogramm installiert, so kannst du das dann damit machen.
Gruß aus DN
Greg

Beitrag geändert von Greg (18.09.2020 18:26:11)

Offline

#3 18.09.2020 23:59:58

stefanhusmann
Moderator

Re: Brother 375CW + archlinux

unitymedia, selbst wenn du das Paket wie Greg beschrieben hat gebaut bekommst, wird es nicht problemlos installierbar sein, da es zu Dateikonflikten kommen wird. Diese wird es geben, weil du dein System verhunzt hast. Man installiert nicht als root an pacman vorbei. Es dürfte schwierig sein, den Mist rückstandsfrei vom System entfernt zu bekommen. Es könnte sogar sein, dass es einfacher ist Arch neu zu installieren.

Greg schrieb:

Du versuchst ein Debianpaket auf Arch-Linux zu installieren.

Es ist noch schlimmer: Er hat einen Installer mit root-Rechten ausgeführt, der dann versucht, mehrere Debian-Pakete zu installieren (und dabei anscheinend nicht einmal prüft, ob er sich überhaupt auf einem Debian-System befindet). Das sollte man m.E. nicht einmal unter Debian so machen.

Offline

#4 19.09.2020 02:10:34

unitymedia
Mitglied

Re: Brother 375CW + archlinux

Vielen Dank  für die Tips , habe vergessen zu erwähnen , dpgk ist drauf

[user@user-pc model]$ pacman -Si dpkg
Repositorium             : community
Name                     : dpkg
Version                  : 1.20.5-1
Beschreibung             : The Debian Package Manager tools
Architektur              : x86_64
URL                      : https://tracker.debian.org/pkg/dpkg
Lizenzen                 : GPL
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : xz  zlib  bzip2  perl
Optionale Abhängigkeiten : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Größe des Downloads      : 1793,97 KiB
Installationsgröße       : 8455,16 KiB
Packer                   : Anatol Pomozov <anatol.pomozov@gmail.com>
Erstellt am              : Do 09 Jul 2020 21:40:51 CEST
Verifiziert durch        : MD5-Summe  SHA-256-Summe  Signatur

[user@user-pc model]$ 

Werde erst mal Greg seine Empfehlung folgen .

Offline

#5 19.09.2020 09:13:54

Greg
Mitglied

Re: Brother 375CW + archlinux

unitymedia schrieb:

Vielen Dank  für die Tips , habe vergessen zu erwähnen , dpgk ist drauf

Mit dem Tool kannst du aber kein Debianpaket ins Arch-Linux installieren wie du bereits gesehen hast.
Zum Glück ist da kein apt-get mit drin gewesen.
Du hast eine Logdatei im 1. Post mitgegeben. Versuche die Dateien herauszunehmen die du zuvor installiert hast.
Wenn das nicht klappt, so installierst du am Besten Arch-Linux neu.
Das Tool dpkg scheint eher ein Werkzeug zu sein, um ein Debianpaket zu bauen. Ich kenne es nicht und weiss nichts darüber.
Gruß aus DN
Greg

Offline

#6 19.09.2020 12:39:10

stefanhusmann
Moderator

Re: Brother 375CW + archlinux

Nein, dpkg ist zum Installieren von lokal vorhandenen Paketen (entspricht grob gesagt pacman -U). apt-get ruft es auf, kümmert sich aber auch um das Herunterladen aus der Ferne (entspricht grob gesagt pacman -S). Bei den "alten" Paketmanagern war diese Funktionalität halt immer getrennt auf zwei Tools.

Offline

#7 19.09.2020 15:40:50

Greg
Mitglied

Re: Brother 375CW + archlinux

stefanhusmann schrieb:

Nein, dpkg ist zum Installieren von lokal vorhandenen Paketen.

Danke für den Hinweis!!
Habe schon ewig nicht mehr mit Debian rumgemacht.

Offline

#8 19.09.2020 19:15:28

schard
Moderator

Re: Brother 375CW + archlinux

... mit dem Unterschied, dass pacman -U auch entfernte Pakete installieren kann.
Und dpkg ist nicht in den Repos, um damit Debian Pakete unter Arch Linux zu installieren, sondern um unter Arch Linux Pakete für Debian bauen zu können.
https://wiki.archlinux.org/index.php/Cr … tributions

Offline

#9 20.09.2020 12:43:59

unitymedia
Mitglied

Re: Brother 375CW + archlinux

Irgend was Feht hier

[user@user-pc BrotherPrinter]$ sudo tar -xf brother-dcp375cw.tar.gz
[user@user-pc BrotherPrinter]$ makepkg
==> FEHLER: Sie haben keine Schreib-Berechtigung für das Verzeichnis  $BUILDDIR (/opt/BrotherPrinter).
    Breche ab...
[user@user-pc BrotherPrinter]$ sudo makepkg
==> FEHLER: makepkg als root auszuführen ist nicht erlaubt, da es Ihrem System bleibenden, katastrophalen Schaden zufügen kann.
[user@user-pc BrotherPrinter]$ 

Offline

#10 20.09.2020 16:30:46

stefanhusmann
Moderator

Re: Brother 375CW + archlinux

Du musst das in einem beliebigen Verzeichnis machen, in dem du auch Schreibrechte hast.

Offline

#11 20.09.2020 20:13:41

unitymedia
Mitglied

Re: Brother 375CW + archlinux

Hier solte mit rechten kein Problem sein und trotzdem gibs meker

[user@user-pc Downloads]$ tar -xf brother-dcp375cw.tar.gz
[user@user-pc Downloads]$ makepkg
==> FEHLER: PKGBUILD existiert nicht.
[user@user-pc Downloads]$ ls
 brother-dcp375cw
 brother-dcp375cw.tar.gz
[user@user-pc Downloads]$

Offline

#12 20.09.2020 21:36:54

stefanhusmann
Moderator

Re: Brother 375CW + archlinux

cd brother-dcp375cw 

und dann

makepkg

Offline

#13 20.09.2020 22:07:26

unitymedia
Mitglied

Re: Brother 375CW + archlinux

Wenn ich richtig sehe meckert noch

/usr/bin/sudo: /usr/bin/sudo: Kann die Datei nicht ausführen.
You can now register your new printer using the web interface at:
  http://localhost:631/

[user@user-pc Downloads]$ cd brother-dcp375cw
[user@user-pc brother-dcp375cw]$  makepkg
==> Erstelle Paket: brother-dcp375cw 1.1.3-1 (So 20 Sep 2020 21:58:09 CEST)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> Lade dcp375cwlpr-1.1.3-1.i386.rpm herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1854k  100 1854k    0     0   822k      0  0:00:02  0:00:02 --:--:--  822k
  -> Lade dcp375cwcupswrapper-1.1.3-1.i386.rpm herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 15705  100 15705    0     0  56290      0 --:--:-- --:--:-- --:--:-- 56290
  -> cupswrapper-license.txt gefunden
  -> lpr-license.txt gefunden
==> Überprüfe source Dateien mit md5sums...
    dcp375cwlpr-1.1.3-1.i386.rpm ... Durchgelaufen
    dcp375cwcupswrapper-1.1.3-1.i386.rpm ... Durchgelaufen
    cupswrapper-license.txt ... Durchgelaufen
    lpr-license.txt ... Durchgelaufen
==> Entpacke Quellen...
  -> Entpacke dcp375cwlpr-1.1.3-1.i386.rpm mit bsdtar
  -> Entpacke dcp375cwcupswrapper-1.1.3-1.i386.rpm mit bsdtar
==> Beginne prepare()...
==> Betrete fakeroot Umgebung...
==> Beginne package()...
==> Säubere Installation...
  -> Entferne libtool Dateien...
  -> Bereinige ungewollte Dateien...
  -> Entferne statische Bibliotheken...
  -> Entferne unnötige Symbole aus Binär-Dateien und Bibliotheken...
  -> Komprimiere Man-Pages und Info-Seiten...
==> Prüfe auf Paketierungsprobleme...
==> Erstelle Paket "brother-dcp375cw"...
  -> Erstelle .PKGINFO Datei...
  -> Erstelle .BUILDINFO Datei...
  -> Füge install Datei hinzu...
  -> Erstelle .MTREE-Datei...
  -> Komprimiere Paket... 
==> Verlasse fakeroot Umgebung.
==> Beendete Erstellung: brother-dcp375cw 1.1.3-1 (So 20 Sep 2020 21:58:18 CEST)
[user@user-pc brother-dcp375cw]$ ls
brother-dcp375cw-1.1.3-1-x86_64.pkg.tar.zst  cupswrapper-license.txt               dcp375cwlpr-1.1.3-1.i386.rpm  pkg       src
brother-dcp375cw.install                     dcp375cwcupswrapper-1.1.3-1.i386.rpm  lpr-license.txt               PKGBUILD
[user@user-pc brother-dcp375cw]$ pacman -U brother-dcp375cw-1.1.3-1-x86_64.pkg.tar.zst
[sudo] Passwort für user: 
Lade Pakete...
Warnung: brother-dcp375cw-1.1.3-1 ist aktuell -- Reinstalliere
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Paket (1)         Alte Version  Neue Version  Netto-Veränderung

brother-dcp375cw  1.1.3-1       1.1.3-1                0,00 MiB

Gesamtgröße der installierten Pakete:  3,20 MiB
Größendifferenz der Aktualisierung:  0,00 MiB

:: Installation fortsetzen? [J/n] J
(1/1) Prüfe Schlüssel im Schlüsselring                                                [-------------------------------------------------] 100%
(1/1) Überprüfe Paket-Integrität                                                      [-------------------------------------------------] 100%
(1/1) Lade Paket-Dateien                                                              [-------------------------------------------------] 100%
(1/1) Prüfe auf Dateikonflikte                                                        [-------------------------------------------------] 100%
:: Verarbeite Paketänderungen...
(1/1) Installiere brother-dcp375cw                                                    [-------------------------------------------------] 100%
Warnung: Verzeichnis-Berechtigungen unterscheiden sich für /opt/brother/Printers/dcp375cw/inf/
Dateisystem: 777  Paket: 755

Restarting CUPS to load the new files...
/usr/bin/sudo: /usr/bin/sudo: Kann die Datei nicht ausführen.
You can now register your new printer using the web interface at:
  http://localhost:631/

If adding a network printer choose LPD/LPR queue
You might have to manually configure your printer's IP adress
To access the network scanner install brscan3 from AUR and read:
   https://wiki.archlinux.org/index.php/SANE/Scanner-specific_problems#Brother
:: Starte post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
[user@user-pc brother-dcp375cw]$

Offline

#14 20.09.2020 23:01:15

stefanhusmann
Moderator

Re: Brother 375CW + archlinux

Wenn ich das richtig sehe, kannst du diese Meldung ignorieren. Das Paket versucht etwas im install-File mit sudo zu tun. Das ist aber egal. Allerdings sollte ein Paket sowas auch nicht tun. Ich hab mal einen entsprechenden Kommentar im AUR hinterlassen.

Offline

#15 20.09.2020 23:06:00

unitymedia
Mitglied

Re: Brother 375CW + archlinux

Über Druckereinstellungen wurde drücker zugefügt , leider  wird der drücker nicht angesprochen .

Offline

#16 22.09.2020 11:56:47

stefanhusmann
Moderator

Re: Brother 375CW + archlinux

Was heißt das? Welche "Druckereinstellungen"?

You can now register your new printer using the web interface at:
  http://localhost:631/

Hast du das gemacht? Was hast du gemacht?

Offline

#17 25.09.2020 12:04:37

unitymedia
Mitglied

Re: Brother 375CW + archlinux

Über Druckereinstellungen wurde  375CW  zugefügt ,
786a6feda68a.png

00f193d1f26f.png

Offline

#18 25.09.2020 14:39:40

stefanhusmann
Moderator

Re: Brother 375CW + archlinux

Versuch das mal über den Browser und http://localhost:631/ wie es im Wiki steht.

Offline

#19 25.09.2020 19:49:22

unitymedia
Mitglied

Re: Brother 375CW + archlinux

Leider bringt es auch nichts .
9aaaac4d145b.png

Offline

#20 27.09.2020 13:07:50

stefanhusmann
Moderator

Re: Brother 375CW + archlinux

Wo liegt das Problem? Keine Druckaufträge -> kein Druck.

Wie ist der Brother-Drucker angeschlossen?
Läuft org.cups.cups-lpd.socket ? Läuft avahi?

Offline

#21 01.10.2020 10:04:35

unitymedia
Mitglied

Re: Brother 375CW + archlinux

Drücker ist ans Netzwerk über Wlan angeschlossen,  muss ich mal mit usb verbindung testen , oder lankabel.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums