Du bist nicht angemeldet.

#1 07.09.2020 07:44:24

pix
Mitglied

[gelöst] Blender startet nicht mehr

Hallo zusammen,

ich habe heute morgen eine Systemaktualisierung mit "pacman -Suy" durchgeführt.

Anschließend wollte ich Blender 2.83.x starten und bekam folgende Fehlermeldung:

blender: error while loading shared libraries: liboslcomp.so.1.10: cannot open shared object file: No such file or directory 

Aktuell ist die Blender Version 2.90.0.
Ich arbeite mit der LTS Version von Blender, Version 2.83.x und wollte auch dabei bleiben, falls möglich.

Habe dazu in der pacman.conf in die Zeile:

IgnorePkg=blender

eingefügt.

Habe dann geschaut im Verzeichnis --> /usr/lib

ls -lisa /usr/lib/liboslcomp.so

Die Ausgabe brachte folgendes Ergebnis:

/usr/lib/liboslcomp.so -> liboslcomp.so.1.11

Das sieht so aus, als wenn die >  liboslcomp.so.1.10 < ersetzt wurde durch die neue Version >  liboslcomp.so.1.11 <

Bedeutet das, das ich auf die neue Version von Blender wechseln muss um damit zu arbeiten?
Hat jemand eine Idee wie ich das Problem beheben kann?

Vielen Dank

Beitrag geändert von pix (07.09.2020 09:45:08)

Offline

#2 07.09.2020 08:06:10

schard
Moderator

Re: [gelöst] Blender startet nicht mehr

Deine installierte Blender Version wurde wohl gegen eine ältere Version von openshadinglanguage gebaut.
Wenn du IgnorePkg benutzt, bist du alleine für die Aktualisierung des Pakets verantwortlich.
https://wiki.archlinux.org/index.php/Sy … nsupported

Offline

#3 07.09.2020 08:26:25

pix
Mitglied

Re: [gelöst] Blender startet nicht mehr

Danke für deine schnelle Antwort.

Wie hast du herausgefunden, dass das Problem bei dem Paket "openshadinglanguage" liegt?

LG

Offline

#4 07.09.2020 08:38:44

schard
Moderator

Re: [gelöst] Blender startet nicht mehr

Ich kann pacman benutzen und man Pages lesen.

# pacman -Fy /usr/lib/liboslcomp.so

Und es liegt nicht an openshadinglanguage, sondern an blender.

Offline

#5 07.09.2020 09:19:15

pix
Mitglied

Re: [gelöst] Blender startet nicht mehr

Habe vielen Dank für deine schnelle Antwort.

Glaube so ungefähr habe ich es verstanden.
Nur mal für mich laut gedacht:

Ein:

tail /var/log/pacman.log -n100

zeigt mir an, dass:

[2020-09-07T08:38:08+0200] [ALPM] upgraded openimageio (2.1.18.1-2 -> 2.2.6.1-1)
[2020-09-07T08:38:09+0200] [ALPM] upgraded gcc (10.2.0-1 -> 10.2.0-2)
[2020-09-07T08:38:09+0200] [ALPM] upgraded openshadinglanguage (1.10.13-1 -> 1.11.7.3-1)       <<===
[2020-09-07T08:38:09+0200] [ALPM] upgraded openssh (8.3p1-3 -> 8.3p1-4)
[2020-09-07T08:38:09+0200] [ALPM] upgraded python-setuptools (1:49.6.0-1 -> 1:50.3.0-1)

openshadinglanguage auf Version 1.11.7.x upgraded wurde.
Blender benötigt aber von openshadinglanguage die ältere Version liboslcomp.so.1.10, welche es nicht mehr gibt.

Dein Befehl:

pacman -Fy /usr/lib/liboslcomp.so

zeigt, dass liboslcomp.so im Paket openshadinglanguage enthalten ist, und dies wurde upgraded.

Fazit für mich:
durch ein upgrade von "openshadinglanguage" auf 1.11.7.3-1 gibt es nicht mehr die von Blender benötigte Version 1.10.13-1.

Hoffe das Rad ist halbwegs rund.

Vielen Dank und LG

Offline

#6 07.09.2020 09:20:40

schard
Moderator

Re: [gelöst] Blender startet nicht mehr

Richtig. Ergo musst du deine LTS Version von Blender gegen die neue(n) Bibliothek(en) neu bauen (kompilieren).

Offline

#7 07.09.2020 09:29:53

pix
Mitglied

Re: [gelöst] Blender startet nicht mehr

@schard

Richtig

freue mich über mich selber, dass ich es verstanden habe, ich fast wie in der Schule smile

Ergo musst du deine LTS Version von Blender gegen die neue(n) Bibliothek(en) neu bauen (kompilieren).

Hm, und ihr bin ich raus. Bedeutet für mich, keine LTS Version, schade, schade sad


1000 Dank für deine Hilfe und den riesen Augenöffner smile

Offline

#8 07.09.2020 09:44:39

pix
Mitglied

Re: [gelöst] Blender startet nicht mehr

Im Prinzip ist es so:
Wenn ich auf https://www.archlinux.de/packages/commu … 64/blender schaue, sehe ich Abhängigkeiten und "benötigt".
Alle Paketeversionen unterhalb von "benötigt" müssen mit der aktuellen Blenderversion zusammenpassen, weil Blender mit diesen Paketversionen "gebaut" bzw. kompiliert wurde.

Nutze ich die LTS Version von Blender und eines dieser Pakete ändert seine Versionsnummer funktioniert Blender nicht mehr.

Da es ziemlich viele Pakte sind ist der Aufwand für die LTS Version erheblich, abgesehen davon, dass ich nicht weiss, wie das Ganze funktioniert.

Okay, soweit verstanden,
grins und wein

Offline

#9 07.09.2020 15:55:52

Dirk
Moderator

Re: [gelöst] Blender startet nicht mehr

pix schrieb:

Ich arbeite mit der LTS Version von Blender, Version 2.83.x und wollte auch dabei bleiben, falls möglich.

Gibt es da einen technisch notwendigen Grund für? Ansonsten aktualisiere einfach alle Pakete, und du hast keine Probleme.

Offline

#10 07.09.2020 15:58:13

schard
Moderator

Offline

#11 07.09.2020 16:03:35

niemand
Mitglied

Re: [gelöst] Blender startet nicht mehr

Ich hab das grad mal getestet: die Version direkt von blender.org ist weitgehend statisch gebaut. Die 2.83.5 lässt sich problemlos unter einem aktuellen Arch nutzen.

Offline

#12 07.09.2020 16:17:02

Dirk
Moderator

Re: [gelöst] Blender startet nicht mehr

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums