Du bist nicht angemeldet.

#1 05.09.2020 11:03:04

ohrschlauch
Mitglied

Probleme bei qemu/kvm [gelöst]

Zunächst ein paar Infos vorweg:
AMD Ryzen 5 2600, Manjaro mit Kernel 5.7 und 5.8 (ja,ja ich weiß), NVidia GTX1060, 32 GB RAM, SSD

Problem:
Ich wollte gerne ein virtualisiertes MacOS installieren (foxlett oder kholia). Habe auch die empfohlenen Pakete und ein paar mehr, die in den entsprechenden Beiträgen von Archlinux empfohlen wurden installiert. libvirtd lässt sich starten und zeigt bei 'sudo systemctl status libvirtd' Folgendes an:

● libvirtd.service - Virtualization daemon
     Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2020-09-05 10:20:51 CEST; 16s ago
TriggeredBy: ● libvirtd-admin.socket
             ● libvirtd.socket
             ● libvirtd-ro.socket
       Docs: man:libvirtd(8)
             [url]https://libvirt.org[/url]
   Main PID: 6409 (libvirtd)
      Tasks: 19 (limit: 32768)
     Memory: 36.4M
     CGroup: /system.slice/libvirtd.service
             ├─2337 /usr/bin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib/libvirt/libvirt_leaseshelper
             ├─2338 /usr/bin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib/libvirt/libvirt_leaseshelper
             └─6409 /usr/bin/libvirtd --timeout 120

Sep 05 10:20:51 LIN-PC systemd[1]: Started Virtualization daemon.
Sep 05 10:20:51 LIN-PC dnsmasq[2337]: read /etc/hosts - 5 addresses
Sep 05 10:20:51 LIN-PC dnsmasq[2337]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses
Sep 05 10:20:51 LIN-PC dnsmasq-dhcp[2337]: read /var/lib/libvirt/dnsmasq/default.hostsfile

Habe mich auch wie empfohlen zur Gruppe 'libvirt' mit 'sudo usermod -a -G libvirt $(whoami)' hinzugefügt.

Wenn ich 'sudo LC_ALL=C lscpu | grep Virtualization' eingebe erhalte ich:

Virtualization:                  AMD-V

'zgrep CONFIG_KVM /proc/config.gz' zeigt Folgendes:

CONFIG_KVM_GUEST=y
# CONFIG_KVM_DEBUG_FS is not set
CONFIG_KVM_MMIO=y
CONFIG_KVM_ASYNC_PF=y
CONFIG_KVM_VFIO=y
CONFIG_KVM_GENERIC_DIRTYLOG_READ_PROTECT=y
CONFIG_KVM_COMPAT=y
CONFIG_KVM=m
CONFIG_KVM_WERROR=y
CONFIG_KVM_INTEL=m
CONFIG_KVM_AMD=m
CONFIG_KVM_AMD_SEV=y
CONFIG_KVM_MMU_AUDIT=y

und 'lsmod | grep kvm' zeigt an:

kvm                   839680  0
irqbypass              16384  1 kvm

Also ist kvm-amd nicht geladen. Wenn ich aber 'sudo modprobe kvm-amd' versuche kriege ich folgende Meldung:

modprobe: ERROR: could not insert 'kvm_amd': Operation not supported

Es gibt zu diesem Problem eine Reihe von Beiträgen wenn man sucht, aber letztlich hat keiner geholfen. Den Tipp einen ganz anderen Kernel aus 4.x zu installieren habe ich noch nicht ausprobiert (würde ich auch ganz gerne vermeiden).
Vielen Dank im Voraus schon mal.

Beitrag geändert von ohrschlauch (05.09.2020 17:36:54)

Offline

#2 05.09.2020 14:14:20

wirr
Mitglied

Re: Probleme bei qemu/kvm [gelöst]

Was hast du für ein Motherboard?
Ich rate einmal: du musst im "BIOS" Secure Virtual Machine (SVM) mode anschalten.

Sonst solltest du google fragen, wie man bei deinem Motherboard 'kvm-amd' aktiviert.

Offline

#3 05.09.2020 14:32:33

ohrschlauch
Mitglied

Re: Probleme bei qemu/kvm [gelöst]

Motherboard: Aorus Ultra Gaming X470 mit neuestem AGESA BIOS.
In den Einstellungen lässt sich die Virtualisation nicht abstellen. Auch habe ich gedacht, dass dann 'sudo LC_ALL=C lscpu | grep Virtualization' bei der Ausgabe nichts anzeigen dürfte. Gegoogelt habe ich ziemlich viel und die Beiträge, unter manjaro/archlinux mit Problemen bei qemu und kvm habe ich auch alle durchgeschaut und leider keine Tipps finden können, die geholfen haben, wobei mindestens 2/3 der Beiträge zwischen 2011 und 2018 liegen, also möglicherweise nicht mehr ganz up-to-Date sein könnten. Einstimmig wurde aber gesagt, dass es mit AMD Ryzen CPU's keine Probleme geben sollte.

Offline

#4 05.09.2020 15:00:38

wirr
Mitglied

Re: Probleme bei qemu/kvm [gelöst]

> Auch habe ich gedacht, dass dann 'sudo LC_ALL=C lscpu | grep Virtualization' bei der Ausgabe nichts anzeigen dürfte.

Ja gut, in dem Fall solltest du SVM und iommu sicher nicht umstellen.

cool Ich habs versucht..sorry

Offline

#5 05.09.2020 15:02:52

ohrschlauch
Mitglied

Re: Probleme bei qemu/kvm [gelöst]

O. K. habe jetzt noch mal versucht mit 'sudo modprobe kvm-amd' und habe dann kontrolliert mit 'sudo dmesg | grep kvm' und siehe da, folgende Ausgabe:

[    4.141144] kvm: disabled by bios
[    4.268681] kvm: disabled by bios
[    4.331129] kvm: disabled by bios
[    4.387870] kvm: disabled by bios
[    4.441385] kvm: disabled by bios
[    4.507840] kvm: disabled by bios
[    4.574608] kvm: disabled by bios
[    4.641117] kvm: disabled by bios
[    4.708152] kvm: disabled by bios
[    4.774647] kvm: disabled by bios
[  521.733393] kvm_arch_init: 15 callbacks suppressed
[  521.733395] kvm: disabled by bios
[ 2400.505634] kvm: disabled by bios

Ich denke evtl. könnte es dann doch was mit den BIOS-Einstellungen zu tun haben. Blöderweise habe ich im BIOS nix gefunden was mit Virtualisation zusammenängt. Werde mal suchen und weiter berichten.
Besten Dank bisher

Offline

#6 05.09.2020 15:16:22

ohrschlauch
Mitglied

Re: Probleme bei qemu/kvm [gelöst]

Sorry, ich lag offensichtlich falsch mit meiner Annahme wegen Virtualisation. Habe jetzt die Einstellung gefunden, ziemlich versteckt unter M.I.T. -> Erweiterte Frequenzeinstellungen -> Erweiterte CPU Einstellungen -> SVM Mode. War tatsächlich deaktiviert!!! Einstellungen werden leider bei jedem Update zurückgesetzt. Jetzt hat auch auf Anhieb modprobe kvm-amd funktioniert. Vielen Dank an wirr, du lagst komplett richtig, Thema gelöst.

Beitrag geändert von ohrschlauch (05.09.2020 15:17:26)

Offline

#7 05.09.2020 15:26:05

ohrschlauch
Mitglied

Re: Probleme bei qemu/kvm [gelöst]

Würde das Thema gerne als gelöst markieren, kann aber dazu nichts finden. Wie mache ich das?

Offline

#8 05.09.2020 15:28:40

wirr
Mitglied

Re: Probleme bei qemu/kvm [gelöst]

Super smile
Du musst beim ersten Beitrag den Titel editieren.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums