Du bist nicht angemeldet.

#1 20.08.2020 10:04:03

rennradler
Mitglied

systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Hallo Leute,
ich habe auf meinem Desktop eine statische IP-Addresse mittels systemd-networkd und  systemd-resolved konfiguriert. Das funktioniert seit ca. 4 Jahren problemlos, ohne daß ich die Konfiguration anfassen mußte. Seit ein paar Tagen habe ich das Problem, daß die Namensauflösung nach jedem Aufwachen aus dem Suspend nicht mehr funktioniert und ich systemd-networkd.service neu starten muß. Dann geht wieder alles. Ich bin ratlos, woran es liegen könnte, da ich weder die Konfiguration des Rechners noch des Netzwerks geändert habe.

Nach dem Aufwachen und vor dem Neustart sieht es wie folgt aus:

Aug 20 09:53:06 xxxx systemd-networkd[271]: lo: Reset carrier
Aug 20 09:53:06 xxxx systemd-networkd[271]: enp4s0: DHCPv6 lease lost
Aug 20 09:53:06 xxxx systemd-networkd[271]: enp4s0: Reset carrier
Aug 20 09:53:06 xxxx systemd-networkd[271]: enp4s0: No static address is stored.
Aug 20 09:53:06 xxxx systemd-networkd[271]: enp4s0: Failed

Hat jemand eine Idee, was das schief laufen könnte?

Das Verhalten tritt 1:1 auf dem aktuellen Kernel und dem LTS-Kernel auf.

Beitrag geändert von rennradler (20.08.2020 10:04:56)

Offline

#2 20.08.2020 11:02:45

Icecube63
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Könnte eventuell am Versionssprung von systemd auf 246 liegen. In dem Zuge gabs auch ne neue system.conf, schau mal ob sich da ev was relevantes geändert hat

Offline

#3 20.08.2020 12:31:01

rennradler
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Ich sehe nichts, was mich auf eine Spur bringen würde. Ich hatte die auch nie geändert - systemd läuft seit jeher mit den Compiletime-Defaults.

Offline

#4 20.08.2020 12:55:18

frostschutz
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

steht sonst noch was im dmesg?

wenn du mit statischer IP unterwegs bist, vielleicht mal das DHCP(v6) abstellen?

Online

#5 20.08.2020 13:39:32

rennradler
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Da steht nichts für mich Erhellendes drin. Das vielleicht noch:

Aug 20 13:22:56 xxxx systemd-resolved[441]: Using degraded feature set UDP instead of UDP+EDNS0 for DNS server 192.168.0.1.
Aug 20 13:22:56 xxxx systemd-resolved[441]: Using degraded feature set UDP instead of UDP+EDNS0 for DNS server 192.168.0.1.

192.168.0.1 ist meine Fritzbox.

Namensauflösung im lokalen Netzwerk (läuft auch über die Fritzbox) funktioniert nach wie vor, nur eben nicht darüber hinaus.

Was meinst Du mit DHCP(v6) abstellen?

Offline

#6 20.08.2020 14:00:28

Greg
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Ist leider nicht das Erste mal, dass systemd-network zicken macht.
Du könntest es mit netctl versuchen.
https://wiki.archlinux.de/title/Netctl

Offline

#7 20.08.2020 15:32:27

wirr
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Du startest systemd-networkd neu, weil die Namensauflösung nicht funktioniert?

Ist die IP oder die Namensauflösung kaputt?

Diese Befehle (ausgeführt, wenn das Problem besteht) sollten diese Frage beantworten:

# resolvectl status
# ip addr
# drill fritzbox
# drill fritzbox @192.168.0.1
# drill archlinux.de
# journalctl -xeu systemd-networkd
# journalctl -xeu systemd-resolved

Beitrag geändert von wirr (21.08.2020 12:52:07)

Offline

#8 20.08.2020 21:51:06

rennradler
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Ok, hier die Ergebnisse:

# resolvectl status
Global
       LLMNR setting: yes                 
MulticastDNS setting: yes                 
  DNSOverTLS setting: no                  
      DNSSEC setting: no                  
    DNSSEC supported: no                  
  Current DNS Server: 192.168.0.1         
         DNS Servers: 192.168.0.1         
Fallback DNS Servers: 1.1.1.1             
                      9.9.9.10            
                      8.8.8.8             
                      2606:4700:4700::1111
                      2620:fe::10         
                      2001:4860:4860::8888

Link 2 (enp4s0)
      Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
DefaultRoute setting: yes                      
       LLMNR setting: yes                      
MulticastDNS setting: no                       
  DNSOverTLS setting: no                       
      DNSSEC setting: no                       
    DNSSEC supported: no                       
  Current DNS Server: 192.168.0.1              
         DNS Servers: 192.168.0.1              
          DNS Domain: fritz.box

# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether d0:50:99:56:50:42 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.4/24 brd 192.168.0.255 scope global enp4s0
       valid_lft forever preferred_lft forever
    inet6 fe80::d250:99ff:fe56:5042/64 scope link 
       valid_lft forever preferred_lft forever

# drill fritz.box
;; ->>HEADER<<- opcode: QUERY, rcode: NOERROR, id: 51866
;; flags: qr rd ra ; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0 
;; QUESTION SECTION:
;; fritz.box.   IN      A

;; ANSWER SECTION:
fritz.box.      9       IN      A       192.168.0.1

;; AUTHORITY SECTION:

;; ADDITIONAL SECTION:

;; Query time: 1 msec
;; SERVER: 127.0.0.53
;; WHEN: Thu Aug 20 21:40:51 2020
;; MSG SIZE  rcvd: 43

# drill archlinux.de
;; ->>HEADER<<- opcode: QUERY, rcode: NOERROR, id: 24247
;; flags: qr rd ra ; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0 
;; QUESTION SECTION:
;; archlinux.de.        IN      A

;; ANSWER SECTION:
archlinux.de.   7019    IN      A       176.9.50.155

;; AUTHORITY SECTION:

;; ADDITIONAL SECTION:

;; Query time: 0 msec
;; SERVER: 127.0.0.53
;; WHEN: Thu Aug 20 21:41:33 2020
;; MSG SIZE  rcvd: 46

Bis hierher sieht für mich alles 100% funktionierend aus. Aber:

# ping archlinux.de
ping: connect: Das Netzwerk ist nicht erreichbar

Die Ausgaben von journalctl  (gekürzt bis zum letzten Neustart des Services):

# journalctl -xeu systemd-networkd
.....
Aug 20 20:33:12 begpc systemd[1]: Starting Network Service...
░░ Subject: A start job for unit systemd-networkd.service has begun execution
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A start job for unit systemd-networkd.service has begun execution.
░░ 
░░ The job identifier is 1561.
Aug 20 20:33:13 begpc systemd-networkd[38484]: enp4s0: Gained IPv6LL
Aug 20 20:33:13 begpc systemd-networkd[38484]: Enumeration completed
Aug 20 20:33:13 begpc systemd-networkd[38484]: enp4s0: IPv6 successfully enabled
Aug 20 20:33:13 begpc systemd[1]: Started Network Service.
░░ Subject: A start job for unit systemd-networkd.service has finished successfully
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A start job for unit systemd-networkd.service has finished successfully.
░░ 
░░ The job identifier is 1561.
Aug 20 21:35:44 begpc systemd-networkd[38484]: lo: Reset carrier
Aug 20 21:35:44 begpc systemd-networkd[38484]: enp4s0: DHCPv6 lease lost
Aug 20 21:35:44 begpc systemd-networkd[38484]: enp4s0: Reset carrier
Aug 20 21:35:44 begpc systemd-networkd[38484]: enp4s0: No static address is stored.
Aug 20 21:35:44 begpc systemd-networkd[38484]: enp4s0: Failed

Und für resolved seit letztem Reboot:

# journalctl -xeu systemd-resolved
....
-- Reboot --
Aug 20 09:31:55 begpc systemd[1]: Starting Network Name Resolution...
░░ Subject: A start job for unit systemd-resolved.service has begun execution
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A start job for unit systemd-resolved.service has begun execution.
░░ 
░░ The job identifier is 91.
Aug 20 09:31:55 begpc systemd-resolved[441]: Positive Trust Anchors:
Aug 20 09:31:55 begpc systemd-resolved[441]: . IN DS 20326 8 2 e06d44b80b8f1d39a95c0b0d7c65d08458e880409bbc683457104237c7f8ec8d
Aug 20 09:31:55 begpc systemd-resolved[441]: Negative trust anchors: 10.in-addr.arpa 16.172.in-addr.arpa 17.172.in-addr.arpa 18.172.in-addr.arpa 19.172.in-addr.arpa 20.172.in-addr.arpa 21.172.in-addr.arpa 22.172.in-addr.arpa 2>
Aug 20 09:31:55 begpc systemd-resolved[441]: Using system hostname 'begpc'.
Aug 20 09:31:55 begpc systemd[1]: Started Network Name Resolution.
░░ Subject: A start job for unit systemd-resolved.service has finished successfully
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A start job for unit systemd-resolved.service has finished successfully.
░░ 
░░ The job identifier is 91.
Aug 20 13:22:56 begpc systemd-resolved[441]: Using degraded feature set UDP instead of UDP+EDNS0 for DNS server 192.168.0.1.
Aug 20 13:22:56 begpc systemd-resolved[441]: Using degraded feature set UDP instead of UDP+EDNS0 for DNS server 192.168.0.1.
Aug 20 14:23:38 begpc systemd-resolved[441]: Grace period over, resuming full feature set (UDP+EDNS0) for DNS server 192.168.0.1.
Aug 20 21:34:25 begpc systemd-resolved[441]: Using degraded feature set UDP instead of UDP+EDNS0 for DNS server fd00::eadf:70ff:fe44:1e1d.
Aug 20 21:37:28 begpc systemd-resolved[441]: Using degraded feature set UDP instead of UDP+EDNS0 for DNS server 192.168.0.1.
Aug 20 21:46:00 begpc systemd-resolved[441]: Grace period over, resuming full feature set (UDP+EDNS0) for DNS server 192.168.0.1.

Offline

#9 21.08.2020 12:51:52

wirr
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Das heisst, die lokale Namensauflösung funktioniert normal und hat sogar noch einiges im Cache.
Anscheinend ist das 'Netzwerk nicht erreichbar'.

Was sagt:

$ drill fritz.box @192.168.0.1
$ ping 192.168.0.1
$ ip route

Was hast du alles in /etc/systemd/network/?

Offline

#10 21.08.2020 17:27:59

rennradler
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Nein, das kommt nicht aus dem Cache. Ich kann alle möglichen DNS-Abfragen machen von Adressen, die ich garantiert seit dem letzten Reboot nicht abgefragt habe.

$ drill fritz.box @192.168.0.1
;; ->>HEADER<<- opcode: QUERY, rcode: NOERROR, id: 50996
;; flags: qr aa rd ra ; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 3 
;; QUESTION SECTION:
;; fritz.box.   IN      A

;; ANSWER SECTION:
fritz.box.      9       IN      A       192.168.0.1

;; AUTHORITY SECTION:
fritz.box.      9       IN      NS      fritz.box.

;; ADDITIONAL SECTION:
fritz.box.      9       IN      A       192.168.0.1
fritz.box.      9       IN      AAAA    fd00::eadf:70ff:fe44:1e1d
fritz.box.      9       IN      AAAA    2003:dc:c721:2a00:eadf:70ff:fe44:1e1d

;; Query time: 0 msec
;; SERVER: 192.168.0.1
;; WHEN: Fri Aug 21 17:13:21 2020
;; MSG SIZE  rcvd: 129

$ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=0.413 ms

$ ip route
192.168.0.0/24 dev enp4s0 proto kernel scope link src 192.168.0.4 

Der Zugriff auf  das lokale Netzwerk funktioniert - ich komme z.B. auf die Webseite meines Druckers.

Meine Konfiguration:

 $ cat /etc/systemd/network/25-wired.network 
[Match]
Name=enp4s0

[Address]
Address=192.168.0.4/24

[Route]
Gateway=192.168.0.1

[Network]
DNS=192.168.0.1
Domains=fritz.box

/etc/systemd/networkd.conf habe ich nicht angefaßt - das ist wie von Arch ausgeliefert und darin ist alles auskommentiert.

Meine Konfiguration von resoved:

cat /etc/systemd/resolved.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See resolved.conf(5) for details

[Resolve]
DNS=192.168.0.1
#FallbackDNS=8.8.8.8 8.8.4.4 2001:4860:4860::8888 2001:4860:4860::8844
#Domains=
#LLMNR=yes
#DNSSEC=no
#Cache=yes
#DNSStubListener=udp

/etc/resolve.conf ist ein Link auf  /run/systemd/resolve/stub-resolv.conf (wie im englischen Wiki vorgeschlagen), Ich habe auch mal die Variante   /run/systemd/resolve/resolv.conf probiert (wie im deutschen Wiki vorgeschlagen), hat aber keinen Unterschied gemacht.

Offline

#11 21.08.2020 21:24:02

bschwehn
Gast

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Ich habe seit ein paar Wochen das gleiche Problem, und meine Symptome genauer beschrieben unter https://bbs.archlinux.org/viewtopic.php?id=258316

Wenn ich in der network Konfiguration "IgnoreCarrierLoss" auf "true" setze, verschwindet das Problem. Ich hatte jetzt gehofft das es mit dem Bug https://github.com/systemd/systemd/issues/16768 zusammenhängt, aber der dafür eingecheckte Fix scheint mir doch nicht relevant zu sein.

#12 22.08.2020 08:11:45

rennradler
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Vielen Dank für die Info! Dann ist es wohl ein Bug und kein Konfigurationsproblem bei mir.

Offline

#13 24.08.2020 07:16:20

flittermice
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Ich habe seit ca. 2 Monaten genau das gleiche Problem und habe vor 2 Wochen herausgefunden, dass das Netzwerk mit "sudo systemctl restart systemd-networkd.service" immerhin ohne Reboot wieder funktioniert. So habe ich auch diesen Beitrag gefunden.

Ich werde mir die vorgeschlagenen Lösungen einmal ansehen und berichten. Danke!

EDIT:
Bei mir ließ sich das Problem jetzt ganz einfach lösen, denn ich habe bemerkt, dass ich sowohl systemd als auch NetworkManager laufen hatte.
Daher habe ich in /etc/systemd/network/20-wired.network einfach alles auskommentiert (d.h. systemd-networkd eliminiert) und die beiden Netzwerkmanager kommen sich nicht mehr in die Quere :-)

Beitrag geändert von flittermice (24.08.2020 19:35:50)

Offline

#14 28.08.2020 22:43:47

rennradler
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

So, mit dem neuesten Upgrade von systemd auf 246.3-1 scheint das Problem gelöst. Der Bug in systemd wurde wohl erfolgreich gefixt.

Beitrag geändert von rennradler (28.08.2020 22:50:27)

Offline

#15 28.08.2020 22:55:03

rennradler
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

flittermice schrieb:

Bei mir ließ sich das Problem jetzt ganz einfach lösen, denn ich habe bemerkt, dass ich sowohl systemd als auch NetworkManager laufen hatte.
Daher habe ich in /etc/systemd/network/20-wired.network einfach alles auskommentiert (d.h. systemd-networkd eliminiert) und die beiden Netzwerkmanager kommen sich nicht mehr in die Quere :-)

Das ist Mist. Entweder NetworkManager oder systemd. Ich würde den NetworkManager deinstallieren. Wenn du den Networkmanger behalten willst, solltest du die entsprechenden systemd-Services deaktivieren und nicht nur die Konfigurationsdateien leeren. Der Saustall fällt dir irgendwann auf die Füße.

Offline

#16 28.08.2020 23:16:37

flittermice
Mitglied

Re: systemd-networkd.service muß nach jedem Suspend neu gestartet werden

Jawoll, wurde erledigt (Variante 2). Danke für den Tipp, rennradler!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums