Du bist nicht angemeldet.

#1 21.07.2020 22:53:06

ithyphallus
Gast

[gelöst] Kann Github nicht erreichen

Hallo liebe Forengemeinde,
das ist mein erstes Hilfegesuch. Normalerweise finde ich alles bei Stackoverflow und Co. Aber diesmal komme ich anders nicht weiter.
Ich bin auch recht neu in Arch.

Folgendes Problem:

ping www.irgendeine-webseite.xyz

antwortet

ping www.github.com

bzw.

ping 140.82.118.4

antwortet nicht.

getent gibt die richtige IP aus.

Es klappt weder über Ethernet noch Wlan.

dhcp ist aktiv
wlan habe ich über iwp eingerichtet.

Ich bedanke mich schonmal im Vorraus für eure Hilfe.

Viele Grüße

___________________
Thread administrativ als gelöst markiert

Beitrag geändert von Dirk (22.07.2020 21:18:43)

#2 21.07.2020 23:27:57

arch-kali-suse
Mitglied

Re: [gelöst] Kann Github nicht erreichen

1. bitte folgendes ausführen und den Output posten (sonst wissen wir nicht was mit dem Netzwerk los ist):

ip a

2. Bei mir funktioniert ping auf sowohl github als auch die IP. Ich verwende immer ccc.de um zu testen ob ich Internet habe.
3. funktioniert denn der Aufruf der IP von einem Anderen Rechner im Netzwerk?

Offline

#3 21.07.2020 23:51:13

ithyphallus
Gast

Re: [gelöst] Kann Github nicht erreichen

Musste noch schnell einen WM installieren, sodass ich's nicht händisch abtippen muss smile


zu 1:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s25: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether f0:de:f1:bc:47:01 brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 10:0b:a9:48:63:ec brd ff:ff:ff:ff:ff:ff
    inet6 2a02:8109:8500:3ffc:120b:a9ff:fe48:63ec/64 scope global dynamic mngtmpaddr 
       valid_lft 300sec preferred_lft 300sec
    inet6 fe80::120b:a9ff:fe48:63ec/64 scope link 
       valid_lft forever preferred_lft forever

zu 2: ccc.de lässt sich anpingen.

zu 3:
Ja, auf allen anderen Rechnern im Netzwerk funktioniert es.

#4 22.07.2020 00:06:12

Poh5oNgo
Gast

Re: [gelöst] Kann Github nicht erreichen

Das Interface scheint keine IPv4-Adressse zu beziehen, und Github ist über IPv6 nicht erreichbar

#5 22.07.2020 00:24:09

ithyphallus
Gast

Re: [gelöst] Kann Github nicht erreichen

Danke, den Hinweis habe ich benötigt. Ist mir gar nicht aufgefallen. Schon spät...

dhcpd sagt ich soll eine subnet declaration in meiner dhcpd.conf defininieren.
Sobald ich das hinbekommen/nicht hinbekommen habe, melde ich mich hier nochmal.

Vielen Dank

#6 22.07.2020 01:09:22

ithyphallus
Gast

Re: [gelöst] Kann Github nicht erreichen

Jetzt geht es.

ich habe folgendes in /etc/dhcpcd.conf geändert:

- den google nameserver wieder entfernt: #static domain_name_servers=8.8.8.8 8.8.4.4
- DHCP im Interface zugelassen(obwohl es per default 'on' sein sollte): dhcp
- IPv4 im Interface zugelassen(obwohl es per default 'on' sein sollte): ipv4
- Standardmässig war der Versuch eine IPv4 Addresse zu konfigurieren deaktiviert,:  noipv4 auskommentiert.

___________________

Hier noch die config, falls es wen juckt.
Danke nochmals.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.
hostname

# Use the hardware address of the interface for the Client ID.
#clientid
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
# Some non-RFC compliant DHCP servers do not reply with this set.
# In this case, comment out duid and enable clientid above.
duid

# Persist interface configuration when dhcpcd exits.
persistent

# vendorclassid is set to blank to avoid sending the default of
# dhcpcd-<version>:<os>:<machine>:<platform>
vendorclassid

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search
option classless_static_routes
# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# Request a hostname from the network
option host_name

# Most distributions have NTP support.
#option ntp_servers

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate SLAAC address using the Hardware Address of the interface
#slaac hwaddr
# OR generate Stable Private IPv6 Addresses based from the DUID
slaac private
#noipv4ll
dhcp
ipv4

#static domain_name_servers=8.8.8.8 8.8.4.4

___________________

leider kann ich nich editieren.

Es scheint mir so als wäre mein wlan-interface von wlan3s0 zu wlan0 umbenannt worden, keine Ahnung welcher Dienst dafür verantwortlich war.
Also habe ich noch dhcpcd für wlan0 enabled und den Service neu gestartet:

systemctl enable dhcpcd@interface.service
systemctl restart dhcpcd@interface.service

___________________

Noch ein paar Fragen.
Falls sich wer mit netzwerken auskennt und zeit dafür findet:

-Warum ist die Konfiguration von IPv4 per default deaktiviert?
-Ich hatte vorher wifi-menu und networkmanager verwendet, kann es sein, dass die etwas in der dhcpcd.conf überschreiben?
-Wie Ihr sicher aus meinen obigen Posts herrauslesen könnt, hab ich nicht wirklich Ahnung was ich da tue. Habt ihr vll. ein paar generelle Tipps, bzw. Verweise? Also weniger arch-wiki sondern mehr so "netzwerken für dummies" smile

___________________
Beiträge administrativ zusammengeführt

Beitrag geändert von Dirk (22.07.2020 21:15:28)

#7 22.07.2020 21:17:18

Dirk
Moderator

Re: [gelöst] Kann Github nicht erreichen

Wenn du dich anmeldest, kannst du Beiträge auch bearbeiten. Ansonsten bitte für neue Themen einen neuen Thread eröffnen. smile

Offline

#8 22.07.2020 21:22:03

arch-kali-suse
Mitglied

Re: [gelöst] Kann Github nicht erreichen

1: Kein v4 DHCP??? WHAAAT???
2: Ich verwende systemd-network mit statischer ip (z.b. 192.168.2.42)
3:
dhcp = dynamische IP vom DHCP-server ziehen (fritzbox), macht bei MIR mehr Probleme als es löst (Telekom zu verdanken)
ip:
    v4: altes ip, keine euro. öffentlichen ips mehr frei
    v6: moderens ip, besser als v4
wlan: Macht bei MIR mehr probleme als es löst
für mehr: https://wiki.archlinux.org/index.php/Ne … figuration



OT:

Musste noch schnell einen WM installieren, sodass ich's nicht händisch abtippen muss

Es gibt cli browser (w3m).
w3m funktioniert sogar mit bbs.archlinux.de

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums