Du bist nicht angemeldet.

#26 14.07.2020 07:42:38

niemand
Mitglied

Re: Immer wieder Verbindungsabbrüche

drcux schrieb:

scheint kein besonders "netter" Chip/Treiber zu sein...

Gibt wohl verschiedene Versionen davon, hab den in mehreren Geräten (teils gehabt): während einige absolut unauffällig liefen, zeigten andere seltsame Fehler, insbesondere im GBit/s-Modus. Da gab’s im Grunde zwei Möglichkeiten: den Code für das Modul von Intel selbst holen, und es sich bauen (vielleicht geht’s heute via dkms – die betreffende Maschinen sind bei mir nicht mehr in Betrieb), oder das Interface auf 100MBit/s festsetzen.

Edit: allerdings könnte das Problem hier auch irgendwo anders liegen – zum Beispiel in der Verkabelung des TE, oder bei seinem Switch.

Beitrag geändert von niemand (14.07.2020 07:44:09)

Offline

#27 15.07.2020 01:22:28

arch-kali-suse
Mitglied

Re: Immer wieder Verbindungsabbrüche

@Niemand & @drcux
Ich habe auch e1000e, funktioniert problemlos:

$ sudo journalctl -g e1000e
Jul 14 14:03:34 tuxhost kernel: e1000e 0000:00:19.0 enp0s25: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
$ lsmod | grep e1000e
e1000e                299008  0
$ lspci -vs00:19.0
00:19.0 Ethernet controller: Intel Corporation 82566DC Gigabit Network Connection (rev 02)
        Subsystem: Intel Corporation Device 0001
        Flags: bus master, fast devsel, latency 0, IRQ 31
        Memory at 90400000 (32-bit, non-prefetchable) [size=128K]
        Memory at 90424000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 30c0 [size=32]
        Capabilities: <access denied>
        Kernel driver in use: e1000e
        Kernel modules: e1000e
$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:16:76:00:00:01 brd ff:ff:ff:ff:ff:ff permaddr 00:16:76:xx:xx:xx
    inet xx.xx.xx.xx/24 brd xx.xx.xx.255 scope global enp0s25
       valid_lft forever preferred_lft forever
    inet6 20xx:xx:xxxx:xxxx:xxx:xxxx:xxxx:x/64 scope global dynamic mngtmpaddr noprefixroute
       valid_lft 172780sec preferred_lft 86380sec
    inet6 fe80::xxx:xxxx:xxxx:x/64 scope link
       valid_lft forever preferred_lft forever
$ cat /sys/class/net/enp0s25/speed
1000

Bei mir ist es ein alter Rechner mit Petium 4 und Intel Mainboard, enp0s25 ist das Onboard-Gigabit

Beitrag geändert von arch-kali-suse (15.07.2020 01:24:38)

Offline

#28 15.07.2020 06:41:47

niemand
Mitglied

Re: Immer wieder Verbindungsabbrüche

Schrieb ich ja: es scheint verschiedene Versionen davon zu geben, und ich hatte auch einige, die problemlos liefen.

Offline

#29 17.07.2020 21:32:15

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

Okay,
ich hab hier ein ASUS Z170-A, dessen Onboard-Netzwerkkarte ich verwende.
Ich werde mal recherchieren und sehen ob ich dazu etwas finden kann.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums