Du bist nicht angemeldet.

#1 19.06.2020 18:47:02

HarleyDavidson
Mitglied

Immer wieder Verbindungsabbrüche

Hallo zusammen,
ich habe hier ein kniffliges Thema, bei dem ich nicht weiß, wie ich es analysieren soll.
Aber vielleicht hat ja hier im Forum noch jemand einen guten Tipp.

Ich bekomme hier auf meinem System immer wieder die Meldung "Netzwerk getrennt",
ich werde also vom Internet getrennt. Das dauert etwa so 30 Sekunden, dann steht die Verbindung wieder.
Das ganze passiert sporadisch, ich kann das ganze also nicht sicher reproduzieren.

journalctl | grep network >> Keine Einträge
Fritz Box Logs >> Keine Einträge

Es ist sogar schon mal passiert, während meine Frau an ihrem Rechner saß. Bei ihr gab es keine Abbrüche.
Das sagt mir schon mal, dass das Problem hier auf meinem System liegen muss (höchst wahrscheinlich).

Hat jemand schonmal so etwas ähnliches beobachtet?
Was kann ich hier noch prüfen, um die Ursache herauszubekommen?

Viele Grüße,
Harley

Offline

#2 20.06.2020 00:55:13

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

niemand schrieb:

Hängt „etwas“ davon ab, wie du überhaupt die Verbindung herstellst. Allerdings ist „Logfiles!“ immer ’ne passende Antwort auf solche Fragen.

Edit: Idealerweise lässt man Filter weg, wenn man mit den verwendeten Filtern keine Information findet.

Den ersten Satz verstehe ich nicht big_smile

Den zweiten Satz allerdings schon: Der letzte Verbindungsabbruch kam mitten bei einer Systemaktualisierung mit "pacman -Syu" ... Ich kann mir also das Systemlog von den genau den Zeitpunkt ansehen. Danke für den Hinweis mit den Filter wink

Offline

#3 20.06.2020 08:44:08

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

Ahh okay, jetzt macht das Sinn. Geb ich dir Recht big_smile

Es handelt sich um ein Desktop PC, die Internetverbindung wird per OnBoard Netzwerkkarte über Kabel hergestellt.

Offline

#4 20.06.2020 16:16:40

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

Okay, dann mal hier ein paar Infos:

[dominik@dominikpc ~]$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 9c:5c:8e:74:2e:97 brd ff:ff:ff:ff:ff:ff
    inet 192.168.178.25/24 brd 192.168.178.255 scope global dynamic noprefixroute enp0s31f6
       valid_lft 863726sec preferred_lft 863726sec
    inet6 fd00::d5aa:1995:c8d1:8411/64 scope global dynamic noprefixroute 
       valid_lft 6927sec preferred_lft 3327sec
    inet6 fe80::d821:782:71c8:633c/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

[dominik@dominikpc ~]$ networkctl list
WARNING: systemd-networkd is not running, output will be incomplete.

IDX LINK      TYPE     OPERATIONAL SETUP    
  1 lo        loopback n/a         unmanaged
  2 enp0s31f6 ether    n/a         unmanaged

2 links listed.

Ich habe systemd-networkd nie bewußt deaktiviert. Sollte das aktiviert sein?

Installiert zum Thema Netzwerk sind bei mir folgende Pakete:

  • networkmanager

  • network-manager-applet

  • nm-connection-editor

"/etc/interfaces" ist nicht vorhanden
"netctl list" gibt eine leere Liste zurück, keine Profile eingerichtet
>> Der Service ist ebenfalls inaktiv.

Offline

#5 20.06.2020 17:45:14

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

Ich kann mich nicht daran erinnern, groß etwas konfiguriert zu haben.

Das Netzwerkkabel war schon während der Installation eingesteckt, ich hab mittels "dhcpcd enp0s31f6" eine IP vom Router bekommen
und das war's eigentlich.
Die Verbindung wurde und wird automatisch aufgebaut.

Offline

#6 20.06.2020 17:58:06

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

big_smile
Ich bin mir absolut sicher.

Bei der Installation hab ich mich an die Anleitung vom Wiki gehalten.
Und bei DHCP wird automatisch eine Verbindung hergestellt.
Ich hab da nichts weiter gesondert konfiguriert. hmm

Offline

#7 20.06.2020 18:36:28

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

Ok.
Darf ich fragen, wie du dein Netzwerk konfiguriert hast?

Trotzdem Danke für deine Beteiligung.

Offline

#8 21.06.2020 09:10:08

Gastl
Gast

Re: Immer wieder Verbindungsabbrüche

Komisch, war bei mir genauso wie beim Threadersteller beschrieben. Einmal das Netzwerk mit wifi-menu eingerichtet und das war's. Weiter musste nix konfiguriert werden. Es scheint da tatsäclich mehrere Arch-Versionen geben.

#9 22.06.2020 09:49:27

Gastl
Gast

Re: Immer wieder Verbindungsabbrüche

Ja, das stimmt. Wenn ich das Kabel anhänge, muss ich nicht mal wifi-menu aufrufen, der Rechner ist gleich mit dem Internet verbunden. :-)

#10 23.06.2020 12:05:34

drcux
Mitglied

Re: Immer wieder Verbindungsabbrüche

Und mit dem entsprechendem Auszug aus dem Log würde man es vielleicht so erkennen...

Offline

#11 01.07.2020 10:20:46

tomsam
Mitglied

Re: Immer wieder Verbindungsabbrüche

Mal nebenbei:

niemand schrieb:

Ansonsten unterstelle ich ’nen Drittanbieter-Installer, der das Netzwerk mitkonfiguriert hat, und gehe entsprechend nicht mehr von einer sauberen Arch-Installation aus – und bin halt raus, schlicht, weil ich mich damit nicht auskenne.

Meinst du eine saubere Arch-Installation z.B. gemäß 
https://wiki.archlinux.de/title/Anleitu … undsystems
??

Dort vielleicht den Punkt "Netzwerkverbindung herstellen" ...

Da steht aber nichts von einer Extra-Konfiguration für den Fall, dass man kabelgebunden mit DHCP arbeitet ...

Offline

#12 01.07.2020 15:48:35

drcux
Mitglied

Re: Immer wieder Verbindungsabbrüche

tomsam schrieb:

Da steht aber nichts von einer Extra-Konfiguration für den Fall, dass man kabelgebunden mit DHCP arbeitet ...

Nein, aber die Verbindung wird händisch aufgebaut, und bei ihm scheint es ja automatisch zu gehen, also +muss+ er etwas eingerichtet (systemctl enable einnetzwerkdienst) haben.

Genau das würde man in dem Journla sehen, aber de TE hat wohl kein Interesse mehr sein Problem zu lösen...

Offline

#13 11.07.2020 15:14:58

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

Hallo, TE hier.
Klar hab ich weiter Interesse, die Ursache zu finden. Ich hab allerdings keine Benachrichtigungen mehr bekommen.

Ich habe mich damals an die Installationsanleitung aus dem offiziellen deutschsprachigen Wiki gehalten. hmm

Ich werde mal das Log hier rein packen. Vielleicht erkennt jemand ja etwas...

Offline

#14 12.07.2020 12:30:25

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

Hallo zusammen,
anbei das Log: Link zum Log
das ist das Log vom kompletten 19. Juni, an dem der Verbindungsabbruch auch auftrat.

Ab Zeile 1771 wird das Systemupdate per pacman -Syu gestartet, kurze Zeit später
Zeile 1787 meldet der NetworkManager dass das Device nicht erreichbar ist.

Ich hoffe das Log bringt auch Klarheit (mir wie euch) wie ich mein Netzwerk konfiguriert habe.

Viele Grüße und danke für die Hilfe.

Offline

#15 12.07.2020 16:59:27

ManfredB
Mitglied

Re: Immer wieder Verbindungsabbrüche

Hallo zusammen,

ich hatte vor einiger Zeit ArchLinux auf einer USB-HDD installiert, um zu sehen, wie das nachher aussieht.

Erster Punkt, als ich das fertige System neu gestartet habe, daß - obwohl auch Kabel-Verbindung - kein Internet vorhanden war.
Bisher hatte ich immer netctl genutzt, doch diesmal habe ich mich an gentoo systemd erinnert, wo ich nur
systemctl enable NetworkManager
systemctl start NetworkManager
eigegeben habe - und siehe da: seit diesem Moment hatte ich problemlos und ohne Unterbrechungen mein Internet.

Vielleicht ist das ja ein kleiner Vorschlag zur Lösung des Problems. Voraussetzung allerdings, daß NetworkManager vorhanden ist.

Gruß
Manfred

Offline

#16 14.07.2020 06:30:14

drcux
Mitglied

Re: Immer wieder Verbindungsabbrüche

kernel: e1000e 0000:00:1f.6 enp0s31f6: NIC Link is Down

Dafür gibt es viele Treffer im Netz, scheint kein besonders "netter" Chip/Treiber zu sein...

Offline

#17 15.07.2020 01:22:28

arch-kali-suse
Mitglied

Re: Immer wieder Verbindungsabbrüche

@Niemand & @drcux
Ich habe auch e1000e, funktioniert problemlos:

$ sudo journalctl -g e1000e
Jul 14 14:03:34 tuxhost kernel: e1000e 0000:00:19.0 enp0s25: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
$ lsmod | grep e1000e
e1000e                299008  0
$ lspci -vs00:19.0
00:19.0 Ethernet controller: Intel Corporation 82566DC Gigabit Network Connection (rev 02)
        Subsystem: Intel Corporation Device 0001
        Flags: bus master, fast devsel, latency 0, IRQ 31
        Memory at 90400000 (32-bit, non-prefetchable) [size=128K]
        Memory at 90424000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 30c0 [size=32]
        Capabilities: <access denied>
        Kernel driver in use: e1000e
        Kernel modules: e1000e
$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:16:76:00:00:01 brd ff:ff:ff:ff:ff:ff permaddr 00:16:76:xx:xx:xx
    inet xx.xx.xx.xx/24 brd xx.xx.xx.255 scope global enp0s25
       valid_lft forever preferred_lft forever
    inet6 20xx:xx:xxxx:xxxx:xxx:xxxx:xxxx:x/64 scope global dynamic mngtmpaddr noprefixroute
       valid_lft 172780sec preferred_lft 86380sec
    inet6 fe80::xxx:xxxx:xxxx:x/64 scope link
       valid_lft forever preferred_lft forever
$ cat /sys/class/net/enp0s25/speed
1000

Bei mir ist es ein alter Rechner mit Petium 4 und Intel Mainboard, enp0s25 ist das Onboard-Gigabit

Beitrag geändert von arch-kali-suse (15.07.2020 01:24:38)

Offline

#18 17.07.2020 21:32:15

HarleyDavidson
Mitglied

Re: Immer wieder Verbindungsabbrüche

Okay,
ich hab hier ein ASUS Z170-A, dessen Onboard-Netzwerkkarte ich verwende.
Ich werde mal recherchieren und sehen ob ich dazu etwas finden kann.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums