Du bist nicht angemeldet.

#1 08.05.2020 16:17:23

amateurlinuxuser
Mitglied

[Gelöst] Netzwerk Problem

Liebe Community,

ich habe archlinux als virtuelle maschine installiert und eingerichtet. Jedoch habe ich überhaupt keinen Netz Zugang, kann weder Packete installieren, noch ein update durchführen. Einer der Error Meldungen am Ende lautet "failed to retrieve packages". Habt ihr eventuel einen Tip dazu?

Beitrag geändert von amateurlinuxuser (08.05.2020 22:08:37)

Offline

#2 08.05.2020 17:33:16

Nick_0278
Gast

Re: [Gelöst] Netzwerk Problem

Ersteinmal Willkommen!

Um dir helfen zu können bräuchten wir ein paar Informationen.
Was nutzt du denn für die Verwaltung von Netzwerken: NetworkManager, netctl ... ?

Grüße Nick

Beitrag geändert von Nick_0278 (08.05.2020 18:10:59)

#3 08.05.2020 20:34:48

amateurlinuxuser
Mitglied

Re: [Gelöst] Netzwerk Problem

Nick_0278 schrieb:

Ersteinmal Willkommen!

Um dir helfen zu können bräuchten wir ein paar Informationen.
Was nutzt du denn für die Verwaltung von Netzwerken: NetworkManager, netctl ... ?

Grüße Nick

Hallo Nick!

Auf dem Hauptsystem(Ubuntu) wo ich die VIrtualBox oben installiert habe, verwende ich NerworkManager.

sobald ich auf archlinux

 ip link 

eintippe, gibt mir das output diese zwei links: 1- lo 2- enp0s3

ich hab bereits enp0s3 auf enable umgeändert, hat aber nichts gebracht.

Welche infos wären für euch noch erforderlich? Danke im Voraus!

GLG

Offline

#4 08.05.2020 20:40:58

sprague
Mitglied

Re: [Gelöst] Netzwerk Problem

Wollte schon fragen welche Virtualisierungslösung Du nutzt.

Stell doch mal die VBox auf Netzwerkbrücke ein.

Gruß, Lyon

Offline

#5 08.05.2020 20:48:14

Nick_0278
Gast

Re: [Gelöst] Netzwerk Problem

Stell es wie sprague es gesagt hat mal um, wobei der Standard NAT eigentlich funktionieren müsste.

Auf dem Hauptsystem(Ubuntu) wo ich die VIrtualBox oben installiert habe, verwende ich NerworkManager.

Und im Arch System?

Was sagt "ping google.com" (Im Archlinux)?

Nick

Beitrag geändert von Nick_0278 (08.05.2020 20:50:09)

#6 08.05.2020 20:51:39

amateurlinuxuser
Mitglied

Re: [Gelöst] Netzwerk Problem

sprague schrieb:

Wollte schon fragen welche Virtualisierungslösung Du nutzt.

Stell doch mal die VBox auf Netzwerkbrücke ein.

Gruß, Lyon

Ich habe von NAT auf Netzwerkbrücke umgestellt. Wie geht es jetzt weiter?

LG

Offline

#7 08.05.2020 20:58:54

Nick_0278
Gast

Re: [Gelöst] Netzwerk Problem

Ok. Und was sagt "ping google.com" im Archsystem?

EDIT: Nutzt du NetworkManager auch im Arch?

Beitrag geändert von Nick_0278 (08.05.2020 21:00:15)

#8 08.05.2020 20:59:45

amateurlinuxuser
Mitglied

Re: [Gelöst] Netzwerk Problem

Nick_0278 schrieb:

Stell es wie sprague es gesagt hat mal um, wobei der Standard NAT eigentlich funktionieren müsste.

Auf dem Hauptsystem(Ubuntu) wo ich die VIrtualBox oben installiert habe, verwende ich NerworkManager.

Und im Arch System?

Was sagt "ping google.com" (Im Archlinux)?

Nick

"ping google.com" sagt: Temporary failure in name resolution.

Kann es eventuel mit pacman- mirrorlist zu tun haben?

Offline

#9 08.05.2020 21:02:09

Nick_0278
Gast

Re: [Gelöst] Netzwerk Problem

Wenn du NetworkManager nutzt gehe ich stark davon aus, dass du vergessen hast diesen zu aktivieren. Versuch mal "systemctl enable NetworkManager" (Das N und M groß geschrieben!)

#10 08.05.2020 21:03:23

amateurlinuxuser
Mitglied

Re: [Gelöst] Netzwerk Problem

Und wenn ich zum Beispiel "sudo pacman -Syyu" eintippe, sehe ich im output in den letzten zwei Zeilen diese Meldungen:

error: failed to update multilib (invalid url for server)
error: failed to synchronize all databases.

Offline

#11 08.05.2020 21:06:14

Nick_0278
Gast

Re: [Gelöst] Netzwerk Problem

Es ist vollkommen verständlich, dass pacman seine Datenbank nicht aktualisieren kann wenn du kein Internet hast.
Versuch doch bitte mal "systemctl enable NetworkManager" und sarte deinen Rechner neu.

Nick

#12 08.05.2020 21:09:23

amateurlinuxuser
Mitglied

Re: [Gelöst] Netzwerk Problem

Nick_0278 schrieb:

Es ist vollkommen verständlich, dass pacman seine Datenbank nicht aktualisieren kann wenn du kein Internet hast.
Versuch doch bitte mal "systemctl enable NetworkManager" und sarte deinen Rechner neu.

Nick

Es hat geklappt! Ich habe networkmanager aktiviert und die vm noch mal gestartet. "ping google.com" sowohl auch alle updates funktionieren.
Ich danke euch! Habt nen schönen Abend!

GLG

Offline

#13 08.05.2020 21:12:01

Nick_0278
Gast

Re: [Gelöst] Netzwerk Problem

Super! Dir auch einen schönen Abend und vergiss nicht den Thread als [GELÖST] zu markieren.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums