Du bist nicht angemeldet.

#1 05.05.2020 21:38:07

Andy123Andy
Mitglied

[GELÖST] Fake-Raid wird nicht gemounted

Hallo zusammen,

seit geraumer Zeit wird mein Raid-5 nicht gemounted beim booten.

timeout waiting for /dev/md127

Der Befehl mdadm --detail /dev/md127 sagt das alle HDDs im Zustand removed sind.

Mein Workaround sieht im moment so aus das Systemd ein Bash-Script ausführt:

#!/bin/bash

mdadm --stop /dev/md127 
mdadm --assemble --scan
mount /dev/md127 /mnt/alpha/
#systemctl restart plexmediaserver.service 
systemctl restart syncthing@andy.service  

Danach sagt mdadm --detail /dev/md127 das alles i.o ist:

/dev/md127:
           Version : 1.2
     Creation Time : Fri Apr 17 06:27:32 2020
        Raid Level : raid5
        Array Size : 8790091776 (8382.88 GiB 9001.05 GB)
     Used Dev Size : 2930030592 (2794.29 GiB 3000.35 GB)
      Raid Devices : 4
     Total Devices : 4
       Persistence : Superblock is persistent

     Intent Bitmap : Internal

       Update Time : Tue May  5 21:32:49 2020
             State : active 
    Active Devices : 4
   Working Devices : 4
    Failed Devices : 0
     Spare Devices : 0

            Layout : left-symmetric
        Chunk Size : 256K

Consistency Policy : bitmap

              Name : jessie:alpha  (local to host jessie)
              UUID : 5b9de3ca:a39a432f:04d0ac03:cf3f4aa6
            Events : 25885

    Number   Major   Minor   RaidDevice State
       0       8        1        0      active sync   /dev/sda1
       1       8       17        1      active sync   /dev/sdb1
       2       8       33        2      active sync   /dev/sdc1
       4       8       49        3      active sync   /dev/sdd1

Meine mdadm.conf sieht wie folgt aus:

DEVICE partitions
ARRAY /dev/md/alpha metadata=1.2 name=jessie:alpha UUID=5b9de3ca:a39a432f:04d0ac03:cf3f4aa6

Meine mkinitcpio.conf:

MODULES=()
BINARIES=(mdmon)
FILES=()
HOOKS=(base udev autodetect modconf block mdadm_udev filesystems keyboard fsck)

Hat jemand eine Idee was ich machen könnte?

Beitrag geändert von Andy123Andy (08.05.2020 13:43:31)

Offline

#2 05.05.2020 23:11:45

frostschutz
Mitglied

Re: [GELÖST] Fake-Raid wird nicht gemounted

dmesg / syslog / journalctl in dem der schiefgegangene Bootprozess zu sehen ist? Kernel-md spuckt meistens Meldungen aus wenn ihm irgendwas nicht gefällt.

Was machst du mit "mdmon" in den Binaries?

Du kannst versuchen, das name=jessie:alpha aus der mdadm.conf rauszuwerfen. Das einzige was hier wirklich zählt, ist die UUID - der Rest kann stören.

Beitrag geändert von frostschutz (05.05.2020 23:12:18)

Offline

#3 07.05.2020 09:59:58

Andy123Andy
Mitglied

Re: [GELÖST] Fake-Raid wird nicht gemounted

Es scheint so als ob es gereicht hat den Namen zu entfernen.  Ich werde es mal beobachten. Vielen Dank.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums