Du bist nicht angemeldet.

#1 03.01.2020 22:54:35

rastabasta
Mitglied

[Solved]In bspwm taucht polybar nicht auf

Wenn ich über startx bspwm starte taucht polybar nicht auf.

Hier meine bspwmrc , ,meine launch.sy, meine bash_profile und meine polybar config.

Wenn ich .config/polybar/launch.sy im treminal aufrufe wird polybar gestartet.

Kann mir wer sagen wo ich einen Fehler habe?

p.s hier mein Xorg.0.log und meine .xinitrc

Beitrag geändert von rastabasta (06.01.2020 00:02:57)

Offline

#2 04.01.2020 12:39:45

stefanhusmann
Moderator

Re: [Solved]In bspwm taucht polybar nicht auf

Hilft es, wenn du das launch-Skript in der bspwmrc in den Hintergrund schickst, d.h. ein & anhängst?

Offline

#3 04.01.2020 13:59:33

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Nein hilft nicht

Offline

#4 04.01.2020 14:16:23

stefanhusmann
Moderator

Re: [Solved]In bspwm taucht polybar nicht auf

Kommentire mal die Zeile mit feh aus. (.xinitrc)

Offline

#5 04.01.2020 14:44:13

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Also habe feh auskommentiert und ein & an das laden des shell scripts gehangen. Funktioniert trotzdem nicht.

habe noch die xrandr zeile in .xinitrc auskommentiert die ich noch zu gefügt have.

Beitrag geändert von rastabasta (04.01.2020 14:47:37)

Offline

#6 04.01.2020 17:47:41

hcjl
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Setz das Ausführen des Skripts doch mal vor die Rules und versuche es mit

~/.config/polybar/launch.sh &

Offline

#7 04.01.2020 19:18:01

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Habe ich ausprobiert, funktioniert trotzdem nicht, ob mit ~ oder $HOME

Offline

#8 04.01.2020 19:55:19

hcjl
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Wird überhaupt etwas aus Deiner .bspwmrc ausgeführt?

Offline

#9 04.01.2020 20:16:14

wirr
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Wenn du in deiner .xinitrc die exec Zeile anpasst, solltest du im Log sehen, was falsch läuft:

exec bspwm > ~/bspwm.log 2>&1

Beitrag geändert von wirr (05.01.2020 23:15:35)

Offline

#10 05.01.2020 00:48:20

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Was mache ich wenn das log leer ist?

Genauer gesagt es steht nichts drin.

Offline

#11 05.01.2020 01:54:21

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

nach dem ich folgendes noch mal gemacht habe:
git clone https://aur.archlinux.org/<paketname>.git
less PKGBUILD
makepkg -si

Bekomme ich folgende Fehlermeldung
-- Font not found: fixed:pixelsize=10
-- Font not found: unifont:fontformat=truetype
-- Font not found: siji:pixelsize=10

kann es daran liegen?

Werde heute im laufe des Tages mal die Windows schriftarten copieren.

Beitrag geändert von rastabasta (05.01.2020 02:00:55)

Offline

#12 05.01.2020 03:26:28

SUSEDJAlex
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Hast du dich auch da eingelesen :

https://wiki.archlinux.org/index.php/Bspwm


P.S. in deiner launch.sy ist in der ersten Zeile ( glaube ich wenn ich die WIKI gelesen habe ) drin
von dir:

#!/usr/bin/env bash

müsste das nicht so lauten:

#!/bin/bash

# Terminate already running bar instances
killall -q polybar
....

Oder ?

LG SUSEDJAlex

Beitrag geändert von SUSEDJAlex (05.01.2020 03:37:12)

Offline

#13 05.01.2020 13:10:53

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

selbst das ändern der bash zeile hilft nicht.

kein ausführen des launch.sy aus bspwmrc, aus der konsoloe gehe beide scripts.

Offline

#14 05.01.2020 14:31:50

hcjl
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

hcjl schrieb:

Wird überhaupt etwas aus Deiner .bspwmrc ausgeführt?

Offline

#15 05.01.2020 15:03:06

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

sxhkd & wird ausgeführt

Macht es nen unterschied ob polybar oder polybar-git?

Beitrag geändert von rastabasta (05.01.2020 15:17:21)

Offline

#16 05.01.2020 20:41:03

wirr
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

rastabasta schrieb:

Was mache ich wenn das log leer ist?

Genauer gesagt es steht nichts drin.

Dann kannst du bei den Scripts ein `-xv` mitgeben:

#!/usr/bin/env bash

set -xv
#! /bin/sh

set -xv

Offline

#17 05.01.2020 21:37:11

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Also so:
bspwmrc

#!/bin/bash
set -xv
~/.config/polybar/launch.sh &
sxhkd & 2>&1 > ~/sxhkd.log

habe es auch bei .xinitrc am anfang eingefügt .

Das bspwm.log ist immernoch leer

Offline

#18 05.01.2020 22:01:52

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

So habe jetzt in Zeile 6 und am Ende des scripts bspwmrc foglendes eingefügt:

echo zeile 6 >> running.log
echo zeile ende >> running.log

Diese werden einwandfrei geschrieben.

Also lässt sich das launch.sh script von bspwmrc aus nicht starten.

Versuch mit ~/.config/polybar/launch.sh wird nicht geladen.
Versuch mit $HOME/.config/polybar/launch.sh wird nicht geladen.

Beitrag geändert von rastabasta (05.01.2020 22:38:50)

Offline

#19 05.01.2020 23:00:29

strcat
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Mal ins Blaue geraten: Vergessen launch.sh ausführbar zu machen?

Offline

#20 05.01.2020 23:15:06

wirr
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

Ich habe dir Blösinn angegeben, entschuldige.

exec bspwm > ~/bspwm.log 2>&1
~/.config/polybar/launch.sh > ~/polybar.log 2>&1 &
sxhkd > ~/sxhkd.log 2>&1 &

Am interessantesten ist `-xv` in launch.sh.

Offline

#21 06.01.2020 00:00:25

rastabasta
Mitglied

Re: [Solved]In bspwm taucht polybar nicht auf

strcat schrieb:

Mal ins Blaue geraten: Vergessen launch.sh ausführbar zu machen?

sowohl bspw,rc und launch.sh sind ausführbar.

-rwxrwxrwx  799  5. Jan 22:48 bspwmrc
-rwxr-xr-x   441  5. Jan 21:26 launch.sy

Ok ich bin nen Idiot, falsche Endung.

Habe launch.sy in launch.sh umbenannt und es funktioniert. Die richtige Schreibweise ist wichtig, sollte man vorher doch mal checken.

Danke für die Hilfe

Beitrag geändert von rastabasta (06.01.2020 00:04:08)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums