Du bist nicht angemeldet.

#1 27.12.2019 19:12:38

pix
Mitglied

Schwarzer Bildschirm bei xfce4

Hallo zusammen,

ich habe Arch nochmal neu auf meinem Laptop  Schenker XMG C703 installiert. Diesmal aber ziemlich sparsam vorgegangen.

Habe nur ein:
pacman -S nvidia    ## xorg-server-1.20.6 wird als Abhängigkeit autom. mitinstalliert
pacman -S xfce4     

gemacht. Unmittelbar nach der Installation konnte ich als normaler user xfce4 starten. Konnte das Glück gar nicht fassen.
Allerdings war es nur von kurzer Dauer. Nach einem reboot des Systems bleibt der Bildschirm schwarz.

Heisst, ich starte xfce4 über die Konsole mit "startx", dann startet auch der xserver aber es erscheint kein Bild.
Der Bildschirm ist schwarz, keine Fehlermeldung, kein Absturz nichts. Der Bildschirm ist und bleibt schwarz.

Auch ein nachträgliches installieren von "xf86-video-intel" brachte keinen Erfolg.
Ich verstehe nicht, warum unmittelbar nach der Installation der xserver startete aber nach einem reboot des Systems nicht.

Kann bitte jemand weiterhelfen?

PS:

vielleicht helfen zur Klärung diese beiden Ausgaben weiter:

lspci -k | grep -A 2 -E "(VGA|3D)" 

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
	DeviceName:  Onboard IGD
	Subsystem: Micro-Star International Co., Ltd. [MSI] 4th Gen Core Processor Integrated Graphics Controller
--
01:00.0 3D controller: NVIDIA Corporation GK106M [GeForce GTX 765M] (rev a1)
	Subsystem: Micro-Star International Co., Ltd. [MSI] GK106M [GeForce GTX 765M]
	Kernel driver in use: nvidia
 less .local/share/xorg/Xorg.0.log

https://hastebin.com/qowasatine.bash

Offline

#2 27.12.2019 19:30:06

brikler
Mitglied

Re: Schwarzer Bildschirm bei xfce4

pix schrieb:

ich habe Arch nochmal neu

hat es vorher etwa funktioniert? das sollte man schnell ändern…^^
schau mal nach pacman -Q xorg-xinit

Beitrag geändert von brikler (27.12.2019 19:31:23)

Offline

#3 27.12.2019 21:30:06

niemand
Mitglied

Re: Schwarzer Bildschirm bei xfce4

Kann bitte jemand weiterhelfen?

Die verlinkte Seite ist leider kaputt, funktioniert ohne Googles Tracking-Ajax-Zeugs nicht – bin nicht eher dazu gekommen, dafür ’ne VM aufzusetzen. Allerdings ist in dem Log kein Fehler zu sehen, der einen Start verhindern würde – hast du mal statt ›startx‹ direkt ›startxfce4‹ eingegeben (oder halt dein System so konfiguriert, dass ›startx‹ auch xfce4-session  hochreißt)?

Offline

#4 27.12.2019 23:52:44

pix
Mitglied

Re: Schwarzer Bildschirm bei xfce4

Vielen Dank für eure fixe Hilfe.

@brikler
Ich hatte wirklich nur pacman -S nvidia und xfce4 installiert.
Das Paket >xorg-xinit< muss irgendwie automatisch als Abhängigkeit mitinstalliert wurden sein, ohne das ich es bemerkt hatte, sorry sad

Nachtrag:
xorg-xinit wurde als Abhängigkeit von "xfce4-session" automatisch mitinstalliert

@niemand

...hast du mal statt ›startx‹ direkt ›startxfce4‹ eingegeben (oder halt dein System so konfiguriert, dass ›startx‹ auch xfce4-session  hochreißt)?

Ich hatte es dirket mit ›startxfce4‹ versucht, leider keine Besserung. Xserver ist anscheind oben bzw. gestartet, der Bildschirm bleibt dauerhaft schwarz, kein Abbruch oder eine Fehlermeldung.
Bzgl. des zweiten Teiles >...dass ›startx‹ auch xfce4-session  hochreißt)...< muss ich gestehen, weiss nicht was oder wie ich es machen soll sad

Habe das Paket xf86-video-intel wieder mit pacman -Rs xf86-video-intel  erstmal wieder entfernt.

Was ich nicht machen wollte aber getan habe ist das Paket "bumblebee" installiert.
Dann ein:
- systemctl enable bumblebeed.service           # Dienst mit Bootvorgang starten
- gpasswd -a MeinNutzerName bumblebee    # Nutzer der Gruppe bumblebee hinzugefügt
- reboot

Check:
systemctl | grep bumb                                     #   loaded active running   Bumblebee C Daemon

Dann als normaler Nutzer angemeldet und Xserver startet.

Ist aber nicht das was ich will.
Warum? weil ich kein bumblebee möchte.
Bin immer in Reichweite einer Steckdose, brauch also kein Strom sparen.

Frage:
brauche ich zwingend "bumblebee" bzw. wie geht es ohne.
Es hat ja funktioniert, leider hat es ein reboot nicht überlebt. Würde gerne bumblebee wieder loswerden aber trotzdem X nutzen

Vielen Dank für eure Hilfe

Beitrag geändert von pix (28.12.2019 09:09:01)

Offline

#5 03.01.2020 15:35:10

nudelholz
Gast

Re: Schwarzer Bildschirm bei xfce4

Hallo,
Bumbelbee brauchst du nur wenn du es unbedingt willst. Nur um ein Deskop anzuzeigen braucht man es meiner Meinung nach nicht.
die xinit wird bei den xserver mit installiert, brauchst du nebenbei für xfce.
Aber prüfe bitte ob du eine user .xinirc hast. Log dich mit einer bash shell als user ein und:

ls ~/.xinitc

Ist diese nicht vorhanden, nimmt der "startx" Befehl nach die Globale aus "/etc/X11/xinit/xinitrc". Und in der wird ken XFCE gestartet. Was du brauchst ist eine User ".xinitrc".
Die muss/kann man selbst anlegen:

cp /etc/X11/xinit/xinitrc ~/.xinirc

Das kopiert die Globale und speichert es in dein Benutzerordner als .xinirc. Diese musst du nun leicht umschreiben, dass XFCE startet:
Die ganzen letzen Zeilen ab twm, xterm ext kommentierst du mit "#" aus. Und ganz am Schluß fügst du einfach ein "exec startxfce4" hinzu.

Bei mir sieht die .xinitrc so aus:

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

#twm &
#xclock -geometry 50x50-1+1 &
#xterm -geometry 80x50+494+51 &
#xterm -geometry 80x20+494-0 &
#exec xterm -geometry 80x66+0+0 -name login
#export QT_QPA_PLATFORMTHEME=qt5ct
#export QT_QPA_PLATFORMTHEME=gtk2
exec startxfce4

Dann sollte es klappen mit dem startx. Nicht vergessen danach ein Displaymanager zu installieren, zb. lightdm.

PS: Ich nutze lieber anstatt nvidia das Paket "nvidia-dkms"
Pacman -Sy nvidia-dkms
Das updatet bei einen linux-kernel update das nvidia-modul automatisch.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums