Du bist nicht angemeldet.

#1 18.11.2019 14:25:48

fablab
Mitglied

_ Midnight Commander - internen Editor auf "nano" umstellen

Hallo User,

wie kann ich den "Midnight Commander" auf den Editor "nano" umstellen?
Zur Zeit wird mir mit F4 nur der der Interne-Midnight-Commander-Editor aufgerufen.

MfG

fablab

Beitrag geändert von fablab (18.11.2019 21:56:07)

Offline

#2 18.11.2019 15:05:51

efreak4u
Mitglied

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

Hallo fablab,

als Erstes musst du in deiner Shell-Konfiguration (z.B. ~/.bashrc) die Variable "EDITOR" setzen. Das sieht dann wie folgt aus:

EDITOR=nano

Dann musst du im MC unter Menu (F9) > Options > Configuration die Option (unter "other options" auf der rechten Seite) "Use internal edit" deaktivieren.

Offline

#3 18.11.2019 15:49:59

fablab
Mitglied

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

Hallo efreak4u,

deine Lösung funktioniert leider nicht, zuvor hatte ich das auch schon ausprobiert.

Wie meinst Du das genau?

Shell-Konfiguration (z.B. ~/.bashrc) die Variable "EDITOR" setzen. Das sieht dann wie folgt aus:

Im Terminal habe "EDITOR=nano" ausgeführt und im MC ist der Haken gesetzt bei "Internen Editor benutzen"

Es wird weiter der MC Editor aufgerufen.

MfG

fablab

Beitrag geändert von fablab (18.11.2019 15:53:58)

Offline

#4 18.11.2019 16:50:44

stefanhusmann
Moderator

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

export EDITOR=nano

exportiert die Variable auch.
Entweder so oder bei jedem Aufruf von mc mitgeben:

EDITOR=nano mc

Und der Haken muss wohl weg!

Offline

#5 18.11.2019 16:53:52

schard
Moderator

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

Dieser "Haken" darf natürlich nicht gesetzt sein:

$ grep use_internal_edit= ~/.config/mc/ini 
use_internal_edit=false

Dann funktioniert auch das von @efreak4u beschriebene:

EDITOR=vim mc

Offline

#6 18.11.2019 17:53:02

efreak4u
Mitglied

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

... und natuerlich muss der Haken raus, wenn ich "deaktivieren" schreibe.. tongue

Offline

#7 18.11.2019 19:52:44

fablab
Mitglied

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

Wenn kein Haken gesetzt ist start nach "EDITOR=nano" gar kein Editor.

EDITOR=nano mc

so gestartet, wird nano verwendet.

Bei Debian genügt die Auswahl im MC Menü, dann hat man dauerhaft den nano als Editor.
Beim ersten Start wird man sogar gefragt, ob man nano verwenden möchte.
Es genügt der Aufruf "mc".

export EDITOR=nano

dann "mc"

Funktioniert auch nur einmal.


Gibt es bei Archlinux eine Möglichkeit dieses Verhalten anderweitig einzustellen?


In der

nano ~/.config/mc/ini

gibt es viel zu stellen, nur was muss ich einstellen?


Version:
Name                     : mc
Version                  : 4.8.23-1


So ein Auswahlmenü fehlt beim ersten Editierstart:

Select an editor.  To change later, run 'select-editor'.
  1. /bin/ed
  2. /bin/nano        <---- easiest
  3. /usr/bin/mcedit
  4. /usr/bin/vim.gtk
  5. /usr/bin/vim.tiny

Choose 1-5 [2]:

Beitrag geändert von fablab (18.11.2019 20:40:40)

Offline

#8 18.11.2019 21:10:17

aesiey4L
Gast

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

Kann ich nicht nachvollziehen. Bei mir ist in .bashrc unter anderem

export EDITOR=nano 

eingetragen, das die Umgebungsvariable setzt.

Wenn ich jetzt im mc die Option für die Benutzung des internen Editors aussetze (was dem Eintrag

use_internal_edit=false 

in der Konfigurationsdatei entspricht), startet nach Druck auf F4 nano als Editor, setze ich es wieder ein, startet der interne Editor.

#9 18.11.2019 21:25:13

fablab
Mitglied

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

Jetzt habe ich es

Midnight_Commander - Optionen - Konfiguration - weitere Optionen

[  ] Internen Editor benutzen (nicht gewählt)

"export EDITOR=nano" der .bashrc hinzugefügt.

cat  .bashrc

 
#
# ~/.bashrc
#

# If not running interactively, don't do anything
[[ $- != *i* ]] && return

alias ls='ls --color=auto'
PS1='[\u@\h \W]\$ '
export EDITOR=nano

ein


Das scheint die Lösung zu sein.


use_internal/_edit=false 

Was macht das zweite Kommando?

Wie muss die Lösung systemweit konfiguriert werden?

Beitrag geändert von fablab (18.11.2019 22:48:39)

Offline

#10 18.11.2019 22:51:51

aesiey4L
Gast

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

fablab schrieb:

Was macht das zweite Kommando?

Verstehe ich nicht. Vielleicht zitierst du zum besseren Verständnis mal das, was du meinst.

Wie muss die Lösung systemweit konfiguriert werden?

Wieso liest du dir nicht einfach mal die manpages durch, anstatt hier jede Kleinigkeit zu erfragen?

/etc/mc/mc.ini
/usr/share/mc/mc.ini

        System-wide setup files for Midnight Commander, used only if the user doesn't have his own ~/.config/mc/ini file. If  /etc/mc/mc.ini  exists,  /usr/share/mc/mc.ini  isn't
        used.

#11 18.11.2019 23:13:03

stefanhusmann
Moderator

Re: _ Midnight Commander - internen Editor auf "nano" umstellen

Die Lösung muss gar nicht systemweit konfiguriert werden. Warum willst du solch höchst individuellen Vorlieben allen Mitbenutzern aufzwingen?

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums