Du bist nicht angemeldet.

#1 14.11.2019 20:12:49

swipe1
Mitglied

[gelöst] Probleme beim Mounten und Dateizugriff

Ich habe meine externe Festplatte, in dem Fall eine Partition /dev/sdb3(ntfs), einmal nach /mnt/externe. einhängen können.

Seitdem kann ich sie nicht mehr mounten, fehler: Spezialgerät /mnt/sdb3 ist nicht vorhanden.

Erstelle ich nun einen neue Einhängepunkt /mnt/test kann ich sie mounten. Was mache ich falsch, dass sie nicht in externe eingebunden werden kann.

Zudem, wie kann ich lese und schreibrechte für meinen normalen Benutzer und nicht nur root erhalten? Mit chmod 777 /mnt/test kann ich zwar auf die Festplatte zugreifen, aber für jeden Unterordner und jede Datei muss ich die Rechte auf chmod 777 switchen.

Beitrag geändert von swipe1 (19.11.2019 15:24:44)

Offline

#2 14.11.2019 20:22:45

Tu9Yamei
Gast

Re: [gelöst] Probleme beim Mounten und Dateizugriff

swipe1 schrieb:

Seitdem kann ich sie nicht mehr mounten, fehler: Spezialgerät /mnt/sdb3 ist nicht vorhanden.

Weil das Gerät /dev/sdb3 heisst und nicht /mnt/sdb3

#3 18.11.2019 06:55:42

swipe1
Mitglied

Re: [gelöst] Probleme beim Mounten und Dateizugriff

Sorry für diie späte Antwort. Also ich habs es nun ein paar mal versucht(google), aber ich bekomme es nicht hin. @Tu9Yamei stimmt, aber das war ein Typo, hatte die richtige (/dev...) gemountet.

[root@myhost mnt]# mount /dev/sdb3 /mnt/externe


chown -R MEINUSER /mnt/externe
....
chown: der Eigentümer von '/mnt/externe' wird geändert: Das Dateisystem ist nur lesbar


[root@myhost mnt]# ls -l
insgesamt 64
dr-x------ 1 root root 65536  9. Nov 19:03 externe


[root@myhost mnt]# groups MEINUSER
audio users

Bin Newbie, hatte zwar Debian auf dual-boot, aber da wurde immer alles automatisch gemountet. Ich will die externe auch nicht in fstab adden, sondern immer alles manuell mounten, auch wenn ein automount(ja/nein) parameter in fstab existiert.

Offline

#4 18.11.2019 23:11:00

swipe1
Mitglied

Re: [gelöst] Probleme beim Mounten und Dateizugriff

Hab meinen user in die Gruppe storage geadded aber es blieb erfolglos. Dann habe ich einfach mal einen media ordner unter / erstellt, den Rest siehe unten. Ich verstehe nun wieso ich mit meinem user nicht auf die Festplatte zugreifen kann (Rechte 500), aber verstehe auf der anderen Seite nicht, wieso ich die Rechte nicht auf 777 setzen kann. HELP PLZ! hmm

[root@myhost /]# mkdir media

[root@myhost /]# mount /dev/sdb3 /media

[root@myhost /]# chmod -v 777 /media

chmod: Beim Setzen der Zugriffsrechte für '/media': Das Dateisystem ist nur lesbar
Das Ändern des Modus von '/media' von 0500 (r-x------) nach 0777 (rwxrwxrwx) ist fehlgeschlagen
[root@myhost /]#

Offline

#5 19.11.2019 00:15:56

Tu9Yamei
Gast

Re: [gelöst] Probleme beim Mounten und Dateizugriff

Das wird daran liegen, dass das Linux-Rechtesystem nicht auf ein NTFS-Dateisystem abgebildet werden kann. Es gibt mount-Parameter, mit denen man beim Einhängen der Partition die Rechte übergeben kann:
https://wiki.archlinux.org/index.php/NT … ermissions

In die fstab würde ich die Partition trotzdem aufnehmen, ohne dass sie beim Start eingebunden wird. Da kannst du dann alle benötigten Parameter hinterlegen und mit einem einfachen "mount /mnt/externe" die Partition einhängen, ohne jedesmal den Rattenschwanz an mount-Parameter übergeben zu müssen. Anhand des fstab-Eintrags weiß mount dann, was zu tun ist.

#6 19.11.2019 15:24:17

swipe1
Mitglied

Re: [gelöst] Probleme beim Mounten und Dateizugriff

Tu9Yamei schrieb:

Das wird daran liegen, dass das Linux-Rechtesystem nicht auf ein NTFS-Dateisystem abgebildet werden kann. Es gibt mount-Parameter, mit denen man beim Einhängen der Partition die Rechte übergeben kann:
https://wiki.archlinux.org/index.php/NT … ermissions

In die fstab würde ich die Partition trotzdem aufnehmen, ohne dass sie beim Start eingebunden wird. Da kannst du dann alle benötigten Parameter hinterlegen und mit einem einfachen "mount /mnt/externe" die Partition einhängen, ohne jedesmal den Rattenschwanz an mount-Parameter übergeben zu müssen. Anhand des fstab-Eintrags weiß mount dann, was zu tun ist.

DANKEEEEEE dir!!!

Mit ntfs-3g /dev/sdb3 /mnt/externe läuft es nun wie gewollt, ohne weitere Paramter etc. Danke!!!!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums