Du bist nicht angemeldet.

#1 23.10.2019 20:15:28

Hanisch
Mitglied

GNOME Shell extensions funktionieren nicht mehr

Hallo,
nachdem nach dem letzten Update die GNOME-Oberfläche wieder startet, beobachte ich, daß im Panel nur

Anwendungen   Orte    und die Uhrzeit rechts

angezeigt werden.
Mit
Firefox -> GNOME Shell extensions -> Installed extensions -> Aktivieren verschiedener extensions hat keinen Effekt.

Nach einem Logout/Login keine Veränderung der Situation.

Woran mag das liegen?

Gruß
Ch. Hanisch

Offline

#2 23.10.2019 22:30:30

schard
Moderator

Re: GNOME Shell extensions funktionieren nicht mehr

Was fehlt dir denn konkret?

Offline

#3 23.10.2019 23:09:59

Hanisch
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

Hallo,

schard schrieb:

Was fehlt dir denn konkret?

Activities Configurator
Extensions
Favorites Menu
Frippery Application Menu
Frippery Move Clock
Removable Drive Menu
TopIcons bzw. TopIcons Plus
Trash
Workspace Indicator

Wenn ich diese extensions auf ON setze passiert gar nichts.

Gruß
Ch. Hanisch

Offline

#4 24.10.2019 02:38:55

TBone
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

Ich finde es komisch, dass es nicht hilft, im Firefox die Gnome Shell Extensions zu aktivieren.
Hast du es mal im Chromium probiert?

Offline

#5 24.10.2019 09:25:16

schard
Moderator

Re: GNOME Shell extensions funktionieren nicht mehr

Wenn die Plugins nicht über die Browsererweiterung zu aktivieren sind, dann benutzte doch direkt gnome-tweak-tools. Möglicherweise funktioniert die Gnome Shell Integration nicht mehr mit dem neuen Firefox.

Offline

#6 24.10.2019 10:07:13

Hanisch
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

schard schrieb:

Wenn die Plugins nicht über die Browsererweiterung zu aktivieren sind, dann benutzte doch direkt gnome-tweak-tools.

Mit dem gnome-tweak-tool 'Optimierungen' habe ich bei
Optimierungen -> Erweiterungen -> alle relevanten extensions aktiviert -> Ohne Erfolg.
Alledings ist bei

Optimierungen -> Erscheiningsbild -> Shell -> ein STOP-Dreieck

Ich habe alle relevanten Ordner/Dateien in ~/.cache/ und ~/.config/  umbenannte. Es wurde nur
~/.cache/gnome-software und   ~/.config/gnome-session  neu angelegt.
Allerdings ohne sichtbare Änderung des Zustandes.

Nach Umbenennen von /usr/share/gnome-shell.OFF  und  /usr/share/gnome-software.OFF  startete GNOME nicht mehr.
Erst nach 'sudo pacman -S gnome'  wurde /usr/share/gnome-software /usr/share/gnome-shell neu angelegt.
Aber dann war der Desktop wieder wie ganz zuvor.

Das Umbenennen von /usr/share/gnome-shell/extensions.OFF  brachte keine Veränderung, wurde nach einem Reboot auch nicht neu angelegt.
Erst nach einem erneuten 'sudo pacman -S gnome' wurde /usr/share/gnome-shell/extensions  neu angelegt mit zwölf Einträgen.

Beim Betätigen der WINDOWS-Taste wird er Bildschirm nur dunkler.

Was ist da los?

Gruß
Ch. Hanisch

Beitrag geändert von Hanisch (24.10.2019 10:58:26)

Offline

#7 24.10.2019 10:12:52

schard
Moderator

Re: GNOME Shell extensions funktionieren nicht mehr

Zeig mal dein Journal.
PS: Falls du ein abweichendes (= nicht Standard) Shell Thema ausgewählt hast, nimm mal das Standard Shell-Thema. Tritt der Fehler dann auch auf?

Offline

#8 24.10.2019 11:19:30

Hanisch
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

schard schrieb:

Zeig mal dein Journal.

Welches journal, wo finde ich das?

PS: Falls du ein abweichendes (= nicht Standard) Shell Thema ausgewählt hast, nimm mal das Standard Shell-Thema. Tritt der Fehler dann auch auf?

Ich habe in
Optimierungen -> Erscheinungsbild -> überall 'Adwaita (Vorgabe)' stehen.
Merkwürdig ist dieses STOP-Dreieck bei 'Shell'.

Wie und wo stelle ich das Standard-Shell-Thema ein?

Gruß
Ch. Hanisch

Beitrag geändert von Hanisch (24.10.2019 11:23:17)

Offline

#9 24.10.2019 14:43:30

Baldr-nolgin
Gast

Re: GNOME Shell extensions funktionieren nicht mehr

Hast du auf 3.34 „geupdated“? Sind die Extensions bereits ans aktuelle Gnome angepasst? Die Extensions scheinen auf den ersten Blick nicht mehr kompatibel zu sein.

#10 24.10.2019 15:07:44

Hanisch
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

Baldr-nolgin schrieb:

Hast du auf 3.34 „geupdated“? Sind die Extensions bereits ans aktuelle Gnome angepasst? Die Extensions scheinen auf den ersten Blick nicht mehr kompatibel zu sein.

GNOME ist Version 3.34.1

$ inxi -F
System:    Host: Arch Kernel: 5.3.7-arch1-1-ARCH x86_64 bits: 64 Desktop: Gnome 3.34.1 Distro: Arch Linux 
Machine:   Type: Virtualbox System: innotek product: VirtualBox v: 1.2 serial: <root required> 
           Mobo: Oracle model: VirtualBox v: 1.2 serial: <root required> BIOS: innotek v: VirtualBox date: 12/01/2006 
CPU:       Topology: Single Core model: Intel Core i7-2630QM bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 1995 MHz min/max: N/A Core speed (MHz): 1: 1995 
Graphics:  Device-1: InnoTek Systemberatung VirtualBox Graphics Adapter driver: vboxvideo v: kernel 
           Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa resolution: 1280x720~60Hz 
           OpenGL: renderer: llvmpipe (LLVM 9.0 256 bits) v: 3.3 Mesa 19.2.1 
Audio:     Device-1: Intel 82801AA AC97 Audio driver: snd_intel8x0 
           Sound Server: ALSA v: k5.3.7-arch1-1-ARCH 
Network:   Device-1: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] driver: pcnet32 
           IF: enp0s3 state: unknown speed: 100 Mbps duplex: full mac: 08:00:27:30:05:22 
           Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge driver: piix4_smbus 
Drives:    Local Storage: total: 24.00 GiB used: 15.54 GiB (64.7%) 
           ID-1: /dev/sda vendor: VirtualBox model: VBOX HARDDISK size: 24.00 GiB 
Partition: ID-1: / size: 17.25 GiB used: 13.52 GiB (78.4%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 5.13 GiB used: 2.01 GiB (39.2%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 1.01 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Info:      Processes: 164 Uptime: 4m Memory: 2.92 GiB used: 562.1 MiB (18.8%) Shell: bash inxi: 3.0.36

Gruß
Ch. Hanisch

Offline

#11 24.10.2019 15:29:19

Baldr-nologin
Gast

Re: GNOME Shell extensions funktionieren nicht mehr

Ich würde erst mal vorschlagen erst alle Extensions zu deaktivieren

$ gsettings set org.gnome.shell enabled-extensions [] 

Dann über https://extensions.gnome.org/local/ prüfen ob Updates vorhanden sind. Diese installieren aber noch nicht aktivieren. Auf der Webseite kannst du auch prüfen, ob die Kompatibilität mit 3.34 gegeben ist.

Nun kannst du wieder über die Webseite oder besser über das Tweak-Tool nach und nach die Extensions aktivieren.

Wenn eine nicht will (das Ausrufezeichen) ist die Extension üblicherweise noch nicht an die neue Gnome-Version angepasst worden. TopIcons Plus ist z.B. so ein Kandidat. Ich nutze daher z.Z. https://extensions.gnome.org/extension/1503/tray-icons/ und https://extensions.gnome.org/extension/ … r-support/. Das läuft bei mir ganz gut.

Gruß, Dirk

#12 24.10.2019 15:57:07

Hanisch
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

Baldr-nologin schrieb:

Ich würde erst mal vorschlagen erst alle Extensions zu deaktivieren

$ gsettings set org.gnome.shell enabled-extensions [] 

Das hat anscheinend bei mir nichts gebracht.

Der erste LInk hat bei mir tatsächlich das Icon für 'guake' und 'Parcellite' im Panel zur Anzeige gebracht.
Der zweite LInk hat zwar funktioniert, aber ich kann nichts Positives feststellen.

Ich habe jetzt 'Aktivitäten' im Panel, aber wenn ich drauf klicke passiert nichts.

Gruß
Ch. Hanisch

Offline

#13 24.10.2019 16:19:12

Baldr-nologin
Gast

Re: GNOME Shell extensions funktionieren nicht mehr

Hanisch schrieb:

Der zweite LInk hat zwar funktioniert, aber ich kann nichts Positives feststellen.

Dies kommt darauf an welche Programme dies nutzen. flameshot zum Beispiel.

Hanisch schrieb:

Ich habe jetzt 'Aktivitäten' im Panel, aber wenn ich drauf klicke passiert nichts.

Ungewöhnlich. Weis aber auch gerade nicht aus dem Kopf welche Extension dafür zuständig ist. Schaue heute Abend mal nach.
Müsste aber eine aus den von Gnome selbst gepflegten Extensions sein https://extensions.gnome.org/accounts/profile/fmuellner und sollte auch im Paket gnome-shell-extensions enthalten sein. Diese laufen üblichweise immer zuverlässig.

#14 24.10.2019 17:34:11

Baldr-nologin
Gast

Re: GNOME Shell extensions funktionieren nicht mehr

Mal noch ne Frage: Wie startest du die Shell, und nutzt du X11 oder Wayland?

#15 24.10.2019 17:40:46

Hanisch
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

Baldr-nologin schrieb:

Mal noch ne Frage: Wie startest du die Shell, und nutzt du X11 oder Wayland?

Ich starte GNOME vom Login-Screen 'slim'.
Dort habe ich die Auswahl mit F1:

Session Xfce
GNOME
GNOME Classic

Ich nutze X11, jedenfalls nicht explizit Wayland.

Gruß
Ch. Hanisch

Offline

#16 24.10.2019 18:34:29

Baldr
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

OK. Die slim-Konfig kenne ich nicht. Beim starten mit startx/xinitrc ist

export XDG_SESSION_TYPE=x11

vor

exec gnome-session

einzufügen. Vielleicht gibt es die Konfig auch hier.


Ansonsten nochmal ganz von vorne damit wir quasi Vanilla-Gnome haben:


gnome-Gruppe und ggf. gnome-extra (wenn du es vorher schon installiert hattest) neu installieren:

# pacman -S gnome gnome-extra

Anwendungen, Mauszeiger und Symbole über das Tweak-Tool (Erscheinungsbild) auf Adwaita (Vorgabe) setzen.


Alle Extensions deaktivieren:

gsettings set org.gnome.shell enabled-extensions []

Einfügen wie oben beschrieben:

export XDG_SESSION_TYPE=x11

Ausloggen oder neu starten.


Nun solltest du im Panel nur Aktivitäten (links), Uhr (Mitte), Symbolbereich (rechts) haben. Wenn unter Aktivitäten weiterhin nichts angezeigt wird, drück mal Windows+A und schreib mal ob dann wenigstens die Anwendungssymbole sichtbar sind.


Um noch eine Frage zu beantworten: Das Ausrufezeichen im Achtung-Schild unter Erscheinungsbild/Shell im Tweak-Tool bedeutet, dass du kein Shell-Thema laden kannst. Ist dann auf default eingestellt. Im Feld sollte auch kein Text stehen. Sofern dies gewünscht ist muss die Extension "User Theme" installiert und aktiviert sein.

Beitrag geändert von Baldr (24.10.2019 18:36:52)

Offline

#17 24.10.2019 19:42:59

Hanisch
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

Baldr schrieb:

OK. Die slim-Konfig kenne ich nicht. Beim starten mit startx/xinitrc ist

export XDG_SESSION_TYPE=x11

vor

exec gnome-session

einzufügen. Vielleicht gibt es die Konfig auch hier.

$ cat .xinitrc
#!/bin/bash
export XDG_SESSION_TYPE=x11
case $1 in
startxfce4)
      exec startxfce4
      ;;
gnome-session)
      exec gnome-session
      ;;
*)
      exec env GNOME_SHELL_SESSION_MODE=classic gnome-session --session gnome-classic
      ;;

esac

...Wenn unter Aktivitäten weiterhin nichts angezeigt wird, drück mal Windows+A und schreib mal ob dann wenigstens die Anwendungssymbole sichtbar sind.

WINDOWS+A bringt nichts und es sind auch keine Anwendungssymbole sichtbar.


Sofern dies gewünscht ist muss die Extension "User Theme" installiert und aktiviert sein.

Extension "User Theme" ist nun installiert sowie aktiviert und es erscheint:
Optimierungen -> Erscheinungsbild -> Shell ->  (keine) und "Vorgabe".

Aber noch immer zeigt ein Klick auf "Aktivitäten" nichts.

Neben "Aktivitäten" habe ich im Panel noch "Anwendungen" (das funktioniert!), "Orte" (das funktioniert!) sowie die Icons für 'guake' und 'Parcellite' , die Arbeitsflächen-Nr., "de" und Datum und Uhrzeit, Lautsprecher und Verlassen usw.

Vielleicht warten wir auch hier, bis die Maintainer die Fehler bemerken und fixen.

Gruß
Ch. Hanisch

Offline

#18 24.10.2019 19:58:04

Baldr
Mitglied

Re: GNOME Shell extensions funktionieren nicht mehr

Schaue aber am besten nochmal über https://extensions.gnome.org/local/ ob es zu deinen Extensions Updates gibt. Die Extensions im Paket gnome-shell-extensions scheinen tatsächlich derzeit nicht ganz aktuell zu sein. Ein Test unter Wayland kann auch nicht verkehrt sein.
Gruß, Dirk

Offline

#19 24.10.2019 22:57:33

OhC8iesu
Gast

Re: GNOME Shell extensions funktionieren nicht mehr

Hanisch schrieb:

Vielleicht warten wir auch hier, bis die Maintainer die Fehler bemerken und fixen.

Vielleicht könntest du auch anstatt dich bequem zurücklehnen und auf die anderen zu warten selber initiativ werden und es den Entwicklern melden, wenn du glaubst, einen Fehler bemerkt zu haben. Und wieso "wir"? Nur du bist es, der wartet, nicht wir.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums