Du bist nicht angemeldet.

#1 17.10.2019 14:53:06

Andy123Andy
Mitglied

[gelöst] Langsamer boot durch systemd-random-seed.service

Hallo,

mein Laptop startet seit neusten nur wenn ich die Maus bewege. Schuld daran ist wohl der systemd-random-seed.service Services. Daraufhin habe ich rng-utils installiert. Jetzt start der Laptop wieder ohne an der maus zu wackeln aber es dauert wie ich finde recht lange:

root:andy/ # systemd-analyze blame
3.017s systemd-random-seed.service                        
1.756s systemd-logind.service                             
1.117s systemd-timesyncd.service                          
 679ms systemd-rfkill.service                             
 632ms lvm2-monitor.service                               
 408ms upower.service                                     
 330ms dev-sda2.device                                    
 205ms systemd-udevd.service                              
 190ms systemd-journald.service                           
 160ms org.cups.cupsd.service                             
  79ms bluetooth.service                                  
  61ms systemd-modules-load.service                       
  61ms polkit.service                                     
  49ms systemd-udev-trigger.service                       
  40ms user@1000.service                                  
  39ms udisks2.service                                    
  37ms NetworkManager.service                             
  37ms avahi-daemon.service                               
  17ms colord.service                                     
  16ms systemd-tmpfiles-setup-dev.service                 
  12ms systemd-tmpfiles-setup.service                     
   9ms systemd-backlight@leds:dell::kbd_backlight.service 
   8ms dev-disk-by\x2dlabel-swap.swap                     
   8ms wpa_supplicant.service                             
   8ms dev-hugepages.mount                                
   7ms dev-mqueue.mount                                   
   6ms sys-kernel-debug.mount                             
   6ms systemd-backlight@backlight:intel_backlight.service
   6ms kmod-static-nodes.service                          
   6ms alsa-restore.service                               
   6ms systemd-remount-fs.service                         
   6ms systemd-update-utmp.service                        
   5ms systemd-journal-flush.service                      
   4ms user-runtime-dir@1000.service                      
   4ms systemd-user-sessions.service                      
   4ms systemd-sysctl.service                             
   3ms rtkit-daemon.service                               
   1ms tmp.mount                                          
   1ms sys-kernel-config.mount 
 
Linux archmini 4.19.79-2-lts #1 SMP Fri Oct 11 20:04:02 UTC 2019 x86_64 GNU/Linux

Hat jemand eine Idee was ich tun kann?

Beitrag geändert von Andy123Andy (17.10.2019 15:42:12)

Offline

#2 17.10.2019 15:13:47

schard
Moderator

Re: [gelöst] Langsamer boot durch systemd-random-seed.service

Verwendest du den Kernel Parameter

random.trust_cpu=on

?
Siehe auch: https://wiki.archlinux.org/index.php/Ra … generation

Offline

#3 17.10.2019 15:23:09

Andy123Andy
Mitglied

Re: [gelöst] Langsamer boot durch systemd-random-seed.service

Ich hab den Parameter mal gesetzt jetzt verhält es sich wieder normal. Das Paket rng-tools konnte ich auch wieder entfernen. Danke

root:andy/ # systemd-analyze blame                                                                                                                                     [15:20:55]
1.471s systemd-logind.service                             
 988ms systemd-timesyncd.service                          
 869ms lvm2-monitor.service                               
 686ms systemd-rfkill.service                             
 664ms dev-sda2.device                                    
 498ms systemd-hostnamed.service                          
 389ms upower.service                                     
 359ms systemd-hwdb-update.service                        
 234ms systemd-journald.service                           
 209ms systemd-udevd.service                              
 157ms udisks2.service                                    
 125ms org.cups.cupsd.service                             
  89ms ldconfig.service                                   
  53ms polkit.service                                     
  52ms systemd-modules-load.service                       
  49ms systemd-udev-trigger.service       
...
..
.

schaut so aus

LABEL arch lts
    MENU LABEL Arch Linux LTS
    LINUX ../vmlinuz-linux-lts
    APPEND root=LABEL=arch resume=LABEL=swap rw quiet splash reboot=warm nospectre_v2 nopti nospec_store_bypass_disable random.trust_cpu=on
    INITRD ../intel-ucode.img,../initramfs-linux-lts.img

Offline

#4 17.10.2019 19:59:19

Andy123Andy
Mitglied

Re: [gelöst] Langsamer boot durch systemd-random-seed.service

Du meinst wegen dem absatz?

"The trust worthiness of modern hardware random number generators is hotly debated whether they may be back-doored for use by spy agencies or other rogue actors given past influence by the NSA and other organizations:" https://www.phoronix.com/scan.php?page= … -RNG-Trust

Was ist den eine alternative? Oder besser wie war es den davor. Das Problem tritt erst seit einiger Zeit auf.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums