Du bist nicht angemeldet.

#1 15.10.2019 01:56:50

lyrreax
Mitglied

Intel iGPU friert PC ein

Schönen guten Tag liebe Userschaft,

ich habe kürzlich mein Arch Linux neu installiert und bin auf einen sonderbaren Fehler gestoßen.

Wenn ich meinen PC über die integrierte Grafikkarte boote und den X-Server starte, friert der PC nach wenigen Sekunden komplett ein und lässt sich dann nur noch über einen Hardreset wieder ausschalten.

Dieser Freeze tritt aber nur dann auf, wenn in dem modesetting-Treiber "glamor" als AccelMethod genutzt. wird "sna" und "uxa" funktionieren dahingegen problemlos.

Durch den notwendigen Hardreset bleiben auch keine Einträge in der /var/log/Xorg.0.log vorhanden und journalctl ist auch befundlos.


EDIT: Nach einem weiteren Versuch hat das Xorg.0.log tatsächlich seine Contents behalten - allerdings kann ich da keinen Rückschluss auf diesen Freeze finden.


Mein System:

Mainboard: H81M-P33
CPU: Intel i7-4790K
GPU: NVIDIA GeForce GTX 1660 Ti
RAM: 16GB

uname -a

Linux archMachine 5.3.5-zen1-1-zen #1 ZEN SMP PREEMPT Mon Oct 7 19:03:07 UTC 2019 x86_64 GNU/Linux

lspci

00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H81 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation TU116 [GeForce GTX 1660 Ti] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 1aeb (rev a1)
01:00.2 USB controller: NVIDIA Corporation Device 1aec (rev a1)
01:00.3 Serial bus controller [0c80]: NVIDIA Corporation Device 1aed (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

xrandr - wenn AccelMethod = uxa / sna

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
VGA-1 disconnected primary (normal left inverted right x axis y axis)
HDMI-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   1920x1080     60.00* 
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    66.67    59.94  
   720x400       70.08  

pacman -Qt

acpid 2.0.32-1
arandr 0.1.10-3
ark 19.08.2-1
autoconf 2.69-5
automake 1.16.1-1
base 2-1
bison 3.4-1
cmake 3.15.4-1
compton 7.4-1
copyq 3.9.2-1
dhcpcd 8.0.6-1
discord 0.0.9-5
dolphin 19.08.2-1
elfutils 0.177-1
fakeroot 1.24-1
filelight 19.08.2-1
flex 2.6.4-2
fontforge 20190801-1
gdm 3.34.1-1
go 2:1.13.1-1
graphviz 2.42.2-2
groff 1.22.4-1
gwenview 19.08.2-1
htop 2.2.0-2
i3-gaps 4.17.1-1
i3status-rust 0.11.0-1
intel-gmmlib 19.3.2-1
intel-media-driver 19.3.0-1
intel-ucode 20190918-1
kate 19.08.2-1
kde-gtk-config 5.16.5-1
kdeplasma-addons 5.16.5-1
kgamma5 5.16.5-1
kinfocenter 5.16.5-1
kwallet-pam 5.16.5-1
kwayland-integration 5.16.5-1
kwrited 5.16.5-1
lib32-libxmu 1.1.3-1
libclc 0.2.0+589+9aa6f35-1
libdmx 1.1.4-1
libxvmc 1.0.12-2
linux-zen 5.3.5.zen1-1
lutris 0.5.3-1
meson 0.52.0-1
nano 4.5-1
neofetch 6.1.0-1
nvidia-dkms 435.21-11
opencl-headers 2:2.2.20170516-2
openssh 8.1p1-1
opera 64.0.3417.54-1
optimus-manager 1.2.1-1
oxygen 5.16.5-1
pavucontrol-qt 0.14.1-1
pkgconf 1.6.3-2
plasma-browser-integration 5.16.5-1
plasma-desktop 5.16.5-1
plasma-pa 5.16.5-1
plasma-sdk 5.16.5-1
plasma-vault 5.16.5-1
python-mako 1.0.14-1
python-recommonmark 0.4.0.133.c410abb-4
python-sphinx_rtd_theme 0.4.3-1
qdirstat 1.6-1
qt5ct 0.41-1
refind-efi 0.11.3-1
rust 1:1.38.0-2
sddm-kcm 5.16.5-1
spectacle 19.08.2-1
swig 4.0.1-1
ttf-font-awesome-4 4.7.0-5
user-manager 5.16.5-1
vulkan-tools 1.1.121-1
which 2.21-4
wine-lol 4.17-2
xdg-desktop-portal-kde 5.16.5-1
xfce4-notifyd 0.4.4-2
xmlto 0.0.28-3
xorg-xinit 1.4.1-1
xtrans 1.4.0-1
yay 9.3.3-1

glxinfo
https://pastebin.com/b2gDG34E

Xorg.0.log - uxa
https://pastebin.com/42G4mFaX

dmesg
https://pastebin.com/ZuTmGG4W


Danke im Voraus!

MfG
lyrreax

Beitrag geändert von lyrreax (15.10.2019 09:53:57)

Offline

#2 15.10.2019 10:48:02

Dirk
Moderator

Re: Intel iGPU friert PC ein

Passiert das auch mit dem normalen Kernel?

Offline

#3 15.10.2019 11:45:36

lyrreax
Mitglied

Re: Intel iGPU friert PC ein

Hallo Dirk!

Ja, das passiert bei dem normalen Kernel, dem CK-Kernel aus dem AUR und dem LTS-Kernel.

Beitrag geändert von lyrreax (15.10.2019 13:09:18)

Offline

#4 15.10.2019 13:36:39

lyrreax
Mitglied

Re: Intel iGPU friert PC ein

TBone schrieb:

Passiert das auch ohne intel_iommu=igfx_off?

Yep, den IOMMU-Kernel-Parameter hatte ich gesetzt, um zu schauen, ob das mein Problem löst. Leider ist es absolut unerheblich, ob Intel_IOMMU auf on, off oder igfx_off steht - das Verhalten ist dasselbe.

TBone schrieb:
[    52.875] ================ WARNING WARNING WARNING WARNING ================
[    52.875] This server has a video driver ABI version of 25.0 that this
driver does not officially support.  Please check
[url]http://www.nvidia.com/[/url] for driver updates or downgrade to an X
server with a supported driver ABI.
[    52.875] =================================================================
[    52.875] (WW) NVIDIA: The driver will continue to load, but may behave strangely.
[    52.875] (WW) NVIDIA: This driver was compiled against the X.Org server SDK from commit 29a8baa031a87ef44d1e5320ecec5015d26fd385 and may not be compatible with the final version of this SDK.

Das hier hast du gelesen? Würde ich testweise auch einfach mal blacklisten. (Ich weiß, es geht dir um die Intel, würde ich aber trotzdem einfach mal probieren).

Die Freezes hatte ich auch schon direkt nach der Systeminstallation, als die NVIDIA-Treiber gar nicht installiert waren. Blacklisting & co habe ich auch schon ausprobiert, allerdings hat das absolut keinen Einfluss gehabt.

Testweise habe ich auch statt dem normalen X-Server aus den Repos die -git Version aus dem AUR installiert, um zu testen, ob sich der Fehler auf Xorg selbst zurückführen lässt - aber auch erfolglos. Daher kommt auch die Meldung aus dem Xorg-Log.



TBone schrieb:

Zeigst du bitte trotzdem mal das Xorg.0.log mit glamor? Da stehen immer hin auch andere Infos drinnen als der Absturz.

Selbstverständlich! Das Log hänge ich sofort an.

Offline

#5 15.10.2019 14:28:35

lyrreax
Mitglied

Re: Intel iGPU friert PC ein

Hier die Xorg.0.log mit glamor als AccelMethod - hat mich jetzt mehrere Anläufe gekostet, damit das Log nicht leer ist.
https://pastebin.com/Hq5W4Zzr


TBone schrieb:

Btw:

initrd=/boot/intel-ucode.img initrd=/boot/initramfs-linux-zen.img

Das funktioniert aber so nicht. Der Bootloader lädt die initrds für den Kernel. Was nutzt du denn für einen Bootloader? Also das haupt initrd wird auf jeden Fall geladen, sonst würde dein PC nicht booten, es kann sein, dass der Microcode für deinen Intel nicht geladen wird, eventuell würde der einen Bug in der CPU beheben.


Ich nutze rEFInd als Bootloader - allerdings habe ich den genau so eingestellt, wie Hier in der Arch Wiki vermerkt.


Eigentlich dürfte der microcode geladen sein...

journalctl -k --grep='microcode'

Oct 15 14:16:12 archMachine kernel: microcode: microcode updated early to revision 0x27, date = 2019-02-26
Oct 15 14:16:12 archMachine kernel: microcode: sig=0x306c3, pf=0x2, revision=0x27
Oct 15 14:16:12 archMachine kernel: microcode: Microcode Update Driver: v2.2.

Beitrag geändert von lyrreax (15.10.2019 14:33:30)

Offline

#6 15.10.2019 19:20:09

Norby07
Mitglied

Re: Intel iGPU friert PC ein

Hallo ich hatte dieses Problem auch.
Mir hat ein Hook in /etc/mkinitcpio.conf. geholfen.

HOOKS=(base systemd autodetect modconf block filesystems sd-vconsole fsck)

An der 2. Position das systemd einfügen.


Gruß von Noby07

Offline

#7 16.10.2019 14:18:05

lyrreax
Mitglied

Re: Intel iGPU friert PC ein

Hallo!

Norby07 schrieb:

Hallo ich hatte dieses Problem auch.
Mir hat ein Hook in /etc/mkinitcpio.conf. geholfen.

HOOKS=(base systemd autodetect modconf block filesystems sd-vconsole fsck)

An der 2. Position das systemd einfügen.


Gruß von Noby07


Leider hat mir das nicht geholfen. Danke trotzdem!




Ich habe gerade festgestellt, dass der Fehler NICHT nur mit glamor auftritt.
Testweise habe ich vom modesetting zum Intel-Treiber gewechselt und dort treten die Freezes absolut unabhängig von der AccelMethod auf. Interessanterweise nutzt der modesetting-Treiber unter uxa oder sna bei mir Software-Rendering (llvmpipe - ersichtlich im "glxinfo"-Log)
Scheinbar liegt das Problem also irgendwo an der Hardwarebeschleunigung. Hat vielleicht irgendjemand eine Idee, wie ich weiter verfahren könnte?

Änderungen von Einstellungen im UEFI scheint auch nicht wirklich zu helfen...

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums