Du bist nicht angemeldet.

#1 09.10.2019 06:22:39

HansHiasl
Mitglied

[gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

Hallo Gemeinde

Gestern gings noch fehlerfrei, heute nicht mehr.

pacman -Syu bringt

Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation von jre-openjdk (13.u33-1) verletzt Abhängigkeit 'java-runtime-openjdk=12', benötigt von java-openjfx

Was kann ich tun?
Wie ist das hier eigentlich zu interpretieren:

Installation von jre-openjdk (13.u33-1) verletzt Abhängigkeit 'java-runtime-openjdk=12', benötigt von java-openjfx

Beitrag geändert von HansHiasl (09.10.2019 17:53:56)

Offline

#2 09.10.2019 07:01:00

niemand
Mitglied

Re: [gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

Was kann ich tun?

Etwas warten, oder selbst ’nen Bugreport verfassen.

Wie ist das hier eigentlich zu interpretieren:
[…]

openjfx braucht runtime-openjdk in Version 12, die nun aktuelle Version von jre-openjdk stellt aber runtime-openjdk in 13 bereit, wodurch die Abhängigkeit nicht mehr erfüllt werden kann. Es ist im Grunde also genau so zu interpretieren, wie es dort steht.

Beitrag geändert von niemand (09.10.2019 07:01:29)

Offline

#3 09.10.2019 07:31:57

HansHiasl
Mitglied

Re: [gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

Danke für Deine schnelle Antwort.
Nur zum Verständnis:
Es müsste nun auch openjfx angepasst werden, so dass es mit runtime-openjdk Version 13 zurecht kommt?
Ich wart mal ab.
Wenn ich mein System "auf biegen und brechen" aktualisieren will, dann müsste ich nur jre-openjdk in ignorepkg der pacman.conf schreiben?
Fragt sich nur, wie lange das gut ginge?
Wie gesagt, nur zum Verständnis.

Offline

#4 09.10.2019 12:57:08

Icecube63
Mitglied

Re: [gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

HansHiasl schrieb:

Fragt sich nur, wie lange das gut ginge?

Bis eine andere Anwendung runtime-openjdk Version 13 oder höher benötigt.

Offline

#5 09.10.2019 15:24:12

Icecube63
Mitglied

Re: [gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

Ich habs gerade mal getestet, nur jre-openjdk auf ignore zu setzen reichte nicht, jre-openjdk-headless musste auch noch dazu. Und selbst dann wurde gemeckert:

Warnung: Kann "jre13-openjdk=13.u33-1" nicht auflösen (eine Abhängigkeit von "jdk-openjdk")

Also lieber warten.

Offline

#6 09.10.2019 17:53:38

HansHiasl
Mitglied

Re: [gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

Hallo Gemeinde
Ich konnte das "Problem" jetzt selber beseitigen.
Ich dachte, das Paket java-openjfx wird von Hibiscus/Jameica, meiner Homebankingsoftware benötigt.
Pacman -Qi sagt aber, dass java-openjfx von nichts benötigt wird.
Da ich dem pacman glaube, was er sagt, er ist ja eine ehrliche Haut, hab ich java-openjfx entfernt.
Und siehe da, alles läuft wieder rund und fehlerfrei.

Offline

#7 09.10.2019 22:57:19

Dirk
Moderator

Re: [gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

Same here …

Das Paket konnte ohne Probleme deinstalliert werden, und die einzige Java-Anwendung die ich verwende funktioniert weiterhin.

Online

#8 10.10.2019 16:58:36

Icecube63
Mitglied

Re: [gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

Heute wurde java-openjfx auf 13 aktualisiert, löschen wäre also nicht mehr notwendig. Habe aber auf meinem Desktop-PC auch keine Auswirkung festgestellt, wurde glaube ich mal wegen mediathekview installiert.

Offline

#9 10.10.2019 22:00:35

Dirk
Moderator

Re: [gelöst] Fehler beim Update - Abhängigkeitskonflikt mit Java

Icecube63 schrieb:

... wurde glaube ich mal wegen mediathekview installiert.

Und genau das braucht es hier nicht mehr smile

Online

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums