Du bist nicht angemeldet.

#1 14.09.2019 01:56:12

akarvi
Mitglied

Update von bestimmtem Paket verhindern

Hi,

ich möchte gern mein System via -Syu auf dem laufenden halten, aber für ein bestimmtes Paket die Updates verhindern.
Sagen wir mal, das bestimmte Paket heißt "xyz".

Wie kann ich das via pacman oder (in meinem Falle) yay hinbekommen?
Gibt es dafür vielleicht eine Art blacklist?

Danke vorab,

Alex
***

Beitrag geändert von akarvi (14.09.2019 02:03:09)

Offline

#2 14.09.2019 06:08:57

Dirk
Moderator

Re: Update von bestimmtem Paket verhindern

Keine Ahnung, wie yay das macht, aber wenn es sich halbwegs an die Standards hält, respektiert es die entsprechende Option in pacman .conf.

       IgnorePkg = package ...
           Instructs pacman to ignore any upgrades for this package when performing a --sysupgrade.
           Shell-style glob patterns are allowed.

Also einfach IgnorePkg = xyz in den options-Abschnitt die pacman.conf schreiben.

Offline

#3 15.09.2019 09:36:05

akarvi
Mitglied

Re: Update von bestimmtem Paket verhindern

yay hält sich da an die Standards. Es klappt.

Danke!

Beitrag geändert von akarvi (15.09.2019 09:37:48)

Offline

#4 15.09.2019 14:24:57

matthias
Moderator

Re: Update von bestimmtem Paket verhindern

Oder auch NoUpgrade = xyz. Man pacman.conf ist hier in jedem Fall dein Freund.
Denk aber bitte auch daran, dass du dir ein partielles Upgrade einfängst, was langfristig keine Lösung sein darf. Je nach den den Abhängigkeiten von "xyz" kriegst du früher oder später Probleme. Geht zwar, ist aber nicht empfohlen.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums