Du bist nicht angemeldet.

#1 30.08.2019 20:21:27

HansHiasl
Mitglied

[gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

Hallo Gemeinde

Ich wende mich heute mit einem Problem an Euch, das ich schon lange habe, mich aber zunehmend nervt.
Ich habe Arch mit Display-Manager LightDM, NetworkManager und XFCE installiert.
Das Netzwerk läuft wireless und die Verbindung sollte sich automatisch beim Systemstart aufbauen.
Und hier ist der Hund irgendwie begraben.
Mit dem nm-connection-editor habe ich eingestellt, dass sich das Netzwerk automatisch verbinden soll und von allen Nutzern benutzt werden darf.
Nun ist es so, dass der Verbindungsaufbau in den meisten Fällen erst dann erfolgt, wenn sich ein Benutzer anmeldet.
Egal, ob im LightDM oder einer VConsole.
Wenn sich kein Benutzer anmeldet und der Rechner in der Anmeldemaske stehen bleibt,
dann erfolgt der Verbindungsaufbau manchmal erst nach einigen Minuten, manchmal auch gar nicht (festgestellt durch ping von einem anderen Rechner).
Gibt es eine Stellschraube, an der ich einstellen kann, dass sich die Netzwerkverbindung immer aufbaut, sobald es der Kiste möglich ist?
Ganz unabhängig davon, ob ein Benutzer angemeldet ist oder nicht.
Wo in den Tiefen des Dateisystems kann ich die beiden Einstellungen finden, dass sich das Netzwerk automatisch verbinden soll und von allen Nutzern benutzt werden darf?
Das müsste doch in irgend einer .conf-Datei gespeichert sein.

Hier der Eintrag in "/etc/NetworkManager/system-connections/HansHiasl", der wohl vom nm-connection-editor angelegt wurde:

[connection]
id=HansHiasl
uuid=6ed73593-17ed-408c-8e1e-ec489e608f77
type=wifi
metered=2
permissions=
timestamp=1567002049

[wifi]
band=a
mac-address=00:16:6F:DC:B0:1D
mac-address-blacklist=
mode=infrastructure
seen-bssids=44:4E:6D:66:19:7A;9C:C7:A6:1F:40:B8;
ssid=HansHiasl

[wifi-security]
key-mgmt=wpa-psk
psk=xyzxyzxyzxyz

[ipv4]
address1=192.168.1.201/24,192.168.1.1
dns=192.168.1.1;
dns-search=
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
ip6-privacy=0
method=ignore

Würde es denn mit netctl oder wicd besser funktionieren?

Bitte nicht auf Forensuche oder eine Suchmaschine meines Vertrauens verweisen, dort hab ich nichts gefunden, was mich zufrieden stellt.
Die sagen alle nur, ich müsse das einstellen, was ich eh eingestellt habe (dass sich das Netzwerk automatisch verbinden soll und von allen Nutzern benutzt werden darf).

Beitrag geändert von HansHiasl (31.08.2019 14:38:59)

Offline

#2 30.08.2019 20:35:18

schard
Moderator

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

HansHiasl schrieb:

Mit dem nm-connection-editor habe ich eingestellt, dass sich das Netzwerk automatisch verbinden soll und von allen Nutzern benutzt werden darf.

Das sollte eigentlich ausreichen, um die automatische Verbindung zu Stande zu bekommen. Dein Konfiguration sieht diesbezüglich auch i.O. aus.
Ich habe es gerade mal mit meinem Notebook gestestet. Dort funktioniert dies einwandfrei.
Ich benutze allerdings GDM als Login Manager, was allerdings auch keine Rollte spielen sollte.
Ist dein System denn soweit aktuell?

Offline

#3 30.08.2019 20:48:55

HansHiasl
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

Ja, mein System ist aktuell.
Ich nutze zwar den LTS-Kernel, aber mit dem tagesaktuellen Kernel ist es das Selbe.

Offline

#4 30.08.2019 21:37:40

primus
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

Hallo HansHiasl,

bei mir in den Einstellungen dieser Datei ist noch das Interface erwähnt.

[connection]
id=WLAN
uuid=9216cfb2-7dca-47c7-9865-af99baa7fb75
type=wifi
interface-name=wlp3s0
permissions=
timestamp=1567188773

Viel Erfolg!

Beitrag geändert von primus (30.08.2019 22:00:14)

Offline

#5 30.08.2019 22:57:11

HansHiasl
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

Der Eintrag "interface-name=wlp5s0" ändert leider gar nichts.
Ich hab hier mal Journalauszüge.
Dieser hier bei sofortiger Benutzeranmeldung im LightDM:

journalctl -b | grep network
Aug 30 22:33:16 arch systemd-udevd[234]: Config file /usr/lib/systemd/network/99-default.link applies to device based on potentially unpredictable interface name 'wlan0'
Aug 30 22:33:20 arch systemd[522]: Listening on GnuPG network certificate management daemon.
Aug 30 22:33:23 arch systemd[571]: Listening on GnuPG network certificate management daemon.
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9656] device (wlp5s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "HansHiasl"
Aug 30 22:33:33 arch systemd[522]: Closed GnuPG network certificate management daemon.

journalctl -b | grep wlan0
Aug 30 22:33:16 arch systemd-udevd[234]: Config file /usr/lib/systemd/network/99-default.link applies to device based on potentially unpredictable interface name 'wlan0'
Aug 30 22:33:16 arch kernel: iwlwifi 0000:05:00.0 wlp5s0: renamed from wlan0

journalctl -b | grep wlp5s0
Aug 30 22:33:16 arch kernel: iwlwifi 0000:05:00.0 wlp5s0: renamed from wlan0
Aug 30 22:33:17 arch NetworkManager[420]: <info>  [1567197197.2164] device (wlp5s0): driver supports Access Point (AP) mode
Aug 30 22:33:17 arch NetworkManager[420]: <info>  [1567197197.2179] manager: (wlp5s0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/3)
Aug 30 22:33:17 arch NetworkManager[420]: <info>  [1567197197.2280] device (wlp5s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Aug 30 22:33:17 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:33:17 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:33:17 arch NetworkManager[420]: <info>  [1567197197.4993] device (wlp5s0): set-hw-addr: set MAC address to 12:46:A2:14:F8:26 (scanning)
Aug 30 22:33:17 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:33:17 arch NetworkManager[420]: <info>  [1567197197.7764] device (wlp5s0): supplicant interface state: init -> starting
Aug 30 22:33:23 arch NetworkManager[420]: <info>  [1567197203.1437] sup-iface[0x5568321d8930,wlp5s0]: supports 5 scan SSIDs

Aug 30 22:33:23 arch NetworkManager[420]: <info>  [1567197203.1456] device (wlp5s0): supplicant interface state: starting -> ready
Aug 30 22:33:23 arch NetworkManager[420]: <info>  [1567197203.1457] Wi-Fi P2P device controlled by interface wlp5s0 created
Aug 30 22:33:23 arch NetworkManager[420]: <info>  [1567197203.1460] manager: (p2p-dev-wlp5s0): new 802.11 Wi-Fi P2P device (/org/freedesktop/NetworkManager/Devices/4)
Aug 30 22:33:23 arch NetworkManager[420]: <info>  [1567197203.1464] device (p2p-dev-wlp5s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Aug 30 22:33:23 arch NetworkManager[420]: <info>  [1567197203.1472] device (p2p-dev-wlp5s0): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:23 arch NetworkManager[420]: <info>  [1567197203.1476] device (wlp5s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Aug 30 22:33:23 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4820] device (wlp5s0): Activation: starting connection 'HansHiasl' (6ed73593-17ed-408c-8e1e-ec489e608f77)
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4821] device (wlp5s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4844] device (wlp5s0): set-hw-addr: reset MAC address to 00:16:6F:DC:B0:1D (preserve)
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4888] device (wlp5s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:26 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4912] device (wlp5s0): Activation: (wifi) access point 'HansHiasl' has security, but secrets are required.
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4913] device (wlp5s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4916] sup-iface[0x5568321d8930,wlp5s0]: wps: type pbc start...
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4975] device (wlp5s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4980] device (wlp5s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.4983] device (wlp5s0): Activation: (wifi) connection 'HansHiasl' has security, and secrets exist.  No new secrets needed.
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.5816] device (wlp5s0): supplicant interface state: ready -> disconnected
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.5817] device (p2p-dev-wlp5s0): supplicant management interface state: ready -> disconnected
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.5883] device (wlp5s0): supplicant interface state: disconnected -> inactive
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.5884] device (p2p-dev-wlp5s0): supplicant management interface state: disconnected -> inactive
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.5942] device (wlp5s0): supplicant interface state: inactive -> scanning
Aug 30 22:33:26 arch NetworkManager[420]: <info>  [1567197206.5943] device (p2p-dev-wlp5s0): supplicant management interface state: inactive -> scanning
Aug 30 22:33:29 arch wpa_supplicant[488]: wlp5s0: SME: Trying to authenticate with 44:4e:6d:66:19:7a (SSID='HansHiasl' freq=5180 MHz)
Aug 30 22:33:29 arch kernel: wlp5s0: authenticate with 44:4e:6d:66:19:7a
Aug 30 22:33:29 arch kernel: wlp5s0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9051] device (wlp5s0): supplicant interface state: scanning -> authenticating
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9052] device (p2p-dev-wlp5s0): supplicant management interface state: scanning -> authenticating
Aug 30 22:33:29 arch wpa_supplicant[488]: wlp5s0: Trying to associate with 44:4e:6d:66:19:7a (SSID='HansHiasl' freq=5180 MHz)
Aug 30 22:33:29 arch kernel: wlp5s0: send auth to 44:4e:6d:66:19:7a (try 1/3)
Aug 30 22:33:29 arch kernel: wlp5s0: authenticated
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9124] device (wlp5s0): supplicant interface state: authenticating -> associating
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9125] device (p2p-dev-wlp5s0): supplicant management interface state: authenticating -> associating
Aug 30 22:33:29 arch wpa_supplicant[488]: wlp5s0: Associated with 44:4e:6d:66:19:7a
Aug 30 22:33:29 arch wpa_supplicant[488]: wlp5s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Aug 30 22:33:29 arch kernel: wlp5s0: associate with 44:4e:6d:66:19:7a (try 1/3)
Aug 30 22:33:29 arch kernel: wlp5s0: RX AssocResp from 44:4e:6d:66:19:7a (capab=0x1511 status=0 aid=1)
Aug 30 22:33:29 arch kernel: wlp5s0: associated
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9221] device (wlp5s0): supplicant interface state: associating -> associated
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9222] device (p2p-dev-wlp5s0): supplicant management interface state: associating -> associated
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9324] device (wlp5s0): supplicant interface state: associated -> 4-way handshake
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9325] device (p2p-dev-wlp5s0): supplicant management interface state: associated -> 4-way handshake
Aug 30 22:33:29 arch wpa_supplicant[488]: wlp5s0: WPA: Key negotiation completed with 44:4e:6d:66:19:7a [PTK=CCMP GTK=CCMP]
Aug 30 22:33:29 arch wpa_supplicant[488]: wlp5s0: CTRL-EVENT-CONNECTED - Connection to 44:4e:6d:66:19:7a completed [id=0 id_str=]
Aug 30 22:33:29 arch kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlp5s0: link becomes ready
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9656] device (wlp5s0): supplicant interface state: 4-way handshake -> completed
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9656] device (wlp5s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "HansHiasl"
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9657] device (p2p-dev-wlp5s0): supplicant management interface state: 4-way handshake -> completed
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9660] device (wlp5s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:29 arch NetworkManager[420]: <warn>  [1567197209.9671] acd[0x556832229590,3]: couldn't init ACD for announcing addresses on interface 'wlp5s0': Die Operation ist nicht erlaubt
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9673] device (wlp5s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:29 arch wpa_supplicant[488]: wlp5s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-58 noise=9999 txrate=6000
Aug 30 22:33:29 arch kernel: wlp5s0: Limiting TX power to 20 (23 - 3) dBm as advertised by 44:4e:6d:66:19:7a
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9844] device (wlp5s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9848] device (wlp5s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9886] policy: set 'HansHiasl' (wlp5s0) as default for IPv4 routing and DNS
Aug 30 22:33:29 arch NetworkManager[420]: <info>  [1567197209.9924] device (wlp5s0): Activation: successful, device activated.

und der hier ohne Benutzeranmeldung (bzw. erst nach ein paar Minuten):

journalctl -b | grep network
Aug 30 22:17:37 arch systemd-udevd[249]: Config file /usr/lib/systemd/network/99-default.link applies to device based on potentially unpredictable interface name 'wlan0'
Aug 30 22:17:40 arch systemd[526]: Listening on GnuPG network certificate management daemon.
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6549] device (wlp5s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "HansHiasl"
Aug 30 22:20:02 arch systemd[623]: Listening on GnuPG network certificate management daemon.
Aug 30 22:20:12 arch systemd[526]: Closed GnuPG network certificate management daemon.

journalctl -b | grep wlan0
Aug 30 22:17:37 arch systemd-udevd[249]: Config file /usr/lib/systemd/network/99-default.link applies to device based on potentially unpredictable interface name 'wlan0'
Aug 30 22:17:37 arch kernel: iwlwifi 0000:05:00.0 wlp5s0: renamed from wlan0

journalctl -b | grep wlp5s0
Aug 30 22:17:37 arch kernel: iwlwifi 0000:05:00.0 wlp5s0: renamed from wlan0
Aug 30 22:17:39 arch NetworkManager[429]: <info>  [1567196259.5176] device (wlp5s0): driver supports Access Point (AP) mode
Aug 30 22:17:39 arch NetworkManager[429]: <info>  [1567196259.5185] manager: (wlp5s0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/3)
Aug 30 22:17:39 arch NetworkManager[429]: <info>  [1567196259.5267] device (wlp5s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Aug 30 22:17:39 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:17:39 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:17:39 arch NetworkManager[429]: <info>  [1567196259.8101] device (wlp5s0): set-hw-addr: set MAC address to 6A:EF:03:37:67:B6 (scanning)
Aug 30 22:17:40 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:17:40 arch NetworkManager[429]: <info>  [1567196260.0720] device (wlp5s0): supplicant interface state: init -> starting
Aug 30 22:18:05 arch NetworkManager[429]: <error> [1567196285.0847] sup-iface[0x560854356130,wlp5s0]: error adding interface: Zeitüberschreitung wurde erreicht
Aug 30 22:18:05 arch NetworkManager[429]: <info>  [1567196285.0849] device (wlp5s0): supplicant interface state: starting -> down
Aug 30 22:18:15 arch NetworkManager[429]: <warn>  [1567196295.5376] device (wlp5s0): re-acquiring supplicant interface (#1).
Aug 30 22:18:40 arch NetworkManager[429]: <error> [1567196320.5655] sup-iface[0x560854356220,wlp5s0]: error adding interface: Zeitüberschreitung wurde erreicht
Aug 30 22:18:40 arch NetworkManager[429]: <info>  [1567196320.5656] device (wlp5s0): supplicant interface state: starting -> down
Aug 30 22:18:50 arch NetworkManager[429]: <warn>  [1567196330.5362] device (wlp5s0): re-acquiring supplicant interface (#2).
Aug 30 22:19:14 arch NetworkManager[429]: <info>  [1567196354.7902] sup-iface[0x560854356310,wlp5s0]: supports 5 scan SSIDs
Aug 30 22:19:14 arch NetworkManager[429]: <info>  [1567196354.7913] device (wlp5s0): supplicant interface state: starting -> ready
Aug 30 22:19:14 arch NetworkManager[429]: <info>  [1567196354.7914] Wi-Fi P2P device controlled by interface wlp5s0 created
Aug 30 22:19:14 arch NetworkManager[429]: <info>  [1567196354.7917] manager: (p2p-dev-wlp5s0): new 802.11 Wi-Fi P2P device (/org/freedesktop/NetworkManager/Devices/4)
Aug 30 22:19:14 arch NetworkManager[429]: <info>  [1567196354.7922] device (p2p-dev-wlp5s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Aug 30 22:19:14 arch NetworkManager[429]: <info>  [1567196354.7932] device (p2p-dev-wlp5s0): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:14 arch NetworkManager[429]: <info>  [1567196354.7935] device (wlp5s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Aug 30 22:19:14 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1765] device (wlp5s0): Activation: starting connection 'HansHiasl' (6ed73593-17ed-408c-8e1e-ec489e608f77)
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1766] device (wlp5s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1783] device (wlp5s0): set-hw-addr: reset MAC address to 00:16:6F:DC:B0:1D (preserve)
Aug 30 22:19:18 arch kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1828] device (wlp5s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1832] device (wlp5s0): Activation: (wifi) access point 'HansHiasl' has security, but secrets are required.
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1833] device (wlp5s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1835] sup-iface[0x560854356310,wlp5s0]: wps: type pbc start...
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1861] device (wlp5s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1867] device (wlp5s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.1870] device (wlp5s0): Activation: (wifi) connection 'HansHiasl' has security, and secrets exist.  No new secrets needed.
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.2724] device (wlp5s0): supplicant interface state: ready -> disconnected
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.2724] device (p2p-dev-wlp5s0): supplicant management interface state: ready -> disconnected
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.2801] device (wlp5s0): supplicant interface state: disconnected -> inactive
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.2802] device (p2p-dev-wlp5s0): supplicant management interface state: disconnected -> inactive
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.2865] device (wlp5s0): supplicant interface state: inactive -> scanning
Aug 30 22:19:18 arch NetworkManager[429]: <info>  [1567196358.2866] device (p2p-dev-wlp5s0): supplicant management interface state: inactive -> scanning
Aug 30 22:19:21 arch wpa_supplicant[520]: wlp5s0: SME: Trying to authenticate with 44:4e:6d:66:19:7a (SSID='HansHiasl' freq=5180 MHz)
Aug 30 22:19:21 arch kernel: wlp5s0: authenticate with 44:4e:6d:66:19:7a
Aug 30 22:19:21 arch kernel: wlp5s0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded
Aug 30 22:19:21 arch wpa_supplicant[520]: wlp5s0: Trying to associate with 44:4e:6d:66:19:7a (SSID='HansHiasl' freq=5180 MHz)
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.5980] device (wlp5s0): supplicant interface state: scanning -> authenticating
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.5980] device (p2p-dev-wlp5s0): supplicant management interface state: scanning -> authenticating
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.5994] device (wlp5s0): supplicant interface state: authenticating -> associating
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.5995] device (p2p-dev-wlp5s0): supplicant management interface state: authenticating -> associating
Aug 30 22:19:21 arch kernel: wlp5s0: send auth to 44:4e:6d:66:19:7a (try 1/3)
Aug 30 22:19:21 arch kernel: wlp5s0: authenticated
Aug 30 22:19:21 arch kernel: wlp5s0: associate with 44:4e:6d:66:19:7a (try 1/3)
Aug 30 22:19:21 arch kernel: wlp5s0: RX AssocResp from 44:4e:6d:66:19:7a (capab=0x1511 status=0 aid=1)
Aug 30 22:19:21 arch wpa_supplicant[520]: wlp5s0: Associated with 44:4e:6d:66:19:7a
Aug 30 22:19:21 arch wpa_supplicant[520]: wlp5s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6204] device (wlp5s0): supplicant interface state: associating -> 4-way handshake
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6205] device (p2p-dev-wlp5s0): supplicant management interface state: associating -> 4-way handshake
Aug 30 22:19:21 arch kernel: wlp5s0: associated
Aug 30 22:19:21 arch wpa_supplicant[520]: wlp5s0: WPA: Key negotiation completed with 44:4e:6d:66:19:7a [PTK=CCMP GTK=CCMP]
Aug 30 22:19:21 arch wpa_supplicant[520]: wlp5s0: CTRL-EVENT-CONNECTED - Connection to 44:4e:6d:66:19:7a completed [id=0 id_str=]
Aug 30 22:19:21 arch kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlp5s0: link becomes ready
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6549] device (wlp5s0): supplicant interface state: 4-way handshake -> completed
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6549] device (wlp5s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "HansHiasl"
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6549] device (p2p-dev-wlp5s0): supplicant management interface state: 4-way handshake -> completed
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6552] device (wlp5s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6566] device (wlp5s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:21 arch wpa_supplicant[520]: wlp5s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-59 noise=9999 txrate=6000
Aug 30 22:19:21 arch kernel: wlp5s0: Limiting TX power to 20 (23 - 3) dBm as advertised by 44:4e:6d:66:19:7a
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6678] device (wlp5s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6681] device (wlp5s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6712] policy: set 'HansHiasl' (wlp5s0) as default for IPv4 routing and DNS
Aug 30 22:19:21 arch NetworkManager[429]: <info>  [1567196361.6735] device (wlp5s0): Activation: successful, device activated.
Aug 30 22:19:25 arch ntpd[457]: Listen normally on 4 wlp5s0 192.168.1.201:123
Aug 30 22:19:25 arch ntpd[457]: Listen normally on 5 wlp5s0 [fe80::216:6fff:fedc:b01d%3]:123

Vielleicht hilft das ja weiter. Sind immerhin zwei Zeilen mit "error" dabei. Ich kann damit leider nichts anfangen.

Offline

#6 30.08.2019 23:21:15

ManfredB
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

Hallo zusammen,

ich habe auf meinem Notebook folgendes gemacht, um nach Login Internet per WLAN zu haben:
Unter /etc/netctl gibt es die Möglichkeit, aus dem Unterverzeichnis /examples die Datei
wireless-wpa-config rüberzukopieren nach /etc/netctl, darin meine WLAN-Verbindung wlp2s0 einzutragen.
Danach habe ich netctl enable wireless-wpa-config ausgeführt.

Das hat meine WLAN-Verbindung automatisch hergestellt.
Wenn ich nun ArchLinux starte und eingeloggt bin, muss ich nichts mehr tun,
denn WLAN funktioniert einwandfrei.

Ich halte das nach wie vor für die einfachste Lösung des Problems,
weil das Verfahren sehr schnell geht.

Gruss
Manfred

Beitrag geändert von ManfredB (30.08.2019 23:22:55)

Offline

#7 31.08.2019 07:35:00

HansHiasl
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

Hallo Manfred
Dein Tipp ändert leider nichts.
Ich hab auch mal die Netzwerkkonfiguration im nm-connection-manager von manuell auf DHCP umgestellt.
Ohne Erfolg.
Hier ist mal ein komplettes Journal ab dem Zeitpunkt, wo NetworkManager erstmalig auftaucht.
Alles vorher gibt keinen Hinweis auf Fehler. Netzwerktreiber/Module werden korrekt erkannt/geladen.....
Die Schnittstelle sollte wlp5s0 und die IP 192.168.1.3 sein.

https://pastebin.com/UQS7XdBQ

Offline

#8 31.08.2019 11:14:33

Photor
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

Moin,

Hatte mal sowas ähnliches (weiß nicht mehr, ob es das WLAN- oder das ETH-Interface war). Das Interface ließ sich nicht bzw. erst nach einer gewissen Zeit (neu) konfigurieren. (Ich glaube, nach einem Warmstart gab es keine Probleme mit dem Device).

Es hat sich dann heraus gestellt, dass das Device direkt nach dem Booten noch im Energiesparmodus war. Nachdem ich das geändert hatte (bitte jetzt nich fragen, wie; vielleicht im BIOS), gab‘s keine Probleme mehr.

Nur als eine Möglichkeit,
Photor

Offline

#9 31.08.2019 13:51:18

ub4000
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

HansHiasl schrieb:

Wenn sich kein Benutzer anmeldet und der Rechner in der Anmeldemaske stehen bleibt,
dann erfolgt der Verbindungsaufbau manchmal erst nach einigen Minuten, manchmal auch gar nicht (festgestellt durch ping von einem anderen Rechner).

Das hört sich dannach an, als ob dein Rechner zu wenig Zufallszahlen (entropy_avail)  nach dem Start hat, und für WLAN brauchst du entropy.
Lies mal hier:
https://wiki.archlinux.org/index.php/Rng-tools
erste Wahl, ansonnsten
https://wiki.archlinux.org/index.php/Haveged

In den Artikeln ist auch beschrieben wie du entropy_avail ausliest und die Funktionalität überprüfst.

Offline

#10 31.08.2019 14:41:03

HansHiasl
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

@ Photor

In meinem Bios gibt es keinerlei Einstellmöglichkeiten für Energiesparmodi.
Folgendes hab ich gemacht:

Datei /etc/modprobe.de/iwlwifi.conf angelegt mit folgendem Inhalt:

options iwlwifi power_save=0

Datei /etc/modprobe.de/iwlmvm.conf angelegt mit folgendem Inhalt:

options iwlmvm power_scheme=1

Diese beiden Maßnahmen haben mein Problem nicht gelöst. Allerdings haben sie dazu geführt, dass sich die Pingzeiten von 5 - 100 ms auf 3-8 ms verringert haben.


@ ub4000

Ich habe die rng-tool mitsamt den Abhängigkeiten gemäß https://wiki.archlinux.org/index.php/Rng-tools installiert.
Die Konfigurantionsdatei hab ich in den Standardeinstellungen belassen.

Und siehe da: Es funktioniert !

DANKE DIR !

PS: Wie kommt man da eigentlich drauf? Woran hast Du das erkannt?
Irgendwie schon genial.

Offline

#11 31.08.2019 15:27:09

Photor
Mitglied

Re: [gelöst] Wireless LAN automatisch vor Benutzeranmeldung verbinden

HansHiasl schrieb:

@ Photor

In meinem Bios gibt es keinerlei Einstellmöglichkeiten für Energiesparmodi.
Folgendes hab ich gemacht:

Datei /etc/modprobe.de/iwlwifi.conf angelegt mit folgendem Inhalt:

options iwlwifi power_save=0

Datei /etc/modprobe.de/iwlmvm.conf angelegt mit folgendem Inhalt:

options iwlmvm power_scheme=1

Diese beiden Maßnahmen haben mein Problem nicht gelöst. Allerdings haben sie dazu geführt, dass sich die Pingzeiten von 5 - 100 ms auf 3-8 ms verringert haben.
.

Iss ja spannend! Die Dateien habe bestimmt nicht angefasst. Aber offensichtlich haben die einen Effekt.

Was gelernt. Das war ein guter Tag,

Photor

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums