Du bist nicht angemeldet.

#1 16.08.2019 09:59:53

atlantisxl
Mitglied

Kann Abhängigkeiten nicht erfüllen....Systemupdate

Hallo,

ich habe mein älteren PC wieder mal rausgeholt und wollte ihn auf dem neusten stand bringen jedoch hänge ich beim Systemupdate fest und hoffe hier auf hilfe

das Installieren von libvpx (1.8.1-1) verletzt Abhängigkeit von 'libvpx.so=4-64' benötigt von ffmpeg2.8
das Entfernen von libx264 verletzt Abhängigkeit von 'libx264.so=148-64' benötigt von ffmpeg2.8
das Installieren von x265 (3.1.2-1) verletzt Abhängigkeit von 'libx265.so=146-64' benötigt von ffmpeg2.8
das Entfernen von attica-qt4 verletzt Abhängigkeit von 'attica-qt4' benötigt von kdelibs
das Entfernen von poppler-qt4 verletzt Abhängigkeit von 'poppler-qt' benötigt von kfilemetadata4


grüße

Offline

#2 16.08.2019 10:17:58

schard
Moderator

Re: Kann Abhängigkeiten nicht erfüllen....Systemupdate

Das Paket ffmpeg2.8 existiert nicht mehr in den Repos.
Du solltest das System vor dem Upgrade aufräumen.

pacman -Rcs $(pacman -Qdtq) $(pacman -Qmq)

Damit deinstallierst du alle nicht mehr benötigten Pakete (-Qdtq) und alle verwaisten, d.h. nicht mehr in den Repos vorhandenen Pakete (-Qmq).
Falls du AUR Pakete installiert hast, wird dies allerdings auch diese entfernen.

Offline

#3 16.08.2019 12:19:00

Dirk
Moderator

Re: Kann Abhängigkeiten nicht erfüllen....Systemupdate

schard schrieb:

Damit deinstallierst du alle nicht mehr benötigten Pakete (-Qdtq) und alle verwaisten, d.h. nicht mehr in den Repos vorhandenen Pakete (-Qmq).

Also nicht blind ausführen, sondern die liste durchgehen, ob da Programme bei sind, die du noch behalten willst, unabhängig davon, ob sie Abhängigkeiten sind.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums