Du bist nicht angemeldet.

#1 15.08.2019 13:06:45

Thorsten Reinbold
Mitglied

[Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Hallo,

ich habe hier ein kleines Problem. Als das letzte Xfce4-Update vor ein paar Tagen kam, habe ich es mir nach langer Zeit mal wieder installiert (neben Gnome). Leider gibt es ein recht nerviges Problem: Xfce merkt sich die Aktualisierungsrate meines Monitor nicht (Asus VG278, 144 Hz) und setzt diese nach jedem Neustart bzw. abschalten des Monitor im Betrieb wieder auf 60 Hz zurück. Ich hatte mal im Netz geschaut, aber leider keine dauerhafte Lösung gefunden. Zwar kann ich über Anwendungen>Einstellungen>Anzeige wieder die richtige Rate einstellen ('xrandr --output DP-2 --mode 1920x1080 --refresh 144' geht auch), aber eine echte Lösung ist das ja irgendwie nicht. Hat Jemand möglicherweise ähnliche Probleme und eine dauerhafte Lösung?

Ich nutze eine Nvidia Geforce GTX 1070 mit dem proprietären Treiber, hier meine 20-nvidia.conf:

Section "Monitor"
    Identifier     "AsusVG278"
    VendorName     "Asus"
    ModelName      "AUS VG278"
    HorizSync       160.0 - 160.0
    VertRefresh     40.0 - 144.0
    Option         "DPMS"
EndSection

Section "Device"
        Identifier "Nvidia GeForce GTX 1070"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName "GeForce GTX 1070"
	BusID "PCI:1:0:0"
	Option	"ConnectToAcpid"	"off"
	Option	"Coolbits"			"12"
EndSection

Section "Screen"
	Identifier	"Screen0"
	Device		"Nvidia GeForce GTX 1070"
	Monitor		"AsusVG278"
	DefaultDepth	24
	Option	"Stereo" "0"
	Option	"nvidiaXineramaInfoOrder" "DFP-4"
	Option	"metamodes" "1920x1080_144 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
	Option	"SLI" "Off"
	Option	"MultiGPU" "Off"
	Option	"BaseMosaic" "off"
	Option	"TripleBuffer"			"on"
		SubSection	"Display"
		Depth		24
		EndSubSection
EndSection

Unter Gnome besteht das Problem übrigens nicht. Danke!

Beitrag geändert von Thorsten Reinbold (18.08.2019 14:14:54)

Offline

#2 15.08.2019 15:51:01

Tor
Gast

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Hallo,

pack den Befehl "xrandr --output DP-2 --mode 1920x1080 --refresh 144" doch einfach in ein ausführbares script und lass das über xfce-autostart bei der Anmeldung starten.

#3 15.08.2019 16:05:40

Thorsten Reinbold
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

An sich eine gute Idee, hilft dauerhaft aber nicht, da es ja nur ein einziges Mal beim Start ausgeführt wird. Bei jedem Monitor-Standby oder anderen Veränderungen setzt sich das ja wieder auf die blöden 60 Hz zurück. Ich bin auch nicht sicher, wo Xfce diese Einstellung eigentlich speichert, ich hatte schon mal versucht, die 'monitors.xml' unter ~/.config/ auf read-only zu setzen, das brachte aber auch nichts. Ich würde einfach gern die 144 Hz als Standard festlegen, weiß aber nicht wie und wo.

Beitrag geändert von Thorsten Reinbold (15.08.2019 16:08:44)

Offline

#4 15.08.2019 16:29:26

Thorsten Reinbold
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Hier übrigens noch die Ausgabe von 'xrandr':

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080     60.00 + 144.00*  119.98    99.93    84.90    59.94    50.00  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)

Macht mich etwas stutzig, dass in der 1920er Zeile zuerst die 60 Hz stehen, gefolgt von + 144.

Offline

#5 15.08.2019 20:23:27

Werner
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Der bevorzugte Modus ist 60 Hz (Pluszeichen) und der aktuelle Modus 144.00 Hz (Sternchen). Demnach ist es so, wie du es haben willst …

Offline

#6 16.08.2019 01:27:12

Thorsten Reinbold
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Wenn es so wäre, wie ich es haben möchte, würde es dauerhaft so bleiben. Schalte ich den Monitor einmal aus und wieder an, sieht das dann so aus:

   1920x1080     60.00*+ 144.00   119.98    99.93    84.90    59.94    50.00  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  

Beitrag geändert von Thorsten Reinbold (16.08.2019 01:27:29)

Offline

#7 16.08.2019 14:19:00

Werner
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Es gab eine Menge Änderungen bei den xfce4-display-settings (Changelog 4.14).
Eine der Änderungen ist diese: Display: Improved support for embedded DisplayPort connectors

Hast du ein DVI-Dual-Link-Kabel, um mal zu versuchen, ob die 144 Hz über DVI gehalten werden?

Offline

#8 16.08.2019 15:14:15

Thorsten Reinbold
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Werner schrieb:

Hast du ein DVI-Dual-Link-Kabel, um mal zu versuchen, ob die 144 Hz über DVI gehalten werden?

Leider nein, ich habe hier nur DP und HDMI als Optionen.

Offline

#9 16.08.2019 15:33:19

KTT73
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Schau mal in die ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml.

Dort die refresh Rate eintragen...

<property name="DP-2" type="string" value="Samsung 32""><property name="Active" type="bool" value="true"/>
<property name="EDID" type="string" value="3f66787930f3165f57227c672a04b9a52596fe0b"/>
<property name="Resolution" type="string" value="1920x1080"/>
<property name="RefreshRate" type="double" value="60.000000"/>   <---------hier
<property name="Rotation" type="int" value="0"/>
<property name="Reflection" type="string" value="0"/>
<property name="Primary" type="bool" value="true"/>
<property name="Position" type="empty"><property name="X" type="int" value="0"/>
<property name="Y" type="int" value="0"/>
</property>
</property>

vll hilfts.

Offline

#10 16.08.2019 16:47:45

Thorsten Reinbold
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Danke, da hatte ich schon rein gesehen. Das sah da und sieht auch immer noch so aus:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="displays" version="1.0">
  <property name="ActiveProfile" type="string" value="Default"/>
  <property name="Default" type="empty">
    <property name="DP-2" type="string" value="AUS 27&quot;">
      <property name="Active" type="bool" value="true"/>
      <property name="EDID" type="string" value="60505ed3999f6ea862789ece0f59643b253f6032"/>
      <property name="Resolution" type="string" value="1920x1080"/>
      <property name="RefreshRate" type="double" value="144.000765"/>
      <property name="Rotation" type="int" value="0"/>
      <property name="Reflection" type="string" value="0"/>
      <property name="Primary" type="bool" value="true"/>
      <property name="Position" type="empty">
        <property name="X" type="int" value="0"/>
        <property name="Y" type="int" value="0"/>
      </property>
    </property>
  </property>
  <property name="Notify" type="bool" value="true"/>
  <property name="AutoEnableProfiles" type="bool" value="true"/>
</channel>

Ich bin da mit meinem Latein etwas am Ende. Ich werde später mal mit einer älteren Live-Distri testen, ob das mit der Xfce-Vorversion auch so war. Da weiß ich zumindest, ob es Bug oder Konfigurationsfehler meinerseits ist.

Beitrag geändert von Thorsten Reinbold (16.08.2019 16:50:16)

Offline

#11 17.08.2019 15:42:52

Thorsten Reinbold
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Scheint in der Vorversion auch schon so gewesen zu sein. Das ist ja ätzend. Es muss doch einen Weg geben, der Oberfläche zu sagen welche Auflösung mit welcher Bildwiederholrate Standard ist?!

Offline

#12 17.08.2019 22:14:54

tuxnix
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

Es könnte helfen den Befehl 'xrandr --output DP-2 --mode 1920x1080 --refresh 144' in der ~.xinitrc bzw. einem xprofil einzutragen.
Dann müsste der Befehl jedes mal neu ausgeführt werden wenn X startet.
https://wiki.archlinux.org/index.php/Xprofile

Ansonsten fällt mir noch die xorg.conf ein.
https://www.x.org/releases/X11R7.7/doc/ … nf.5.xhtml

Beitrag geändert von tuxnix (17.08.2019 22:24:44)

Offline

#13 18.08.2019 14:14:18

Thorsten Reinbold
Mitglied

Re: [Gelöst] Xfce merkt sich Monitor-Aktualisierungsrate nicht

tuxnix schrieb:

Es könnte helfen den Befehl 'xrandr --output DP-2 --mode 1920x1080 --refresh 144' in der ~.xinitrc bzw. einem xprofil einzutragen.
Dann müsste der Befehl jedes mal neu ausgeführt werden wenn X startet.

Der Tipp mit der .xprofile hat offenbar geholfen. Ich verstehe allerdings absolut nicht, warum. Immerhin wird ja der X-Server nicht jedes Mal neu gestartet, wenn ich den Monitor nach Standby o.Ä. wieder einschalte. Aber wie gesagt: bislang hilft es. Danke!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums