#1 27.05.2019 17:54:43

sewulba
Mitglied

[gelöst]Probleme mit BCM4313 Wireless

Hallo Archer.

Hier nun mein letztes Problem, welches ich habe.
Ich bekomme meine WLAN unter Archlinux nicht so wirklich zum Laufen.

Folgendes habe ich gemacht:

/etc/rc.local angepasst

wpa_supplicant -iwlp2s0b1 -c /etc/wpa_supplicant/wpa_supplicant.conf -Dwext -B

Außerdem steht folgendes in /etc/wpa_supplicant/wpa_supplicant.conf drin:

network={
        ssid="rtac88u"
        scan_ssid=1
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=CCMP
        psk="DaStehtMeinPasswortDrin"
}

In ssid habe ich meine SSID eingetragen und im psk steht mein PW drin.

Ich habe gelesen, dass es mit dem BCM4313 zu problemen kommen kann. Aber von etwa 15 mal booten, verbindet sich mein WLAN einmal. Leider tut es das nun gar nicht mehr..

Als WM nutze ich i3, falls das wichtig wäre.

Der AccessPoint ist WPA2-Personal mit AES eingestellt.

Ich freue mich auf Eure Vorschläge. Auch auf Schard's Vorschläge, die bei mir ja jedes mal getroffen haben bis jetzt. :-)

Gruss Sewulba

Beitrag geändert von sewulba (27.05.2019 18:38:42)

Offline

#2 27.05.2019 18:04:29

niemand
Mitglied

Re: [gelöst]Probleme mit BCM4313 Wireless

Aber von etwa 15 mal booten, verbindet sich mein WLAN einmal. Leider tut es das nun gar nicht mehr.

Wenn du wpa_supplicant manuell aufrufst, bekommst du möglicherweise sogar aussagekräftige Meldungen zum Problem. Ansonsten wären die Logs eine Anlaufstelle – sowohl die der betreffenden Maschine, als auch die vom AP, sofern man dort rankommt (bei billigen Consumer-Plastik-APs ist das ja auch nicht immer möglich).

Offline

#3 27.05.2019 18:08:52

rriw
Gast

Re: [gelöst]Probleme mit BCM4313 Wireless

Was ist die Ausgabe des Befehls mit dem Debug Flag (-dd)?

#4 27.05.2019 18:11:31

schard
Moderator

Re: [gelöst]Probleme mit BCM4313 Wireless

sewulba schrieb:

Folgendes habe ich gemacht:

/etc/rc.local angepasst

Diese Datei ist seit der Einführung von systemd ohne Funktion.

Offline

#5 27.05.2019 18:13:18

sewulba
Mitglied

Re: [gelöst]Probleme mit BCM4313 Wireless

Ich habe nun folgendes getan:

wpa_supplicant -i wlp2s0b1 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf -d

Dann hat sich das WLAN verbunden, siehe da:

ifconfig
wlp2s0b1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.4.63  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::7228:8b3f:fe13:59e8  prefixlen 64  scopeid 0x20<link>
        ether 70:18:8b:13:79:e8  txqueuelen 1000  (Ethernet)
        RX packets 815  bytes 273787 (267.3 KiB)
        RX errors 0  dropped 12  overruns 0  frame 0
        TX packets 50  bytes 7246 (7.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Die Ausgabe des wpa-Befehls, gekürzt, sieht so aus:

WPA: GTK in EAPOL-Key - hexdump(len=24): [REMOVED]
wlp2s0b1: WPA: Sending EAPOL-Key 4/4
WPA: Send EAPOL-Key frame to 4c:ed:fb:a0:33:20 ver=2 mic_len=16 key_mgmt=0x2
WPA: EAPOL-Key MIC using HMAC-SHA1
WPA: KCK - hexdump(len=16): [REMOVED]
WPA: Derived Key MIC - hexdump(len=16): bd 08 d1 d1 27 c7 ef d6 bd 1b c2 05 95 84 66 31
wlp2s0b1: WPA: Installing PTK to the driver
wpa_driver_wext_set_key: alg=3 key_idx=0 set_tx=1 seq_len=6 key_len=16
EAPOL: External notification - portValid=1
wlp2s0b1: State: 4WAY_HANDSHAKE -> GROUP_HANDSHAKE
RSN: received GTK in pairwise handshake - hexdump(len=18): [REMOVED]
WPA: Group Key - hexdump(len=16): [REMOVED]
wlp2s0b1: WPA: Installing GTK to the driver (keyidx=2 tx=0 len=16)
WPA: RSC - hexdump(len=6): 26 68 00 00 00 00
wpa_driver_wext_set_key: alg=3 key_idx=2 set_tx=0 seq_len=6 key_len=16
wlp2s0b1: WPA: Key negotiation completed with 4c:ed:fb:a0:33:20 [PTK=CCMP GTK=CCMP]
wlp2s0b1: Cancelling authentication timeout
wlp2s0b1: State: GROUP_HANDSHAKE -> COMPLETED
wlp2s0b1: Radio work 'connect'@0x56026539b460 done in 0.027816 seconds
wlp2s0b1: radio_work_free('connect'@0x56026539b460): num_active_works --> 0
wlp2s0b1: CTRL-EVENT-CONNECTED - Connection to 4c:ed:fb:a0:33:20 completed [id=0 id_str=]
wpa_driver_wext_set_operstate: operstate 0->1 (UP)
netlink: Operstate: ifindex=3 linkmode=-1 (no change), operstate=6 (IF_OPER_UP)
EAPOL: External notification - portValid=1
EAPOL: External notification - EAP success=1
EAPOL: SUPP_PAE entering state AUTHENTICATING
EAPOL: SUPP_BE entering state SUCCESS
EAP: EAP entering state DISABLED
EAPOL: SUPP_PAE entering state AUTHENTICATED
EAPOL: Supplicant port status: Authorized
EAPOL: SUPP_BE entering state IDLE
EAPOL authentication completed - result=SUCCESS
RTM_NEWLINK: operstate=1 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlp2s0b1' added
WEXT: if_removed already cleared - ignore event
RTM_NEWLINK: operstate=1 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlp2s0b1' added
WEXT: if_removed already cleared - ignore event
EAPOL: startWhen --> 0
EAPOL: disable timer tick
wlp2s0b1: BSS: Remove id 1 BSSID 90:5c:44:c9:0d:54 SSID 'UPC725B496' due to wpa_bss_flush_by_age
wlp2s0b1: BSS: Remove id 2 BSSID 90:5c:44:7d:15:f5 SSID 'Dasistmeines' due to wpa_bss_flush_by_age

Ausgabe iwconfig:

wlp2s0b1  IEEE 802.11  ESSID:"default2"
          Mode:Managed  Frequency:2.432 GHz  Access Point: 4C:ED:FB:A0:23:20
          Bit Rate=1 Mb/s   Tx-Power=19 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-30 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:49   Missed beacon:0

Warum geht es jetzt? Und wenn ich einen neustart mache, geht es nicht mehr. Ich mache oder habe doch wieder einen dummen Fehler irgendwo gemacht, oder?

Beitrag geändert von sewulba (27.05.2019 18:16:10)

Offline

#6 27.05.2019 18:19:30

sewulba
Mitglied

Re: [gelöst]Probleme mit BCM4313 Wireless

schard schrieb:
sewulba schrieb:

Folgendes habe ich gemacht:

/etc/rc.local angepasst

Diese Datei ist seit der Einführung von systemd ohne Funktion.

Verstehe ich das richtig? Der richtige weg ist demnach:

systemctl enable wpa_supplicant

Ist das korrekt weil ich mehrere zur Auswahl habe:

systemctl list-unit-files | grep wpa
wpa_supplicant-nl80211@.service            disabled
wpa_supplicant-wired@.service              disabled
wpa_supplicant.service                     disabled
wpa_supplicant@.service                    disabled

Offline

#7 27.05.2019 18:27:52

schard
Moderator

Re: [gelöst]Probleme mit BCM4313 Wireless

Offline

#8 27.05.2019 18:37:51

sewulba
Mitglied

Re: [gelöst]Probleme mit BCM4313 Wireless

Das hat nun endgültig geholfen.

Habe die wpa_supplicant.conf in wpa_supplicant-wlp2s0b1.conf umbenannt und folgenden Befehl abgeschossen:

systemctl enable wpa_supplicant@wlp2s0b1

Jetzt hat es nach einen Neustart geklappt. WLAN geht! :-)

Ich möchte mich an dieser Stelle noch mal bei allen bedanken. Waren alles super Tipps. Danke schön! :-)

Gruss Sewulba

Offline

#9 27.05.2019 22:35:32

schard
Moderator

Re: [gelöst]Probleme mit BCM4313 Wireless

Schön. dass du es lösen konntest.
Bitte schau in Zukunft bei derartigen Problemen zuerst mal im englischen Wiki nach.
Unseres ist leider nicht immer aktuell.

Offline

#10 04.06.2019 15:36:14

sewulba
Mitglied

Re: [gelöst]Probleme mit BCM4313 Wireless

schard schrieb:

Schön. dass du es lösen konntest.
Bitte schau in Zukunft bei derartigen Problemen zuerst mal im englischen Wiki nach.
Unseres ist leider nicht immer aktuell.

Geht klar. Werde ich tun. :-)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums