#1 02.01.2019 15:51:27

Phoen7x
Mitglied

[gelöst] Arch bootet seit Update nicht mehr (e485)

Hallo zusammen,

seit meinem letzten pacman -Syu am 30.12.18 nachmittags startet mein System nicht mehr korrekt und bleibt stattdessen im Bootprozess hängen (siehe Bild).

Hardware: Thinkpad e485 mit Bootparameter ivrs_ioapic[32]=00:14.0 pci=noaer

Ich habe die Vermutung es könne mit dem neuen 4.20 Kernel zusammenhängen, da diesen den Abend aktualisiert wurde. Um mich auf das System zu chrooten habe ich die aktuelle iso vom 1.1.19 verwendet (auch 4.20 Kernel), dort allerdings mit dem Parameter intremap=off (da die beiden o.g. in Kernelpanik enden).
Nun wollte ich diesen zum Test per chroot abändern, allerdings läuft grub-mkconfig nicht durch sondern hängt sich direkt auf und zeigt mir nur einen blinkenden Cursor an :? .

Hat jemand eine Idee? Vielen Dank schonmal. smile

Beitrag geändert von Phoen7x (18.02.2019 13:16:09)

Offline

#2 02.01.2019 15:55:55

skull-y
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

Die kannst die Bootparameter doch in GRUB selbst temporär ändern. Wenn dein System gestartet ist, einfach die config bearbeiten.

Offline

#3 02.01.2019 16:05:19

schard
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

1) Auf dem Bild kann man nichts erkennen, da die Auflösung zu niedrig ist.
2) Poste das Journal des letzten Bootvorgangs als Text in Code-Tags hier.
3) Schuss ins Blaue: Was sagt

$ cat /proc/sys/kernel/random/entropy_avail

?

Offline

#4 02.01.2019 16:55:02

Phoen7x
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

Vielen Dank für eure Antworten. smile

skull-y schrieb:

Die kannst die Bootparameter doch in GRUB selbst temporär ändern. Wenn dein System gestartet ist, einfach die config bearbeiten.

Meinst du direkt die /boot/grub/grub.cfg Datei händisch ändern, was nicht empfohlen wird?

schard schrieb:

2) Poste das Journal des letzten Bootvorgangs als Text in Code-Tags hier.

Wie kann ich mir das anzeigen lassen?

Ausgabe von /proc/sys/kernel/random/entropy_avail:

2113

Beitrag geändert von Phoen7x (02.01.2019 16:55:46)

Offline

#5 02.01.2019 17:21:01

hcjl
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

Phoen7x schrieb:

Vielen Dank für eure Antworten. smile

skull-y schrieb:

Die kannst die Bootparameter doch in GRUB selbst temporär ändern. Wenn dein System gestartet ist, einfach die config bearbeiten.

Meinst du direkt die /boot/grub/grub.cfg Datei händisch ändern, was nicht empfohlen wird?

Nein, er meint die Änderung des Booteintrags im Boot-Menü. M.W. über E-Taste (verwende selbstkein Grub).

schard schrieb:

2) Poste das Journal des letzten Bootvorgangs als Text in Code-Tags hier.

Phoen7x schrieb:

Wie kann ich mir das anzeigen lassen?

Vor dem Stellen einer Frage einfach mal ins Wiki schauen. -> https://wiki.archlinux.de/title/Systemd#journalctl

Offline

#6 02.01.2019 17:31:59

Phoen7x
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

hcjl schrieb:

Nein, er meint die Änderung des Booteintrags im Boot-Menü. M.W. über E-Taste (verwende selbstbkein Grub).

Ich habe grub-timout auf 0 stehen und bin somit nicht in der Lage dort einzugreifen (zumindest wüsste ich nicht wie).

Vor dem Stellen einer Frage einfach mal ins Wiki schauen. -> https://wiki.archlinux.de/title/Systemd#journalctl

Das habe ich, jedoch wenn ich nicht genau weiß was gefragt ist, weiß ich auch nicht wonach ich suchen muss...

Als Ausgabe für

journalctl --list-boots

erhalte ich fünf Zeilen -4 bis 0, alles vom 17.09.2018. Falls das wirklich hilfreich ist, kann ich lediglich ein Foto davon machen.

Edit:
Ich habe jetzt mal testhalber in der /boot/grub/grub.cfg Datei händisch alle alten Kernelparameter durch den neuen ersetzt. Gleiches Problem er bleibt weiterhin bei

[OK] Started Hostname Service

stehen. Möglicherweise ist der Kernel nicht das Problem. Alternativ könnte ich mit pacman -U den alten Kernel installieren und schauen ob es dann geht?

Beitrag geändert von Phoen7x (02.01.2019 17:51:26)

Offline

#7 02.01.2019 17:50:50

skull-y
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

Startknopf drücken und gleich auf "E" hämmern, in der Hoffnung, dass du doch noch bearbeiten kannst.

Offline

#8 02.01.2019 17:55:00

Phoen7x
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

skull-y schrieb:

Startknopf drücken und gleich auf "E" hämmern, in der Hoffnung, dass du doch noch bearbeiten kannst.

Ohne Erfolg. Die NVME-SSD ist einfach zu schnell... allerdings hatte ich den Wert ja schon händisch probiert, siehe einen Post eher.
Kann es denn überhaupt am Kernel liegen wenn selbst cryptsetup zum entschlüsseln der Platte erfolgreich durchgelaufen ist? Der Fehler steckt sicherlich irgendwo anders... sad

Beitrag geändert von Phoen7x (02.01.2019 17:55:40)

Offline

#9 02.01.2019 20:28:39

hcjl
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

Phoen7x schrieb:

Als Ausgabe für

journalctl --list-boots

erhalte ich fünf Zeilen -4 bis 0, alles vom 17.09.2018. Falls das wirklich hilfreich ist, kann ich lediglich ein Foto davon machen.

Wenn dort nicht aktuelle Bootvorgänge gelistet sind, scheint bei Dir noch ein anderes Problem vorzuliegen. Wie hast Du Arch installiert und hast Du es regelmäßig vollständig aktualisiert?

Offline

#10 02.01.2019 21:41:42

Phoen7x
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

hcjl schrieb:

Wie hast Du Arch installiert und hast Du es regelmäßig vollständig aktualisiert?

Installiert habe ich es ganz normal per Konsolenbefehle gemäß Anleitung im Wiki. Updates führe ich spätestens Wöchentlich via pacman -Syu durch. Es wird auch regelmäßig neugestartet, weshalb ich das Problem auf Updates vom 30.12.18 Nachmittags einschränken kann.

Offline

#11 03.01.2019 01:12:19

Phoen7x
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

Ich habe nun da ich ein lauffähigen Laptop benötige mittels

pacman -U linux.4.19...tar.xz tp_smapi.xx.tar.xz

ein Kernel-Downgrade durchgeführt. Erfolgreich. Das System läuft nun wieder wie vorher, dementsprechend scheint ein BUG im 4.20 Kernel.

Offline

#12 18.02.2019 13:17:50

Phoen7x
Mitglied

Re: [gelöst] Arch bootet seit Update nicht mehr (e485)

Kernelparamter abgeändert zu:

amd_iommu=off ivrs_ioapic[32]=00:14.0

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums