#1 23.12.2018 15:21:56

primus
Mitglied

at-spi-bus-launcher[550]: XIO: fatal IO error 11

Hallo Forenmitglieder,

journalctl --boot=-1 | grep error

gibt folgenden Hinweis/Fehler heraus.

Dez 22 16:57:31  at-spi-bus-launcher[550]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"

Reicht es hierfür aus einer der beiden oder sollten sogar beide folgende Pakete installiert werden?

https://www.archlinux.org/packages/extr … spi2-core/

https://www.archlinux.org/packages/extr … -spi2-atk/

Gruss/Primus

Beitrag geändert von primus (23.12.2018 15:30:56)

Offline

#2 24.12.2018 11:37:41

primus
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Die beiden Pakete wurden bereits installiert.
Der oben genannte Hinweis/Fehler besteht weiterhin.

Offline

#3 24.12.2018 11:56:24

Henrikx
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Ich habe noch dieses Paket am Start.

https://www.archlinux.de/packages/extra … thon-atspi

Offline

#4 24.12.2018 12:03:47

primus
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Henrikx schrieb:

Ich habe noch dieses Paket am Start.

https://www.archlinux.de/packages/extra … thon-atspi

Hallo Henrikx,
erst einmal vielen Dank für deine Unterstützung!
Kannst du bitte bei dir mal überprüfen, ob diese Fehlermeldung vorhanden ist.
Wenn Nein, hast du dieses Paket auch bei dir auch installiert?

Gruß/Primus

Beitrag geändert von primus (24.12.2018 12:08:03)

Offline

#5 24.12.2018 12:48:15

Henrikx
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Fehlermeldung = Nein.
Paket installiert = Ja.

Offline

#6 24.12.2018 13:08:01

primus
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Die Installation des Paketes "python-atspi" hat leider auch nach einem Neustart nichts gebracht. sad

Offline

#7 24.12.2018 14:21:21

stefanhusmann
Moderator

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Hattest du auch einen Absturz von X oder nur diese Fehlermeldung? Generell scheinen die Logfiles von X hier untersuchenswert zu sein. Du bist mit der Meldung nicht allein.

Offline

#8 25.12.2018 12:18:47

primus
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Bisher keinen Absturz nur Fehlermeldungen.

Alles funktioniert bisher zufriedenstellend mit dem aktuellen Intel Treiber "xf86-video-intel" (Sound, Grafik)

Es handelt sich hierbei um ein "ASUS Laptop Model F555L"

Mit dem aktuellen "Nvidia" Treiber und dem "Nvidia-340xx" konnte ich X gar nicht starten oder hatte beim Start von X ein schwarzes Bild.

lspci -k | grep -A 2 -E "(VGA|3D)"

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
	Subsystem: ASUSTeK Computer Inc. Haswell-ULT Integrated Graphics Controller
	Kernel driver in use: i915
--
04:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2)
	Subsystem: ASUSTeK Computer Inc. GM108M [GeForce 840M]
	Kernel modules: nouveau

Habe dabei bzw. später auch ermittelt, dass man hierfür am besten den "Bumblebee" Treiber verwenden sollte.
https://wiki.archlinux.org/index.php/bumblebee
Aber dies nur am Rande.


Xorg.0.log

[    10.299] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[    10.299] 
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
[    10.299] Build Operating System: Linux Arch Linux
[    10.299] Current Operating System: Linux F555LN 4.19.12-arch1-1-ARCH #1 SMP PREEMPT Fri Dec 21 13:56:54 UTC 2018 x86_64
[    10.300] Kernel command line: initrd=\intel-ucode.img initrd=\initramfs-linux.img root=LABEL=ROOT rw
[    10.300] Build Date: 25 October 2018  04:42:32PM
[    10.300]  
[    10.300] Current version of pixman: 0.36.0
[    10.300] 	Before reporting problems, check [url]http://wiki.x.org[/url]
	to make sure that you have the latest version.
[    10.300] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    10.300] (==) Log file: "/home/primus/.local/share/xorg/Xorg.0.log", Time: Tue Dec 25 10:41:19 2018
[    10.302] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    10.302] (==) No Layout section.  Using the first Screen section.
[    10.302] (==) No screen section available. Using defaults.
[    10.302] (**) |-->Screen "Default Screen Section" (0)
[    10.302] (**) |   |-->Monitor "<default monitor>"
[    10.303] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    10.303] (==) Automatically adding devices
[    10.303] (==) Automatically enabling devices
[    10.303] (==) Automatically adding GPU devices
[    10.303] (==) Automatically binding GPU devices
[    10.303] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    10.304] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    10.304] 	Entry deleted from font path.
[    10.304] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    10.304] 	Entry deleted from font path.
[    10.304] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    10.304] 	Entry deleted from font path.
[    10.304] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    10.304] 	Entry deleted from font path.
[    10.304] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    10.304] 	Entry deleted from font path.
[    10.304] (==) FontPath set to:
	/usr/share/fonts/TTF
[    10.304] (==) ModulePath set to "/usr/lib/xorg/modules"
[    10.304] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    10.304] (II) Module ABI versions:
[    10.304] 	X.Org ANSI C Emulation: 0.4
[    10.304] 	X.Org Video Driver: 24.0
[    10.304] 	X.Org XInput driver : 24.1
[    10.304] 	X.Org Server Extension : 10.0
[    10.305] (++) using VT number 1

[    10.306] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    10.307] (II) xfree86: Adding drm device (/dev/dri/card0)
[    10.308] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 0
[    10.310] (--) PCI:*(0@0:2:0) 8086:0a16:1043:16cd rev 11, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[    10.310] (--) PCI: (4@0:0:0) 10de:1341:1043:16cd rev 162, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
[    10.310] (II) Open ACPI successful (/var/run/acpid.socket)
[    10.310] (II) LoadModule: "glx"
[    10.311] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    10.326] (II) Module glx: vendor="X.Org Foundation"
[    10.326] 	compiled for 1.20.3, module version = 1.0.0
[    10.326] 	ABI class: X.Org Server Extension, version 10.0
[    10.326] (==) Matched intel as autoconfigured driver 0
[    10.326] (==) Matched modesetting as autoconfigured driver 1
[    10.326] (==) Matched fbdev as autoconfigured driver 2
[    10.326] (==) Matched vesa as autoconfigured driver 3
[    10.326] (==) Assigned the driver to the xf86ConfigLayout
[    10.326] (II) LoadModule: "intel"
[    10.327] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    10.336] (II) Module intel: vendor="X.Org Foundation"
[    10.336] 	compiled for 1.20.3, module version = 2.99.917
[    10.336] 	Module class: X.Org Video Driver
[    10.336] 	ABI class: X.Org Video Driver, version 24.0
[    10.336] (II) LoadModule: "modesetting"
[    10.337] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    10.339] (II) Module modesetting: vendor="X.Org Foundation"
[    10.339] 	compiled for 1.20.3, module version = 1.20.3
[    10.339] 	Module class: X.Org Video Driver
[    10.339] 	ABI class: X.Org Video Driver, version 24.0
[    10.339] (II) LoadModule: "fbdev"
[    10.340] (WW) Warning, couldn't open module fbdev
[    10.340] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    10.340] (II) LoadModule: "vesa"
[    10.340] (WW) Warning, couldn't open module vesa
[    10.340] (EE) Failed to load module "vesa" (module does not exist, 0)
[    10.340] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    10.340] (II) intel: Driver for Intel(R) HD Graphics
[    10.340] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[    10.340] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[    10.340] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    10.340] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    10.341] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20180719
[    10.341] (II) intel(0): SNA compiled from 2.99.917-855-g746ab3bb
[    10.356] (WW) Falling back to old probe method for modesetting
[    10.356] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    10.357] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4400
[    10.357] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[    10.357] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    10.357] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    10.357] (==) intel(0): RGB weight 888
[    10.357] (==) intel(0): Default visual is TrueColor
[    10.358] (II) intel(0): Output eDP1 has no monitor section
[    10.358] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[    10.358] (II) intel(0): Enabled output eDP1
[    10.358] (II) intel(0): Output DP1 has no monitor section
[    10.359] (II) intel(0): Enabled output DP1
[    10.359] (II) intel(0): Output HDMI1 has no monitor section
[    10.359] (II) intel(0): Enabled output HDMI1
[    10.359] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    10.359] (II) intel(0): Output VIRTUAL1 has no monitor section
[    10.359] (II) intel(0): Enabled output VIRTUAL1
[    10.359] (--) intel(0): Output eDP1 using initial mode 1366x768 on pipe 0
[    10.359] (==) intel(0): TearFree disabled
[    10.359] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[    10.359] (==) intel(0): DPI set to (96, 96)
[    10.359] (II) Loading sub module "dri3"
[    10.359] (II) LoadModule: "dri3"
[    10.359] (II) Module "dri3" already built-in
[    10.359] (II) Loading sub module "dri2"
[    10.359] (II) LoadModule: "dri2"
[    10.359] (II) Module "dri2" already built-in
[    10.359] (II) Loading sub module "present"
[    10.359] (II) LoadModule: "present"
[    10.359] (II) Module "present" already built-in
[    10.359] (II) UnloadModule: "modesetting"
[    10.359] (II) Unloading modesetting
[    10.362] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[    10.362] (==) intel(0): Backing store enabled
[    10.362] (==) intel(0): Silken mouse disabled
[    10.362] (II) intel(0): HW Cursor enabled
[    10.363] (==) intel(0): DPMS enabled
[    10.363] (==) intel(0): Display hotplug detection enabled
[    10.363] (II) intel(0): [DRI2] Setup complete
[    10.363] (II) intel(0): [DRI2]   DRI driver: i965
[    10.363] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    10.363] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[    10.363] (II) intel(0): hardware support for Present enabled
[    10.363] (II) Initializing extension Generic Event Extension
[    10.363] (II) Initializing extension SHAPE
[    10.363] (II) Initializing extension MIT-SHM
[    10.363] (II) Initializing extension XInputExtension
[    10.364] (II) Initializing extension XTEST
[    10.364] (II) Initializing extension BIG-REQUESTS
[    10.364] (II) Initializing extension SYNC
[    10.364] (II) Initializing extension XKEYBOARD
[    10.364] (II) Initializing extension XC-MISC
[    10.364] (II) Initializing extension SECURITY
[    10.364] (II) Initializing extension XFIXES
[    10.364] (II) Initializing extension RENDER
[    10.364] (II) Initializing extension RANDR
[    10.364] (II) Initializing extension COMPOSITE
[    10.364] (II) Initializing extension DAMAGE
[    10.364] (II) Initializing extension MIT-SCREEN-SAVER
[    10.364] (II) Initializing extension DOUBLE-BUFFER
[    10.364] (II) Initializing extension RECORD
[    10.364] (II) Initializing extension DPMS
[    10.364] (II) Initializing extension Present
[    10.364] (II) Initializing extension DRI3
[    10.364] (II) Initializing extension X-Resource
[    10.364] (II) Initializing extension XVideo
[    10.364] (II) Initializing extension XVideo-MotionCompensation
[    10.364] (II) Initializing extension GLX
[    10.392] (II) AIGLX: Loaded and initialized i965
[    10.392] (II) GLX: Initialized DRI2 GL provider for screen 0
[    10.392] (II) Initializing extension XFree86-VidModeExtension
[    10.392] (II) Initializing extension XFree86-DGA
[    10.392] (II) Initializing extension XFree86-DRI
[    10.392] (II) Initializing extension DRI2
[    10.394] (II) intel(0): switch to mode 1366x768@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    10.394] (II) intel(0): Setting screen physical size to 361 x 203
[    10.438] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    10.438] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    10.438] (II) LoadModule: "libinput"
[    10.439] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    10.443] (II) Module libinput: vendor="X.Org Foundation"
[    10.443] 	compiled for 1.20.1, module version = 0.28.1
[    10.443] 	Module class: X.Org XInput Driver
[    10.443] 	ABI class: X.Org XInput driver, version 24.1
[    10.443] (II) Using input driver 'libinput' for 'Power Button'
[    10.443] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 17 paused 0
[    10.443] (**) Power Button: always reports core events
[    10.443] (**) Option "Device" "/dev/input/event2"
[    10.443] (**) Option "_source" "server/udev"
[    10.452] (II) event2  - Power Button: is tagged by udev as: Keyboard
[    10.452] (II) event2  - Power Button: device is a keyboard
[    10.452] (II) event2  - Power Button: device removed
[    10.452] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[    10.452] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    10.453] (II) event2  - Power Button: is tagged by udev as: Keyboard
[    10.453] (II) event2  - Power Button: device is a keyboard
[    10.453] (II) config/udev: Adding input device Asus Wireless Radio Control (/dev/input/event6)
[    10.453] (**) Asus Wireless Radio Control: Applying InputClass "libinput keyboard catchall"
[    10.453] (II) Using input driver 'libinput' for 'Asus Wireless Radio Control'
[    10.454] (II) systemd-logind: got fd for /dev/input/event6 13:70 fd 20 paused 0
[    10.454] (**) Asus Wireless Radio Control: always reports core events
[    10.454] (**) Option "Device" "/dev/input/event6"
[    10.454] (**) Option "_source" "server/udev"
[    10.455] (II) event6  - Asus Wireless Radio Control: is tagged by udev as: Keyboard
[    10.455] (II) event6  - Asus Wireless Radio Control: device is a keyboard
[    10.455] (II) event6  - Asus Wireless Radio Control: device removed
[    10.455] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/ATK4002:00/input/input10/event6"
[    10.455] (II) XINPUT: Adding extended input device "Asus Wireless Radio Control" (type: KEYBOARD, id 7)
[    10.456] (II) event6  - Asus Wireless Radio Control: is tagged by udev as: Keyboard
[    10.456] (II) event6  - Asus Wireless Radio Control: device is a keyboard
[    10.457] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[    10.457] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[    10.457] (II) Using input driver 'libinput' for 'Video Bus'
[    10.458] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 21 paused 0
[    10.458] (**) Video Bus: always reports core events
[    10.458] (**) Option "Device" "/dev/input/event4"
[    10.458] (**) Option "_source" "server/udev"
[    10.459] (II) event4  - Video Bus: is tagged by udev as: Keyboard
[    10.459] (II) event4  - Video Bus: device is a keyboard
[    10.459] (II) event4  - Video Bus: device removed
[    10.459] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input4/event4"
[    10.459] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[    10.460] (II) event4  - Video Bus: is tagged by udev as: Keyboard
[    10.460] (II) event4  - Video Bus: device is a keyboard
[    10.461] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[    10.461] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[    10.461] (II) Using input driver 'libinput' for 'Video Bus'
[    10.462] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 22 paused 0
[    10.462] (**) Video Bus: always reports core events
[    10.462] (**) Option "Device" "/dev/input/event3"
[    10.462] (**) Option "_source" "server/udev"
[    10.463] (II) event3  - Video Bus: is tagged by udev as: Keyboard
[    10.463] (II) event3  - Video Bus: device is a keyboard
[    10.464] (II) event3  - Video Bus: device removed
[    10.464] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:12/LNXVIDEO:00/input/input3/event3"
[    10.464] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 9)
[    10.465] (II) event3  - Video Bus: is tagged by udev as: Keyboard
[    10.465] (II) event3  - Video Bus: device is a keyboard
[    10.465] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[    10.465] (II) No input driver specified, ignoring this device.
[    10.465] (II) This device may have been added with another device file.
[    10.466] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[    10.466] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[    10.466] (II) Using input driver 'libinput' for 'Sleep Button'
[    10.467] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 23 paused 0
[    10.467] (**) Sleep Button: always reports core events
[    10.467] (**) Option "Device" "/dev/input/event1"
[    10.467] (**) Option "_source" "server/udev"
[    10.468] (II) event1  - Sleep Button: is tagged by udev as: Keyboard
[    10.468] (II) event1  - Sleep Button: device is a keyboard
[    10.468] (II) event1  - Sleep Button: device removed
[    10.468] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[    10.468] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 10)
[    10.469] (II) event1  - Sleep Button: is tagged by udev as: Keyboard
[    10.469] (II) event1  - Sleep Button: device is a keyboard
[    10.470] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=3 (/dev/input/event11)
[    10.470] (II) No input driver specified, ignoring this device.
[    10.470] (II) This device may have been added with another device file.
[    10.471] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=7 (/dev/input/event12)
[    10.471] (II) No input driver specified, ignoring this device.
[    10.471] (II) This device may have been added with another device file.
[    10.471] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=8 (/dev/input/event13)
[    10.471] (II) No input driver specified, ignoring this device.
[    10.471] (II) This device may have been added with another device file.
[    10.472] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=9 (/dev/input/event14)
[    10.472] (II) No input driver specified, ignoring this device.
[    10.472] (II) This device may have been added with another device file.
[    10.472] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=10 (/dev/input/event15)
[    10.472] (II) No input driver specified, ignoring this device.
[    10.472] (II) This device may have been added with another device file.
[    10.473] (II) config/udev: Adding input device USB Camera: USB Camera (/dev/input/event10)
[    10.473] (**) USB Camera: USB Camera: Applying InputClass "libinput keyboard catchall"
[    10.473] (II) Using input driver 'libinput' for 'USB Camera: USB Camera'
[    10.474] (II) systemd-logind: got fd for /dev/input/event10 13:74 fd 24 paused 0
[    10.474] (**) USB Camera: USB Camera: always reports core events
[    10.474] (**) Option "Device" "/dev/input/event10"
[    10.474] (**) Option "_source" "server/udev"
[    10.475] (II) event10 - USB Camera: USB Camera: is tagged by udev as: Keyboard
[    10.475] (II) event10 - USB Camera: USB Camera: device is a keyboard
[    10.476] (II) event10 - USB Camera: USB Camera: device removed
[    10.476] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/input/input17/event10"
[    10.476] (II) XINPUT: Adding extended input device "USB Camera: USB Camera" (type: KEYBOARD, id 11)
[    10.477] (II) event10 - USB Camera: USB Camera: is tagged by udev as: Keyboard
[    10.477] (II) event10 - USB Camera: USB Camera: device is a keyboard
[    10.478] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event16)
[    10.478] (II) No input driver specified, ignoring this device.
[    10.478] (II) This device may have been added with another device file.
[    10.478] (II) config/udev: Adding input device Asus WMI hotkeys (/dev/input/event9)
[    10.478] (**) Asus WMI hotkeys: Applying InputClass "libinput keyboard catchall"
[    10.478] (II) Using input driver 'libinput' for 'Asus WMI hotkeys'
[    10.479] (II) systemd-logind: got fd for /dev/input/event9 13:73 fd 25 paused 0
[    10.479] (**) Asus WMI hotkeys: always reports core events
[    10.479] (**) Option "Device" "/dev/input/event9"
[    10.479] (**) Option "_source" "server/udev"
[    10.480] (II) event9  - Asus WMI hotkeys: is tagged by udev as: Keyboard
[    10.480] (II) event9  - Asus WMI hotkeys: device is a keyboard
[    10.480] (II) event9  - Asus WMI hotkeys: device removed
[    10.480] (**) Option "config_info" "udev:/sys/devices/platform/asus-nb-wmi/input/input16/event9"
[    10.480] (II) XINPUT: Adding extended input device "Asus WMI hotkeys" (type: KEYBOARD, id 12)
[    10.481] (II) event9  - Asus WMI hotkeys: is tagged by udev as: Keyboard
[    10.481] (II) event9  - Asus WMI hotkeys: device is a keyboard
[    10.482] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[    10.482] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[    10.482] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[    10.483] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 26 paused 0
[    10.483] (**) AT Translated Set 2 keyboard: always reports core events
[    10.483] (**) Option "Device" "/dev/input/event5"
[    10.483] (**) Option "_source" "server/udev"
[    10.484] (II) event5  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[    10.484] (II) event5  - AT Translated Set 2 keyboard: device is a keyboard
[    10.484] (II) event5  - AT Translated Set 2 keyboard: device removed
[    10.484] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input5/event5"
[    10.484] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 13)
[    10.485] (II) event5  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[    10.485] (II) event5  - AT Translated Set 2 keyboard: device is a keyboard
[    10.485] (II) config/udev: Adding input device FocalTechPS/2 FocalTech Touchpad (/dev/input/event8)
[    10.485] (**) FocalTechPS/2 FocalTech Touchpad: Applying InputClass "libinput touchpad catchall"
[    10.485] (II) Using input driver 'libinput' for 'FocalTechPS/2 FocalTech Touchpad'
[    10.486] (II) systemd-logind: got fd for /dev/input/event8 13:72 fd 27 paused 0
[    10.486] (**) FocalTechPS/2 FocalTech Touchpad: always reports core events
[    10.486] (**) Option "Device" "/dev/input/event8"
[    10.486] (**) Option "_source" "server/udev"
[    10.487] (II) event8  - FocalTechPS/2 FocalTech Touchpad: is tagged by udev as: Touchpad
[    10.487] (II) event8  - FocalTechPS/2 FocalTech Touchpad: no resolution or size hints, assuming a size of 69x50mm
[    10.487] (II) event8  - FocalTechPS/2 FocalTech Touchpad: device is a touchpad
[    10.487] (II) event8  - FocalTechPS/2 FocalTech Touchpad: device removed
[    10.488] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input15/event8"
[    10.488] (II) XINPUT: Adding extended input device "FocalTechPS/2 FocalTech Touchpad" (type: TOUCHPAD, id 14)
[    10.488] (**) Option "AccelerationScheme" "none"
[    10.488] (**) FocalTechPS/2 FocalTech Touchpad: (accel) selected scheme none/0
[    10.488] (**) FocalTechPS/2 FocalTech Touchpad: (accel) acceleration factor: 2.000
[    10.488] (**) FocalTechPS/2 FocalTech Touchpad: (accel) acceleration threshold: 4
[    10.489] (II) event8  - FocalTechPS/2 FocalTech Touchpad: is tagged by udev as: Touchpad
[    10.489] (II) event8  - FocalTechPS/2 FocalTech Touchpad: no resolution or size hints, assuming a size of 69x50mm
[    10.489] (II) event8  - FocalTechPS/2 FocalTech Touchpad: device is a touchpad
[    10.490] (II) config/udev: Adding input device FocalTechPS/2 FocalTech Touchpad (/dev/input/mouse0)
[    10.490] (II) No input driver specified, ignoring this device.
[    10.490] (II) This device may have been added with another device file.
[    10.490] (II) config/udev: Adding input device PC Speaker (/dev/input/event7)
[    10.490] (II) No input driver specified, ignoring this device.
[    10.490] (II) This device may have been added with another device file.
[    12.365] (II) intel(0): EDID vendor "AUO", prod id 18156
[    12.365] (II) intel(0): Printing DDC gathered Modelines:
[    12.365] (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1374 1384 1462  768 771 772 790 -hsync -vsync (47.4 kHz eP)

grep "EE" /home/primus/.local/share/xorg/Xorg.0.log

[    10.299] Current Operating System: Linux F555LN 4.19.12-arch1-1-ARCH #1 SMP PREEMPT Fri Dec 21 13:56:54 UTC 2018 x86_64
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    10.340] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    10.340] (EE) Failed to load module "vesa" (module does not exist, 0)
[    10.364] (II) Initializing extension MIT-SCREEN-SAVER

Da bisher im Bereich: "Grafik" alles zufriedenstellend funktioniert, benötige ich überhaupt oder ist es empfehlenswert diese beiden Videotreiber "xf86-video-fbdev" und "xf86-video-vesa" noch zusätzlich zu installieren?



journalctl | grep at-spi
Dies wiederholt sich immer wieder:

Dez 25 00:00:15 F555LN at-spi-bus-launcher[646]: dbus-daemon[652]: Successfully activated service 'org.a11y.atspi.Registry'
Dez 25 00:00:15 F555LN at-spi-bus-launcher[646]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Dez 25 00:05:43 F555LN at-spi-bus-launcher[646]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Dez 25 00:05:43 F555LN at-spi-bus-launcher[646]:       after 237 requests (237 known processed) with 0 events remaining.
Dez 25 00:06:05 F555LN dbus-daemon[533]: [session uid=1000 pid=533] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service' requested by ':1.5' (uid=1000 pid=545 comm="volumeicon ")
Dez 25 00:06:05 F555LN at-spi-bus-launcher[572]: dbus-daemon[578]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=1000 pid=545 comm="volumeicon ")
Dez 25 00:06:05 F555LN at-spi-bus-launcher[572]: dbus-daemon[578]: Successfully activated service 'org.a11y.atspi.Registry'
Dez 25 00:06:05 F555LN at-spi-bus-launcher[572]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Dez 25 00:08:02 F555LN at-spi-bus-launcher[572]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Dez 25 00:08:02 F555LN at-spi-bus-launcher[572]:       after 73 requests (73 known processed) with 0 events remaining.
Dez 25 10:41:20 F555LN dbus-daemon[547]: [session uid=1000 pid=547] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service' requested by ':1.5' (uid=1000 pid=559 comm="volumeicon ")
Dez 25 10:41:20 F555LN at-spi-bus-launcher[585]: dbus-daemon[591]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=1000 pid=559 comm="volumeicon ")

Frohe Weihnachten und danke fürs lesen! smile

Beitrag geändert von primus (25.12.2018 21:16:13)

Offline

#9 26.12.2018 10:26:27

Henrikx
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

primus schrieb:

Da bisher im Bereich: "Grafik" alles zufriedenstellend funktioniert, benötige ich überhaupt oder ist es empfehlenswert diese beiden Videotreiber "xf86-video-fbdev" und "xf86-video-vesa" noch zusätzlich zu installieren?

https://wiki.archlinux.org/index.php/xorg

Offline

#10 26.12.2018 11:32:04

primus
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Hallo Henrikx.
hatte ich nicht mehr auf dem Schirm.
Danke für den Link!

Auszug:
Xorg sucht automatisch nach installierten Treibern:
Wenn der für die Hardware installierte Treiber (siehe unten) nicht gefunden wird, wird zunächst nach fbdev (xf86-video-fbdev) gesucht.
Wird diese nicht gefunden, wird nach vesa (xf86-video-vesa) gesucht, dem generischen Treiber, der eine große Anzahl von Chipsätzen verarbeitet, aber keine 2D- oder 3D-Beschleunigung beinhaltet.
Wenn vesa nicht gefunden wird, greift Xorg auf die Kernelmoduseinstellung zurück, die die GLAMOR-Beschleunigung beinhaltet (siehe modesetting(4)).

Beitrag geändert von primus (26.12.2018 15:21:00)

Offline

#11 26.12.2018 16:19:10

GerBra
Mitglied

Re: at-spi-bus-launcher[550]: XIO: fatal IO error 11

Zur ursprünglichen "Fehlermeldung" meine Meinung:
Man muß nicht versuchen, jegliche Art von "Fehler-/Warnmeldung" aus Logs oder Konsolen auf Teufel komm raus wegzukriegen. Ich versuche diese Meldungen immer erstmal zu ergründen: "Wer oder was will da was von mir und warum?". Dann: "Kann diese Meldung - nachdem ich sie eingeordnet habe - überhaupt etwas mit einem evtl. vorhandenen *konkretem* Problem zu tun haben?"

In meinen Logs tauchen Meldungen vom/zum "at-spi-bus" ebenfalls (seit Jahren?) auf. Da mich der Komplex um den es wohl geht:
https://de.wikipedia.org/wiki/Assistive … _Interface
nicht betrifft und ich keine erkennbaren negativen Auswirkungen sehe, deshalb kümmere ich mich einfach nicht drum. Ich installiere auch keine Zusatzsoftware um die "Fehlermeldung" zu befriedigen.

Rant: in meinem aktuellen Log wird mir mitgeteilt:
"Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=1020 pid=629 comm="mate-session ")"
und danach irgendwann:
"SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry"
Das befriedigt mich nun auch, daß der Dämon unter einem gutbekannten Namen rumläuft, alles andere wäre ja auch sicher irgendwie illegal... Da mir Notationen wie org.foo.bar,blablubb seitens freedesktop.org/gnome/Konsorten mittlerweile eh wie Sauermilch aufstoßen (AD und Registry konnte Microsoft schon seit 30 Jahren kommerziell am besten verbocken, jetzt mit Dingen wie LDAP und Gnome-Reg nachstoßen zu wollen ist IMHO einfach nur peinlich...)

Also mein Rat zur Lebensverlängerung:
Don't panic!
Habe ich ein Problem? Nein!
Will ich mir eines konstruieren? Nein!
Also: dann ist jetzt Zeit für Kaffee und Kuchen.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums