#1 02.12.2018 04:52:59

perlenfischer1984
Mitglied

dhcpd service für lan deaktivieren

Hallo zusammen
im Rahmen meiner Neuinstallation habe ich das LAN verwendet. Im aktuellen Betrieb nutze ich nur WLAN.
Beim Boot wird trotzdem immer versucht eine ADresse über die Lan SChnittstelle (enp2s0) herzustellen.

Ich habe bereits versucht den job mittels systemctl disable dhcpd@enp2s0 zu deaktivieren.
Allerdings bekomme ich dann immer die Meldung : Failed to disable unit: Unit file dhcpd@enp2s0.service does not exist.

Die Ausgabe von systemctl status dhcpcd*@*.service :
● dhcpcd@enp2s0.service - dhcpcd on enp2s0
   Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; enabled; vendor pre>
   Active: failed (Result: exit-code) since Sun 2018-12-02 02:46:32 CET; 43min >
  Process: 377 ExecStart=/usr/bin/dhcpcd -q -w enp2s0 (code=exited, status=1/FA>

Warning: Journal has been rotated since unit was started. Log output is incompl>

● dhcpcd@wlp3s0.service - dhcpcd on wlp3s0
   Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; enabled; vendor pre>
   Active: active (running) since Sun 2018-12-02 02:46:12 CET; 43min ago
  Process: 421 ExecStart=/usr/bin/dhcpcd -q -w wlp3s0 (code=exited, status=0/SU>
Main PID: 521 (dhcpcd)
    Tasks: 1 (limit: 4510)
   Memory: 1.9M
   CGroup: /system.slice/system-dhcpcd.slice/dhcpcd@wlp3s0.service
           └─521 /usr/bin/dhcpcd -q -w wlp3s0

Warning: Journal has been rotated since unit was started. Log output is incompl>


Kann mir jemand einen Tipp geben ?
Vielen Dank

Offline

#2 02.12.2018 09:11:19

drcux
Mitglied

Re: dhcpd service für lan deaktivieren

Du kannst den dhcpcd ganz ausschalten, bei der Verbindung mit deinem WLAN wird der dhcpc direkt ausgeführt.

Offline

#3 02.12.2018 10:14:38

perlenfischer1984
Mitglied

Re: dhcpd service für lan deaktivieren

Okay danke kannst du mir bitte sagen wie ich das mache ?

Und falls ich es doch wieder benötigen sollte - wie aktiviere ich es wieder ?

Offline

#4 02.12.2018 11:07:46

primus
Mitglied

Re: dhcpd service für lan deaktivieren

Hallo perlenfischer1984,

war das Netzwerkkabel mit dem Gerät verbunden als du den Befehl: systemctl disable dhcpd@enp2s0 ausgeführt hast?

Alternativ könntest du das Interface deaktivieren:
Enabling and disabling network interfaces
Network interfaces can be enabled / disabled using ip link set interface up|down [see ip-link(8).

https://wiki.archlinux.org/index.php/Ne … interfaces
https://jlk.fjfi.cvut.cz/arch/manpages/man/ip-link.8

Viel Erfolg!

Beitrag geändert von primus (02.12.2018 14:37:05)

Offline

#5 02.12.2018 15:18:10

brikler
Mitglied

Re: dhcpd service für lan deaktivieren

drcux schrieb:

Du kannst den dhcpcd ganz ausschalten, bei der Verbindung mit deinem WLAN wird der dhcpc direkt ausgeführt.

wenn er den networkmanager nutzt, ob connman oder netctl, dhcpd startet weiß ich nicht

Offline

#6 02.12.2018 18:26:41

drcux
Mitglied

Re: dhcpd service für lan deaktivieren

brikler schrieb:
drcux schrieb:

Du kannst den dhcpcd ganz ausschalten, bei der Verbindung mit deinem WLAN wird der dhcpc direkt ausgeführt.

wenn er den networkmanager nutzt, ob connman oder netctl, dhcpd startet weiß ich nicht

Jede Software die sich um das Netzwerk kümmert _muss_ einen dhcp-client selber aufrufen, ansonsten würde der dhcp-client-daemon immer dazwischen funken...

Beispiel:

Du hast per netctl dem Interface enp0s25 eine feste IP vergeben hast aber auch den dhcpcd laufen. Dieser ließt bestimmt nicht deine Konfiguration von netctl ein und verhält sich still, er wird immer versuchen eine IP per dhcp auf enp0s25 zu bekommen sobald das Interface Up ist. Einer wird gewinnen, und meistens ist das der dhcpcd! ;-)

Deswegen: Den dhcpcd _immer_ ausschalten, wenn ein Netzwerkmanager (welcher auch immer) benutzt wird!

Offline

#7 02.12.2018 19:59:42

Whitie
Mitglied

Re: dhcpd service für lan deaktivieren

Hallo perlenfischer,
dhcpd@enp2s0 != dhcpcd@enp2s0. Man achte auf das fehlende c.

Gruß
Whitie

Offline

#8 02.12.2018 22:12:56

drcux
Mitglied

Re: dhcpd service für lan deaktivieren

# systemctl disable dhcpcd

und Ruhe ist. Was ich noch nie versucht habe:

# systemctl enable dhcpcd@enp2s0

damit der Client nur enp2s0 bedient...

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums