#1 09.11.2018 20:28:55

Greg
Mitglied

[gelöst] autologin

Hallo Leute,
nach Aktualisierung von systemd auf Version systemd-239.300-1 funktioniert der autologin nicht mehr.

Damals hatte ich es so eingerichtet:

cp /usr/lib/systemd/system/getty@.service /etc/systemd/system/autologin@tty1.service

Zeile ändern in:
ExecStart=-/usr/bin/agetty --noclear -a gl %I 38400

systemctl daemon-reload
systemctl disable getty@tty1.service
systemctl enable autologin@tty1.service
systemctl start autologin@tty1.service

Weiß Jemand bescheid was sich da getan hat?

Mit einem Downgrade auf Version 239-2 funktioniert der autologin wieder.

Besten Dank im Voraus!!
Gruß aus DN
Greg

Beitrag geändert von Greg (10.11.2018 19:23:47)

Offline

#2 09.11.2018 21:32:27

flugbaer
Mitglied

Re: [gelöst] autologin

Hallo Greg,

nur zur Info,
bei mir funktioniert diese "autolgin-config" auch noch mit systemd-239.300-1 einwandfrei.

lg
markus

Offline

#3 09.11.2018 22:37:30

Haller
Mitglied

Re: [gelöst] autologin

Versuchs mal mit:
ExecStart=-/usr/bin/agetty --autologin USER --noclear %I $TERM

Also 38400 durch $TERM ersetzen

Offline

#4 10.11.2018 14:03:11

Greg
Mitglied

Re: [gelöst] autologin

Danke für die Antworten!!
Hier ist die geänderte Zeile:

ExecStart=-/usr/bin/agetty --autologin ich --noclear %I $TERM

Auf neue systemd aktualisiert, Neustart, bleibt wieder beim login stehen.
Aber gut zu wissen flugbaer, dass es bei dir noch funktioniert.
Werde ich wohl weiter suchen müssen.
Schade, beim Journal steht nichts problematisches.

Offline

#5 10.11.2018 15:05:40

Haller
Mitglied

Re: [gelöst] autologin

Ich vermute, dass es an "systemctl disable getty@tty1.service" liegt. Denn die getty@ttyX-Services sind die ganze Zeit disabled und werden active sobald die tty aufgerufen wird.

Führ mal systemctl edit getty@tty2 aus und schreib folgendes hinein. Funktioniert dann der Autologin auf tty2?
[Service]
ExecStart=
ExecStart=-/usr/bin/agetty --autologin ich --noclear %I $TERM

Offline

#6 10.11.2018 18:57:57

Greg
Mitglied

Re: [gelöst] autologin

Hallo Haller, danke für den Tip, hat aber leider auch nichts gebracht.
Beim login wird aber bei mir auch tty1 angezeigt.
Ich denke, ich warte einfach mal ab, ob die nächste Version wieder funktioniert. Solange kann das alte systemd locker drin bleiben.
Ist ja nicht das Erste mal, dass systemd etwas hakt.
Ich werde mich aber auch weiter im Netz rumtreiben....
Bis denn..
Greg

Etwas später:
Ich bin auf dieser Seite gestoßen:
https://unix.stackexchange.com/question … th-systemd
da wird im Prinzip das Gleiche erklärt wie auf den Wikiseiten.
Ich also das Paket systemd wieder aktualisiert und diesmal eine /usr/lib/systemd/system/getty@.service neu kopiert nach /etc/systemd/system/autologin@tty1.service.
Zeile geändert von

ExecStart=-/sbin/agetty -o '-p -- \\u' --noclear %I $TERM

nach

ExecStart=-/usr/bin/agetty -a ich --noclear %I $TERM

Und siehe da, es geht wieder.
Es wurde an der /usr/lib/systemd/system/getty@.service einiges verändert.

Damit ist das Problem gelöst.
Meinen besten Dank an die Helfer!!!

Gruß aus DN
Greg

Beitrag geändert von Greg (10.11.2018 19:23:27)

Offline

#7 10.11.2018 19:33:17

brikler
Mitglied

Re: [gelöst] autologin

Greg schrieb:

Zeile geändert von

ExecStart=-/sbin/agetty -o '-p -- \\u' --noclear %I $TERM

nach

ExecStart=-/usr/bin/agetty -a ich --noclear %I $TERM

Und siehe da, es geht wieder.
Es wurde an der /usr/lib/systemd/system/getty@.service einiges verändert.

das heißt also, es gibt keinen link von agetty nach /sbin?

Offline

#8 10.11.2018 20:00:44

Greg
Mitglied

Re: [gelöst] autologin

brikler schrieb:

..das heißt also, es gibt keinen link von agetty nach /sbin?

Doch, /sbin gibt es als Link immer noch. Ich habe halt /usr/bin/ eingetragen. Muss aber nicht.
Vielleicht ist der Link sbin auch irgendwann mal weg. Dann geht die Suche wieder von vorne los. Daher den echten absoluten Pfad eingetragen.
Und so nebenbei, im Arch-wiki:
https://wiki.archlinux.org/index.php/Ge … al_console
stehts auch so drin.

Beitrag geändert von Greg (10.11.2018 20:04:28)

Offline

#9 10.11.2018 21:20:28

brikler
Mitglied

Re: [gelöst] autologin

ich meinte den link /usr/bin/agetty nach /sbin/agetty also:

ln -s /usr/bin/agetty  /sbin/agetty

Offline

#10 10.11.2018 21:57:44

Haller
Mitglied

Re: [gelöst] autologin

Greg schrieb:

Hallo Haller, danke für den Tip, hat aber leider auch nichts gebracht.
Beim login wird aber bei mir auch tty1 angezeigt.

Du hättest mit Strg+Alt+F2 auf tty2 wechseln müssen...
Aber gut, dass du es lösen konntest.

Offline

#11 11.11.2018 09:27:44

Greg
Mitglied

Re: [gelöst] autologin

brikler schrieb:

ich meinte den link /usr/bin/agetty nach /sbin/agetty also:

ln -s /usr/bin/agetty  /sbin/agetty

Nein, nicht direkt. Was ich meinte, es gibt ein /sbin dass verlinkt ist mit /usr/bin. Damit findet man in /sbin/agetty

brikler schrieb:

Du hättest mit Strg+Alt+F2 auf tty2 wechseln müssen...
Aber gut, dass du es lösen konntest.

Hätte ich wohl machen müssen.

Der PC wurde damals am 01.09.2010 eingerichtet. Seit dem sind einige Konfigdateien enthalten die ich angepasst hatte.
Ich muß eben nur mal nachsehen an welchen Dateien ich was geändert habe und diese auf den neuesten Stand bringen.
Solch ein ähnliches Problem hatte ich bereits mit .xinitrc . Damals ließ sich nach einem update X nicht mehr starten auch hier war eine neue .xinitrc erforderlich.

Nochmal Nachtrag:
Es muß der alte Serviceeintrag beseitigt werden mit
systemctl disable getty@tty1
und ein neuer angelegt werden mit
systemctl enable autologin@tty1

Nochmals Danke an Euch!!
Maacht et joot!! (Ist ja fast 11.11. 11:11)
Gruß aus DN
Greg

Beitrag geändert von Greg (12.11.2018 08:51:26)

Offline

#12 13.11.2018 14:38:36

hiess
Mitglied

Re: [gelöst] autologin

Danke. Gleiches Problem. Hat mir viel Sucharbeit erspart.

Offline

#13 13.11.2018 15:45:30

matthias
Moderator

Re: [gelöst] autologin

Greg schrieb:

Der PC wurde damals am 01.09.2010 eingerichtet. Seit dem sind einige Konfigdateien enthalten die ich angepasst hatte.

Das Problem kenne ich. Mein System ist ziemlich genauso alt wie deins (der Hardware nach). Nachdem eines meiner Probleme hier mal nicht gelöst werden konnte, bin ich damit mal zu bbs.al.org gegangen. Trotz des braven regelmässigen -Syu habe ich mich aber seit 2010 auch nie um die Konfigdateien gekümmert. Das ist jetzt irgendwie der Fluch des Rolling Release, wo man einmal aufsetzt, und es dann für immer und ewig ...

Am Ende musste ich dort die Ausgabe von uname -a posten, weil mir sonst niemand geglaubt hätte, dass ich überhaupt Arch nutze (und somit gar nicht mehr mit mir gesprochen hätte).

Offline

#14 25.11.2018 15:06:02

DieKleene
Mitglied

Re: [gelöst] autologin

Autologin mittels LightDM

Bearbeite lightdm.conf :

Pfad:
/etc/lightdm/lightdm.conf

Befehl:
sudo mousepad /etc/lightdm/lightdm.conf

Suche in der Datei und ersetze nachfolgendes:

[Seat:*]
pam-service=lightdm
pam-autologin-service=lightdm-autologin
autologin-user=DEIN_USERNAME
autologin-user-timeout=0
session-wrapper=/etc/lightdm/Xsession

Damit der Autologin unter LightDM funktioniert, muss der User zur "autologin group" hinzugefügt werden mittels:

sudo groupadd -r autologin
sudo gpasswd -a DEIN_USERNAME autologin

Dann einen Neustart wink

Offline

#15 25.11.2018 16:57:31

Greg
Mitglied

Re: [gelöst] autologin

Nee nee, ohne lightDM oder sonstigen Display,- Login Managern.
Wie oben schon beschrieben, ist das alles schon längst wieder am Laufen.

Gruß aus DN
Greg

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums