#1 30.08.2018 18:07:47

DarkSilence
Mitglied

Probleme mit PyCharm Community Edition

Hallo zusammen,
seit dem Update auf PyCharm Community Edition 2018.2 kommt beim Starten des Programms eine Fehlermeldung.


Internal error. Please report to http://jb.gg/ide/critical-startup-errors

java.lang.RuntimeException: com.intellij.ide.plugins.PluginManager$StartupAbortedException: Fatal error initializing 'com.intellij.ide.ui.LafManager'
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:216)
    at com.intellij.idea.IdeaApplication.lambda$initApplication$0(IdeaApplication.java:75)
    at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
    at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
    at java.desktop/java.awt.EventQueue.access$600(EventQueue.java:97)
    at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
    at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
    at java.base/java.security.AccessController.doPrivileged(Native Method)
    at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:87)
    at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
    at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:361)
    at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
    at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
    at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
    at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
    at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
    at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)
Caused by: com.intellij.ide.plugins.PluginManager$StartupAbortedException: Fatal error initializing 'com.intellij.ide.ui.LafManager'
    at com.intellij.ide.plugins.PluginManager.handleComponentError(PluginManager.java:257)
    at com.intellij.openapi.components.impl.PlatformComponentManagerImpl.handleInitComponentError(PlatformComponentManagerImpl.java:43)
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentConfigComponentAdapter.getComponentInstance(ComponentManagerImpl.java:506)
    at com.intellij.openapi.components.impl.ComponentManagerImpl.createComponents(ComponentManagerImpl.java:107)
    at com.intellij.openapi.application.impl.ApplicationImpl.lambda$createComponents$9(ApplicationImpl.java:446)
    at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcess$1(CoreProgressManager.java:157)
    at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(CoreProgressManager.java:580)
    at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:525)
    at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:85)
    at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(CoreProgressManager.java:144)
    at com.intellij.openapi.application.impl.ApplicationImpl.createComponents(ApplicationImpl.java:453)
    at com.intellij.openapi.components.impl.ComponentManagerImpl.init(ComponentManagerImpl.java:91)
    at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:405)
    at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:391)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:209)
    ... 16 more
Caused by: java.lang.NoClassDefFoundError: com/sun/java/swing/plaf/windows/WindowsLookAndFeel
    at com.intellij.ide.ui.laf.IdeaLaf.initIdeaDefaults(IdeaLaf.java:81)
    at com.intellij.ide.ui.laf.IdeaLaf.initComponentDefaults(IdeaLaf.java:28)
    at java.desktop/javax.swing.plaf.basic.BasicLookAndFeel.getDefaults(BasicLookAndFeel.java:150)
    at java.desktop/javax.swing.plaf.metal.MetalLookAndFeel.getDefaults(MetalLookAndFeel.java:1560)
    at com.intellij.ide.ui.laf.darcula.DarculaLaf.getDefaults(DarculaLaf.java:95)
    at java.desktop/javax.swing.UIManager.setLookAndFeel(UIManager.java:587)
    at com.intellij.ide.ui.laf.LafManagerImpl.setCurrentLookAndFeel(LafManagerImpl.java:395)
    at com.intellij.ide.ui.laf.LafManagerImpl.initComponent(LafManagerImpl.java:191)
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentConfigComponentAdapter.getComponentInstance(ComponentManagerImpl.java:488)
    ... 28 more
Caused by: java.lang.ClassNotFoundException: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
    at com.intellij.util.lang.UrlClassLoader.findClass(UrlClassLoader.java:224)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
    ... 37 more


Das Programm habe ich aus den Repositories gedownloadet.
Lieder weiß ich hier nicht weiter und auch wenn ich das Programm von der Jetbrains-Internetseite downloade bekomme ich dieselbe Fehlermeldung.

Hat jemand eine Ahnung wie ich das Problem lösen kann?

Offline

#2 30.08.2018 18:20:22

niemand
Mitglied

Re: Probleme mit PyCharm Community Edition

Du könntest testweise mal die alte Config verschieben (oder löschen, wenn nix Wichtiges drin ist). Hatte da auch schon mal ’n Problem mit.

OT: wäre gut, wenn du so Ausgaben in Code-Tags packen könntest, dann ist’s einfacher zu lesen.

Offline

#3 06.09.2018 17:40:12

DarkSilence
Mitglied

Re: Probleme mit PyCharm Community Edition

Danke für deine Antwort.
Ich habe schon versucht die Config zu löschen, das hat aber das Problem nicht behoben.

Gäbe es noch eine andere Möglichkeit das Problem zu beheben oder sollte ich dann auf das nächste Update von PyCharm warten?

Offline

#4 17.01.2019 00:43:35

omee
Mitglied

Re: Probleme mit PyCharm Community Edition

https://bugs.archlinux.org/task/60800?p … ty-edition

giwig (giwig) schrieb:

need to change the file /usr/bin/pycharm
from: PYCHARM_JDK="/usr/lib/jvm/java-8-openjdk"
tp: PYCHARM_JDK="/usr/lib/jvm/java-8-openjdk/jre"

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums